source: projects/specs/trunk/p/pyOpenSSL/pyOpenSSL-vl.spec @ 8154

Revision 8154, 6.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pkg_release     1%{?_dist_release}
4
5Summary: Python wrapper module around the OpenSSL library
6Summary(ja): OpenSSL ライブラリの Python ラッパーモジュール
7Name: pyOpenSSL
8Version: 0.13.1
9Release: %{pkg_release}
10Source0: http://pyopenssl.sf.net/%{name}-%{version}.tar.gz
11Patch2: pyOpenSSL-elinks.patch
12Patch3: pyOpenSSL-nopdfout.patch
13License: LGPLv2+
14Group: Development/Libraries
15URL: http://pyopenssl.sourceforge.net/
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: openssl-devel, python-devel
19#BuildRequires: latex2html
20
21%description
22High-level wrapper around a subset of the OpenSSL library, includes
23 * SSL.Connection objects, wrapping the methods of Python's portable
24   sockets
25 * Callbacks written in Python
26 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
27...  and much more ;)
28
29
30%prep
31%setup -q
32%patch2 -p1 -b .elinks
33%patch3 -p1 -b .nopdfout
34
35%build
36CFLAGS="%{optflags}" %{__python} setup.py build
37
38%install
39%{__rm} -rf %{buildroot}
40%{__python} setup.py install -O1 --skip-build --root %{buildroot}
41#pushd doc
42#make text
43#make dvi
44
45%clean
46%{__rm} -rf %{buildroot}
47
48%files
49%defattr(-,root,root,-)
50%doc README ChangeLog LICENSE
51#%doc pyOpenSSL.ps pyOpenSSL.txt html
52%{python_sitearch}/OpenSSL/
53%{python_sitearch}/%{name}*.egg-info
54
55%changelog
56* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
57- new upstream release
58- remove Patch0 (pyOpenSSL-0.7-openssl.patch)
59- remove Patch4 (pyOpenSSL-threadsafe.patch)
60
61* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-4
62- rebuild with python-2.7.2
63
64* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-3
65- rebuilt with openssl-1.0.0c
66- remove BuildRequires: tetex
67
68* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.7-2
69- rebuilt with python-2.6.4
70
71* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7-1
72- initial build for Vine Linux based on fedora package
73
74* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7-3
75- Rebuild for Python 2.6
76
77* Fri Sep 19 2008 Dennis Gilmore <dennis@ausil.us> - 0.7-2
78- update threadsafe  patch
79- bug#462807
80
81* Mon Sep 15 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7-1
82- bump to new release
83- the inevitable patch fixes
84
85
86* Wed Mar 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-4
87- fix horrific release tag
88- fix license tag
89- add egg-info
90
91* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6-3.p24.9
92- Autorebuild for GCC 4.3
93
94* Wed Dec  5 2007 Jeremy Katz <katzj@redhat.com> - 0.6-2.p24.9
95- rebuild for new openssl
96
97* Mon Dec 11 2006 Paul Howarth <paul@city-fan.org> - 0.6-1.p24.9
98- add missing buildreq latex2html, needed to build HTML docs
99- rewrite to be more in line with Fedora python spec template and use
100  %%{python_sitearch} rather than a script-generated %%files list
101- package is not relocatable - drop Prefix: tag
102- buildreq perl not necessary
103- fix permissions for files going into debuginfo package
104
105* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.8
106- rebuild for python 2.5
107
108* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.2
109- rebuild
110
111* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.1
112- bump again for double-long bug on ppc(64)
113
114* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2
115- rebuilt for new gcc4.1 snapshot and glibc changes
116
117* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
118- rebuilt
119
120* Wed Nov  9 2005 Mihai Ibanescu <misa@redhat.com> - 0.6-1.p24.7
121- rebuilt against newer openssl
122
123* Wed Aug 24 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.6
124- add dcbw's patch to fix some threading problems
125
126* Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 0.6-1.p24.5
127- current rpm creates .pyo files, include them in filelist
128
129* Thu Mar 17 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.4
130- rebuilt
131
132* Mon Mar 14 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.3
133- rebuilt
134
135* Mon Mar  7 2005 Tomas Mraz <tmraz@redhat.com> 0.6-1.p23.2
136- rebuild with openssl-0.9.7e
137
138* Tue Nov  9 2004 Nalin Dahyabhai <nalin@redhat.com> 0.6-1.p23.1
139- rebuild
140
141* Fri Aug 13 2004 Mihai Ibanescu <misa@redhat.com> 0.6-1
142- 0.6 is out
143
144* Tue Aug 10 2004 Mihai Ibanescu <misa@redhat.com> 0.6-0.90.rc1
145- release candidate
146
147* Thu Jun 24 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-24
148- rebuilt
149
150* Mon Jun 21 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-23
151- rebuilt
152
153* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
154- rebuilt
155
156* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
157- rebuilt
158
159* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
160- rebuilt
161
162* Wed Nov  5 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-20
163- rebuilt against python 2.3.2
164
165* Fri Aug  8 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-12
166- lynx no longer supported, using elinks instead (patch from
167  Michael Redinger <michael.redinger@uibk.ac.at>, bug #101947 )
168
169* Wed Jun  4 2003 Elliot Lee <sopwith@redhat.com> 0.5.1-11
170- Rebuilt
171
172* Wed Jun  4 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-10.7.x
173- Built on 7.x
174
175* Mon Mar  3 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-9
176- bug #73967: Added Requires: python
177
178* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
179- rebuilt
180
181* Fri Feb 21 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-7
182- bug #84803: Added patch to expose more flags
183
184* Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-5
185- installing to %%{_libdir}
186
187* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
188- rebuilt
189
190* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-3
191- rebuild
192
193* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
194- Add -I and -L flags for finding Kerberos headers and libraries, in case
195  they're referenced
196
197* Tue Dec  3 2002 Mihai Ibanescu <misa@redhat.com>
198- Fix for bug 73967: site-packages/OpenSSL not owned by this package
199- Adding hacks around the lack of latex2html on ia64
200
201* Tue Sep 24 2002 Mihai Ibanescu <misa@redhat.com>
202- 0.5.1
203
204* Thu Aug 29 2002 Mihai Ibanescu <misa@redhat.com>
205- Building 0.5.1rc1 with version number 0.5.0.91 (this should also fix the big
206  error of pushing 0.5pre previously, since it breaks rpm's version comparison
207  algorithm).
208- We use %%{__python}. Too bad I can't pass --define's to distutils.
209
210* Fri Aug 16 2002 Mihai Ibanescu <misa@redhat.com>
211- Building 0.5
212
213* Fri Jun 14 2002 Mihai Ibanescu <misa@redhat.com>
214- Added documentation
Note: See TracBrowser for help on using the repository browser.