source: projects/specs/trunk/p/pstoedit/pstoedit-vl.spec @ 941

Revision 941, 8.5 KB checked in by inagaki, 14 years ago (diff)

updated: ImageMagicj?, libfprint, dvdauthor, inkscape, koffice, pstoedit, xine-lib

Line 
1Summary:         Translator of PostScript and PDF graphics into various vector formats
2Summary(ja):     ポストスクリプトやPDFを多種多様なベクタ形式に変換
3Name:            pstoedit
4Version:         3.50
5Release:         1%{?_dist_release}
6Group:           Applications/Graphics
7License:         GPLv2
8URL:             http://www.pstoedit.net/pstoedit
9
10Source0:         http://prdownloads.sourceforge.net/pstoedit/%{name}-%{version}.tar.gz
11#Source1:         http://www.helga-glunz.homepage.t-online.de/plugins/plugins_linux_350.tgz
12
13BuildRoot:       %{_tmppath}/%{name}-%{version}-root
14BuildRequires:   libemf-devel libpng-devel gd-devel
15BuildRequires:   ImageMagick-c++-devel zlib-devel
16BuildRequires:   libtool sed
17
18Vendor:          Project Vine
19Distribution:    Vine Linux
20
21%description
22pstoedit translates PostScript and PDF graphics into other vector
23formats. Currently pstoedit can generate the following formats:
24    * Tgif .obj format (for tgif version >= 3)
25    * .fig format for xfig
26    * pdf - Adobe's Portable Document Format
27    * gnuplot format
28    * Flattened PostScript (with or without Bezier curves)
29    * DXF - CAD exchange format
30    * LWO - LightWave 3D
31    * RIB - RenderMan
32    * RPL - Real3D
33    * Java 1 or Java 2 applet
34    * Idraw format (in fact a special form of EPS that idraw can read)
35    * Tcl/Tk
36    * HPGL
37    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
38    * Windows Meta Files (WMF) (Windows 9x/NT only)
39    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
40    * OS/2 meta files (OS/2 only)
41    * PIC format for troff/groff
42    * MetaPost format for usage with TeX/LaTeX
43    * LaTeX2e picture
44    * Kontour
45    * GNU Metafile (plotutils / libplot)
46    * Sketch ( http://sketch.sourceforge.net )
47    * Mathematica
48    * via ImageMagick to any format supported by ImageMagick
49    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
50
51%description -l ja
52pstoeditはポストスクリプトやPDFを多種多様なベクタ形式に変換します。サ
53ポートしている出力ファイル形式は下記の通りです。
54    *  Tgif .obj format (for tgif version >= 3)
55    * .fig format for xfig
56    * pdf - Adobe's Portable Document Format
57    * gnuplot format
58    * Flattened PostScript (with or without Bezier curves)
59    * DXF - CAD exchange format
60    * LWO - LightWave 3D
61    * RIB - RenderMan
62    * RPL - Real3D
63    * Java 1 or Java 2 applet
64    * Idraw format (in fact a special form of EPS that idraw can read)
65    * Tcl/Tk
66    * HPGL
67    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
68    * Windows Meta Files (WMF) (Windows 9x/NT only)
69    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
70    * OS/2 meta files (OS/2 only)
71    * PIC format for troff/groff
72    * MetaPost format for usage with TeX/LaTeX
73    * LaTeX2e picture
74    * Kontour
75    * GNU Metafile (plotutils / libplot)
76    * Sketch ( http://sketch.sourceforge.net )
77    * Mathematica
78    * via ImageMagick to any format supported by ImageMagick
79    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
80
81%package        devel
82Summary:        pstoedit C Library developer.
83Summary(ja):    pstoedit 開発ライブラリ
84Group:          Development/Libraries
85URL:            http://www.pstoedit.net/pstoedit
86Requires:       pstoedit = %{version}-%{release}
87Requires:       libpng-devel libstdc++-devel zlib-devel
88
89%description devel
90pstoedit library
91
92%description -l ja devel
93pstoedit 開発ライブラリ
94
95%prep
96%setup -q
97 %{__perl} -p -i -e 's|BINDIR=/usr/local/bin||' autogen.sh
98
99%build
100./autogen.sh
101libtoolize -c -f
102
103# needed because of definitions in imagemagick headers that break with -pedantic
104sed -ie 's/-pedantic//' configure
105
106%configure  \
107        --disable-static \
108        --without-swf \
109        --with-emf \
110        --with-libemf-lib=%{_libdir} \
111        --with-libemf-include=%{_includedir}/libEMF
112 
113# don't use _smp_mflags
114%{__make}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119%makeinstall
120#ifarch %{ix86}
121#{__install} -m 755 plugins_linux_350.so %{buildroot}%{_libdir}/%{name}
122#endif
123
124%{__mkdir_p} $RPM_BUILD_ROOT%{_mandir}/man1
125%{__install} -m 644 doc/%{name}.1  %{buildroot}%{_mandir}/man1
126
127%{__mkdir_p} $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
128echo "%{_libdir}/%{name}" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/pstoedit.conf
129
130# %{__mkdir_p} %{buildroot}%{_bindir}
131# %{__install} -c config/pstoedit-config %{buildroot}%{_bindir}
132# %{__mkdir_p} %{buildroot}%{_datadir}
133# %{__install} -c -m 644 config/pstoedit.m4  %{buildroot}%{_datadir}/aclocal
134# %{__mkdir_p} %{buildroot}%{_datadir}/pstoedit/swffonts
135# %{__install} -c -m 644 misc/swffonts/default.fdb %{buildroot}%{_datadir}/pstoedit/swffonts
136# %{__install} -c -m 644 misc/latex2e.fmp %{buildroot}%{_datadir}/pstoedit
137# %{__install} -c -m 644 misc/mpost.fmp %{buildroot}%{_datadir}/pstoedit
138# %{__install} -c -m 644 misc/safer.ps %{buildroot}%{_datadir}/pstoedit
139# %{__install} -c -m 644 misc/svg.fmp %{buildroot}%{_datadir}/pstoedit
140# %{__install} -c -m 644 misc/wemf.fmp %{buildroot}%{_datadir}/pstoedit
141# %{__install} -c -m 644 misc/examplefigmap.fmp %{buildroot}%{_datadir}/pstoedit
142# ./libtool --mode=install %{__install} -c  src/libpstoedit.la  %{buildroot}%{_libdir}
143# ./libtool --mode=install %{__install} -c  src/pstoedit  %{buildroot}%{_bindir}
144# %{__mkdir_p} %{buildroot}%{_libdir}/pstoedit
145# ./libtool --mode=install %{__install} -c  src/libp2edrvstd.la   %{buildroot}%{_libdir}/pstoedit
146# ./libtool --mode=install %{__install} -c  src/libp2edrvmagick++.la  -inst-prefix %{buildroot} %{buildroot}%{_libdir}/pstoedit
147# %{__install} -c -m 644 src/pstoedit.h  %{buildroot}%{_prefix}/include/pstoedit
148# %{__install} -c -m 644 src/pstoedll.h  %{buildroot}%{_prefix}/include/pstoedit
149# %{__install} -c -m 644 src/pstoeditoutputlib.h  %{buildroot}%{_prefix}/include/pstoedit
150# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
151# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
152# %{__install} -c -m 644 src/cppcomp.h  %{buildroot}%{_prefix}/include/pstoedit
153# %{__install} -c -m 644 src/drvbase.h  %{buildroot}%{_prefix}/include/pstoedit
154# %{__install} -c -m 644 src/drvfuncs.h  %{buildroot}%{_prefix}/include/pstoedit
155# %{__install} -c -m 644 src/miscutil.h  %{buildroot}%{_prefix}/include/pstoedit
156# %{__install} -c -m 644 src/base64writer.h  %{buildroot}%{_prefix}/include/pstoedit
157# %{__install} -c -m 644 src/poptions.h  %{buildroot}%{_prefix}/include/pstoedit
158# %{__install} -c -m 644 src/ordlist.h  %{buildroot}%{_prefix}/include/pstoedit
159# %{__install} -c -m 644 src/psimage.h  %{buildroot}%{_prefix}/include/pstoedit
160#
161# %{__install} -m 775 lib/pstoedit/plugins_linux.so %{buildroot}%{_libdir}/pstoedit
162# for i in %{buildroot}%{_libdir}/*.la %{buildroot}%{_libdir}/pstoedit/*.la
163#  do cp -p $i $i~
164#  sed s:%{buildroot}::g <$i~ >$i
165#  rm $i~
166# done
167#
168
169%clean
170rm -rf $RPM_BUILD_ROOT
171
172%post -p /sbin/ldconfig
173
174%postun -p /sbin/ldconfig
175
176%files
177%defattr(-,root,root)
178%doc copying doc/*.htm
179%{_sysconfdir}/ld.so.conf.d/%{name}.conf
180%{_bindir}/pstoedit
181%{_libdir}/*.so.*
182%dir %{_libdir}/pstoedit
183%{_libdir}/%{name}/*.so
184%{_libdir}/%{name}/*.so.*
185%{_datadir}/%{name}
186%{_mandir}/*/*
187
188%files devel
189%defattr(-,root,root)
190%{_libdir}/*.so
191%{_includedir}/pstoedit/*
192%{_libdir}/pkgconfig/*.pc
193%{_datadir}/aclocal/*
194%exclude %{_libdir}/*.la
195%exclude %{_libdir}/pstoedit/*.la
196
197%changelog
198* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-1
199- new upstream release
200- built with new toolchain and ImageMagick-6.6.1.5
201- used ld.so.conf.d instead of ld.so.conf
202
203* Sun Jun 14 2009 Shu KONNO <owa@bg.wakwak.com> 3.45-1
204- applied new versioning policy, and spec in utf-8
205- update pstoedit to 3.45
206- added --disable-static option to %%configure
207- added --without-swf option, because of fail to compile
208
209* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.44-0vl2
210- install plugins_linux.3.42.so only on ix86 archs
211  (what should we do with the intel binary file on other archs, huh?)
212
213* Thu Aug 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.44-0vl1
214- rebuilt for VineSeed (4.0)
215- updated to 3.44
216- fixed build dependancy
217
218* Wed Sep 28 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
219- Updated to 3.42
220
221* Tue Jan 11 2005 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
222- Updated to 3.40
223
224* Fri Sep 24 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
225- Added plugins
226- Disable emf support
227
228* Wed Sep 22 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
229- Added buildrequires
230
231* Thu Oct  2 2003  Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
232- initial package
Note: See TracBrowser for help on using the repository browser.