source: projects/specs/trunk/p/pstoedit/pstoedit-vl.spec @ 521

Revision 521, 8.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:         Translator of PostScript and PDF graphics into various vector formats
2Summary(ja):     ポストスクリプトやPDFを多種多様なベクタ形式に変換
3Name:            pstoedit
4Version:         3.45
5Release:         1%{?_dist_release}
6Group:           Applications/Graphics
7License:         GPL
8URL:             http://www.pstoedit.net/pstoedit
9#Source0:         http://home.t-online.de/home/helga.glunz/wglunz/pstoedit/%{name}-%{version}.tar.gz
10Source0:         %{name}-%{version}.tar.gz
11Source1:         http://www.helga-glunz.homepage.t-online.de/plugins/plugins_linux.3.42.tgz
12
13BuildRoot:       %{_tmppath}/%{name}-%{version}-root
14Vendor:          Project Vine
15Distribution:    Vine Linux
16
17Requires:        libemf libtiff
18Requires:        ming ImageMagick-c++ freetype2 xorg-x11-libs
19BuildRequires:   libemf-devel libtiff-devel gd-devel
20BuildRequires:   ming ImageMagick-c++-devel freetype2-devel xorg-x11-devel zlib-devel
21Prereq:          perl grep
22
23%description
24pstoedit translates PostScript and PDF graphics into other vector
25formats. Currently pstoedit can generate the following formats:
26    * Tgif .obj format (for tgif version >= 3)
27    * .fig format for xfig
28    * pdf - Adobe's Portable Document Format
29    * gnuplot format
30    * Flattened PostScript (with or without Bezier curves)
31    * DXF - CAD exchange format
32    * LWO - LightWave 3D
33    * RIB - RenderMan
34    * RPL - Real3D
35    * Java 1 or Java 2 applet
36    * Idraw format (in fact a special form of EPS that idraw can read)
37    * Tcl/Tk
38    * HPGL
39    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
40    * Windows Meta Files (WMF) (Windows 9x/NT only)
41    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
42    * OS/2 meta files (OS/2 only)
43    * PIC format for troff/groff
44    * MetaPost format for usage with TeX/LaTeX
45    * LaTeX2e picture
46    * Kontour
47    * GNU Metafile (plotutils / libplot)
48    * Sketch ( http://sketch.sourceforge.net )
49    * Mathematica
50    * via ImageMagick to any format supported by ImageMagick
51    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
52
53%description -l ja
54pstoeditはポストスクリプトやPDFを多種多様なベクタ形式に変換します。サ
55ポートしている出力ファイル形式は下記の通りです。
56    *  Tgif .obj format (for tgif version >= 3)
57    * .fig format for xfig
58    * pdf - Adobe's Portable Document Format
59    * gnuplot format
60    * Flattened PostScript (with or without Bezier curves)
61    * DXF - CAD exchange format
62    * LWO - LightWave 3D
63    * RIB - RenderMan
64    * RPL - Real3D
65    * Java 1 or Java 2 applet
66    * Idraw format (in fact a special form of EPS that idraw can read)
67    * Tcl/Tk
68    * HPGL
69    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
70    * Windows Meta Files (WMF) (Windows 9x/NT only)
71    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
72    * OS/2 meta files (OS/2 only)
73    * PIC format for troff/groff
74    * MetaPost format for usage with TeX/LaTeX
75    * LaTeX2e picture
76    * Kontour
77    * GNU Metafile (plotutils / libplot)
78    * Sketch ( http://sketch.sourceforge.net )
79    * Mathematica
80    * via ImageMagick to any format supported by ImageMagick
81    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
82
83%package        devel
84Summary:        pstoedit C Library developer.
85Summary(ja):    pstoedit 開発ライブラリ
86Group:          Development/Libraries
87URL:            http://www.pstoedit.net/pstoedit
88Requires:       pstoedit = %{version}-%{release}
89Requires:       libpng-devel libstdc++3-devel zlib-devel
90
91%description devel
92pstoedit library
93
94%description -l ja devel
95pstoedit 開発ライブラリ
96
97%prep
98%setup -a 1
99 %{__perl} -p -i -e 's|BINDIR=/usr/local/bin||' autogen.sh
100# %{__perl} -p -i -e 's|_la_LDFLAGS\)|_la_LDFLAGS\) -module -avoid-version|g' Makefile.in
101
102
103%build
104./autogen.sh
105libtoolize -c -f
106
107# needed because of definitions in imagemagick headers that break with -pedantic
108sed -ie 's/-pedantic//' configure
109
110%configure  \
111        --disable-static \
112        --without-swf \
113        --with-emf \
114        --with-libemf-lib=%{_libdir} \
115        --with-libemf-include=%{_includedir}/libEMF
116 
117# don't use _smp_mflags
118%{__make}
119
120# gcc -o libp2edrvmagick++.so.0.0.0 hoge.c -L`pwd` -Wl,-rpath -Wl,/usr/lib/pstoedit -lhoge
121
122# /usr/lib/pstoedit/libp2edrvstd.so.0.0.0
123# /usr/lib/pstoedit/libp2edrvswf.so.0.0.0
124# /usr/lib/pstoedit/libp2edrvwmf.so.0.0.0
125# /usr/lib/pstoedit/plugins_linux.so
126#
127
128%install
129rm -rf $RPM_BUILD_ROOT/
130
131%makeinstall
132%ifarch %{ix86}
133%{__install} -m 755 plugins_linux.3.42.so %{buildroot}%{_libdir}/%{name}
134%endif
135
136%{__mkdir_p} %{buildroot}%{_mandir}/man1
137%{__install} -m 644 doc/%{name}.1  %{buildroot}%{_mandir}/man1
138
139# %{__mkdir_p} %{buildroot}%{_bindir}
140# %{__install} -c config/pstoedit-config %{buildroot}%{_bindir}
141# %{__mkdir_p} %{buildroot}%{_datadir}
142# %{__install} -c -m 644 config/pstoedit.m4  %{buildroot}%{_datadir}/aclocal
143# %{__mkdir_p} %{buildroot}%{_datadir}/pstoedit/swffonts
144# %{__install} -c -m 644 misc/swffonts/default.fdb %{buildroot}%{_datadir}/pstoedit/swffonts
145# %{__install} -c -m 644 misc/latex2e.fmp %{buildroot}%{_datadir}/pstoedit
146# %{__install} -c -m 644 misc/mpost.fmp %{buildroot}%{_datadir}/pstoedit
147# %{__install} -c -m 644 misc/safer.ps %{buildroot}%{_datadir}/pstoedit
148# %{__install} -c -m 644 misc/svg.fmp %{buildroot}%{_datadir}/pstoedit
149# %{__install} -c -m 644 misc/wemf.fmp %{buildroot}%{_datadir}/pstoedit
150# %{__install} -c -m 644 misc/examplefigmap.fmp %{buildroot}%{_datadir}/pstoedit
151# ./libtool --mode=install %{__install} -c  src/libpstoedit.la  %{buildroot}%{_libdir}
152# ./libtool --mode=install %{__install} -c  src/pstoedit  %{buildroot}%{_bindir}
153# %{__mkdir_p} %{buildroot}%{_libdir}/pstoedit
154# ./libtool --mode=install %{__install} -c  src/libp2edrvstd.la   %{buildroot}%{_libdir}/pstoedit
155# ./libtool --mode=install %{__install} -c  src/libp2edrvmagick++.la  -inst-prefix %{buildroot} %{buildroot}%{_libdir}/pstoedit
156# %{__install} -c -m 644 src/pstoedit.h  %{buildroot}%{_prefix}/include/pstoedit
157# %{__install} -c -m 644 src/pstoedll.h  %{buildroot}%{_prefix}/include/pstoedit
158# %{__install} -c -m 644 src/pstoeditoutputlib.h  %{buildroot}%{_prefix}/include/pstoedit
159# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
160# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
161# %{__install} -c -m 644 src/cppcomp.h  %{buildroot}%{_prefix}/include/pstoedit
162# %{__install} -c -m 644 src/drvbase.h  %{buildroot}%{_prefix}/include/pstoedit
163# %{__install} -c -m 644 src/drvfuncs.h  %{buildroot}%{_prefix}/include/pstoedit
164# %{__install} -c -m 644 src/miscutil.h  %{buildroot}%{_prefix}/include/pstoedit
165# %{__install} -c -m 644 src/base64writer.h  %{buildroot}%{_prefix}/include/pstoedit
166# %{__install} -c -m 644 src/poptions.h  %{buildroot}%{_prefix}/include/pstoedit
167# %{__install} -c -m 644 src/ordlist.h  %{buildroot}%{_prefix}/include/pstoedit
168# %{__install} -c -m 644 src/psimage.h  %{buildroot}%{_prefix}/include/pstoedit
169#
170# %{__install} -m 775 lib/pstoedit/plugins_linux.so %{buildroot}%{_libdir}/pstoedit
171# for i in %{buildroot}%{_libdir}/*.la %{buildroot}%{_libdir}/pstoedit/*.la
172#  do cp -p $i $i~
173#  sed s:%{buildroot}::g <$i~ >$i
174#  rm $i~
175# done
176#
177
178%clean
179rm -rf $RPM_BUILD_ROOT/
180
181%post
182/bin/grep -q /usr/lib/pstoedit /etc/ld.so.conf || \
183     echo /usr/lib/pstoedit >> /etc/ld.so.conf
184/sbin/ldconfig
185
186%postun
187%{__perl} -p -i -e 's|/usr/lib/pstoedit$||' /etc/ld.so.conf
188/sbin/ldconfig
189
190%files
191%defattr(-,root,root)
192%doc copying doc/*.htm
193%{_bindir}/pstoedit
194%{_libdir}/*.so.*
195%dir %{_libdir}/pstoedit
196%{_libdir}/%{name}/*.so
197%{_libdir}/%{name}/*.so.*
198%{_datadir}/%{name}
199%{_mandir}/*/*
200
201%files devel
202%defattr(-,root,root)
203%{_libdir}/*.so
204#%{_libdir}/*.*a
205#%{_libdir}/pstoedit/*.*a
206%{_includedir}/pstoedit/*
207%{_libdir}/pkgconfig/*.pc
208%{_datadir}/aclocal/*
209%exclude %{_libdir}/*.la
210%exclude %{_libdir}/pstoedit/*.la
211
212%changelog
213* Sun Jun 14 2009 Shu KONNO <owa@bg.wakwak.com> 3.45-1
214- applied new versioning policy, and spec in utf-8
215- update pstoedit to 3.45
216- added --disable-static option to %%configure
217- added --without-swf option, because of fail to compile
218
219* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.44-0vl2
220- install plugins_linux.3.42.so only on ix86 archs
221  (what should we do with the intel binary file on other archs, huh?)
222
223* Thu Aug 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.44-0vl1
224- rebuilt for VineSeed (4.0)
225- updated to 3.44
226- fixed build dependancy
227
228* Wed Sep 28 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
229- Updated to 3.42
230
231* Tue Jan 11 2005 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
232- Updated to 3.40
233
234* Fri Sep 24 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
235- Added plugins
236- Disable emf support
237
238* Wed Sep 22 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
239- Added buildrequires
240
241* Thu Oct  2 2003  Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
242- initial package
Note: See TracBrowser for help on using the repository browser.