source: projects/specs/trunk/p/proftpd/proftpd-vl.spec @ 2490

Revision 2490, 13.4 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.2e
6%define origversion     1.3.2e
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 2%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/%{name}-%{origversion}.tar.bz2
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25
26# auth
27Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
28
29# iconv patch (CharsetLocal/CharsetRemote)
30# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
31Patch300: proftpd-1.3.1-iconv.patch.bz2
32
33# fix build on recent kernel headers
34# Patch400: proftpd-1.3.1-umode.patch
35
36# security fix
37Patch1000: proftpd/proftpd-1.3.2e-CVE-2010-4221.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: pam-devel, openldap-devel, openssl-devel
41BuildRequires: ncurses-devel, libcap-devel, libacl-devel
42Requires: pam > 0.59
43Obsoletes: wu-ftpd, anonftp
44Provides: ftpserver
45
46Vendor: Project Vine
47Distribution: Vine Linux
48
49%description
50ProFTPd is an enhanced FTP server with a focus toward simplicity,
51security, and ease of configuration.  It features a very Apache-like
52configuration syntax, and a highly customizable server infrastructure,
53including support for multiple 'virtual' FTP servers, anonymous FTP,
54and permission-based directory visibility.
55
56%description -l ja
57ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
58FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
59anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
60高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
61
62%prep
63%setup -q -n %{name}-%{tarballversion}
64find . -type d -name CVS | xargs -r rm -frv
65
66# upstream fixes
67
68## patches from mdk
69# use system-auth instaed of pam_pwdb
70%patch201 -p1
71
72# iconv patch (CharsetLocal/CharsetRemote)
73%patch300 -p1
74
75# fix build on recent kernel headers
76# %patch400 -p0
77
78# security fixes
79%patch1000 -p1 -b .ZDI-CAN-925
80
81%build
82# Disable stripping in order to get useful debuginfo packages
83%{__perl} -pi -e 's|"-s"|""|g' configure
84
85%configure \
86    --libexecdir="%{_libexecdir}/proftpd" \
87    --localstatedir="%{_var}/run" \
88    --enable-ctrls \
89    --enable-facl \
90    --enable-dso \
91    --enable-ipv6 \
92    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
93mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
94    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
95
96# It seems that with _smp_mflags -lsupp tries to get linked before being built
97# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
98%{__make}
99
100
101%install
102%{__rm} -rf %{buildroot}
103%{__make} install DESTDIR=%{buildroot} \
104    rundir="%{_var}/run/proftpd" \
105    INSTALL_USER=`id -un` \
106    INSTALL_GROUP=`id -gn`
107
108# auth
109mkdir -p %{buildroot}%{_sysconfdir}/pam.d
110%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
111
112# logrotate
113mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
114%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
115
116# init.d
117%{__install} -D -p -m 0755 %{SOURCE3} \
118    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
119
120%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
121%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
122%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
123
124touch %{buildroot}%{_sysconfdir}/ftpusers
125
126rm contrib/README.* || :
127# eliminate executable bit in %doc
128find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
129
130# remove .{la,a}
131rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
132
133# remove development files (headers and pkgconfig file)
134# who need these files?
135rm -rf %{buildroot}%{_includedir}/proftpd
136rm -rf %{buildroot}%{_libdir}/pkgconfig
137
138%preun
139if [ -d %{_rundir} ] ; then
140        rm -rf %{_rundir}/*
141fi
142
143if [ $1 = 0 ] ; then
144        /sbin/chkconfig --del proftpd
145fi
146
147%postun
148if [ $1 -ge 1 ]; then
149    /sbin/service proftpd condrestart
150fi
151
152%post
153/sbin/chkconfig --add proftpd
154
155
156%clean
157rm -rf %{buildroot}
158
159%files
160%defattr(-,root,root)
161%doc COPYING CREDITS ChangeLog INSTALL NEWS
162%doc README.{LDAP,PAM,modules} doc/*
163%doc contrib/README contrib/xferstats.holger-preiss
164%doc sample-configurations/
165%{_sbindir}/*
166%{_bindir}/*
167%{_mandir}/*/*
168%{_var}/ftp/welcome.msg
169%dir %{_libexecdir}/proftpd/
170%{_libexecdir}/proftpd/mod_*
171%dir %{_rundir}
172%dir %{_var}/ftp
173%config %{_sysconfdir}/rc.d/init.d/proftpd
174%config(noreplace) %{_sysconfdir}/pam.d/ftp
175%config(noreplace) %{_sysconfdir}/proftpd.conf
176%config(noreplace) %{_sysconfdir}/ftpusers
177%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
178
179
180%changelog
181* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
182- rebuild with openssl-1.0.0c
183
184* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
185- new upstream release
186- add patch1000 for CVE-2010-4221 (TELNET_IAC)
187- add BRs: ncurses-devel, libcap-devel, libacl-devel
188
189* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
190- new upstream release with security fix (CVE-2009-3555)
191
192* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
193- new upstream release with security fix (NULL char in X.509 certificate)
194- add chkconfig --add in post script
195
196* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
197- remove .{la,a}
198- remove headers and pkgconfig file
199
200* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
201- update Source1 (sample config file for vine)
202  set default char set to UTF-8
203
204* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
205- new upstream release
206
207* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
208- rebuild with openldap-2.4.11
209
210* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
211- built with openssl-0.9.8k
212
213* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
214- new upstream release
215- add configure option to activate new modules
216- drop patch400
217
218* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
219- built with openssl-0.9.8j
220
221* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
222- built with openssl-0.9.8i
223
224* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
225- add Patch400 to fix build failure at least on i386
226- spec in UTF-8
227
228* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
229- built with openssl-0.9.8h
230
231* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
232- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
233
234* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
235- new upstream release
236- drop old patches which are included in new release
237- update patch201, 300
238- build under new versioning policy
239
240* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
241- new upstream release
242- built with openssl098
243- drop old (for 1.2.10) patches
244- Patch100-150 from FC8 package
245- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
246- update patch300 for 1.3.0
247- change configure option refer to FC8
248- add process reboot with message output when package is upgraded
249- docfiles list update
250- fix changelog ver number typo
251
252* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
253- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
254  (<WISHES:15>)
255- add Vendor/Distribution tag
256- add patch104 for fix pr_ctrls_recv_request issue
257- add patch103 for fix CVE-2006-6170
258- add patch102 for fix CVE-2006-5815
259- add patch101 for fix CVE-2006-6171
260
261* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
262- rebuilt with openldap-2.3.27-0vl
263
264* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
265- rebuilt with openldap-2.3.24-0vl1
266
267* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
268- add patch300 for iconv patch
269
270* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
271- enable mod_ldap
272- add BuildRequires: openldap-devel, openssl-devel
273- add Patch200 from MDK to support ldap
274- add Patch201 from MDK to use system-auth instead of pam_pwdb
275  (pam_pwdb is now obsolete, and will be removed in the future pam version)
276
277* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
278- 1.2.10-0vl1.1
279- add patch100 for fix CAN-2005-2390
280
281* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
282- new upstream release
283
284* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
285- new upstream release (1.2.10rc3)
286- build for Vine Linux 3.0
287
288* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
289- new upstream release
290- fix security issue: http://secunia.com/advisories/11527/
291
292* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
293- new upstream release
294
295* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
296- new upstream release
297- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
298
299* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
300- new upstream release
301
302* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
303- new upstream release 1.2.7
304- add logrotate config file.
305- move ftp home directory from /home/ftp to /var/ftp
306
307* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
308- new upstream release 1.2.6
309
310* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
311- new upstream release 1.2.5 (stable release version)
312
313* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
314- new upstream release 1.2.5-rc3
315
316* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
317- eliminate executable bit in %doc (requierment for /usr/bin/perl)
318- put files in sample-configurations/ to the according directory
319- remove unnecessary README.* files
320
321* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
322- updated to 1.2.5rc1 for problems in file globbing
323
324* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
325- 1.2.4-0vl1
326
327* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
328- 1.2.3-0vl1
329
330* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
331- 1.2.2-0vl1: update to 1.2.2 release
332- added more documents
333
334* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
335- update to 1.2.2rc3
336- use macros
337
338* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
339- 1.2.1-0vl3
340- rebuilt for VineSeed
341
342* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
343- update to 1.2.1
344
345* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
346- build for VineSeed
347
348* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
349- update to 1.2.0
350- set Epoch 1 to update from pre* and rc* version
351 
352* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
353- 1.2.0rc3-0vl3
354- removed PreReq and postun about /etc/ftpusers stuff
355
356* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
357- remove setup of /etc/ftpusers in %%pre script
358- add ftpusers.vine insted of the %%pre script
359- remove contrib/README.* frpm %%files
360- add BuildRequires: pam-devel
361
362* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
363- rebuild for VineSeed
364
365* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
366- update to 1.2.0rc3
367- add 'TimesGMT FALSE' in default configuration file
368- build on Vine 2.1
369
370* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
371- modified pre script to make it run by bash2 and added PreReq
372- remove /etc/ftpusers after uninstall
373
374* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
375- 1.2.0rc2-0vl8
376- rebuilt on VineSeed
377
378* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
379- remove patch from CVS to avoid 'after 5min data brake'
380- add passive patch insted of abobe CVS patch
381- revival contribute's proftpd.init.d
382
383* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
384- fixed %pre script and remove /etc/ftpusers from files
385- modify Japanese summary and descriptions
386
387* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
388- actually fixed to make the package relocatable.
389- non-root build failure by broken %prein, which should be %pre.
390- dont include CVS directory in doc
391- add %config /etc/rc.d/init.d/proftpd
392
393* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
394- correct config directive of the init.d script
395
396* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
397- adopt current patch from CVS to avoid the 'put on passive mode' probrem
398
399* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
400- 1.2.0rc2-0vl1
401- obsoletes anonftp
402- do not chkconfig --add in %post
403- requires: pam
404- added proftpd.vine.conf
405
406* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
407- libtoolize for alpha
408
409* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
410- [1.2.0rc2]
411
412* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
413- repackaging for VineLinux
414
415* Thu Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
416- Multi package creation.
417  Created core, standalone, inetd (&doc) package creations.
418  Added startup script for init.d
419  Need to make the "standalone & inetd" packages being created as "noarch"
420- Added URL.
421- Added prefix to make the package relocatable.
422
423* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
424- Corrected inetd.conf line addition/change logic.
425
426* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
427- Initial import of spec.
428
Note: See TracBrowser for help on using the repository browser.