source: projects/specs/trunk/p/proftpd/proftpd-vl.spec @ 2401

Revision 2401, 13.3 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild vine5.2 packages

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.2e
6%define origversion     1.3.2e
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 1%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/%{name}-%{origversion}.tar.bz2
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25
26# auth
27Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
28
29# iconv patch (CharsetLocal/CharsetRemote)
30# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
31Patch300: proftpd-1.3.1-iconv.patch.bz2
32
33# fix build on recent kernel headers
34# Patch400: proftpd-1.3.1-umode.patch
35
36# security fix
37Patch1000: proftpd/proftpd-1.3.2e-CVE-2010-4221.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: pam-devel, openldap-devel, openssl-devel
41BuildRequires: ncurses-devel, libcap-devel, libacl-devel
42Requires: pam > 0.59
43Obsoletes: wu-ftpd, anonftp
44Provides: ftpserver
45
46Vendor: Project Vine
47Distribution: Vine Linux
48
49%description
50ProFTPd is an enhanced FTP server with a focus toward simplicity,
51security, and ease of configuration.  It features a very Apache-like
52configuration syntax, and a highly customizable server infrastructure,
53including support for multiple 'virtual' FTP servers, anonymous FTP,
54and permission-based directory visibility.
55
56%description -l ja
57ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
58FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
59anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
60高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
61
62%prep
63%setup -q -n %{name}-%{tarballversion}
64find . -type d -name CVS | xargs -r rm -frv
65
66# upstream fixes
67
68## patches from mdk
69# use system-auth instaed of pam_pwdb
70%patch201 -p1
71
72# iconv patch (CharsetLocal/CharsetRemote)
73%patch300 -p1
74
75# fix build on recent kernel headers
76# %patch400 -p0
77
78# security fixes
79%patch1000 -p1 -b .ZDI-CAN-925
80
81%build
82# Disable stripping in order to get useful debuginfo packages
83%{__perl} -pi -e 's|"-s"|""|g' configure
84
85%configure \
86    --libexecdir="%{_libexecdir}/proftpd" \
87    --localstatedir="%{_var}/run" \
88    --enable-ctrls \
89    --enable-facl \
90    --enable-dso \
91    --enable-ipv6 \
92    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
93mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
94    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
95
96# It seems that with _smp_mflags -lsupp tries to get linked before being built
97# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
98%{__make}
99
100
101%install
102%{__rm} -rf %{buildroot}
103%{__make} install DESTDIR=%{buildroot} \
104    rundir="%{_var}/run/proftpd" \
105    INSTALL_USER=`id -un` \
106    INSTALL_GROUP=`id -gn`
107
108# auth
109mkdir -p %{buildroot}%{_sysconfdir}/pam.d
110%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
111
112# logrotate
113mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
114%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
115
116# init.d
117%{__install} -D -p -m 0755 %{SOURCE3} \
118    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
119
120%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
121%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
122%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
123
124touch %{buildroot}%{_sysconfdir}/ftpusers
125
126rm contrib/README.* || :
127# eliminate executable bit in %doc
128find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
129
130# remove .{la,a}
131rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
132
133# remove development files (headers and pkgconfig file)
134# who need these files?
135rm -rf %{buildroot}%{_includedir}/proftpd
136rm -rf %{buildroot}%{_libdir}/pkgconfig
137
138%preun
139if [ -d %{_rundir} ] ; then
140        rm -rf %{_rundir}/*
141fi
142
143if [ $1 = 0 ] ; then
144        /sbin/chkconfig --del proftpd
145fi
146
147%postun
148if [ $1 -ge 1 ]; then
149    /sbin/service proftpd condrestart
150fi
151
152%post
153/sbin/chkconfig --add proftpd
154
155
156%clean
157rm -rf %{buildroot}
158
159%files
160%defattr(-,root,root)
161%doc COPYING CREDITS ChangeLog INSTALL NEWS
162%doc README.{LDAP,PAM,modules} doc/*
163%doc contrib/README contrib/xferstats.holger-preiss
164%doc sample-configurations/
165%{_sbindir}/*
166%{_bindir}/*
167%{_mandir}/*/*
168%{_var}/ftp/welcome.msg
169%dir %{_libexecdir}/proftpd/
170%{_libexecdir}/proftpd/mod_*
171%dir %{_rundir}
172%dir %{_var}/ftp
173%config %{_sysconfdir}/rc.d/init.d/proftpd
174%config(noreplace) %{_sysconfdir}/pam.d/ftp
175%config(noreplace) %{_sysconfdir}/proftpd.conf
176%config(noreplace) %{_sysconfdir}/ftpusers
177%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
178
179
180%changelog
181* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
182- new upstream release
183- add patch1000 for CVE-2010-4221 (TELNET_IAC)
184- add BRs: ncurses-devel, libcap-devel, libacl-devel
185
186* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
187- new upstream release with security fix (CVE-2009-3555)
188
189* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
190- new upstream release with security fix (NULL char in X.509 certificate)
191- add chkconfig --add in post script
192
193* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
194- remove .{la,a}
195- remove headers and pkgconfig file
196
197* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
198- update Source1 (sample config file for vine)
199  set default char set to UTF-8
200
201* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
202- new upstream release
203
204* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
205- rebuild with openldap-2.4.11
206
207* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
208- built with openssl-0.9.8k
209
210* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
211- new upstream release
212- add configure option to activate new modules
213- drop patch400
214
215* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
216- built with openssl-0.9.8j
217
218* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
219- built with openssl-0.9.8i
220
221* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
222- add Patch400 to fix build failure at least on i386
223- spec in UTF-8
224
225* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
226- built with openssl-0.9.8h
227
228* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
229- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
230
231* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
232- new upstream release
233- drop old patches which are included in new release
234- update patch201, 300
235- build under new versioning policy
236
237* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
238- new upstream release
239- built with openssl098
240- drop old (for 1.2.10) patches
241- Patch100-150 from FC8 package
242- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
243- update patch300 for 1.3.0
244- change configure option refer to FC8
245- add process reboot with message output when package is upgraded
246- docfiles list update
247- fix changelog ver number typo
248
249* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
250- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
251  (<WISHES:15>)
252- add Vendor/Distribution tag
253- add patch104 for fix pr_ctrls_recv_request issue
254- add patch103 for fix CVE-2006-6170
255- add patch102 for fix CVE-2006-5815
256- add patch101 for fix CVE-2006-6171
257
258* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
259- rebuilt with openldap-2.3.27-0vl
260
261* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
262- rebuilt with openldap-2.3.24-0vl1
263
264* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
265- add patch300 for iconv patch
266
267* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
268- enable mod_ldap
269- add BuildRequires: openldap-devel, openssl-devel
270- add Patch200 from MDK to support ldap
271- add Patch201 from MDK to use system-auth instead of pam_pwdb
272  (pam_pwdb is now obsolete, and will be removed in the future pam version)
273
274* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
275- 1.2.10-0vl1.1
276- add patch100 for fix CAN-2005-2390
277
278* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
279- new upstream release
280
281* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
282- new upstream release (1.2.10rc3)
283- build for Vine Linux 3.0
284
285* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
286- new upstream release
287- fix security issue: http://secunia.com/advisories/11527/
288
289* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
290- new upstream release
291
292* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
293- new upstream release
294- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
295
296* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
297- new upstream release
298
299* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
300- new upstream release 1.2.7
301- add logrotate config file.
302- move ftp home directory from /home/ftp to /var/ftp
303
304* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
305- new upstream release 1.2.6
306
307* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
308- new upstream release 1.2.5 (stable release version)
309
310* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
311- new upstream release 1.2.5-rc3
312
313* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
314- eliminate executable bit in %doc (requierment for /usr/bin/perl)
315- put files in sample-configurations/ to the according directory
316- remove unnecessary README.* files
317
318* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
319- updated to 1.2.5rc1 for problems in file globbing
320
321* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
322- 1.2.4-0vl1
323
324* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
325- 1.2.3-0vl1
326
327* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
328- 1.2.2-0vl1: update to 1.2.2 release
329- added more documents
330
331* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
332- update to 1.2.2rc3
333- use macros
334
335* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
336- 1.2.1-0vl3
337- rebuilt for VineSeed
338
339* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
340- update to 1.2.1
341
342* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
343- build for VineSeed
344
345* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
346- update to 1.2.0
347- set Epoch 1 to update from pre* and rc* version
348 
349* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
350- 1.2.0rc3-0vl3
351- removed PreReq and postun about /etc/ftpusers stuff
352
353* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
354- remove setup of /etc/ftpusers in %%pre script
355- add ftpusers.vine insted of the %%pre script
356- remove contrib/README.* frpm %%files
357- add BuildRequires: pam-devel
358
359* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
360- rebuild for VineSeed
361
362* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
363- update to 1.2.0rc3
364- add 'TimesGMT FALSE' in default configuration file
365- build on Vine 2.1
366
367* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
368- modified pre script to make it run by bash2 and added PreReq
369- remove /etc/ftpusers after uninstall
370
371* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
372- 1.2.0rc2-0vl8
373- rebuilt on VineSeed
374
375* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
376- remove patch from CVS to avoid 'after 5min data brake'
377- add passive patch insted of abobe CVS patch
378- revival contribute's proftpd.init.d
379
380* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
381- fixed %pre script and remove /etc/ftpusers from files
382- modify Japanese summary and descriptions
383
384* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
385- actually fixed to make the package relocatable.
386- non-root build failure by broken %prein, which should be %pre.
387- dont include CVS directory in doc
388- add %config /etc/rc.d/init.d/proftpd
389
390* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
391- correct config directive of the init.d script
392
393* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
394- adopt current patch from CVS to avoid the 'put on passive mode' probrem
395
396* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
397- 1.2.0rc2-0vl1
398- obsoletes anonftp
399- do not chkconfig --add in %post
400- requires: pam
401- added proftpd.vine.conf
402
403* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
404- libtoolize for alpha
405
406* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
407- [1.2.0rc2]
408
409* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
410- repackaging for VineLinux
411
412* Thu Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
413- Multi package creation.
414  Created core, standalone, inetd (&doc) package creations.
415  Added startup script for init.d
416  Need to make the "standalone & inetd" packages being created as "noarch"
417- Added URL.
418- Added prefix to make the package relocatable.
419
420* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
421- Corrected inetd.conf line addition/change logic.
422
423* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
424- Initial import of spec.
425
Note: See TracBrowser for help on using the repository browser.