source: projects/specs/trunk/p/proftpd/proftpd-vl.spec @ 521

Revision 521, 12.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.2c
6%define origversion     1.3.2c
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 1%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/%{name}-%{origversion}.tar.bz2
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25
26# auth
27Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
28
29# iconv patch (CharsetLocal/CharsetRemote)
30# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
31Patch300: proftpd-1.3.1-iconv.patch.bz2
32
33# fix build on recent kernel headers
34# Patch400: proftpd-1.3.1-umode.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37BuildRequires: pam-devel, openldap-devel, openssl-devel
38Requires: pam > 0.59
39Obsoletes: wu-ftpd, anonftp
40Provides: ftpserver
41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%description
46ProFTPd is an enhanced FTP server with a focus toward simplicity,
47security, and ease of configuration.  It features a very Apache-like
48configuration syntax, and a highly customizable server infrastructure,
49including support for multiple 'virtual' FTP servers, anonymous FTP,
50and permission-based directory visibility.
51
52%description -l ja
53ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
54FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
55anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
56高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
57
58%prep
59%setup -q -n %{name}-%{tarballversion}
60find . -type d -name CVS | xargs -r rm -frv
61
62# upstream fixes
63
64## patches from mdk
65# use system-auth instaed of pam_pwdb
66%patch201 -p1
67
68# iconv patch (CharsetLocal/CharsetRemote)
69%patch300 -p1
70
71# fix build on recent kernel headers
72# %patch400 -p0
73
74%build
75# Disable stripping in order to get useful debuginfo packages
76%{__perl} -pi -e 's|"-s"|""|g' configure
77
78%configure \
79    --libexecdir="%{_libexecdir}/proftpd" \
80    --localstatedir="%{_var}/run" \
81    --enable-ctrls \
82    --enable-facl \
83    --enable-dso \
84    --enable-ipv6 \
85    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
86mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
87    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
88
89# It seems that with _smp_mflags -lsupp tries to get linked before being built
90# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
91%{__make}
92
93
94%install
95%{__rm} -rf %{buildroot}
96%{__make} install DESTDIR=%{buildroot} \
97    rundir="%{_var}/run/proftpd" \
98    INSTALL_USER=`id -un` \
99    INSTALL_GROUP=`id -gn`
100
101# auth
102mkdir -p %{buildroot}%{_sysconfdir}/pam.d
103%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
104
105# logrotate
106mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
107%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
108
109# init.d
110%{__install} -D -p -m 0755 %{SOURCE3} \
111    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
112
113%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
114%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
115%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
116
117touch %{buildroot}%{_sysconfdir}/ftpusers
118
119rm contrib/README.* || :
120# eliminate executable bit in %doc
121find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
122
123# remove .{la,a}
124rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
125
126# remove development files (headers and pkgconfig file)
127# who need these files?
128rm -rf %{buildroot}%{_includedir}/proftpd
129rm -rf %{buildroot}%{_libdir}/pkgconfig
130
131%preun
132if [ -d %{_rundir} ] ; then
133        rm -rf %{_rundir}/*
134fi
135
136if [ $1 = 0 ] ; then
137        /sbin/chkconfig --del proftpd
138fi
139
140%postun
141if [ $1 -ge 1 ]; then
142    /sbin/service proftpd condrestart
143fi
144
145%post
146/sbin/chkconfig --add proftpd
147
148
149%clean
150rm -rf %{buildroot}
151
152%files
153%defattr(-,root,root)
154%doc COPYING CREDITS ChangeLog INSTALL NEWS
155%doc README.{LDAP,PAM,modules} doc/*
156%doc contrib/README contrib/xferstats.holger-preiss
157%doc sample-configurations/
158%{_sbindir}/*
159%{_bindir}/*
160%{_mandir}/*/*
161%{_var}/ftp/welcome.msg
162%dir %{_libexecdir}/proftpd/
163%{_libexecdir}/proftpd/mod_*
164%dir %{_rundir}
165%dir %{_var}/ftp
166%config %{_sysconfdir}/rc.d/init.d/proftpd
167%config(noreplace) %{_sysconfdir}/pam.d/ftp
168%config(noreplace) %{_sysconfdir}/proftpd.conf
169%config(noreplace) %{_sysconfdir}/ftpusers
170%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
171
172
173%changelog
174* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
175- new upstream release with security fix (CVE-2009-3555)
176
177* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
178- new upstream release with security fix (NULL char in X.509 certificate)
179- add chkconfig --add in post script
180
181* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
182- remove .{la,a}
183- remove headers and pkgconfig file
184
185* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
186- update Source1 (sample config file for vine)
187  set default char set to UTF-8
188
189* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
190- new upstream release
191
192* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
193- rebuild with openldap-2.4.11
194
195* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
196- built with openssl-0.9.8k
197
198* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
199- new upstream release
200- add configure option to activate new modules
201- drop patch400
202
203* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
204- built with openssl-0.9.8j
205
206* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
207- built with openssl-0.9.8i
208
209* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
210- add Patch400 to fix build failure at least on i386
211- spec in UTF-8
212
213* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
214- built with openssl-0.9.8h
215
216* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
217- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
218
219* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
220- new upstream release
221- drop old patches which are included in new release
222- update patch201, 300
223- build under new versioning policy
224
225* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
226- new upstream release
227- built with openssl098
228- drop old (for 1.2.10) patches
229- Patch100-150 from FC8 package
230- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
231- update patch300 for 1.3.0
232- change configure option refer to FC8
233- add process reboot with message output when package is upgraded
234- docfiles list update
235- fix changelog ver number typo
236
237* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
238- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
239  (<WISHES:15>)
240- add Vendor/Distribution tag
241- add patch104 for fix pr_ctrls_recv_request issue
242- add patch103 for fix CVE-2006-6170
243- add patch102 for fix CVE-2006-5815
244- add patch101 for fix CVE-2006-6171
245
246* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
247- rebuilt with openldap-2.3.27-0vl
248
249* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
250- rebuilt with openldap-2.3.24-0vl1
251
252* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
253- add patch300 for iconv patch
254
255* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
256- enable mod_ldap
257- add BuildRequires: openldap-devel, openssl-devel
258- add Patch200 from MDK to support ldap
259- add Patch201 from MDK to use system-auth instead of pam_pwdb
260  (pam_pwdb is now obsolete, and will be removed in the future pam version)
261
262* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
263- 1.2.10-0vl1.1
264- add patch100 for fix CAN-2005-2390
265
266* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
267- new upstream release
268
269* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
270- new upstream release (1.2.10rc3)
271- build for Vine Linux 3.0
272
273* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
274- new upstream release
275- fix security issue: http://secunia.com/advisories/11527/
276
277* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
278- new upstream release
279
280* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
281- new upstream release
282- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
283
284* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
285- new upstream release
286
287* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
288- new upstream release 1.2.7
289- add logrotate config file.
290- move ftp home directory from /home/ftp to /var/ftp
291
292* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
293- new upstream release 1.2.6
294
295* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
296- new upstream release 1.2.5 (stable release version)
297
298* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
299- new upstream release 1.2.5-rc3
300
301* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
302- eliminate executable bit in %doc (requierment for /usr/bin/perl)
303- put files in sample-configurations/ to the according directory
304- remove unnecessary README.* files
305
306* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
307- updated to 1.2.5rc1 for problems in file globbing
308
309* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
310- 1.2.4-0vl1
311
312* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
313- 1.2.3-0vl1
314
315* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
316- 1.2.2-0vl1: update to 1.2.2 release
317- added more documents
318
319* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
320- update to 1.2.2rc3
321- use macros
322
323* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
324- 1.2.1-0vl3
325- rebuilt for VineSeed
326
327* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
328- update to 1.2.1
329
330* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
331- build for VineSeed
332
333* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
334- update to 1.2.0
335- set Epoch 1 to update from pre* and rc* version
336 
337* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
338- 1.2.0rc3-0vl3
339- removed PreReq and postun about /etc/ftpusers stuff
340
341* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
342- remove setup of /etc/ftpusers in %%pre script
343- add ftpusers.vine insted of the %%pre script
344- remove contrib/README.* frpm %%files
345- add BuildRequires: pam-devel
346
347* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
348- rebuild for VineSeed
349
350* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
351- update to 1.2.0rc3
352- add 'TimesGMT FALSE' in default configuration file
353- build on Vine 2.1
354
355* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
356- modified pre script to make it run by bash2 and added PreReq
357- remove /etc/ftpusers after uninstall
358
359* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
360- 1.2.0rc2-0vl8
361- rebuilt on VineSeed
362
363* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
364- remove patch from CVS to avoid 'after 5min data brake'
365- add passive patch insted of abobe CVS patch
366- revival contribute's proftpd.init.d
367
368* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
369- fixed %pre script and remove /etc/ftpusers from files
370- modify Japanese summary and descriptions
371
372* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
373- actually fixed to make the package relocatable.
374- non-root build failure by broken %prein, which should be %pre.
375- dont include CVS directory in doc
376- add %config /etc/rc.d/init.d/proftpd
377
378* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
379- correct config directive of the init.d script
380
381* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
382- adopt current patch from CVS to avoid the 'put on passive mode' probrem
383
384* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
385- 1.2.0rc2-0vl1
386- obsoletes anonftp
387- do not chkconfig --add in %post
388- requires: pam
389- added proftpd.vine.conf
390
391* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
392- libtoolize for alpha
393
394* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
395- [1.2.0rc2]
396
397* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
398- repackaging for VineLinux
399
400* Thu Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
401- Multi package creation.
402  Created core, standalone, inetd (&doc) package creations.
403  Added startup script for init.d
404  Need to make the "standalone & inetd" packages being created as "noarch"
405- Added URL.
406- Added prefix to make the package relocatable.
407
408* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
409- Corrected inetd.conf line addition/change logic.
410
411* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
412- Initial import of spec.
413
Note: See TracBrowser for help on using the repository browser.