source: projects/specs/trunk/p/procps/procps-vl.spec @ 9617

Revision 9617, 12.9 KB checked in by tomop, 9 years ago (diff)

procps-3.3.10-1

Line 
1%define origname procps-ng
2
3Summary: System and process monitoring utilities.
4Name: procps
5Version: 3.3.10
6Release: 1%{?_dist_release}
7License: GPL
8Group: Applications/System
9Url: http://sourceforge.net/projects/procps-ng/
10Source: %{origname}-%{version}.tar.xz
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12Requires(post): /sbin/ldconfig, /bin/rm
13Requires(postun): /sbin/ldconfig
14Obsoletes: procps-X11, pgrep
15
16# Vine patches
17Patch10: procps-ng-3.3.10-po-fix.patch
18Source10: procps-ng-3.3.10-ja.po
19
20BuildRequires: ncurses-devel
21
22Vendor:       Project Vine
23Distribution: Vine Linux
24Packager: daisuke
25
26%description
27The procps package contains a set of system utilities that provide
28system information. Procps includes ps, free, skill, snice, tload,
29top, uptime, vmstat, w, and watch. The ps command displays a snapshot
30of running processes. The top command provides a repetitive update of
31the statuses of running processes. The free command displays the
32amounts of free and used memory on your system. The skill command
33sends a terminate command (or another specified signal) to a specified
34set of processes. The snice command is used to change the scheduling
35priority of specified processes. The tload command prints a graph of
36the current system load average to a specified tty. The uptime command
37displays the current time, how long the system has been running, how
38many users are logged on, and system load averages for the past one,
39five, and fifteen minutes. The w command displays a list of the users
40who are currently logged on and what they are running. The watch
41program watches a running program. The vmstat command displays virtual
42memory statistics about processes, memory, paging, block I/O, traps,
43and CPU activity.
44
45%description -l ja
46システムの状態を知るためのユーティリティ集です. 実行中のプロセス, 使用
47可能なメモリ容量, 現在ログインしているユーザの情報等を得ることができます.
48
49%package devel
50Summary:  System and process monitoring utilities
51Group:    Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55System and process monitoring utilities development headers
56
57%prep
58%setup -q -n %{origname}-%{version}
59
60# vine
61%patch10 -p1 -b .fix
62cp -f %{SOURCE10} po/ja.po
63
64echo "ja" > po/LINGUAS
65
66%build
67autoreconf --verbose --force --install
68./configure --prefix=/ \
69            --bindir=%{_bindir} \
70            --sbindir=%{_syssbindir} \
71            --libdir=%{_libdir} \
72            --datadir=%{_datadir} \
73            --localedir=%{_datadir}/locale \
74            --mandir=%{_mandir} \
75            --includedir=%{_includedir} \
76            --sysconfdir=%{_sysconfdir} \
77            --docdir=/unwanted \
78            --disable-static \
79            --disable-w-from \
80            --disable-kill \
81            --enable-watch8bit \
82            --enable-skill \
83            --enable-sigwinch \
84            --disable-libselinux \
85            --without-systemd
86
87make CFLAGS="%{optflags}"
88
89make -C po update-po
90make -C po ja.gmo
91
92%install
93make DESTDIR=%{buildroot} install
94make DESTDIR=%{buildroot} -C po install
95
96mkdir -p %{buildroot}%{_sysconfdir}/sysctl.d
97
98# for compatibility
99mkdir -p %{buildroot}%{_sysbindir}
100mv %{buildroot}%{_bindir}/ps %{buildroot}%{_sysbindir}/
101ln -sf %{_sysbindir}/ps %{buildroot}%{_bindir}/ps
102
103rm -f %{buildroot}/%{_libdir}/libprocps.la
104rm -rf %{buildroot}/unwanted
105rm -f %{buildroot}%{_bindir}/pidof
106
107%clean
108rm -rf %{buildroot}
109
110%post -p /sbin/ldconfig
111
112%postun -p /sbin/ldconfig
113
114%files
115%defattr(-,root,root,-)
116%doc AUTHORS Documentation/BUGS COPYING COPYING.LIB Documentation/FAQ NEWS README top/README.top Documentation/TODO
117%{_libdir}/libprocps.so.*
118%{_bindir}/*
119%{_sysbindir}/*
120%{_syssbindir}/*
121%{_sysconfdir}/sysctl.d
122%{_mandir}/man1/*
123%{_mandir}/man8/*
124%{_mandir}/man5/*
125%{_localedir}/ja/LC_MESSAGES/*.mo
126
127%files devel
128%defattr(-,root,root,-)
129%doc COPYING COPYING.LIB
130%{_libdir}/libprocps.so
131%{_libdir}/pkgconfig/libprocps.pc
132%{_includedir}/proc
133
134%changelog
135* Sat Jun 20 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-1
136- new upstream release.
137- updated Source10 and Patch10.
138
139* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.9-1
140- update to forked version of procps 3.3.9
141- add minimum ja.po
142
143* Sat Sep 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
144- update to 3.2.8
145- add patch30 to fix top highlight bug
146  (thanks to <BTS:916>)
147
148* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-2
149- spec in utf-8
150
151* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
152- new upstream release
153
154* Wed Sep 20 2006 IWAI, Masaharu <iwai@alib.jp> 3.2.6-0vl3
155- [BTS:205] update ja.po ( in Patch20 )
156
157* Tue Feb 14 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl2
158- add Obsoletes: pgrep
159
160* Sun Feb 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl1
161- upstream release
162- update Patch20
163- fix encode of spec file (SJIS -> EUC-JP)
164- add pwdx command (new from 3.2.4)
165
166* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl3
167- update gettext patch
168
169* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl2
170- add gettext patch (Patch20)
171  still needs more work ( only for "free" and "uptime" )
172
173* Sun Feb 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl1
174- new upstream release
175
176* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.0-1vl1
177- modified for Vine
178- add obsoletes -X11 package
179
180* Tue Feb 24 2004 Dan Walsh <dwalsh@redhat.com> 3.2.0-1
181- New version from upstream
182
183* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
184- rebuilt
185
186* Thu Jan 22 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-3
187- Match -Z to --context
188
189* Wed Jan 21 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-2
190- Add back in -Z support
191
192* Wed Jan 21 2004 Alexander Larsson <alexl@redhat.com> 3.1.15-1
193- upgrade to procps3
194- Some regressions, see bug #114012
195
196* Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 2.0.17-7
197- Remove LIBCURSES from skill and sysctl
198
199* Wed Dec  10 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-6
200- Turn on SELinux
201
202* Mon Dec  8 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-5
203- Fix top total percentages (#109484)
204
205* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-4
206- Turn off selinux
207
208* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-3.sel
209- Fix help message
210
211* Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-2.sel
212- Turn on selinux
213
214* Fri Oct  3 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-1
215- Update to 2.0.17, drop upstream patches, forward port remaining patches
216
217* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-11
218- Turn off selinux
219
220* Thu Aug 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-10.sel
221- Add -Z switch for SELinux
222
223* Sun Aug 17 2003 Doug Ledford <dledford@redhat.com> 2.0.13-9E
224- Add patch to recognize irq and softirq time accounting in kernels that
225  support this feature
226
227* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-8
228- rebuild
229
230* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-7E
231- Add swapped patch from rik van riel
232
233* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-6
234- rebuild
235
236* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-5E
237- Update iowait patch (#101657)
238- Add wchan 64bit patch from Mark DeWandel
239
240* Mon Jul 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-4E
241- Add SELinux patch
242
243* Wed Jul 16 2003 Matt Wilson <msw@redhat.com> 2.0.13-3E
244- display iowait with procps-2.0.13-iowait.patch (#99061)
245
246* Fri Jul 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-2E
247- Disable linuxthreads thread hack
248
249* Mon Jul  7 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1E
250- rebuild
251
252* Fri Jul  4 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1
253- update to 2.0.13
254- Re-merged ntpl patch
255- Add hertz fix from Ernie Petrides <petrides@redhat.com>
256
257* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
258- rebuilt
259
260* Fri May 23 2003 Alexander Larsson <alexl@redhat.com> 2.0.12-1
261- Update to 2.0.12
262- Add patch to fix segfault on ps axl (#91453)
263
264* Fri Mar 14 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-7
265- Add patch that fixes negative priorities in top.
266
267* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-6
268- New NPTL patch:
269- Added skipthreads optimization to top
270- Don't read threads in 'w'
271
272* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-5
273- Update the NPTL patch since the kernel /proc was fixed
274- For kernels >= 2.4.20-2.50
275
276* Mon Feb 17 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-4
277- Update nptl patch to new /proc layout.
278
279* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.11-3
280- rebuilt
281
282* Wed Jan 22 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-2
283- Created nptl patch after discussion with ingo and arjan
284
285* Tue Jan 21 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-1
286- Update to 2.0.11
287
288* Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 2.0.10-4
289- Fix %%install in changelog
290
291* Tue Nov 19 2002 Jakub Jelinek <jakub@redhat.com> 2.0.10-3
292- Fix for Hammer
293
294* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-2
295- Remove uninstalled files in %%install. Add pmap to %%files
296
297* Tue Oct  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-1
298- Update to 2.0.10
299- Removed applied patches.
300
301* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-25
302- Add patch to protect against idle ticks going backwards. Fixes #71237
303
304* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-24
305- Fix saving of sort, fixes #32757
306- Fix printing size, fixes #48224
307- Fix float decimal point input #58163
308
309* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-23
310- Fix unsigned/signed bug. Closes #60998.
311- Update threadbadhack to correctly propagate process time to the main thread.
312
313* Wed Aug  7 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-22
314- Don't strip binaries
315
316* Fri Jul 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-21
317- Remove the X11 subpackage
318
319* Mon Jul  1 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-19
320- Added patch that fixes #35174
321
322* Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-18
323- New thread badhack patch. Fixes a segfault.
324
325* Mon Jun 24 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-16
326- New thread badhack. Now enabled by default.
327
328* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
329- automated rebuild
330
331* Thu Jun 20 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-14
332- Added badhack to support hiding threads
333
334* Thu May 23 2002 Tim Powers <timp@redhat.com>
335- automated rebuild
336
337* Mon Apr 15 2002 Bill Nottingham <notting@redhat.com> 2.0.7-12
338- add ldconfig in %postun
339
340* Mon Aug 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 2.0.7-11
341- Add ncurses-devel as a build dependency (#49562)
342
343* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
344- removed applnk entry, one of the things that's cluttering our menus
345
346* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
347- Bump release + rebuild.
348
349* Thu Apr  5 2001 Jakub Jelinek <jakub@redhat.com>
350- fix AIX style user defined formats (#34833)
351
352* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
353- add a '-e' to sysctl to ignore errors (#31852)
354
355* Mon Mar  5 2001 Preston Brown <pbrown@redhat.com>
356- bigger buffer for reading /proc/stat fixes segfault (#27840)
357
358* Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
359- make sysctl return a value when errors occur (#18820).
360- support big UIDs (#22683)
361
362* Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
363- work-around for negative CPU output (Bug #18380)
364
365* Thu Aug 17 2000 Than Ngo <than@redhat.com>
366- fix failing in RPM post script (Bug #16226)
367
368* Wed Jul 26 2000 Michael K. Johnson <johnsonm@redhat.com>
369- Added Jakub's locale patch
370
371* Fri Jul 14 2000 Michael K. Johnson <johnsonm@redhat.com>
372- procps-2.0.7
373- integrated all patches except for signames patch, which is broken
374  and unnecessary
375- See NEWS for changes between 2.0.6 and 2.0.7
376- Added patch to correctly install desktop file.  Oops.
377
378* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
379- automatic rebuild
380
381* Mon Jul 03 2000 Preston Brown <pbrown@redhat.com>
382- larger buffers for reading /proc/stat
383
384* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
385- FHS paths
386
387* Tue May 30 2000 Preston Brown <pbrown@redhat.com>
388- add smp, signal name patches from VA Linux.  Thanks guys.
389
390* Mon May 22 2000 Harald Hoyer <harald@redhat.com>
391- added sysctl.conf (5) man page
392
393* Wed May 10 2000 Bill Nottingham <notting@redhat.com>
394- fix PAGE_SIZE mismatch on ia64
395
396* Sun May  7 2000 Bill Nottingham <notting@redhat.com>
397- rebuild with different optimizations for ia64
398
399* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
400- rebuild with current ncurses
401
402* Tue Mar  7 2000 Bill Nottingham <notting@redhat.com>
403- fix end-of-file behavior in sysctl
404
405* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
406- wmconfig -> desktop
407
408* Mon Feb  7 2000 Jakub Jelinek <jakub@redhat.com>
409- don't try to load System.map (and spit error messages if it does not
410  exist) if ps or top are not going to use it, both to speed things up
411  and remove the ugly messages when they don't make sense.
412- in top, print the possible error messages using standard top SHOWMESSAGE
413  (because it will be now printed out when already in terminal mode).
414
415* Thu Feb  3 2000 Matt Wilson <msw@redhat.com>
416- added patch to prevent divide by zero on UltraSparc
417- gzip man pages
418
Note: See TracBrowser for help on using the repository browser.