source: projects/specs/trunk/p/procps/procps-vl.spec @ 12379

Revision 12379, 13.9 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

authconfig-7.0.1-2

nmap-7.80-1

php74-7.4.5-1

procps-3.3.16-1

rubygem-json-2.3.0-2

wget-1.20.3-1

Line 
1%bcond_with systemd
2
3%define origname procps-ng
4
5Summary: System and process monitoring utilities.
6Summary(ja): システムやプロセスのモニタリングユーティリティ
7Name: procps
8Version: 3.3.16
9Release: 1%{?_dist_release}%{?with_systemd:.systemd}
10Group: Applications/System
11Vendor: Project Vine
12Distribution: Vine Linux
13Packager: daisuke
14
15License: GPL
16Url: https://gitlab.com/procps-ng/procps
17# alternative: http://sourceforge.net/projects/procps-ng/
18Source: https://downloads.sourceforge.net/project/procps-ng/Production/%{origname}-%{version}.tar.xz
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20Requires(post): /sbin/ldconfig, /bin/rm
21Requires(postun): /sbin/ldconfig
22Obsoletes: procps-X11, pgrep
23
24# Vine source/patches
25Source10: procps-ng-3.3.10-ja.po
26
27BuildRequires: ncurses-devel
28%if %{with systemd}
29BuildRequires: systemd-devel
30%else
31BuildRequires: elogind-devel
32%endif
33
34%description
35The procps package contains a set of system utilities that provide
36system information. Procps includes ps, free, skill, snice, tload,
37top, uptime, vmstat, w, and watch. The ps command displays a snapshot
38of running processes. The top command provides a repetitive update of
39the statuses of running processes. The free command displays the
40amounts of free and used memory on your system. The skill command
41sends a terminate command (or another specified signal) to a specified
42set of processes. The snice command is used to change the scheduling
43priority of specified processes. The tload command prints a graph of
44the current system load average to a specified tty. The uptime command
45displays the current time, how long the system has been running, how
46many users are logged on, and system load averages for the past one,
47five, and fifteen minutes. The w command displays a list of the users
48who are currently logged on and what they are running. The watch
49program watches a running program. The vmstat command displays virtual
50memory statistics about processes, memory, paging, block I/O, traps,
51and CPU activity.
52
53%description -l ja
54システムの状態を知るためのユーティリティ集です. 実行中のプロセス, 使用
55可能なメモリ容量, 現在ログインしているユーザの情報等を得ることができます.
56
57%package devel
58Summary:     System and process monitoring utilities
59Summary(ja): procpsを利用した開発に必要なファイル
60Group:       Development/Libraries
61Requires:    %{name} = %{version}-%{release}
62
63%description devel
64System and process monitoring utilities development headers
65
66%description devel -l ja
67 このパッケージにはprocpsを利用した開発に必要なヘッダ・ライブラリファイル
68が収録されています。
69
70%prep
71%setup -q -n %{origname}-%{version}
72
73# vine
74cp -f %{SOURCE10} po/ja.po
75
76#echo "ja" > po/LINGUAS
77
78%build
79autoreconf --verbose --force --install
80./configure --prefix=/ \
81            --bindir=%{_bindir} \
82            --sbindir=%{_syssbindir} \
83            --libdir=%{_libdir} \
84            --datadir=%{_datadir} \
85            --localedir=%{_datadir}/locale \
86            --mandir=%{_mandir} \
87            --includedir=%{_includedir} \
88            --sysconfdir=%{_sysconfdir} \
89            --docdir=/unwanted \
90            --disable-static \
91            --disable-w-from \
92            --disable-kill \
93            --enable-watch8bit \
94            --enable-skill \
95            --enable-sigwinch \
96            --disable-libselinux \
97%if %{with systemd}
98            --with-systemd
99%else
100            --without-systemd \
101            --with-elogind
102%endif
103
104make CFLAGS="%{optflags}"
105
106sed -i -e 's|/procps-ng-.*-dirty/|/|' po/Makefile
107sed -i -e 's|^procps-ng-.*-dirty/||' po/POTFILES.in
108
109make -C po update-po
110make -C po ja.gmo
111
112%install
113make DESTDIR=%{buildroot} install
114make DESTDIR=%{buildroot} -C po install
115
116mkdir -p %{buildroot}%{_sysconfdir}/sysctl.d
117
118# for compatibility
119mkdir -p %{buildroot}%{_sysbindir}
120mv %{buildroot}%{_bindir}/ps %{buildroot}%{_sysbindir}/
121ln -sf %{_sysbindir}/ps %{buildroot}%{_bindir}/ps
122
123rm -f %{buildroot}/%{_libdir}/libprocps.la
124rm -rf %{buildroot}/unwanted
125rm -f %{buildroot}%{_bindir}/pidof
126
127%find_lang procps-ng
128
129%clean
130rm -rf %{buildroot}
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136%files -f procps-ng.lang
137%defattr(-,root,root,-)
138%license COPYING COPYING.LIB
139%doc AUTHORS NEWS README*
140%{_libdir}/libprocps.so.*
141%{_bindir}/*
142%{_sysbindir}/*
143%{_syssbindir}/*
144%{_sysconfdir}/sysctl.d
145%{_mandir}/man1/*
146%{_mandir}/man3/*
147%{_mandir}/man8/*
148%{_mandir}/man5/*
149
150%files devel
151%defattr(-,root,root,-)
152%doc COPYING COPYING.LIB
153%{_libdir}/libprocps.so
154%{_libdir}/pkgconfig/libprocps.pc
155%{_includedir}/proc
156
157%changelog
158* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.16-1
159- new upstream release.
160- added systemd support (disabled as default).
161
162* Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.15-1
163- new upstream release.
164- enabled elogind.
165- added japanese summary.
166
167* Sun Jun 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-2
168- fixed Source10.
169
170* Sat Jun 20 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-1
171- new upstream release.
172- updated Source10 and Patch10.
173
174* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.9-1
175- update to forked version of procps 3.3.9
176- add minimum ja.po
177
178* Sat Sep 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
179- update to 3.2.8
180- add patch30 to fix top highlight bug
181  (thanks to <BTS:916>)
182
183* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-2
184- spec in utf-8
185
186* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
187- new upstream release
188
189* Wed Sep 20 2006 IWAI, Masaharu <iwai@alib.jp> 3.2.6-0vl3
190- [BTS:205] update ja.po ( in Patch20 )
191
192* Tue Feb 14 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl2
193- add Obsoletes: pgrep
194
195* Sun Feb 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl1
196- upstream release
197- update Patch20
198- fix encode of spec file (SJIS -> EUC-JP)
199- add pwdx command (new from 3.2.4)
200
201* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl3
202- update gettext patch
203
204* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl2
205- add gettext patch (Patch20)
206  still needs more work ( only for "free" and "uptime" )
207
208* Sun Feb 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl1
209- new upstream release
210
211* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.0-1vl1
212- modified for Vine
213- add obsoletes -X11 package
214
215* Tue Feb 24 2004 Dan Walsh <dwalsh@redhat.com> 3.2.0-1
216- New version from upstream
217
218* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
219- rebuilt
220
221* Thu Jan 22 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-3
222- Match -Z to --context
223
224* Wed Jan 21 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-2
225- Add back in -Z support
226
227* Wed Jan 21 2004 Alexander Larsson <alexl@redhat.com> 3.1.15-1
228- upgrade to procps3
229- Some regressions, see bug #114012
230
231* Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 2.0.17-7
232- Remove LIBCURSES from skill and sysctl
233
234* Wed Dec  10 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-6
235- Turn on SELinux
236
237* Mon Dec  8 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-5
238- Fix top total percentages (#109484)
239
240* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-4
241- Turn off selinux
242
243* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-3.sel
244- Fix help message
245
246* Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-2.sel
247- Turn on selinux
248
249* Fri Oct  3 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-1
250- Update to 2.0.17, drop upstream patches, forward port remaining patches
251
252* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-11
253- Turn off selinux
254
255* Thu Aug 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-10.sel
256- Add -Z switch for SELinux
257
258* Sun Aug 17 2003 Doug Ledford <dledford@redhat.com> 2.0.13-9E
259- Add patch to recognize irq and softirq time accounting in kernels that
260  support this feature
261
262* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-8
263- rebuild
264
265* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-7E
266- Add swapped patch from rik van riel
267
268* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-6
269- rebuild
270
271* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-5E
272- Update iowait patch (#101657)
273- Add wchan 64bit patch from Mark DeWandel
274
275* Mon Jul 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-4E
276- Add SELinux patch
277
278* Wed Jul 16 2003 Matt Wilson <msw@redhat.com> 2.0.13-3E
279- display iowait with procps-2.0.13-iowait.patch (#99061)
280
281* Fri Jul 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-2E
282- Disable linuxthreads thread hack
283
284* Mon Jul  7 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1E
285- rebuild
286
287* Fri Jul  4 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1
288- update to 2.0.13
289- Re-merged ntpl patch
290- Add hertz fix from Ernie Petrides <petrides@redhat.com>
291
292* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
293- rebuilt
294
295* Fri May 23 2003 Alexander Larsson <alexl@redhat.com> 2.0.12-1
296- Update to 2.0.12
297- Add patch to fix segfault on ps axl (#91453)
298
299* Fri Mar 14 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-7
300- Add patch that fixes negative priorities in top.
301
302* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-6
303- New NPTL patch:
304- Added skipthreads optimization to top
305- Don't read threads in 'w'
306
307* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-5
308- Update the NPTL patch since the kernel /proc was fixed
309- For kernels >= 2.4.20-2.50
310
311* Mon Feb 17 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-4
312- Update nptl patch to new /proc layout.
313
314* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.11-3
315- rebuilt
316
317* Wed Jan 22 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-2
318- Created nptl patch after discussion with ingo and arjan
319
320* Tue Jan 21 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-1
321- Update to 2.0.11
322
323* Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 2.0.10-4
324- Fix %%install in changelog
325
326* Tue Nov 19 2002 Jakub Jelinek <jakub@redhat.com> 2.0.10-3
327- Fix for Hammer
328
329* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-2
330- Remove uninstalled files in %%install. Add pmap to %%files
331
332* Tue Oct  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-1
333- Update to 2.0.10
334- Removed applied patches.
335
336* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-25
337- Add patch to protect against idle ticks going backwards. Fixes #71237
338
339* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-24
340- Fix saving of sort, fixes #32757
341- Fix printing size, fixes #48224
342- Fix float decimal point input #58163
343
344* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-23
345- Fix unsigned/signed bug. Closes #60998.
346- Update threadbadhack to correctly propagate process time to the main thread.
347
348* Wed Aug  7 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-22
349- Don't strip binaries
350
351* Fri Jul 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-21
352- Remove the X11 subpackage
353
354* Mon Jul  1 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-19
355- Added patch that fixes #35174
356
357* Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-18
358- New thread badhack patch. Fixes a segfault.
359
360* Mon Jun 24 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-16
361- New thread badhack. Now enabled by default.
362
363* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
364- automated rebuild
365
366* Thu Jun 20 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-14
367- Added badhack to support hiding threads
368
369* Thu May 23 2002 Tim Powers <timp@redhat.com>
370- automated rebuild
371
372* Mon Apr 15 2002 Bill Nottingham <notting@redhat.com> 2.0.7-12
373- add ldconfig in %postun
374
375* Mon Aug 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 2.0.7-11
376- Add ncurses-devel as a build dependency (#49562)
377
378* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
379- removed applnk entry, one of the things that's cluttering our menus
380
381* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
382- Bump release + rebuild.
383
384* Thu Apr  5 2001 Jakub Jelinek <jakub@redhat.com>
385- fix AIX style user defined formats (#34833)
386
387* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
388- add a '-e' to sysctl to ignore errors (#31852)
389
390* Mon Mar  5 2001 Preston Brown <pbrown@redhat.com>
391- bigger buffer for reading /proc/stat fixes segfault (#27840)
392
393* Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
394- make sysctl return a value when errors occur (#18820).
395- support big UIDs (#22683)
396
397* Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
398- work-around for negative CPU output (Bug #18380)
399
400* Thu Aug 17 2000 Than Ngo <than@redhat.com>
401- fix failing in RPM post script (Bug #16226)
402
403* Wed Jul 26 2000 Michael K. Johnson <johnsonm@redhat.com>
404- Added Jakub's locale patch
405
406* Fri Jul 14 2000 Michael K. Johnson <johnsonm@redhat.com>
407- procps-2.0.7
408- integrated all patches except for signames patch, which is broken
409  and unnecessary
410- See NEWS for changes between 2.0.6 and 2.0.7
411- Added patch to correctly install desktop file.  Oops.
412
413* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
414- automatic rebuild
415
416* Mon Jul 03 2000 Preston Brown <pbrown@redhat.com>
417- larger buffers for reading /proc/stat
418
419* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
420- FHS paths
421
422* Tue May 30 2000 Preston Brown <pbrown@redhat.com>
423- add smp, signal name patches from VA Linux.  Thanks guys.
424
425* Mon May 22 2000 Harald Hoyer <harald@redhat.com>
426- added sysctl.conf (5) man page
427
428* Wed May 10 2000 Bill Nottingham <notting@redhat.com>
429- fix PAGE_SIZE mismatch on ia64
430
431* Sun May  7 2000 Bill Nottingham <notting@redhat.com>
432- rebuild with different optimizations for ia64
433
434* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
435- rebuild with current ncurses
436
437* Tue Mar  7 2000 Bill Nottingham <notting@redhat.com>
438- fix end-of-file behavior in sysctl
439
440* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
441- wmconfig -> desktop
442
443* Mon Feb  7 2000 Jakub Jelinek <jakub@redhat.com>
444- don't try to load System.map (and spit error messages if it does not
445  exist) if ps or top are not going to use it, both to speed things up
446  and remove the ugly messages when they don't make sense.
447- in top, print the possible error messages using standard top SHOWMESSAGE
448  (because it will be now printed out when already in terminal mode).
449
450* Thu Feb  3 2000 Matt Wilson <msw@redhat.com>
451- added patch to prevent divide by zero on UltraSparc
452- gzip man pages
453
Note: See TracBrowser for help on using the repository browser.