source: projects/specs/trunk/p/procps/procps-vl.spec @ 521

Revision 521, 12.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: System and process monitoring utilities.
2Name: procps
3Version: 3.2.7
4Release: 2%{?_dist_release}
5License: GPL
6Group: Applications/System
7Source: http://procps.sourceforge.net/procps-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-root
9Requires(post): /sbin/ldconfig, /bin/rm
10Requires(postun): /sbin/ldconfig
11Obsoletes: procps-X11, pgrep
12Patch4: procps-3.1.15-misc.patch
13
14# Vine patches
15Patch10: procps-3.2.0-make_install.patch
16Patch20: procps-3.2.7-gettext.patch
17
18BuildRequires: ncurses-devel
19
20Vendor:       Project Vine
21Distribution: Vine Linux
22
23%description
24The procps package contains a set of system utilities that provide
25system information. Procps includes ps, free, skill, snice, tload,
26top, uptime, vmstat, w, and watch. The ps command displays a snapshot
27of running processes. The top command provides a repetitive update of
28the statuses of running processes. The free command displays the
29amounts of free and used memory on your system. The skill command
30sends a terminate command (or another specified signal) to a specified
31set of processes. The snice command is used to change the scheduling
32priority of specified processes. The tload command prints a graph of
33the current system load average to a specified tty. The uptime command
34displays the current time, how long the system has been running, how
35many users are logged on, and system load averages for the past one,
36five, and fifteen minutes. The w command displays a list of the users
37who are currently logged on and what they are running. The watch
38program watches a running program. The vmstat command displays virtual
39memory statistics about processes, memory, paging, block I/O, traps,
40and CPU activity.
41
42%description -l ja
43システムの状態を知るためのユーティリティ集です. 実行中のプロセス, 使用
44可能なメモリ容量, 現在ログインしているユーザの情報等を得ることができます.
45
46%prep
47%setup -q
48
49%patch4 -p1 -b .misc
50
51# vine
52%patch10 -p1 -b .mkinst
53%patch20 -p1 -b .gettext
54
55%build
56PATH=/usr/X11R6/bin:$PATH
57
58%__make %{?_smp_mflags} CC="gcc $RPM_OPT_FLAGS" MANDIR=%{_mandir} W_SHOWFROM=-DW_SHOWFROM lib64=%{_lib}
59
60(cd po; %__make)
61
62%install
63rm -rf %{buildroot}
64mkdir -p %{buildroot}/bin %{buildroot}/usr/bin %{buildroot}/sbin
65mkdir -p %{buildroot}%{_mandir}/{man1,man5,man8}
66mkdir -p %{buildroot}/%{_lib} %{buildroot}/usr/X11R6/bin
67mkdir -p %{buildroot}/etc/X11/applnk/Utilities
68
69make ldconfig="/bin/true" DESTDIR=%{buildroot} SHLIBDIR=%{buildroot}/%{_lib} OWNERGROUP= MANDIR=%{_mandir} lib64=%{_lib} install
70
71(cd po; %makeinstall)
72
73%find_lang %{name}
74
75# Remove unpackaged files:
76rm -f %{buildroot}/bin/kill
77rm -f %{buildroot}%{_mandir}/man1/kill.1*
78
79%clean
80rm -rf %{buildroot}
81
82%post
83# add libproc to the cache
84/sbin/ldconfig
85# remove obsolete files
86rm -f /etc/psdevtab /etc/psdatabase
87
88%postun -p /sbin/ldconfig
89
90%files -f %{name}.lang
91%defattr(0644,root,root,755)
92%doc NEWS BUGS TODO
93%attr(755,root,root) /%{_lib}/libproc*
94%attr(555,root,root) /bin/ps
95%attr(555,root,root) /sbin/sysctl
96%attr(555,root,root) /usr/bin/uptime
97%attr(555,root,root) /usr/bin/tload
98%attr(555,root,root) /usr/bin/free
99%attr(555,root,root) /usr/bin/w
100%attr(555,root,root) /usr/bin/top
101%attr(555,root,root) /usr/bin/vmstat
102%attr(555,root,root) /usr/bin/watch
103%attr(555,root,root) /usr/bin/skill
104%attr(555,root,root) /usr/bin/snice
105%attr(555,root,root) /usr/bin/pgrep
106%attr(555,root,root) /usr/bin/pkill
107%attr(555,root,root) /usr/bin/pmap
108%attr(555,root,root) /usr/bin/slabtop
109%attr(555,root,root) /usr/bin/pwdx
110
111%attr(0644,root,root) %{_mandir}/man1/free.1*
112%attr(0644,root,root) %{_mandir}/man1/ps.1*
113%attr(0644,root,root) %{_mandir}/man1/skill.1*
114%attr(0644,root,root) %{_mandir}/man1/snice.1*
115%attr(0644,root,root) %{_mandir}/man1/pgrep.1*
116%attr(0644,root,root) %{_mandir}/man1/pkill.1*
117%attr(0644,root,root) %{_mandir}/man1/pmap.1*
118%attr(0644,root,root) %{_mandir}/man1/pwdx.1*
119%attr(0644,root,root) %{_mandir}/man1/slabtop.1*
120%attr(0644,root,root) %{_mandir}/man1/tload.1*
121%attr(0644,root,root) %{_mandir}/man1/top.1*
122%attr(0644,root,root) %{_mandir}/man1/uptime.1*
123%attr(0644,root,root) %{_mandir}/man1/w.1*
124%attr(0644,root,root) %{_mandir}/man1/watch.1*
125%attr(0644,root,root) %{_mandir}/man8/vmstat.8*
126%attr(0644,root,root) %{_mandir}/man8/sysctl.8*
127%attr(0644,root,root) %{_mandir}/man5/sysctl.conf.5*
128
129%changelog
130* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-2
131- spec in utf-8
132
133* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
134- new upstream release
135
136* Wed Sep 20 2006 IWAI, Masaharu <iwai@alib.jp> 3.2.6-0vl3
137- [BTS:205] update ja.po ( in Patch20 )
138
139* Tue Feb 14 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl2
140- add Obsoletes: pgrep
141
142* Sun Feb 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl1
143- upstream release
144- update Patch20
145- fix encode of spec file (SJIS -> EUC-JP)
146- add pwdx command (new from 3.2.4)
147
148* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl3
149- update gettext patch
150
151* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl2
152- add gettext patch (Patch20)
153  still needs more work ( only for "free" and "uptime" )
154
155* Sun Feb 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl1
156- new upstream release
157
158* Thu Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.0-1vl1
159- modified for Vine
160- add obsoletes -X11 package
161
162* Tue Feb 24 2004 Dan Walsh <dwalsh@redhat.com> 3.2.0-1
163- New version from upstream
164
165* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
166- rebuilt
167
168* Thu Jan 22 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-3
169- Match -Z to --context
170
171* Wed Jan 21 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-2
172- Add back in -Z support
173
174* Wed Jan 21 2004 Alexander Larsson <alexl@redhat.com> 3.1.15-1
175- upgrade to procps3
176- Some regressions, see bug #114012
177
178* Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 2.0.17-7
179- Remove LIBCURSES from skill and sysctl
180
181* Wed Dec  10 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-6
182- Turn on SELinux
183
184* Mon Dec  8 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-5
185- Fix top total percentages (#109484)
186
187* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-4
188- Turn off selinux
189
190* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-3.sel
191- Fix help message
192
193* Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-2.sel
194- Turn on selinux
195
196* Fri Oct  3 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-1
197- Update to 2.0.17, drop upstream patches, forward port remaining patches
198
199* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-11
200- Turn off selinux
201
202* Thu Aug 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-10.sel
203- Add -Z switch for SELinux
204
205* Sun Aug 17 2003 Doug Ledford <dledford@redhat.com> 2.0.13-9E
206- Add patch to recognize irq and softirq time accounting in kernels that
207  support this feature
208
209* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-8
210- rebuild
211
212* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-7E
213- Add swapped patch from rik van riel
214
215* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-6
216- rebuild
217
218* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-5E
219- Update iowait patch (#101657)
220- Add wchan 64bit patch from Mark DeWandel
221
222* Mon Jul 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-4E
223- Add SELinux patch
224
225* Wed Jul 16 2003 Matt Wilson <msw@redhat.com> 2.0.13-3E
226- display iowait with procps-2.0.13-iowait.patch (#99061)
227
228* Fri Jul 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-2E
229- Disable linuxthreads thread hack
230
231* Mon Jul  7 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1E
232- rebuild
233
234* Fri Jul  4 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1
235- update to 2.0.13
236- Re-merged ntpl patch
237- Add hertz fix from Ernie Petrides <petrides@redhat.com>
238
239* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
240- rebuilt
241
242* Fri May 23 2003 Alexander Larsson <alexl@redhat.com> 2.0.12-1
243- Update to 2.0.12
244- Add patch to fix segfault on ps axl (#91453)
245
246* Fri Mar 14 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-7
247- Add patch that fixes negative priorities in top.
248
249* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-6
250- New NPTL patch:
251- Added skipthreads optimization to top
252- Don't read threads in 'w'
253
254* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-5
255- Update the NPTL patch since the kernel /proc was fixed
256- For kernels >= 2.4.20-2.50
257
258* Mon Feb 17 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-4
259- Update nptl patch to new /proc layout.
260
261* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.11-3
262- rebuilt
263
264* Wed Jan 22 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-2
265- Created nptl patch after discussion with ingo and arjan
266
267* Tue Jan 21 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-1
268- Update to 2.0.11
269
270* Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 2.0.10-4
271- Fix %%install in changelog
272
273* Tue Nov 19 2002 Jakub Jelinek <jakub@redhat.com> 2.0.10-3
274- Fix for Hammer
275
276* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-2
277- Remove uninstalled files in %%install. Add pmap to %%files
278
279* Tue Oct  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-1
280- Update to 2.0.10
281- Removed applied patches.
282
283* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-25
284- Add patch to protect against idle ticks going backwards. Fixes #71237
285
286* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-24
287- Fix saving of sort, fixes #32757
288- Fix printing size, fixes #48224
289- Fix float decimal point input #58163
290
291* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-23
292- Fix unsigned/signed bug. Closes #60998.
293- Update threadbadhack to correctly propagate process time to the main thread.
294
295* Wed Aug  7 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-22
296- Don't strip binaries
297
298* Fri Jul 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-21
299- Remove the X11 subpackage
300
301* Mon Jul  1 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-19
302- Added patch that fixes #35174
303
304* Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-18
305- New thread badhack patch. Fixes a segfault.
306
307* Mon Jun 24 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-16
308- New thread badhack. Now enabled by default.
309
310* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
311- automated rebuild
312
313* Thu Jun 20 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-14
314- Added badhack to support hiding threads
315
316* Thu May 23 2002 Tim Powers <timp@redhat.com>
317- automated rebuild
318
319* Mon Apr 15 2002 Bill Nottingham <notting@redhat.com> 2.0.7-12
320- add ldconfig in %postun
321
322* Mon Aug 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 2.0.7-11
323- Add ncurses-devel as a build dependency (#49562)
324
325* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
326- removed applnk entry, one of the things that's cluttering our menus
327
328* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
329- Bump release + rebuild.
330
331* Thu Apr  5 2001 Jakub Jelinek <jakub@redhat.com>
332- fix AIX style user defined formats (#34833)
333
334* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
335- add a '-e' to sysctl to ignore errors (#31852)
336
337* Mon Mar  5 2001 Preston Brown <pbrown@redhat.com>
338- bigger buffer for reading /proc/stat fixes segfault (#27840)
339
340* Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
341- make sysctl return a value when errors occur (#18820).
342- support big UIDs (#22683)
343
344* Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
345- work-around for negative CPU output (Bug #18380)
346
347* Thu Aug 17 2000 Than Ngo <than@redhat.com>
348- fix failing in RPM post script (Bug #16226)
349
350* Wed Jul 26 2000 Michael K. Johnson <johnsonm@redhat.com>
351- Added Jakub's locale patch
352
353* Fri Jul 14 2000 Michael K. Johnson <johnsonm@redhat.com>
354- procps-2.0.7
355- integrated all patches except for signames patch, which is broken
356  and unnecessary
357- See NEWS for changes between 2.0.6 and 2.0.7
358- Added patch to correctly install desktop file.  Oops.
359
360* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
361- automatic rebuild
362
363* Tue Jul 03 2000 Preston Brown <pbrown@redhat.com>
364- larger buffers for reading /proc/stat
365
366* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
367- FHS paths
368
369* Tue May 30 2000 Preston Brown <pbrown@redhat.com>
370- add smp, signal name patches from VA Linux.  Thanks guys.
371
372* Mon May 22 2000 Harald Hoyer <harald@redhat.com>
373- added sysctl.conf (5) man page
374
375* Wed May 10 2000 Bill Nottingham <notting@redhat.com>
376- fix PAGE_SIZE mismatch on ia64
377
378* Sun May  7 2000 Bill Nottingham <notting@redhat.com>
379- rebuild with different optimizations for ia64
380
381* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
382- rebuild with current ncurses
383
384* Tue Mar  7 2000 Bill Nottingham <notting@redhat.com>
385- fix end-of-file behavior in sysctl
386
387* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
388- wmconfig -> desktop
389
390* Mon Feb  7 2000 Jakub Jelinek <jakub@redhat.com>
391- don't try to load System.map (and spit error messages if it does not
392  exist) if ps or top are not going to use it, both to speed things up
393  and remove the ugly messages when they don't make sense.
394- in top, print the possible error messages using standard top SHOWMESSAGE
395  (because it will be now printed out when already in terminal mode).
396
397* Thu Feb  3 2000 Matt Wilson <msw@redhat.com>
398- added patch to prevent divide by zero on UltraSparc
399- gzip man pages
400
Note: See TracBrowser for help on using the repository browser.