source: projects/specs/trunk/p/procps/procps-vl.spec @ 12000

Revision 12000, 13.5 KB checked in by tomop, 5 years ago (diff)

new: elogind-239.3 (and packages that depends on elogind)

Line 
1%define origname procps-ng
2
3Summary: System and process monitoring utilities.
4Summary(ja): システムやプロセスのモニタリングユーティリティ
5Name: procps
6Version: 3.3.15
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10Url: https://gitlab.com/procps-ng/procps
11# alternative: http://sourceforge.net/projects/procps-ng/
12Source: %{origname}-%{version}.tar.xz
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires(post): /sbin/ldconfig, /bin/rm
15Requires(postun): /sbin/ldconfig
16Obsoletes: procps-X11, pgrep
17
18# Vine source/patches
19Source10: procps-ng-3.3.10-ja.po
20
21BuildRequires: ncurses-devel
22
23Vendor:       Project Vine
24Distribution: Vine Linux
25Packager: daisuke
26
27%description
28The procps package contains a set of system utilities that provide
29system information. Procps includes ps, free, skill, snice, tload,
30top, uptime, vmstat, w, and watch. The ps command displays a snapshot
31of running processes. The top command provides a repetitive update of
32the statuses of running processes. The free command displays the
33amounts of free and used memory on your system. The skill command
34sends a terminate command (or another specified signal) to a specified
35set of processes. The snice command is used to change the scheduling
36priority of specified processes. The tload command prints a graph of
37the current system load average to a specified tty. The uptime command
38displays the current time, how long the system has been running, how
39many users are logged on, and system load averages for the past one,
40five, and fifteen minutes. The w command displays a list of the users
41who are currently logged on and what they are running. The watch
42program watches a running program. The vmstat command displays virtual
43memory statistics about processes, memory, paging, block I/O, traps,
44and CPU activity.
45
46%description -l ja
47システムの状態を知るためのユーティリティ集です. 実行中のプロセス, 使用
48可能なメモリ容量, 現在ログインしているユーザの情報等を得ることができます.
49
50%package devel
51Summary:     System and process monitoring utilities
52Summary(ja): procpsを利用した開発に必要なファイル
53Group:       Development/Libraries
54Requires:    %{name} = %{version}-%{release}
55
56%description devel
57System and process monitoring utilities development headers
58
59%description devel -l ja
60 このパッケージにはprocpsを利用した開発に必要なヘッダ・ライブラリファイル
61が収録されています。
62
63%prep
64%setup -q -n %{origname}-%{version}
65
66# vine
67cp -f %{SOURCE10} po/ja.po
68
69#echo "ja" > po/LINGUAS
70
71%build
72autoreconf --verbose --force --install
73./configure --prefix=/ \
74            --bindir=%{_bindir} \
75            --sbindir=%{_syssbindir} \
76            --libdir=%{_libdir} \
77            --datadir=%{_datadir} \
78            --localedir=%{_datadir}/locale \
79            --mandir=%{_mandir} \
80            --includedir=%{_includedir} \
81            --sysconfdir=%{_sysconfdir} \
82            --docdir=/unwanted \
83            --disable-static \
84            --disable-w-from \
85            --disable-kill \
86            --enable-watch8bit \
87            --enable-skill \
88            --enable-sigwinch \
89            --disable-libselinux \
90            --with-elogind \
91            --without-systemd
92
93make CFLAGS="%{optflags}"
94
95make -C po update-po
96make -C po ja.gmo
97
98%install
99make DESTDIR=%{buildroot} install
100make DESTDIR=%{buildroot} -C po install
101
102mkdir -p %{buildroot}%{_sysconfdir}/sysctl.d
103
104# for compatibility
105mkdir -p %{buildroot}%{_sysbindir}
106mv %{buildroot}%{_bindir}/ps %{buildroot}%{_sysbindir}/
107ln -sf %{_sysbindir}/ps %{buildroot}%{_bindir}/ps
108
109rm -f %{buildroot}/%{_libdir}/libprocps.la
110rm -rf %{buildroot}/unwanted
111rm -f %{buildroot}%{_bindir}/pidof
112
113%find_lang procps-ng
114
115%clean
116rm -rf %{buildroot}
117
118%post -p /sbin/ldconfig
119
120%postun -p /sbin/ldconfig
121
122%files -f procps-ng.lang
123%defattr(-,root,root,-)
124%doc AUTHORS Documentation/BUGS COPYING COPYING.LIB Documentation/FAQ NEWS README top/README.top Documentation/TODO
125%{_libdir}/libprocps.so.*
126%{_bindir}/*
127%{_sysbindir}/*
128%{_syssbindir}/*
129%{_sysconfdir}/sysctl.d
130%{_mandir}/man1/*
131%{_mandir}/man3/*
132%{_mandir}/man8/*
133%{_mandir}/man5/*
134
135%files devel
136%defattr(-,root,root,-)
137%doc COPYING COPYING.LIB
138%{_libdir}/libprocps.so
139%{_libdir}/pkgconfig/libprocps.pc
140%{_includedir}/proc
141
142%changelog
143* Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.15-1
144- new upstream release.
145- enabled elogind.
146- added japanese summary.
147
148* Sun Jun 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-2
149- fixed Source10.
150
151* Sat Jun 20 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-1
152- new upstream release.
153- updated Source10 and Patch10.
154
155* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.9-1
156- update to forked version of procps 3.3.9
157- add minimum ja.po
158
159* Sat Sep 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
160- update to 3.2.8
161- add patch30 to fix top highlight bug
162  (thanks to <BTS:916>)
163
164* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-2
165- spec in utf-8
166
167* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
168- new upstream release
169
170* Wed Sep 20 2006 IWAI, Masaharu <iwai@alib.jp> 3.2.6-0vl3
171- [BTS:205] update ja.po ( in Patch20 )
172
173* Tue Feb 14 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl2
174- add Obsoletes: pgrep
175
176* Sun Feb 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl1
177- upstream release
178- update Patch20
179- fix encode of spec file (SJIS -> EUC-JP)
180- add pwdx command (new from 3.2.4)
181
182* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl3
183- update gettext patch
184
185* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl2
186- add gettext patch (Patch20)
187  still needs more work ( only for "free" and "uptime" )
188
189* Sun Feb 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl1
190- new upstream release
191
192* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.0-1vl1
193- modified for Vine
194- add obsoletes -X11 package
195
196* Tue Feb 24 2004 Dan Walsh <dwalsh@redhat.com> 3.2.0-1
197- New version from upstream
198
199* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
200- rebuilt
201
202* Thu Jan 22 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-3
203- Match -Z to --context
204
205* Wed Jan 21 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-2
206- Add back in -Z support
207
208* Wed Jan 21 2004 Alexander Larsson <alexl@redhat.com> 3.1.15-1
209- upgrade to procps3
210- Some regressions, see bug #114012
211
212* Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 2.0.17-7
213- Remove LIBCURSES from skill and sysctl
214
215* Wed Dec  10 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-6
216- Turn on SELinux
217
218* Mon Dec  8 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-5
219- Fix top total percentages (#109484)
220
221* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-4
222- Turn off selinux
223
224* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-3.sel
225- Fix help message
226
227* Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-2.sel
228- Turn on selinux
229
230* Fri Oct  3 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-1
231- Update to 2.0.17, drop upstream patches, forward port remaining patches
232
233* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-11
234- Turn off selinux
235
236* Thu Aug 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-10.sel
237- Add -Z switch for SELinux
238
239* Sun Aug 17 2003 Doug Ledford <dledford@redhat.com> 2.0.13-9E
240- Add patch to recognize irq and softirq time accounting in kernels that
241  support this feature
242
243* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-8
244- rebuild
245
246* Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-7E
247- Add swapped patch from rik van riel
248
249* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-6
250- rebuild
251
252* Wed Aug  6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-5E
253- Update iowait patch (#101657)
254- Add wchan 64bit patch from Mark DeWandel
255
256* Mon Jul 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-4E
257- Add SELinux patch
258
259* Wed Jul 16 2003 Matt Wilson <msw@redhat.com> 2.0.13-3E
260- display iowait with procps-2.0.13-iowait.patch (#99061)
261
262* Fri Jul 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-2E
263- Disable linuxthreads thread hack
264
265* Mon Jul  7 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1E
266- rebuild
267
268* Fri Jul  4 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1
269- update to 2.0.13
270- Re-merged ntpl patch
271- Add hertz fix from Ernie Petrides <petrides@redhat.com>
272
273* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
274- rebuilt
275
276* Fri May 23 2003 Alexander Larsson <alexl@redhat.com> 2.0.12-1
277- Update to 2.0.12
278- Add patch to fix segfault on ps axl (#91453)
279
280* Fri Mar 14 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-7
281- Add patch that fixes negative priorities in top.
282
283* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-6
284- New NPTL patch:
285- Added skipthreads optimization to top
286- Don't read threads in 'w'
287
288* Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-5
289- Update the NPTL patch since the kernel /proc was fixed
290- For kernels >= 2.4.20-2.50
291
292* Mon Feb 17 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-4
293- Update nptl patch to new /proc layout.
294
295* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.11-3
296- rebuilt
297
298* Wed Jan 22 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-2
299- Created nptl patch after discussion with ingo and arjan
300
301* Tue Jan 21 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-1
302- Update to 2.0.11
303
304* Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 2.0.10-4
305- Fix %%install in changelog
306
307* Tue Nov 19 2002 Jakub Jelinek <jakub@redhat.com> 2.0.10-3
308- Fix for Hammer
309
310* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-2
311- Remove uninstalled files in %%install. Add pmap to %%files
312
313* Tue Oct  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-1
314- Update to 2.0.10
315- Removed applied patches.
316
317* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-25
318- Add patch to protect against idle ticks going backwards. Fixes #71237
319
320* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-24
321- Fix saving of sort, fixes #32757
322- Fix printing size, fixes #48224
323- Fix float decimal point input #58163
324
325* Thu Aug  8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-23
326- Fix unsigned/signed bug. Closes #60998.
327- Update threadbadhack to correctly propagate process time to the main thread.
328
329* Wed Aug  7 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-22
330- Don't strip binaries
331
332* Fri Jul 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-21
333- Remove the X11 subpackage
334
335* Mon Jul  1 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-19
336- Added patch that fixes #35174
337
338* Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-18
339- New thread badhack patch. Fixes a segfault.
340
341* Mon Jun 24 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-16
342- New thread badhack. Now enabled by default.
343
344* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
345- automated rebuild
346
347* Thu Jun 20 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-14
348- Added badhack to support hiding threads
349
350* Thu May 23 2002 Tim Powers <timp@redhat.com>
351- automated rebuild
352
353* Mon Apr 15 2002 Bill Nottingham <notting@redhat.com> 2.0.7-12
354- add ldconfig in %postun
355
356* Mon Aug 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 2.0.7-11
357- Add ncurses-devel as a build dependency (#49562)
358
359* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
360- removed applnk entry, one of the things that's cluttering our menus
361
362* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
363- Bump release + rebuild.
364
365* Thu Apr  5 2001 Jakub Jelinek <jakub@redhat.com>
366- fix AIX style user defined formats (#34833)
367
368* Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
369- add a '-e' to sysctl to ignore errors (#31852)
370
371* Mon Mar  5 2001 Preston Brown <pbrown@redhat.com>
372- bigger buffer for reading /proc/stat fixes segfault (#27840)
373
374* Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
375- make sysctl return a value when errors occur (#18820).
376- support big UIDs (#22683)
377
378* Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
379- work-around for negative CPU output (Bug #18380)
380
381* Thu Aug 17 2000 Than Ngo <than@redhat.com>
382- fix failing in RPM post script (Bug #16226)
383
384* Wed Jul 26 2000 Michael K. Johnson <johnsonm@redhat.com>
385- Added Jakub's locale patch
386
387* Fri Jul 14 2000 Michael K. Johnson <johnsonm@redhat.com>
388- procps-2.0.7
389- integrated all patches except for signames patch, which is broken
390  and unnecessary
391- See NEWS for changes between 2.0.6 and 2.0.7
392- Added patch to correctly install desktop file.  Oops.
393
394* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
395- automatic rebuild
396
397* Mon Jul 03 2000 Preston Brown <pbrown@redhat.com>
398- larger buffers for reading /proc/stat
399
400* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
401- FHS paths
402
403* Tue May 30 2000 Preston Brown <pbrown@redhat.com>
404- add smp, signal name patches from VA Linux.  Thanks guys.
405
406* Mon May 22 2000 Harald Hoyer <harald@redhat.com>
407- added sysctl.conf (5) man page
408
409* Wed May 10 2000 Bill Nottingham <notting@redhat.com>
410- fix PAGE_SIZE mismatch on ia64
411
412* Sun May  7 2000 Bill Nottingham <notting@redhat.com>
413- rebuild with different optimizations for ia64
414
415* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
416- rebuild with current ncurses
417
418* Tue Mar  7 2000 Bill Nottingham <notting@redhat.com>
419- fix end-of-file behavior in sysctl
420
421* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
422- wmconfig -> desktop
423
424* Mon Feb  7 2000 Jakub Jelinek <jakub@redhat.com>
425- don't try to load System.map (and spit error messages if it does not
426  exist) if ps or top are not going to use it, both to speed things up
427  and remove the ugly messages when they don't make sense.
428- in top, print the possible error messages using standard top SHOWMESSAGE
429  (because it will be now printed out when already in terminal mode).
430
431* Thu Feb  3 2000 Matt Wilson <msw@redhat.com>
432- added patch to prevent divide by zero on UltraSparc
433- gzip man pages
434
Note: See TracBrowser for help on using the repository browser.