source: projects/specs/trunk/p/ppp/ppp-vl.spec @ 521

Revision 521, 8.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The PPP (Point-to-Point Protocol) daemon.
2Summary(ja): PPP (Point-to-Point Protocol) デーモン
3Name: ppp
4Version: 2.4.4
5Release: 4%{?_dist_release}
6License: distributable
7Group: System Environment/Daemons
8Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
9Source1: ppp-2.4.4-pamd.conf
10Patch0: ppp-2.4.3-makefile.patch
11Patch1: ppp-2.3.6-sample.patch
12Patch8: ppp-2.4.3-fix.patch
13Patch9: ppp-2.4.3-fix64.patch
14Patch13: ppp-2.4.4-no_strip2.patch
15Patch16: ppp-2.4.2-pppoatm-mtu.patch
16Patch17: ppp-2.4.2-pppoatm-make.patch
17Patch19: ppp-2.4.3-local.patch
18Patch22: ppp-2.4.4-cbcp.patch
19Patch24: ppp-2.4.4-closelog.patch
20Patch25: ppp-2.4.4-response_len.patch
21Patch26: ppp-2.4.4-new_speeds.patch
22
23URL: http://ppp.samba.org/
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildPreReq: libpcap >= 0.8.3, pam-devel
26#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
27Requires: glibc >= 2.0.6, pam >= 1.0
28
29%description
30The ppp package contains the PPP (Point-to-Point Protocol) daemon and
31documentation for PPP support.  The PPP protocol provides a method for
32transmitting datagrams over serial point-to-point links. PPP is
33usually used to dial in to an ISP (Internet Service Provider) or other
34organization over a modem and phone line.
35
36%description -l ja
37ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
38PPP を使う為のドキュメントが収められています.PPP プロトコルを
39使うとシリアルな point-to-point 接続上でデータグラムを転送する
40事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
41モデムを介した電話回線で接続する際に使われます.
42
43
44%package devel
45Summary: Headers for ppp plugin development
46SUmmary(ja): ppp プラグイン開発用ヘッダファイル
47Group: Development/Libraries
48
49%description devel
50This package contains the header files for building plugins for ppp.
51
52%description -l ja devel
53このパッケージには ppp のプラグインを開発するためのヘッダファイルが
54含まれています。
55
56%prep
57%setup  -q
58
59%patch0 -p1 -b .makefile
60%patch1 -p1 -b .sample
61%patch8 -p1 -b .fix
62%patch9 -p1 -b .fix64
63%patch13 -p1 -b .no_strip2
64%patch16 -p1 -b .atm-mtu
65%patch17 -p1 -b .atm-make
66%patch19 -p1 -b .local
67%patch22 -p1 -b .cbcp
68%patch24 -p1 -b .closelog
69%patch25 -p1 -b .response_len
70%patch26 -p1 -b .new_speeds
71
72find . -type f -name "*.sample" | xargs rm -f
73
74%build
75./configure
76make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
77
78
79%install
80[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
81export INSTROOT=$RPM_BUILD_ROOT
82%ifarch x86_64
83make install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
84%else
85make install install-etcppp
86%endif
87
88## it shouldn't be SUID root be default
89#chmod 755 %{buildroot}/usr/sbin/pppd
90
91chmod go+r scripts/*
92mkdir -p %{buildroot}/etc/pam.d
93install -m 644 %{SOURCE1} %{buildroot}/etc/pam.d/ppp
94
95mkdir -p %{buildroot}/etc/ppp
96cp etc.ppp/* %{buildroot}/etc/ppp
97chmod 600 %{buildroot}/etc/ppp/*-secrets
98
99mkdir -p %{buildroot}/etc/radiusclient
100cp pppd/plugins/radius/etc/* %{buildroot}/etc/radiusclient
101mv %{buildroot}/etc/radiusclient/radiusclient.conf %{buildroot}/etc/
102perl -pi -e 's|/usr/local||g' %{buildroot}/etc/radiusclient/radiusclient.conf
103
104find scripts -type f | xargs chmod 644
105
106%clean
107rm -rf %{buildroot}
108
109
110%files
111%defattr(-,root,root)
112%{_sbindir}/*
113%{_libdir}/pppd
114%{_mandir}/man8/chat.8*
115%{_mandir}/man8/pppd.8*
116%{_mandir}/man8/pppdump.8*
117%{_mandir}/man8/pppstats.8*
118%{_mandir}/man8/pppd-radattr.8*
119%{_mandir}/man8/pppd-radius.8*
120%dir /etc/ppp
121%config(noreplace) /etc/ppp/*
122%config(noreplace) /etc/pam.d/ppp
123%config(noreplace) /etc/radiusclient/*
124%config(noreplace) /etc/radiusclient.conf
125%doc README README.linux scripts sample
126
127%files devel
128%defattr(-,root,root)
129%{_includedir}/pppd
130%doc PLUGINS
131
132
133%changelog
134* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
135- update pam.d/ppp to fix pam-1.0
136
137* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
138- added option LIBDIR at makeinstall for x86_64
139
140* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
141- add -devel subpackage to develop ppp plugins
142
143* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
144- update Source1 for pam-1.0.1
145- import several patches from Fedora 2.4.4-7
146
147* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
148- new upstream release
149- rebuilt with new toolchain and environment
150- added URL (also URL of Source0)
151
152* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
153- use License: instead of Copyright:
154
155* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
156- new upstream release.
157- replace patch0.
158
159* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
160- new upstream release.
161- remove patch 2-4 (no longer needed).
162
163* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
164- rebuild with new toolchains
165
166* Sun Jun 10 2001 <sagami@vinelinux.org>
167- 2.4.1-0vl1: update to 2.4.1
168
169* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
170- 2.4.0-2vl1
171- based on 2.4.0-2 from Rawhide
172- added Japanese summary and description
173- Requires: /etc/pam.d/system-auth -> pam >= 0.72
174  (for better compatibility with apt for rpm)
175
176* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
177- rebuild in new environment
178
179* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
180- update to 2.4.0
181
182* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
183- automatic rebuild
184
185* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
186- move man pages to %{_mandir}
187
188* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
189- change perms using defattr
190- modify PAM setup to use system-auth
191
192* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
193- change to root:root perms
194
195* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
196- reaper bugs verified as fixed
197- check pam_open_session result code (bug #9966)
198
199* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
200- take a shot at the wrong reaper bugs (#8153, #5290)
201
202* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
203- free ride through the build system (release 2)
204
205* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
206- Update to 2.3.11
207
208* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
209- Better fix for both problems
210
211* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
212- fix for double-dial problem
213- fix for requiring a controlling terminal problem
214
215* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
216- 2.3.10 bugfix release
217
218* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
219- New version 2.3.9 required for kernel 2.3.13 and will be required
220  for new initscripts.  auth patch removed; 2.3.9 does the same thing
221  more readably than the previous patch.
222
223* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
224- add pppdump
225
226* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
227- force pppd use the glibc's logwtmp instead of implementing its own
228
229* Wed Apr 01 1999 Preston Brown <pbrown@redhat.com>
230- version 2.3.7 bugfix release
231
232* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
233- version 2.3.6
234
235* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
236- auth patch
237
238* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
239- auto rebuild in the new build environment (release 3)
240
241* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
242- build for glibc 2.1
243
244* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
245- updated to 2.3.5.
246
247* Tue May 19 1998 Prospector System <bugs@redhat.com>
248- translations modified for de
249
250* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
251- make it run with kernels 2.1.100 and above.
252
253* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
254- translations modified for de, fr, tr
255
256* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
257- requires glibc 2.0.6 or later
258
259* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
260- updated PAM patch to not turn off wtmp/utmp/syslog logging.
261
262* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
263- added the /etc/pam.d config file
264- updated PAM patch to include session support
265
266* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
267- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
268  required any more.
269- added buildroot
270- fixed the PAM support, which was really, completely broken and against any
271  standards (session support is still not here... :-( )
272- we build against running kernel and pray that it will work
273- added a samples patch; updated glibc patch
274
275* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
276- added a patch to use our own route.h, rather then glibc's (which has
277  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
278  though it should be safe everywhere
279
280* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
281- turned off the execute bit for scripts in /usr/doc
282
283* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
284- built against glibc
285
286* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
287- Integrated new patch from David Mosberger
288- Improved description
289
Note: See TracBrowser for help on using the repository browser.