source: projects/specs/trunk/p/ppp/ppp-vl.spec @ 12341

Revision 12341, 13.1 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

libcgroup-0.42.2-1

ppp-2.4.8-1

Line 
1%bcond_with ifupdown
2
3%define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
4
5Summary: The PPP (Point-to-Point Protocol) daemon.
6Summary(ja): PPP (Point-to-Point Protocol) デーモン
7Name: ppp
8Version: 2.4.8
9Release: 1%{?_dist_release}
10Group: System Environment/Daemons
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16License: BSD and LGPLv2+ and GPLv2+ and Public Domain
17URL: https://github.com/paulusmack/ppp
18
19Source0: https://github.com/paulusmack/ppp/archive/ppp-%{version}.tar.gz
20Source1: ppp-pam.conf
21Source2: ppp-logrotate.conf
22Source3: ppp-tmpfiles.conf
23Source4: ip-down
24Source5: ip-down.ipv6to4
25Source6: ip-up
26Source7: ip-up.ipv6to4
27Source8: ipv6-down
28Source9: ipv6-up
29Source10: ifup-ppp
30Source11: ifdown-ppp
31Source12: ppp-watch.tar.xz
32
33# Fedora-specific
34Patch0001:      0001-build-sys-use-gcc-as-our-compiler-of-choice.patch
35Patch0002:      ppp-2.4.8-build-sys-enable-PAM-support.patch
36Patch0003:      ppp-2.4.8-build-sys-utilize-compiler-flags-handed-to-us-by-rpm.patch
37Patch0004:      0004-doc-add-configuration-samples.patch
38Patch0005:      ppp-2.4.8-build-sys-don-t-hardcode-LIBDIR-but-set-it-according.patch
39Patch0006:      0006-scritps-use-change_resolv_conf-function.patch
40Patch0007:      0007-build-sys-don-t-strip-binaries-during-installation.patch
41Patch0008:      0008-build-sys-use-prefix-usr-instead-of-usr-local.patch
42Patch0009:      ppp-2.4.8-pppd-introduce-ipv6-accept-remote.patch
43Patch0010:      0010-build-sys-enable-CBCP.patch
44Patch0011:      0011-build-sys-don-t-put-connect-errors-log-to-etc-ppp.patch
45Patch0012:      ppp-2.4.8-pppd-we-don-t-want-to-accidentally-leak-fds.patch
46Patch0013:      ppp-2.4.8-everywhere-O_CLOEXEC-harder.patch
47Patch0014:      0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
48Patch0015:      0015-pppd-move-pppd-database-to-var-run-ppp.patch
49Patch0016:      0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
50Patch0018:      0018-scritps-fix-ip-up.local-sample.patch
51Patch0019:      ppp-2.4.8-sys-linux-rework-get_first_ethernet.patch
52Patch0020:      0020-pppd-put-lock-files-in-var-lock-ppp.patch
53Patch0021:      ppp-2.4.8-build-sys-compile-pppol2tp-plugin-with-RPM_OPT_FLAGS.patch
54Patch0022:      ppp-2.4.8-build-sys-compile-pppol2tp-with-multilink-support.patch
55Patch0023:      0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
56Patch0024:      0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
57Patch0025:      ppp-2.4.8-pppd-install-pppd-binary-using-standard-perms-755.patch
58Patch0026:      ppp-2.4.8-eaptls-mppe-1.102.patch
59
60Patch0032:      ppp-2.4.8-CVE-2020-8597.patch
61
62
63BuildRoot: %{_tmppath}/%{name}-%{version}-root
64BuildRequires: glib2-devel, libpcap >= 0.8.3, eudev-libudev-devel, openssl-devel, pam-devel
65#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
66Requires: glibc >= 2.0.6, pam >= 1.0
67Requires(pre): shadow-utils
68
69
70%description
71The ppp package contains the PPP (Point-to-Point Protocol) daemon and
72documentation for PPP support.  The PPP protocol provides a method for
73transmitting datagrams over serial point-to-point links. PPP is
74usually used to dial in to an ISP (Internet Service Provider) or other
75organization over a modem and phone line.
76
77%description -l ja
78ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
79PPP を使う為のドキュメントが収められています.PPP プロトコルを
80使うとシリアルな point-to-point 接続上でデータグラムを転送する
81事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
82モデムを介した電話回線で接続する際に使われます.
83
84
85%package devel
86Summary: Headers for ppp plugin development
87SUmmary(ja): ppp プラグイン開発用ヘッダファイル
88Group: Development/Libraries
89
90%description devel
91This package contains the header files for building plugins for ppp.
92
93%description -l ja devel
94このパッケージには ppp のプラグインを開発するためのヘッダファイルが
95含まれています。
96
97%prep
98%setup  -q -n ppp-ppp-%{version}
99%autopatch -p1
100
101tar -xJf %{SOURCE12}
102
103%build
104export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Wall -fno-strict-aliasing"
105%configure
106make %{?_smp_mflags}
107make -C ppp-watch %{?_smp_mflags}
108
109%install
110[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
111
112%ifarch x86_64
113make INSTROOT=%{buildroot} install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
114%else
115make INSTROOT=%{buildroot} install install-etcppp
116%endif
117
118find scripts -type f | xargs chmod a-x
119
120make ROOT=%{buildroot} -C ppp-watch install
121
122# create log files dir
123mv -f %{buildroot}/usr/var %{buildroot}/
124
125# install pam config
126install -d %{buildroot}%{_sysconfdir}/pam.d
127install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/ppp
128
129# install logrotate script
130install -d %{buildroot}%{_sysconfdir}/logrotate.d
131install -m 644 -p %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/ppp
132
133# install tmpfiles drop-in
134install -d %{buildroot}%{_tmpfilesdir}
135install -p %{SOURCE3} %{buildroot}%{_tmpfilesdir}/ppp.conf
136
137# install scripts (previously owned by initscripts package)
138install -d %{buildroot}%{_sysconfdir}/ppp
139%if %{with ifupdown}
140install -p %{SOURCE4} %{buildroot}%{_sysconfdir}/ppp/ip-down
141install -p %{SOURCE5} %{buildroot}%{_sysconfdir}/ppp/ip-down.ipv6to4
142install -p %{SOURCE6} %{buildroot}%{_sysconfdir}/ppp/ip-up
143install -p %{SOURCE7} %{buildroot}%{_sysconfdir}/ppp/ip-up.ipv6to4
144install -p %{SOURCE8} %{buildroot}%{_sysconfdir}/ppp/ipv6-down
145install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/ppp/ipv6-up
146%endif
147
148%if %{with ifupdown}
149install -d %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/
150install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifup-ppp
151install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdown-ppp
152%endif
153
154
155%clean
156rm -rf %{buildroot}
157
158
159%pre
160/usr/bin/getent group dip >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 40 dip >/dev/null 2>&1 || :
161
162
163%files
164%defattr(-,root,root)
165%doc FAQ README README.cbcp README.linux README.MPPE README.MSCHAP80 README.MSCHAP81 README.pwfd README.pppoe scripts sample README.eap-tls
166%{_sbindir}/*
167%{_libdir}/pppd
168%{_mandir}/man8/chat.8*
169%{_mandir}/man8/ppp-watch.8*
170%{_mandir}/man8/pppd.8*
171%{_mandir}/man8/pppdump.8*
172%{_mandir}/man8/pppstats.8*
173%{_mandir}/man8/pppd-radattr.8*
174%{_mandir}/man8/pppd-radius.8*
175%{_mandir}/man8/pppoe-discovery.8*
176%dir /etc/ppp
177%config(noreplace) /etc/ppp/*
178%config(noreplace) /etc/pam.d/ppp
179%config(noreplace) /etc/logrotate.d/ppp
180%{_tmpfilesdir}/ppp.conf
181%ghost %dir %{_localstatedir}/run/ppp
182%ghost %dir %{_localstatedir}/lock/ppp
183%attr(700, root, root) %dir %{_localstatedir}/log/ppp
184
185%if %{with ifupdown}
186/etc/sysconfig/network-scripts/ifup-ppp
187/etc/sysconfig/network-scripts/ifdown-ppp
188%endif
189
190%files devel
191%defattr(-,root,root)
192%{_includedir}/pppd
193%doc PLUGINS
194
195
196%changelog
197* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.8-1
198- new upstream release.
199- updated patches.
200
201* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-4
202- rebuilt with openssl-1.1.1.
203- dropped Patch17.
204- imported Patch26-30 from rawhide.
205
206* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-3
207- changed permissions for /etc/logrotate.d/ppp from 755 to 644.
208
209* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.7-2
210- rebuild with openssl-1.0.2
211
212* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-1
213- new upstream release.
214
215* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
216- change BuildRequires: eudev-libudev-devel instead of libudev-devel
217
218* Wed Jun 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
219- new upstream release.
220- replaceed all patches.
221
222* Tue Sep 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-4
223- added /var/run/ppp to %%files. (BTS:1215)
224- added /var/log/ppp to %%files.
225
226* Mon Apr 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-3
227- remove include/linux/if_pppol2tp.h to build pppoe plugin
228- update License tag
229
230* Fri Apr 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-2
231- rebuilt with new toolchain.
232
233* Mon Mar 08 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
234- new upstream release.
235- replaced all patches with Fedora's.
236- replaced 'BuildPreReq:' with 'BuildRequires:'.
237
238* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
239- update pam.d/ppp to fix pam-1.0
240
241* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
242- added option LIBDIR at makeinstall for x86_64
243
244* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
245- add -devel subpackage to develop ppp plugins
246
247* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
248- update Source1 for pam-1.0.1
249- import several patches from Fedora 2.4.4-7
250
251* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
252- new upstream release
253- rebuilt with new toolchain and environment
254- added URL (also URL of Source0)
255
256* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
257- use License: instead of Copyright:
258
259* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
260- new upstream release.
261- replace patch0.
262
263* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
264- new upstream release.
265- remove patch 2-4 (no longer needed).
266
267* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
268- rebuild with new toolchains
269
270* Sun Jun 10 2001 <sagami@vinelinux.org>
271- 2.4.1-0vl1: update to 2.4.1
272
273* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
274- 2.4.0-2vl1
275- based on 2.4.0-2 from Rawhide
276- added Japanese summary and description
277- Requires: /etc/pam.d/system-auth -> pam >= 0.72
278  (for better compatibility with apt for rpm)
279
280* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
281- rebuild in new environment
282
283* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
284- update to 2.4.0
285
286* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
287- automatic rebuild
288
289* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
290- move man pages to %{_mandir}
291
292* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
293- change perms using defattr
294- modify PAM setup to use system-auth
295
296* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
297- change to root:root perms
298
299* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
300- reaper bugs verified as fixed
301- check pam_open_session result code (bug #9966)
302
303* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
304- take a shot at the wrong reaper bugs (#8153, #5290)
305
306* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
307- free ride through the build system (release 2)
308
309* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
310- Update to 2.3.11
311
312* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
313- Better fix for both problems
314
315* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
316- fix for double-dial problem
317- fix for requiring a controlling terminal problem
318
319* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
320- 2.3.10 bugfix release
321
322* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
323- New version 2.3.9 required for kernel 2.3.13 and will be required
324  for new initscripts.  auth patch removed; 2.3.9 does the same thing
325  more readably than the previous patch.
326
327* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
328- add pppdump
329
330* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
331- force pppd use the glibc's logwtmp instead of implementing its own
332
333* Thu Apr 01 1999 Preston Brown <pbrown@redhat.com>
334- version 2.3.7 bugfix release
335
336* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
337- version 2.3.6
338
339* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
340- auth patch
341
342* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
343- auto rebuild in the new build environment (release 3)
344
345* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
346- build for glibc 2.1
347
348* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
349- updated to 2.3.5.
350
351* Tue May 19 1998 Prospector System <bugs@redhat.com>
352- translations modified for de
353
354* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
355- make it run with kernels 2.1.100 and above.
356
357* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
358- translations modified for de, fr, tr
359
360* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
361- requires glibc 2.0.6 or later
362
363* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
364- updated PAM patch to not turn off wtmp/utmp/syslog logging.
365
366* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
367- added the /etc/pam.d config file
368- updated PAM patch to include session support
369
370* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
371- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
372  required any more.
373- added buildroot
374- fixed the PAM support, which was really, completely broken and against any
375  standards (session support is still not here... :-( )
376- we build against running kernel and pray that it will work
377- added a samples patch; updated glibc patch
378
379* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
380- added a patch to use our own route.h, rather then glibc's (which has
381  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
382  though it should be safe everywhere
383
384* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
385- turned off the execute bit for scripts in /usr/doc
386
387* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
388- built against glibc
389
390* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
391- Integrated new patch from David Mosberger
392- Improved description
393
Note: See TracBrowser for help on using the repository browser.