source: projects/specs/trunk/p/ppp/ppp-vl.spec @ 11919

Revision 11919, 12.9 KB checked in by tomop, 5 years ago (diff)

ppp-2.4.7-4

Line 
1%bcond_with ifupdown
2
3%define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
4
5Summary: The PPP (Point-to-Point Protocol) daemon.
6Summary(ja): PPP (Point-to-Point Protocol) デーモン
7Name: ppp
8Version: 2.4.7
9Release: 4%{?_dist_release}
10License: BSD and LGPLv2+ and GPLv2+ and Public Domain
11Group: System Environment/Daemons
12URL: http://www.samba.org/ppp
13
14Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
15Source1: ppp-pam.conf
16Source2: ppp-logrotate.conf
17Source3: ppp-tmpfiles.conf
18Source4: ip-down
19Source5: ip-down.ipv6to4
20Source6: ip-up
21Source7: ip-up.ipv6to4
22Source8: ipv6-down
23Source9: ipv6-up
24Source10: ifup-ppp
25Source11: ifdown-ppp
26Source12: ppp-watch.tar.xz
27
28# Fedora-specific
29Patch0001: 0001-build-sys-use-gcc-as-our-compiler-of-choice.patch
30Patch0002: 0002-build-sys-enable-PAM-support.patch
31Patch0003: 0003-build-sys-utilize-compiler-flags-handed-to-us-by-rpm.patch
32Patch0004: 0004-doc-add-configuration-samples.patch
33Patch0005: 0005-build-sys-don-t-hardcode-LIBDIR-but-set-it-according.patch
34Patch0006: 0006-scritps-use-change_resolv_conf-function.patch
35Patch0007: 0007-build-sys-don-t-strip-binaries-during-installation.patch
36Patch0008: 0008-build-sys-use-prefix-usr-instead-of-usr-local.patch
37Patch0009: 0009-pppd-introduce-ipv6-accept-remote.patch
38Patch0010: 0010-build-sys-enable-CBCP.patch
39Patch0011: 0011-build-sys-don-t-put-connect-errors-log-to-etc-ppp.patch
40Patch0012: 0012-pppd-we-don-t-want-to-accidentally-leak-fds.patch
41Patch0013: 0013-everywhere-O_CLOEXEC-harder.patch
42Patch0014: 0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
43Patch0015: 0015-pppd-move-pppd-database-to-var-run-ppp.patch
44Patch0016: 0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
45Patch0018: 0018-scritps-fix-ip-up.local-sample.patch
46Patch0019: 0019-sys-linux-rework-get_first_ethernet.patch
47Patch0020: 0020-pppd-put-lock-files-in-var-lock-ppp.patch
48Patch0021: 0021-build-sys-compile-pppol2tp-plugin-with-RPM_OPT_FLAGS.patch
49Patch0022: 0022-build-sys-compile-pppol2tp-with-multilink-support.patch
50Patch0023: 0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
51Patch0024: 0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
52Patch0025: 0025-pppd-install-pppd-binary-using-standard-perms-755.patch
53Patch0026: ppp-2.4.7-eaptls-mppe-1.102.patch
54Patch0028: 0028-pppoe-include-netinet-in.h-before-linux-in.h.patch
55
56# rhbz#1556132
57Patch0029: ppp-2.4.7-DES-openssl.patch
58# https://github.com/paulusmack/ppp/pull/95
59Patch0030: ppp-2.4.7-honor-ldflags.patch
60
61BuildRoot: %{_tmppath}/%{name}-%{version}-root
62BuildRequires: glib2-devel, libpcap >= 0.8.3, eudev-libudev-devel, openssl-devel, pam-devel
63#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
64Requires: glibc >= 2.0.6, pam >= 1.0
65Requires(pre): shadow-utils
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: daisuke
70
71%description
72The ppp package contains the PPP (Point-to-Point Protocol) daemon and
73documentation for PPP support.  The PPP protocol provides a method for
74transmitting datagrams over serial point-to-point links. PPP is
75usually used to dial in to an ISP (Internet Service Provider) or other
76organization over a modem and phone line.
77
78%description -l ja
79ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
80PPP を使う為のドキュメントが収められています.PPP プロトコルを
81使うとシリアルな point-to-point 接続上でデータグラムを転送する
82事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
83モデムを介した電話回線で接続する際に使われます.
84
85
86%package devel
87Summary: Headers for ppp plugin development
88SUmmary(ja): ppp プラグイン開発用ヘッダファイル
89Group: Development/Libraries
90
91%description devel
92This package contains the header files for building plugins for ppp.
93
94%description -l ja devel
95このパッケージには ppp のプラグインを開発するためのヘッダファイルが
96含まれています。
97
98%prep
99%setup  -q
100%autopatch -p1
101
102tar -xJf %{SOURCE12}
103
104%build
105export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Wall"
106%configure
107make %{?_smp_mflags}
108make -C ppp-watch %{?_smp_mflags}
109
110%install
111[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
112
113%ifarch x86_64
114make INSTROOT=%{buildroot} install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
115%else
116make INSTROOT=%{buildroot} install install-etcppp
117%endif
118
119find scripts -type f | xargs chmod a-x
120
121make ROOT=%{buildroot} -C ppp-watch install
122
123# create log files dir
124mv -f %{buildroot}/usr/var %{buildroot}/
125
126# install pam config
127install -d %{buildroot}%{_sysconfdir}/pam.d
128install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/ppp
129
130# install logrotate script
131install -d %{buildroot}%{_sysconfdir}/logrotate.d
132install -m 644 -p %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/ppp
133
134# install tmpfiles drop-in
135install -d %{buildroot}%{_tmpfilesdir}
136install -p %{SOURCE3} %{buildroot}%{_tmpfilesdir}/ppp.conf
137
138# install scripts (previously owned by initscripts package)
139install -d %{buildroot}%{_sysconfdir}/ppp
140%if %{with ifupdown}
141install -p %{SOURCE4} %{buildroot}%{_sysconfdir}/ppp/ip-down
142install -p %{SOURCE5} %{buildroot}%{_sysconfdir}/ppp/ip-down.ipv6to4
143install -p %{SOURCE6} %{buildroot}%{_sysconfdir}/ppp/ip-up
144install -p %{SOURCE7} %{buildroot}%{_sysconfdir}/ppp/ip-up.ipv6to4
145install -p %{SOURCE8} %{buildroot}%{_sysconfdir}/ppp/ipv6-down
146install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/ppp/ipv6-up
147%endif
148
149%if %{with ifupdown}
150install -d %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/
151install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifup-ppp
152install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdown-ppp
153%endif
154
155
156%clean
157rm -rf %{buildroot}
158
159
160%pre
161/usr/bin/getent group dip >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 40 dip >/dev/null 2>&1 || :
162
163
164%files
165%defattr(-,root,root)
166%doc FAQ README README.cbcp README.linux README.MPPE README.MSCHAP80 README.MSCHAP81 README.pwfd README.pppoe scripts sample README.eap-tls
167%{_sbindir}/*
168%{_libdir}/pppd
169%{_mandir}/man8/chat.8*
170%{_mandir}/man8/ppp-watch.8*
171%{_mandir}/man8/pppd.8*
172%{_mandir}/man8/pppdump.8*
173%{_mandir}/man8/pppstats.8*
174%{_mandir}/man8/pppd-radattr.8*
175%{_mandir}/man8/pppd-radius.8*
176%{_mandir}/man8/pppoe-discovery.8*
177%dir /etc/ppp
178%config(noreplace) /etc/ppp/*
179%config(noreplace) /etc/pam.d/ppp
180%config(noreplace) /etc/logrotate.d/ppp
181%{_tmpfilesdir}/ppp.conf
182%ghost %dir %{_localstatedir}/run/ppp
183%ghost %dir %{_localstatedir}/lock/ppp
184%attr(700, root, root) %dir %{_localstatedir}/log/ppp
185
186%if %{with ifupdown}
187/etc/sysconfig/network-scripts/ifup-ppp
188/etc/sysconfig/network-scripts/ifdown-ppp
189%endif
190
191%files devel
192%defattr(-,root,root)
193%{_includedir}/pppd
194%doc PLUGINS
195
196
197%changelog
198* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-4
199- rebuilt with openssl-1.1.1.
200- dropped Patch17.
201- imported Patch26-30 from rawhide.
202
203* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-3
204- changed permissions for /etc/logrotate.d/ppp from 755 to 644.
205
206* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.7-2
207- rebuild with openssl-1.0.2
208
209* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-1
210- new upstream release.
211
212* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
213- change BuildRequires: eudev-libudev-devel instead of libudev-devel
214
215* Wed Jun 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
216- new upstream release.
217- replaceed all patches.
218
219* Tue Sep 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-4
220- added /var/run/ppp to %%files. (BTS:1215)
221- added /var/log/ppp to %%files.
222
223* Mon Apr 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-3
224- remove include/linux/if_pppol2tp.h to build pppoe plugin
225- update License tag
226
227* Fri Apr 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-2
228- rebuilt with new toolchain.
229
230* Mon Mar 08 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
231- new upstream release.
232- replaced all patches with Fedora's.
233- replaced 'BuildPreReq:' with 'BuildRequires:'.
234
235* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
236- update pam.d/ppp to fix pam-1.0
237
238* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
239- added option LIBDIR at makeinstall for x86_64
240
241* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
242- add -devel subpackage to develop ppp plugins
243
244* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
245- update Source1 for pam-1.0.1
246- import several patches from Fedora 2.4.4-7
247
248* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
249- new upstream release
250- rebuilt with new toolchain and environment
251- added URL (also URL of Source0)
252
253* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
254- use License: instead of Copyright:
255
256* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
257- new upstream release.
258- replace patch0.
259
260* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
261- new upstream release.
262- remove patch 2-4 (no longer needed).
263
264* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
265- rebuild with new toolchains
266
267* Sun Jun 10 2001 <sagami@vinelinux.org>
268- 2.4.1-0vl1: update to 2.4.1
269
270* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
271- 2.4.0-2vl1
272- based on 2.4.0-2 from Rawhide
273- added Japanese summary and description
274- Requires: /etc/pam.d/system-auth -> pam >= 0.72
275  (for better compatibility with apt for rpm)
276
277* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
278- rebuild in new environment
279
280* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
281- update to 2.4.0
282
283* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
284- automatic rebuild
285
286* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
287- move man pages to %{_mandir}
288
289* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
290- change perms using defattr
291- modify PAM setup to use system-auth
292
293* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
294- change to root:root perms
295
296* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
297- reaper bugs verified as fixed
298- check pam_open_session result code (bug #9966)
299
300* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
301- take a shot at the wrong reaper bugs (#8153, #5290)
302
303* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
304- free ride through the build system (release 2)
305
306* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
307- Update to 2.3.11
308
309* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
310- Better fix for both problems
311
312* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
313- fix for double-dial problem
314- fix for requiring a controlling terminal problem
315
316* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
317- 2.3.10 bugfix release
318
319* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
320- New version 2.3.9 required for kernel 2.3.13 and will be required
321  for new initscripts.  auth patch removed; 2.3.9 does the same thing
322  more readably than the previous patch.
323
324* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
325- add pppdump
326
327* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
328- force pppd use the glibc's logwtmp instead of implementing its own
329
330* Thu Apr 01 1999 Preston Brown <pbrown@redhat.com>
331- version 2.3.7 bugfix release
332
333* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
334- version 2.3.6
335
336* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
337- auth patch
338
339* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
340- auto rebuild in the new build environment (release 3)
341
342* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
343- build for glibc 2.1
344
345* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
346- updated to 2.3.5.
347
348* Tue May 19 1998 Prospector System <bugs@redhat.com>
349- translations modified for de
350
351* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
352- make it run with kernels 2.1.100 and above.
353
354* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
355- translations modified for de, fr, tr
356
357* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
358- requires glibc 2.0.6 or later
359
360* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
361- updated PAM patch to not turn off wtmp/utmp/syslog logging.
362
363* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
364- added the /etc/pam.d config file
365- updated PAM patch to include session support
366
367* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
368- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
369  required any more.
370- added buildroot
371- fixed the PAM support, which was really, completely broken and against any
372  standards (session support is still not here... :-( )
373- we build against running kernel and pray that it will work
374- added a samples patch; updated glibc patch
375
376* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
377- added a patch to use our own route.h, rather then glibc's (which has
378  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
379  though it should be safe everywhere
380
381* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
382- turned off the execute bit for scripts in /usr/doc
383
384* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
385- built against glibc
386
387* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
388- Integrated new patch from David Mosberger
389- Improved description
390
Note: See TracBrowser for help on using the repository browser.