source: projects/specs/trunk/p/postfix/postfix-vl.spec @ 7153

Revision 7153, 30.6 KB checked in by daisuke, 12 years ago (diff)

postfix:

  • update to 2.9.4
  • update dynamicmaps patches
  • add sqite3 map support, add postfix-sqlite subpackage.
  • drop unneeded patches
Line 
1#%define build_mysql %{?_with_mysql:1}%{!?_with_mysql:0}
2#%define build_pgsql %{?_with_pgsql:1}%{!?_with_pgsql:0}
3
4%define build_mysql 1
5%define build_pgsql 1
6
7%define _sysconfdir   /etc
8%define _data_dir     %{_var}/lib/postfix
9
10%define origversion 2.9.4
11
12# Macro: %{dynmap_add_cmd <name> [-m]}
13%define dynmap_add_cmd(m) FILE=%{_sysconfdir}/postfix/dynamicmaps.cf; if ! grep -q "^%{1}[[:space:]]" ${FILE}; then echo "Adding %{1} map entry to ${FILE}"; printf '%%-8s%%-35s%%-18s%%s\\n' %{1} %{_libdir}/postfix/dict_%{1}.so dict_%{1}_open %{-m:mkmap_%{1}_open} >> ${FILE}; fi;
14%define dynmap_rm_cmd() FILE=%{_sysconfdir}/postfix/dynamicmaps.cf; if [ $1 = 0 -a -s $FILE ]; then cp -p ${FILE} ${FILE}.$$; grep -v "^%{1}[[:space:]]" ${FILE}.$$ > ${FILE}; rm -f ${FILE}.$$; fi;
15
16Summary:   Postfix Mail Transport Agent
17Summary(ja):   Postfix メールトランスポートエージェント
18Name:      postfix
19Version:   %{origversion}
20Release:   1%{?_dist_release}
21URL:       http://www.postfix.org/
22License:   Distributable - IBM PUBLIC LICENSE VERSION 1.0 - SECURE MAILER
23Group:     System Environment/Daemons
24
25Source0:   ftp://postfix.cloud9.net/official/%{name}-%{version}.tar.gz
26Source1:   postfix.aliases
27Source2:   postfix.cron
28Source3:   postfix.init
29
30Patch0:    postfix-2.9.1-vine.patch
31
32# patches 100-199 are imported from debian package.
33# patches 100/101 for postfix 2.8.x are from mdk.
34Patch100: postfix-2.9.1-dynamicmaps.diff
35Patch101: postfix-2.9.1-dynamicmaps2.diff
36
37# patches 200-299 are imported from rh/fedora
38Patch200: postfix-2.5.7-large-fs.patch     
39
40Provides:  smtpdaemon
41Conflicts: sendmail
42Requires(pre):    chkconfig
43BuildRequires: db4-devel >= 4.6.21, pam-devel, gdbm-devel
44BuildRequires: cyrus-sasl-devel >= 2
45BuildRequires: openldap-devel, openssl-devel
46BuildRequires: pcre-devel
47%if %build_mysql
48BuildRequires: MySQL-devel
49%endif
50%if %build_pgsql
51BuildRequires: postgresql-devel
52%endif
53BuildRequires: sqlite3-devel
54
55Requires:    cyrus-sasl >= 2, cyrus-sasl-md5, cyrus-sasl-plain
56Requires:    gdbm, pam, openssl
57Requires(pre):      db4 >= 4.6.21
58Obsoletes: postfix-beta
59BuildRoot: %{_tmppath}/%{name}-%{version}-root
60
61Vendor: Project Vine
62Distribution: Vine Linux
63Packager: daisuke
64
65
66%description
67Postfix aims to be an alternative to the widely-used sendmail
68program.  Sendmail is responsible for 70 percent of all e-mail delivered
69on the Internet.  With an estimated 100 million users, that's an
70estimated 10 billion (10^10) messages daily. A stunning number.
71
72Although IBM supported the Postfix development, it abstains from
73control over its evolution. The goal is to have Postfix installed
74on as many systems as possible. To this end, the software is given
75away with no strings attached to it, so that it can evolve with
76input from and under control by its users.
77
78#'
79%description -l ja
80Postfix は現在広く使われている sendmail を置き換える目的で
81開発されています。sendmail は約 70% の E-mail サーバで使用
82されています。また、その使用者は 100万人にもおよび、およそ
83一日 1 千万通ものメールを処理しています。
84
85Postfix の開発は IBM によってサポートされており、全世界の
86全てのシステムを postfix にすることを目標としています。
87
88%package sqlite
89Summary: SQLite3 map support for Postfix
90Group:     System Environment/Daemons
91Requires(pre): postfix = %{version}-%{release}
92Requires: sqlite3
93%description sqlite
94This package contains shared lib module which support
95SQLite map on Postfix.
96%description -l ja sqlite
97このパッケージには、Postfix で SQLite map を使うのに
98必要なライブラリが納められています。
99
100%if %build_pgsql
101%package pgsql
102Summary: PGSQL map support for Postfix
103Group:     System Environment/Daemons
104Requires(pre): postfix = %{version}-%{release}
105Requires: postgresql-libs, postgresql
106%description pgsql
107This package contains shared lib module which support
108PostgreSQL map on Postfix.
109%description -l ja pgsql
110このパッケージには、Postfix で PostgreSQL を使うのに必要な
111ライブラリが納められています。
112%endif
113
114%if %build_mysql
115%package mysql
116Summary: MySQL map support for Postfix
117Group:     System Environment/Daemons
118Requires(pre): postfix = %{version}-%{release}
119%description mysql
120This package contains shared lib module which support
121MySQL map on Postfix.
122%description -l ja mysql
123このパッケージには、Postfix で MySQL を使うのに必要な
124ライブラリが納められています。
125%endif
126
127%package ldap
128Summary: LDAP map support for Postfix
129Group:     System Environment/Daemons
130Requires(pre): postfix = %{version}-%{release}
131Requires: openldap
132%description ldap
133This package contains shared lib module which support
134OpenLDAP map on Postfix.
135%description -l ja ldap
136このパッケージには、Postfix で OpenLDAP を使うのに必要な
137ライブラリが納められています。
138
139%package pcre
140Summary: PCRE map support for Postfix
141Group:     System Environment/Daemons
142Requires(pre): postfix = %{version}-%{release}
143Requires: pcre
144%description pcre
145This package contains shared lib module which support
146PCRE map on Postfix.
147%description -l ja pcre
148このパッケージには、Postfix で PCRE マップを使うのに必要な
149ライブラリが納められています。
150
151%prep
152# japanese documant for 2.4.x is not ready.
153# %setup -q -a 10 -a 20 -a 30 -a 40
154%setup -q
155
156%patch0 -p1 -b .vine
157
158%ifarch x86_64
159sed -i -e 's|/usr/lib/postfix|/usr/lib64/postfix|g' conf/main.cf
160%endif
161
162%patch100 -p1 -b .dynamicmaps
163%patch101 -p1 -b .dynamicmaps2
164
165%patch200 -p1 -b .large-fs
166
167# patching src/global/Makefile to remove dependency
168pushd src/global
169%if %build_mysql
170:
171%else
172sed -ie "s/ dict_mysql.so/ /" Makefile.in
173%endif
174%if %build_pgsql
175:
176%else
177sed -ie "s/ dict_pgsql.so/ /" Makefile.in
178%endif
179popd
180
181%build
182make makefiles \
183        CCARGS="-DMAX_DYNAMIC_MAPS \
184                -DUSE_SASL_AUTH -I/usr/include/sasl \
185                -DUSE_CYRUS_SASL \
186                -DHAS_LDAP \
187                -DHAS_SSL -I/usr/include/openssl \
188                -DHAS_PCRE -I/usr/include/pcre \
189                -DHAS_SQLITE \
190%if %build_mysql
191                -DHAS_MYSQL -I/usr/include/mysql  \
192%endif
193%if %build_pgsql
194                -DHAS_PGSQL -I/usr/include/pgsql \
195%endif
196                -DUSE_TLS" \
197        AUXLIBS="-lsasl2 -lssl -lcrypto" \
198        OPT="$RPM_OPT_FLAGS" DEBUG=""
199for libs in master global util dns tls milter xsasl
200do
201  ln -sf lib${libs}.a lib/libpostfix-${libs}.so.1
202done
203
204# make %{?_smp_mflags} DEBUG="" OPT="$RPM_OPT_FLAGS" \
205#      LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH}
206
207# using _smp_mflags makes build error. why? (2008.10.11)
208make DEBUG="" OPT="$RPM_OPT_FLAGS" \
209     LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH} CDBSO=""
210
211%install
212rm -rf $RPM_BUILD_ROOT
213rm -f html/Makefile.in
214rm -f README_FILES/*.*
215
216install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
217install -d $RPM_BUILD_ROOT%{_sysconfdir}/postfix
218install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
219install -d $RPM_BUILD_ROOT%{_bindir}
220install -d $RPM_BUILD_ROOT%{_libdir}/postfix
221install -d $RPM_BUILD_ROOT%{_mandir}/man{1,5,8}
222install -d $RPM_BUILD_ROOT%{_mandir}/ja/man{1,5,8}
223install -d $RPM_BUILD_ROOT%{_sbindir}
224install -d $RPM_BUILD_ROOT%{_var}/spool/postfix
225install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,incoming,pid,public}
226install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{bounce,defer,flush,maildrop,private,saved}
227
228install -m755 bin/* $RPM_BUILD_ROOT%{_sbindir}
229install -m755 libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
230#install -m755 lib/dict_* $RPM_BUILD_ROOT%{_libdir}/postfix
231install -m755 lib/lib*.so.1 $RPM_BUILD_ROOT%{_libdir}
232
233touch conf/dynamicmaps.cf
234for i in main.cf master.cf access aliases canonical header_checks \
235         main.cf.default post-install postfix-files postfix-script \
236         relocated transport virtual dynamicmaps.cf
237do
238  install -m644 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
239done
240for i in post-install postfix-script
241do
242  install -m755 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
243done
244
245install -m644 man/man1/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
246install -m644 man/man5/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
247install -m644 man/man8/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
248
249install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/postfix/aliases
250install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/postfix
251install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/postfix
252
253ln -sf postfix/aliases $RPM_BUILD_ROOT%{_sysconfdir}/aliases
254ln -sf postfix/aliases.db $RPM_BUILD_ROOT%{_sysconfdir}/aliases.db
255
256( cd $RPM_BUILD_ROOT%{_bindir}
257  ln -sf ../sbin/sendmail mailq
258  ln -sf ../sbin/sendmail newaliases
259)
260( cd $RPM_BUILD_ROOT%{_libdir}
261  ln -sf ../sbin/sendmail sendmail
262)
263
264for I in etc/postfix/{aliases,access,canonical,header_check,relocated,transport,virtual}
265do
266   touch $RPM_BUILD_ROOT/$I{,.db}
267done
268
269# data dir
270install -d $RPM_BUILD_ROOT%{_data_dir}
271
272%pre
273if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 0 ]; then
274   %{_sbindir}/useradd -M -r -d %{_var}/spool/postfix -s "" \
275                     -c "postfix" postfix || :
276fi
277if [ `grep postfix %{_sysconfdir}/group | wc -l` = 0 ]; then
278  %{_sbindir}/groupadd -r postfix
279fi
280if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 0 ]; then
281  %{_sbindir}/groupadd -r postdrop
282fi
283#if [ -f %{_var}/lock/subsys/postfix ]; then
284#   %{_sysconfdir}/rc.d/init.d/postfix stop
285#fi
286
287
288%post
289/sbin/ldconfig
290%dynmap_add_cmd tcp
291/sbin/chkconfig --add postfix
292if [ ! -f %{_sysconfdir}/postfix/aliases.db ]; then
293  touch %{_sysconfdir}/postfix/aliases.db
294fi
295%{_sbindir}/postalias %{_sysconfdir}/postfix/aliases ||:
296if [ ! -e %{_libdir}/sendmail ]; then
297        ln -sf %{_sbindir}/sendmail %{_libdir}/sendmail
298fi
299/sbin/chkconfig --del sendmail &> /dev/null ||:
300%{_sbindir}/postfix check >/dev/null 2>&1 ||:
301if [ -f %{_var}/lock/subsys/postfix ]; then
302   %{_sysconfdir}/rc.d/init.d/postfix restart
303fi
304
305
306%preun
307if [ $1 = 0 ]; then
308   if [ -f %{_var}/lock/subsys/postfix -a -f %{_sysconfdir}/rc.d/init.d/postfix ]; then
309      %{_sysconfdir}/rc.d/init.d/postfix stop
310   fi
311   /sbin/chkconfig --del postfix
312fi
313
314
315%postun
316/sbin/ldconfig
317if [ $1 = 0 ]; then
318   if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 1 ]; then
319      %{_sbindir}/userdel postfix
320   fi
321   if [ `grep postfix %{_sysconfdir}/group | wc -l` = 1 ]; then
322      %{_sbindir}/groupdel postfix
323   fi
324   if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 1 ]; then
325      %{_sbindir}/groupdel postdrop
326   fi
327   if ! [ -f %{_var}/lock/subsys/postfix ]; then
328        rm -rf %{_var}/lock/subsys/postfix
329   fi
330fi
331
332%post sqlite
333%dynmap_add_cmd sqlite
334
335%preun sqlite
336%dynmap_rm_cmd sqlite
337
338%if %build_pgsql
339%post pgsql
340%dynmap_add_cmd pgsql
341
342%preun pgsql
343%dynmap_rm_cmd pgsql
344%endif
345
346%if %build_mysql
347%post mysql
348%dynmap_add_cmd mysql
349
350%preun mysql
351%dynmap_rm_cmd mysql
352%endif
353
354%post ldap
355%dynmap_add_cmd ldap
356
357%postun ldap
358%dynmap_rm_cmd ldap
359
360%post pcre
361%dynmap_add_cmd pcre
362
363%postun pcre
364%dynmap_rm_cmd pcre
365
366%clean
367rm -rf $RPM_BUILD_ROOT
368
369
370%files
371%defattr(-,root,root)
372%doc COMPATIBILITY COPYRIGHT HISTORY LICENSE INSTALL PORTING RELEASE_NOTES
373# japanese documant for 2.4.x is not ready.
374# %doc conf.ja
375# %doc html html.ja
376# %doc README_FILES README_FILES.ja
377%doc README_FILES
378# %doc man-%{jmanversion}/readme_ja.txt
379%{_sysconfdir}/aliases
380%{_sysconfdir}/aliases.db
381%config %{_sysconfdir}/cron.daily/postfix
382%dir %{_sysconfdir}/postfix
383%config %{_sysconfdir}/postfix/main.cf.default
384%config %{_sysconfdir}/postfix/master.cf
385%config(noreplace) %{_sysconfdir}/postfix/aliases
386%config(noreplace) %{_sysconfdir}/postfix/access
387%config(noreplace) %{_sysconfdir}/postfix/canonical
388%config(noreplace) %{_sysconfdir}/postfix/header_check
389%config(noreplace) %{_sysconfdir}/postfix/header_checks
390%config(noreplace) %{_sysconfdir}/postfix/main.cf
391%config(noreplace) %{_sysconfdir}/postfix/relocated
392%config(noreplace) %{_sysconfdir}/postfix/transport
393%config(noreplace) %{_sysconfdir}/postfix/virtual
394%config(noreplace) %{_sysconfdir}/postfix/dynamicmaps.cf
395%config %{_sysconfdir}/postfix/postfix-files
396%config %{_sysconfdir}/postfix/post-install
397%config %{_sysconfdir}/postfix/postfix-script
398%config %{_sysconfdir}/rc.d/init.d/postfix
399%{_bindir}/*
400%dir %{_libdir}/postfix
401%{_libdir}/postfix/*
402
403%if %{build_pgsql}
404%exclude %{_libdir}/postfix/dict_pgsql.so
405%endif
406%if %{build_mysql}
407%exclude %{_libdir}/postfix/dict_mysql.so
408%endif
409
410%exclude %{_libdir}/postfix/dict_sqlite.so
411%exclude %{_libdir}/postfix/dict_ldap.so
412%exclude %{_libdir}/postfix/dict_pcre.so
413%{_libdir}/lib*.so.1
414%{_sbindir}/postalias
415%{_sbindir}/postcat
416%{_sbindir}/postconf
417%attr(2755,root,postdrop) %{_sbindir}/postdrop
418%{_sbindir}/postfix
419%{_sbindir}/postkick
420%{_sbindir}/postlock
421%{_sbindir}/postlog
422%{_sbindir}/postmap
423%{_sbindir}/postmulti
424%attr(2755,root,postdrop) %{_sbindir}/postqueue
425%{_sbindir}/postsuper
426%{_sbindir}/qmqp-sink
427%{_sbindir}/qmqp-source
428%{_sbindir}/sendmail
429%{_sbindir}/smtp-sink
430%{_sbindir}/smtp-source
431%attr(-,root,man) %{_mandir}/man*/*
432# %attr(-,root,man) %{_mandir}/ja/man*/*
433%dir %{_var}/spool/postfix
434%attr(0750,postfix,root) %dir %{_data_dir}
435%attr(1733,postfix,postdrop) %dir %{_var}/spool/postfix/maildrop
436%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/active
437%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/corrupt
438%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/deferred
439%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/incoming
440%attr(0755,root,root) %dir %{_var}/spool/postfix/pid
441%attr(0710,postfix,postdrop) %dir %{_var}/spool/postfix/public
442%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/bounce
443%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/defer
444%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/flush
445%attr(0710,postfix,postfix) %dir %{_var}/spool/postfix/private
446%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/saved
447%{_libdir}/sendmail
448
449%files sqlite
450%defattr(-,root,root)
451%{_libdir}/postfix/dict_sqlite.so
452
453%if %build_pgsql
454%files pgsql
455%defattr(-,root,root)
456%{_libdir}/postfix/dict_pgsql.so
457%endif
458
459%if %build_mysql
460%files mysql
461%defattr(-,root,root)
462%{_libdir}/postfix/dict_mysql.so
463%endif
464
465%files ldap
466%defattr(-,root,root)
467%{_libdir}/postfix/dict_ldap.so
468
469%files pcre
470%defattr(-,root,root)
471%{_libdir}/postfix/dict_pcre.so
472
473%changelog
474* Sun Nov 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.4-1
475- update to 2.9.4
476- update dynamicmaps patches
477- add sqite3 map support, add postfix-sqlite subpackage.
478- drop unneeded patches
479
480* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.12-1
481- update to 2.8.12
482- rebuild with pcre-8.31
483
484* Tue May 01 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.10-1
485- update to 2.8.10
486
487* Sun Mar 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.9-1
488- update to 2.8.9
489
490* Thu May 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-1
491- update to 2.8.3
492
493* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-1
494- update to 2.8.2
495- update dynamicmaps patch
496
497* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.8-5
498- rebuilt with postgresql-9.0.3
499
500* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.8-4
501- rebuilt with openssl 1.0.0c
502- fix changelog typo..
503
504* Wed Dec 01 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.8-3
505- new upstream release.
506- updated %%patch100 and %%patch210.
507
508* Sat Feb 20 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.5-2
509- removed MySQL-shared from "Requires:" and "BuildRequires:".
510- replaced "Prereq:" with "Requires(pre):".
511- replaced "BuildPrereq:" with "BuildRequires:".
512
513* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-1
514- new upstream release
515- rebuild with db4-4.8.0
516
517* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-2
518- change /var/spool/postfix/pid owner and permission
519  (0700,postfix,postfix -> 0755,root,root)
520
521* Mon Aug  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-1
522- new upstream release
523
524* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.2-1
525- new upstream release.
526
527* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-2
528- added a missing file.
529
530* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-1
531- new upstream release.
532- updated dynamicmaps patch.
533
534* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.7-2
535- made to build -mysql and -pgsql as default.
536- rebuilt with MySQL-5.1.34.
537
538* Wed May 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.7-1
539- new upstream release
540- update Patch200 from fc10
541
542* Sun Mar 01 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.6-2
543- rebuilt with openldap-2.4.11
544
545* Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.6-1
546- new upstream release
547
548* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-4
549- add patch200/patch210 from fedora
550
551* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-3
552- add Requires cyrus-sasl-md5, cyrus-sasl-plain for smtp auth
553- add Japanese description into sub packages
554
555* Sat Oct 11 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-2
556- update patch100/101 to fix libxsasl build issue
557- remove smp flag in build section to solve build error
558- add _data_dir
559
560* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
561- new upstream release
562- update patch100/101 to fit 2.5.5 (from suse)
563- add %exclude dict_{my,pg}sql.so to %%files to avoid unneeded dependancy
564  when option "--with XXsql" is specified. (from Vine 4.x update package)
565- remove HAS_DLOPEN macro.
566
567* Sat Sep 06 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.9-1
568- new upstream release with security fix
569
570* Sat Aug 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-2
571- add %%if %%build_mysql and %%if %%mysql from BuildRequires section again
572- remove unnessary dependency
573
574* Thu Aug 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-1
575- new upstream release with security fix
576
577* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-4
578- spec in UTF-8
579
580* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.7-3
581- rebuilt against db4-4.6.21
582
583* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.7-2
584- add HAS_DLOPEN macro.
585- add USE_CYRUS_SASL macro.
586- modify dynamicmaps.cf (/usr/lib -> %%{_libdir}).
587
588* Thu Mar 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.7-1
589- new upstream release
590- update patch100 (it is based from mdk 2008.0)
591- add smp_mflags in make section
592- build under new versioning policy
593
594* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl10
595- rebuilt with postgresql-devel 8.2.5
596- updated Source20, 30 and 40
597
598* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl9
599- rebuild with new openssl
600
601* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.10-0vl8
602- rebuilt with new toolchain and db4-4.3.x
603
604* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 2.2.10-0vl7
605- <BTS:493> fix typo in %%if statement for %%files mysql section.
606- remove %%if %%build_mysql and %%if %%mysql from BuildRequires section,
607  (Patch100 always builds dict_mysql.o and dict_pgsql.o)
608
609* Fri Oct 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl6
610- disable MySQL, PostgreSQL support by default.
611  use "--with {mysql|pgsql}" to build them.
612
613* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl5
614- add lib64 patch to correct daemon_directory on x86_64 architecture
615
616* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl4
617- remove duplicated entry from aliases. (<BTS:170>)
618
619* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl3
620- add some pseudo accounts to aliases. (<BTS:170>)
621- add BuildPreReq: MySQL-shared
622
623* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl2
624- rebuilt with openldap-2.3.27-0vl1
625
626* Sun Apr 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl1
627- new upstream release
628
629* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
630- new upstream release
631
632* Fri Sep 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.5-0vl1
633- new upstream release
634  - update to 2.2.5
635- update dynamicmaps from debian package
636- update Japaese manpages and jconf
637- add jhtml and jreadme
638- enable TLS/SSL
639
640* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
641- new upstream release
642- update all patches
643- link sasl2 instead of sasl1
644
645* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.20-0vl6
646- enable cyrus-sasl.
647- add TLS/IPv6 patch.
648- modify main.cf to disable IPv6 as default.
649
650* Wed Oct 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl5
651- add PreReq: db4 >= 4.2.52
652  (to avoid errors when upgrading from db40-linked version)
653
654* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl4
655- rebuilt with db4-4.2.52
656
657* Tue Jun  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl3
658- fix first installation time bugs...
659  - remove aliases.db from %%files again
660  - add 'touch aliases.db' in %%post script
661- update default main.cf to use /etc/postfix/aliases as default alias_database
662
663* Mon Jun  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl2
664- add /etc/postfix/aliases.db to %%files
665
666* Sat May  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl1
667- new upstream release
668
669* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.19-0vl1
670- new upstream release
671- build with new postgresql
672
673* Fri Sep 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.16-0vl1
674- new upstream release
675- update jconf/jman/jhtml
676
677* Fri Jul  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.13-0vl1
678- new upstream release
679- update jman/jhtml/jreadme
680
681* Mon Jun 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-0vl1
682- new upstream release
683- update jconf/jman/jhtml/jreadme
684
685* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.10-0vl1
686- new upstream release
687
688* Fri May 23 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.9-0vl5
689- rebuild by new cyrus-sasl(2.1.13-3vl1)
690
691* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl4
692- add more BuildPreReq, Requires
693- fix some typo
694- add missing files to %%files.
695
696* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl3
697- rebuild
698
699* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl2
700- add debian's dynamic map patch.
701  some additional feature is divided to sub package.
702  - postfix-ldap, postfix-mysql, postfix-pgsql, postfix-pcre
703- split common postfix libraries as shared libs.
704  - libpostfix-{master,global,util,dns}.so.1
705- use cyrus-sasl for SMTP-AUTH
706
707* Wed Apr 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl1
708- new upstream release 2.0.9
709- update jman/jhtml/jconf to 2.0.8
710
711* Wed Apr  9 2003 IWAI Masaharu <iwai@alib.jp> 2.0.7-0vl1
712- new upstream version
713- update documents
714    - jman (source4)
715    - jconf (Source5)
716    - faq.html (Source6)
717    - INSTALL.jp (Source7)
718    - jhtml (Source12)
719
720* Sun Jan 19 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.12-0vl3
721- rebuilt against db4
722
723* Wed Dec 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl2
724- rebuild to remove unnecessary dependancy.
725
726* Sat Nov 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl1
727- new upstream version
728- modified /etc/init.d/postfix
729
730* Sun Oct 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl3
731- fixed brainless mistakes...
732  update main.cf again.
733
734* Thu Oct 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl2
735- update main.cf patch
736  - do not use procmail for local mailer.
737  - do not show version and OS name for smtpd greeting banner.
738
739* Thu Jun 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl1
740- new upstream release
741- update jman, jconf, jhtml
742
743* Tue May 28 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl2
744- updated main.cf patch ( Patch0 )
745    undefine myhostname
746
747* Fri May 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl1
748- changed %%{_var}/spool/postfix/private directory permission (0700 -> 0710)
749    Thanks Mr. Daisuke SUZUKI ([VineSeed:06454])
750
751* Thu May 23 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl0
752- upstream release
753- updated japanese documents Source4-9
754    ( and the unofficial Japanese Web Site moved. )
755- added japanese documents  Source10-12
756- updated main.cf patch ( Patch0 )
757- added postdrop group
758- added some directories in %%{_var}/spool/postfix/
759    active, corrupt, deferred, incoming, pid, public, bounce,
760    defer,flush,private and saved directories
761
762* Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl3
763- not stop in %%pre
764- not start but restart in %%post
765
766* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl2
767- added BuildPreReq: db3-devel
768
769* Sat Nov 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl08-0vl1
770- updated to 20010228-pl08
771
772* Fri Nov  9 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl06-0vl1
773- updated to 20010228-pl06
774
775* Sun Sep 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl05-0vl1
776- updated to 20010228-pl05
777
778* Wed Aug  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl04-0vl1
779- updated to 20010228-pl04
780
781* Wed Jun 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl2
782- update Japanese documents and manpages
783
784* Sun May 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl1
785- updated to 20010228-pl03
786
787* Mon May 21 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
788- 0.0.20010228pl02-0vl3
789- modified %%preun script again
790  (to check whether %%{_sysconfidir}/rc.d/init.d/postfix already exists)
791
792* Wed May 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
793- 0.0.20010228pl02-0vl2
794- fixed incorrect %%preun script :-P
795
796* Tue May  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl02-0vl1
797- updated to 20010228-pl02
798
799* Wed Apr 11 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl4
800- add {pcre,regexp}_table to %files
801- don't replace config files
802- start postfix after install/upgrade
803
804* Mon Apr 09 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl2
805- updated jman pages and translations.
806- added japanese sample config files.
807
808* Sat Mar 31 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl1
809- updated to 20010228-pl01
810
811* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl2
812- fixed file location
813
814* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl1
815- updated to 20010228
816
817* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 0.0.199912310pl13-0vl2
818- fixed about mandir
819
820* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl13-0vl1
821- updated to 19991231-pl13
822- use rpm macros in spec
823
824* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl11-0vl1
825- updated to 19991231-pl11
826
827* Thu Nov  9 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl10-0vl1
828- updated to 19991231-pl10
829
830* Thu Oct 12 2000 Yoshihiro Kajiki <kajiki@ylug.org>
831- fix newaliases problem by adding slink
832
833* Sat Oct  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
834- add japanese man pages
835
836* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
837- updates to 19991231-pl09-0vl2
838- fixed Group
839
840* Sat Sep 22 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
841- updates to 19991231-pl09
842
843* Wed Aug 09 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
844- %build, removed bzip2 -9 and strip
845- fixed %files section to handle compressed man page
846
847* Wed Jun 21 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
848- Version name changes to 0.0.version
849- updates to 19991231-pl08
850  + Major changes with postfix-19991231-pl08:
851    Specify "body_checks = regexp:%{_sysconfdir}/postfix/body_checks" for a quick
852    and dirty emergency content filter that looks at non-header lines
853    one line at a time (including MIME headers inside the message body).
854    Details in conf/sample-filter.cf.
855  + Incompatible changes with postfix-19991231-pl07:
856    As required by RFC 822, Postfix now inserts a generic destination
857    message header when no destination header is present.  The text is
858    specified via the undisclosed_recipients_header configuration
859    parameter (default:  "To: undisclosed-recipients:;").
860
861* Thu Apr  6 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
862- updates to 19991231-pl06
863- added percent hack to main.cf
864
865* Sun Feb 20 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
866- adopted to Vine Linux
867
868* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
869- updated to 19991231
870- added postfix group
871- corrected aliases.db bug
872
873* Mon Dec 27 1999 Jerome Dumonteil <jd@mandrakesoft.com>
874- Add postfix check in post to create sub dirs in spool
875
876* Mon Dec 20 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
877- Add -a $DOMAIN -d $LOGNAME to procmail (philippe).
878- New banner.
879
880* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
881- fix if conflicts with sendmail.
882
883* Sat Jun  5 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
884- install bins from libexec/
885
886* Sat Jun  5 1999 Bernhard Rosenkr舅zer <bero@mandrakesoft.com>
887- 19990601
888- .spec cleanup for easier updates
889
890* Wed May 26 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
891- created link from %{_sbindir}/sendmail to %{_libdir}/sendmail
892  so it doesn't bug out when i rpm -e sendmail
893- Now removes %{_var}/lock/subsys/postfix like a good little prog
894  upon rpm -e
895
896* Fri Apr 23 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
897
898- Mandrake adptations.
899
900* Tue Apr 13 1999 Arne Coucheron <arneco@online.no>
901  [19990317-pl04-1]
902
903* Tue Mar 30 1999 Arne Coucheron <arneco@online.no>
904  [19990317-pl03-2]
905- Castro, Castro, pay attention my friend. You're making it very hard
906  maintaining the package if you don't follow the flow of the releases
907
908* Thu Mar 25 1999 Arne Coucheron <arneco@online.no>
909  [19990317-pl02-1]
910
911* Tue Mar 23 1999 Arne Coucheron <arneco@online.no>
912  [19990317-3]
913- added bugfix patch01
914
915* Sat Mar 20 1999 Arne Coucheron <arneco@online.no>
916  [19990317-2]
917- removed the mynetworks line in main.cf, let postfix figure it out
918- striping of the files in %{_sbindir}
919- alias database moved to %{_sysconfdir}/postfix and made a symlink to it in %{_sysconfdir}
920- enabled procmail support in main.cf and added it to Requires:
921- check status on master instead of postfix in the init script
922- obsoletes postfix-beta
923- had to move some of my latest changelog entries up here since Edgard Castro
924  didn't follow my releases
925
926* Thu Mar 18 1999 Edgard Castro <castro@usmatrix.net>
927  [19990317]
928
929* Tue Mar 16 1999 Edgard Castro <castro@usmatrix.net>
930  [alpha-19990315]
931
932* Tue Mar  9 1999 Edgard Castro <castro@usmatrix.net>
933  [19990122-pl01-2]
934- shell and gecho information changed to complie with Red Hat stardand
935- changed the name of the rpm package to postfix, instead of postfix-beta
936
937* Tue Feb 16 1999 Edgard Castro <castro@usmatrix.net>
938  [19990122-pl01-1]
939
940* Sun Jan 24 1999 Arne Coucheron <arneco@online.no>
941  [19990122-1]
942- shell for postfix user changed to /bin/true to avoid logins to the account
943- files in %{_libdir}exec/postfix moved to %{_libdir}/postfix since this complies
944  more with the Red Hat standard
945
946* Wed Jan 06 1999 Arne Coucheron <arneco@online.no>
947  [19981230-2]
948- added URL for the source
949- added a cron job for daily check of errors
950- sample config files moved from /etc/postfix/sample to the docdir
951- dropped making of symlinks in %{_sbindir} and instead installing the real
952  files there
953- because of the previous they're not needed anymore in %{_libdir}exec/postfix,
954  so they are removed from that place
955
956* Fri Jan 01 1999 Arne Coucheron <arneco@online.no>
957  [19981230-1]
958
959* Tue Dec 29 1998 Arne Coucheron <arneco@online.no>
960  [19981222-1]
961- first build of rpm version
Note: See TracBrowser for help on using the repository browser.