source: projects/specs/trunk/p/postfix/postfix-vl.spec @ 7190

Revision 7190, 30.8 KB checked in by tomop, 11 years ago (diff)

postfix-2.9.4-2

Line 
1#%define build_mysql %{?_with_mysql:1}%{!?_with_mysql:0}
2#%define build_pgsql %{?_with_pgsql:1}%{!?_with_pgsql:0}
3
4%define build_mysql 1
5%define build_pgsql 1
6
7%define _sysconfdir   /etc
8%define _data_dir     %{_var}/lib/postfix
9
10%define origversion 2.9.4
11
12# Macro: %{dynmap_add_cmd <name> [-m]}
13%define dynmap_add_cmd(m) FILE=%{_sysconfdir}/postfix/dynamicmaps.cf; if ! grep -q "^%{1}[[:space:]]" ${FILE}; then echo "Adding %{1} map entry to ${FILE}"; printf '%%-8s%%-35s%%-18s%%s\\n' %{1} %{_libdir}/postfix/dict_%{1}.so dict_%{1}_open %{-m:mkmap_%{1}_open} >> ${FILE}; fi;
14%define dynmap_rm_cmd() FILE=%{_sysconfdir}/postfix/dynamicmaps.cf; if [ $1 = 0 -a -s $FILE ]; then cp -p ${FILE} ${FILE}.$$; grep -v "^%{1}[[:space:]]" ${FILE}.$$ > ${FILE}; rm -f ${FILE}.$$; fi;
15
16Summary:   Postfix Mail Transport Agent
17Summary(ja):   Postfix メールトランスポートエージェント
18Name:      postfix
19Version:   %{origversion}
20Release:   2%{?_dist_release}
21URL:       http://www.postfix.org/
22License:   Distributable - IBM PUBLIC LICENSE VERSION 1.0 - SECURE MAILER
23Group:     System Environment/Daemons
24
25Source0:   ftp://postfix.cloud9.net/official/%{name}-%{version}.tar.gz
26Source1:   postfix.aliases
27Source2:   postfix.cron
28Source3:   postfix.init
29
30Patch0:    postfix-2.9.1-vine.patch
31
32# patches 100-199 are imported from debian package.
33# patches 100/101 for postfix 2.8.x are from mdk.
34Patch100: postfix-2.9.1-dynamicmaps.diff
35Patch101: postfix-2.9.1-dynamicmaps2.diff
36# add HAS_DLOPEN to definitions for LINUX3.
37Patch102: postfix-2.9.4-dynamicmaps3.diff
38
39# patches 200-299 are imported from rh/fedora
40Patch200: postfix-2.5.7-large-fs.patch     
41
42Provides:  smtpdaemon
43Conflicts: sendmail
44Requires(pre):    chkconfig
45BuildRequires: db4-devel >= 4.6.21, pam-devel, gdbm-devel
46BuildRequires: cyrus-sasl-devel >= 2
47BuildRequires: openldap-devel, openssl-devel
48BuildRequires: pcre-devel
49%if %build_mysql
50BuildRequires: MySQL-devel
51%endif
52%if %build_pgsql
53BuildRequires: postgresql-devel
54%endif
55BuildRequires: sqlite3-devel
56
57Requires:    cyrus-sasl >= 2, cyrus-sasl-md5, cyrus-sasl-plain
58Requires:    gdbm, pam, openssl
59Requires(pre):      db4 >= 4.6.21
60Obsoletes: postfix-beta
61BuildRoot: %{_tmppath}/%{name}-%{version}-root
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: daisuke
66
67
68%description
69Postfix aims to be an alternative to the widely-used sendmail
70program.  Sendmail is responsible for 70 percent of all e-mail delivered
71on the Internet.  With an estimated 100 million users, that's an
72estimated 10 billion (10^10) messages daily. A stunning number.
73
74Although IBM supported the Postfix development, it abstains from
75control over its evolution. The goal is to have Postfix installed
76on as many systems as possible. To this end, the software is given
77away with no strings attached to it, so that it can evolve with
78input from and under control by its users.
79
80#'
81%description -l ja
82Postfix は現在広く使われている sendmail を置き換える目的で
83開発されています。sendmail は約 70% の E-mail サーバで使用
84されています。また、その使用者は 100万人にもおよび、およそ
85一日 1 千万通ものメールを処理しています。
86
87Postfix の開発は IBM によってサポートされており、全世界の
88全てのシステムを postfix にすることを目標としています。
89
90%package sqlite
91Summary: SQLite3 map support for Postfix
92Group:     System Environment/Daemons
93Requires(pre): postfix = %{version}-%{release}
94Requires: sqlite3
95%description sqlite
96This package contains shared lib module which support
97SQLite map on Postfix.
98%description -l ja sqlite
99このパッケージには、Postfix で SQLite map を使うのに
100必要なライブラリが納められています。
101
102%if %build_pgsql
103%package pgsql
104Summary: PGSQL map support for Postfix
105Group:     System Environment/Daemons
106Requires(pre): postfix = %{version}-%{release}
107Requires: postgresql-libs, postgresql
108%description pgsql
109This package contains shared lib module which support
110PostgreSQL map on Postfix.
111%description -l ja pgsql
112このパッケージには、Postfix で PostgreSQL を使うのに必要な
113ライブラリが納められています。
114%endif
115
116%if %build_mysql
117%package mysql
118Summary: MySQL map support for Postfix
119Group:     System Environment/Daemons
120Requires(pre): postfix = %{version}-%{release}
121%description mysql
122This package contains shared lib module which support
123MySQL map on Postfix.
124%description -l ja mysql
125このパッケージには、Postfix で MySQL を使うのに必要な
126ライブラリが納められています。
127%endif
128
129%package ldap
130Summary: LDAP map support for Postfix
131Group:     System Environment/Daemons
132Requires(pre): postfix = %{version}-%{release}
133Requires: openldap
134%description ldap
135This package contains shared lib module which support
136OpenLDAP map on Postfix.
137%description -l ja ldap
138このパッケージには、Postfix で OpenLDAP を使うのに必要な
139ライブラリが納められています。
140
141%package pcre
142Summary: PCRE map support for Postfix
143Group:     System Environment/Daemons
144Requires(pre): postfix = %{version}-%{release}
145Requires: pcre
146%description pcre
147This package contains shared lib module which support
148PCRE map on Postfix.
149%description -l ja pcre
150このパッケージには、Postfix で PCRE マップを使うのに必要な
151ライブラリが納められています。
152
153%prep
154# japanese documant for 2.4.x is not ready.
155# %setup -q -a 10 -a 20 -a 30 -a 40
156%setup -q
157
158%patch0 -p1 -b .vine
159
160%ifarch x86_64
161sed -i -e 's|/usr/lib/postfix|/usr/lib64/postfix|g' conf/main.cf
162%endif
163
164%patch100 -p1 -b .dynamicmaps
165%patch101 -p1 -b .dynamicmaps2
166%patch102 -p0 -b .dynamicmaps3
167
168%patch200 -p1 -b .large-fs
169
170# patching src/global/Makefile to remove dependency
171pushd src/global
172%if %build_mysql
173:
174%else
175sed -ie "s/ dict_mysql.so/ /" Makefile.in
176%endif
177%if %build_pgsql
178:
179%else
180sed -ie "s/ dict_pgsql.so/ /" Makefile.in
181%endif
182popd
183
184%build
185make makefiles \
186        CCARGS="-DMAX_DYNAMIC_MAPS \
187                -DUSE_SASL_AUTH -I/usr/include/sasl \
188                -DUSE_CYRUS_SASL \
189                -DHAS_LDAP \
190                -DHAS_SSL -I/usr/include/openssl \
191                -DHAS_PCRE -I/usr/include/pcre \
192                -DHAS_SQLITE \
193%if %build_mysql
194                -DHAS_MYSQL -I/usr/include/mysql  \
195%endif
196%if %build_pgsql
197                -DHAS_PGSQL -I/usr/include/pgsql \
198%endif
199                -DUSE_TLS" \
200        AUXLIBS="-lsasl2 -lssl -lcrypto" \
201        OPT="$RPM_OPT_FLAGS" DEBUG=""
202for libs in master global util dns tls milter xsasl
203do
204  ln -sf lib${libs}.a lib/libpostfix-${libs}.so.1
205done
206
207# make %{?_smp_mflags} DEBUG="" OPT="$RPM_OPT_FLAGS" \
208#      LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH}
209
210# using _smp_mflags makes build error. why? (2008.10.11)
211make DEBUG="" OPT="$RPM_OPT_FLAGS" \
212     LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH} CDBSO=""
213
214%install
215rm -rf $RPM_BUILD_ROOT
216rm -f html/Makefile.in
217rm -f README_FILES/*.*
218
219install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
220install -d $RPM_BUILD_ROOT%{_sysconfdir}/postfix
221install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
222install -d $RPM_BUILD_ROOT%{_bindir}
223install -d $RPM_BUILD_ROOT%{_libdir}/postfix
224install -d $RPM_BUILD_ROOT%{_mandir}/man{1,5,8}
225install -d $RPM_BUILD_ROOT%{_mandir}/ja/man{1,5,8}
226install -d $RPM_BUILD_ROOT%{_sbindir}
227install -d $RPM_BUILD_ROOT%{_var}/spool/postfix
228install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,incoming,pid,public}
229install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{bounce,defer,flush,maildrop,private,saved}
230
231install -m755 bin/* $RPM_BUILD_ROOT%{_sbindir}
232install -m755 libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
233#install -m755 lib/dict_* $RPM_BUILD_ROOT%{_libdir}/postfix
234install -m755 lib/lib*.so.1 $RPM_BUILD_ROOT%{_libdir}
235
236touch conf/dynamicmaps.cf
237for i in main.cf master.cf access aliases canonical header_checks \
238         main.cf.default post-install postfix-files postfix-script \
239         relocated transport virtual dynamicmaps.cf
240do
241  install -m644 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
242done
243for i in post-install postfix-script
244do
245  install -m755 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
246done
247
248install -m644 man/man1/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
249install -m644 man/man5/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
250install -m644 man/man8/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
251
252install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/postfix/aliases
253install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/postfix
254install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/postfix
255
256ln -sf postfix/aliases $RPM_BUILD_ROOT%{_sysconfdir}/aliases
257ln -sf postfix/aliases.db $RPM_BUILD_ROOT%{_sysconfdir}/aliases.db
258
259( cd $RPM_BUILD_ROOT%{_bindir}
260  ln -sf ../sbin/sendmail mailq
261  ln -sf ../sbin/sendmail newaliases
262)
263( cd $RPM_BUILD_ROOT%{_libdir}
264  ln -sf ../sbin/sendmail sendmail
265)
266
267for I in etc/postfix/{aliases,access,canonical,header_check,relocated,transport,virtual}
268do
269   touch $RPM_BUILD_ROOT/$I{,.db}
270done
271
272# data dir
273install -d $RPM_BUILD_ROOT%{_data_dir}
274
275%pre
276if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 0 ]; then
277   %{_sbindir}/useradd -M -r -d %{_var}/spool/postfix -s "" \
278                     -c "postfix" postfix || :
279fi
280if [ `grep postfix %{_sysconfdir}/group | wc -l` = 0 ]; then
281  %{_sbindir}/groupadd -r postfix
282fi
283if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 0 ]; then
284  %{_sbindir}/groupadd -r postdrop
285fi
286#if [ -f %{_var}/lock/subsys/postfix ]; then
287#   %{_sysconfdir}/rc.d/init.d/postfix stop
288#fi
289
290
291%post
292/sbin/ldconfig
293%dynmap_add_cmd tcp
294/sbin/chkconfig --add postfix
295if [ ! -f %{_sysconfdir}/postfix/aliases.db ]; then
296  touch %{_sysconfdir}/postfix/aliases.db
297fi
298%{_sbindir}/postalias %{_sysconfdir}/postfix/aliases ||:
299if [ ! -e %{_libdir}/sendmail ]; then
300        ln -sf %{_sbindir}/sendmail %{_libdir}/sendmail
301fi
302/sbin/chkconfig --del sendmail &> /dev/null ||:
303%{_sbindir}/postfix check >/dev/null 2>&1 ||:
304if [ -f %{_var}/lock/subsys/postfix ]; then
305   %{_sysconfdir}/rc.d/init.d/postfix restart
306fi
307
308
309%preun
310if [ $1 = 0 ]; then
311   if [ -f %{_var}/lock/subsys/postfix -a -f %{_sysconfdir}/rc.d/init.d/postfix ]; then
312      %{_sysconfdir}/rc.d/init.d/postfix stop
313   fi
314   /sbin/chkconfig --del postfix
315fi
316
317
318%postun
319/sbin/ldconfig
320if [ $1 = 0 ]; then
321   if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 1 ]; then
322      %{_sbindir}/userdel postfix
323   fi
324   if [ `grep postfix %{_sysconfdir}/group | wc -l` = 1 ]; then
325      %{_sbindir}/groupdel postfix
326   fi
327   if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 1 ]; then
328      %{_sbindir}/groupdel postdrop
329   fi
330   if ! [ -f %{_var}/lock/subsys/postfix ]; then
331        rm -rf %{_var}/lock/subsys/postfix
332   fi
333fi
334
335%post sqlite
336%dynmap_add_cmd sqlite
337
338%preun sqlite
339%dynmap_rm_cmd sqlite
340
341%if %build_pgsql
342%post pgsql
343%dynmap_add_cmd pgsql
344
345%preun pgsql
346%dynmap_rm_cmd pgsql
347%endif
348
349%if %build_mysql
350%post mysql
351%dynmap_add_cmd mysql
352
353%preun mysql
354%dynmap_rm_cmd mysql
355%endif
356
357%post ldap
358%dynmap_add_cmd ldap
359
360%postun ldap
361%dynmap_rm_cmd ldap
362
363%post pcre
364%dynmap_add_cmd pcre
365
366%postun pcre
367%dynmap_rm_cmd pcre
368
369%clean
370rm -rf $RPM_BUILD_ROOT
371
372
373%files
374%defattr(-,root,root)
375%doc COMPATIBILITY COPYRIGHT HISTORY LICENSE INSTALL PORTING RELEASE_NOTES
376# japanese documant for 2.4.x is not ready.
377# %doc conf.ja
378# %doc html html.ja
379# %doc README_FILES README_FILES.ja
380%doc README_FILES
381# %doc man-%{jmanversion}/readme_ja.txt
382%{_sysconfdir}/aliases
383%{_sysconfdir}/aliases.db
384%config %{_sysconfdir}/cron.daily/postfix
385%dir %{_sysconfdir}/postfix
386%config %{_sysconfdir}/postfix/main.cf.default
387%config %{_sysconfdir}/postfix/master.cf
388%config(noreplace) %{_sysconfdir}/postfix/aliases
389%config(noreplace) %{_sysconfdir}/postfix/access
390%config(noreplace) %{_sysconfdir}/postfix/canonical
391%config(noreplace) %{_sysconfdir}/postfix/header_check
392%config(noreplace) %{_sysconfdir}/postfix/header_checks
393%config(noreplace) %{_sysconfdir}/postfix/main.cf
394%config(noreplace) %{_sysconfdir}/postfix/relocated
395%config(noreplace) %{_sysconfdir}/postfix/transport
396%config(noreplace) %{_sysconfdir}/postfix/virtual
397%config(noreplace) %{_sysconfdir}/postfix/dynamicmaps.cf
398%config %{_sysconfdir}/postfix/postfix-files
399%config %{_sysconfdir}/postfix/post-install
400%config %{_sysconfdir}/postfix/postfix-script
401%config %{_sysconfdir}/rc.d/init.d/postfix
402%{_bindir}/*
403%dir %{_libdir}/postfix
404%{_libdir}/postfix/*
405
406%if %{build_pgsql}
407%exclude %{_libdir}/postfix/dict_pgsql.so
408%endif
409%if %{build_mysql}
410%exclude %{_libdir}/postfix/dict_mysql.so
411%endif
412
413%exclude %{_libdir}/postfix/dict_sqlite.so
414%exclude %{_libdir}/postfix/dict_ldap.so
415%exclude %{_libdir}/postfix/dict_pcre.so
416%{_libdir}/lib*.so.1
417%{_sbindir}/postalias
418%{_sbindir}/postcat
419%{_sbindir}/postconf
420%attr(2755,root,postdrop) %{_sbindir}/postdrop
421%{_sbindir}/postfix
422%{_sbindir}/postkick
423%{_sbindir}/postlock
424%{_sbindir}/postlog
425%{_sbindir}/postmap
426%{_sbindir}/postmulti
427%attr(2755,root,postdrop) %{_sbindir}/postqueue
428%{_sbindir}/postsuper
429%{_sbindir}/qmqp-sink
430%{_sbindir}/qmqp-source
431%{_sbindir}/sendmail
432%{_sbindir}/smtp-sink
433%{_sbindir}/smtp-source
434%attr(-,root,man) %{_mandir}/man*/*
435# %attr(-,root,man) %{_mandir}/ja/man*/*
436%dir %{_var}/spool/postfix
437%attr(0750,postfix,root) %dir %{_data_dir}
438%attr(1733,postfix,postdrop) %dir %{_var}/spool/postfix/maildrop
439%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/active
440%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/corrupt
441%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/deferred
442%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/incoming
443%attr(0755,root,root) %dir %{_var}/spool/postfix/pid
444%attr(0710,postfix,postdrop) %dir %{_var}/spool/postfix/public
445%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/bounce
446%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/defer
447%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/flush
448%attr(0710,postfix,postfix) %dir %{_var}/spool/postfix/private
449%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/saved
450%{_libdir}/sendmail
451
452%files sqlite
453%defattr(-,root,root)
454%{_libdir}/postfix/dict_sqlite.so
455
456%if %build_pgsql
457%files pgsql
458%defattr(-,root,root)
459%{_libdir}/postfix/dict_pgsql.so
460%endif
461
462%if %build_mysql
463%files mysql
464%defattr(-,root,root)
465%{_libdir}/postfix/dict_mysql.so
466%endif
467
468%files ldap
469%defattr(-,root,root)
470%{_libdir}/postfix/dict_ldap.so
471
472%files pcre
473%defattr(-,root,root)
474%{_libdir}/postfix/dict_pcre.so
475
476%changelog
477* Fri Nov 30 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9.4-2
478- added patch102.
479
480* Sun Nov 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.4-1
481- update to 2.9.4
482- update dynamicmaps patches
483- add sqite3 map support, add postfix-sqlite subpackage.
484- drop unneeded patches
485
486* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.12-1
487- update to 2.8.12
488- rebuild with pcre-8.31
489
490* Tue May 01 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.10-1
491- update to 2.8.10
492
493* Sun Mar 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.9-1
494- update to 2.8.9
495
496* Thu May 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-1
497- update to 2.8.3
498
499* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-1
500- update to 2.8.2
501- update dynamicmaps patch
502
503* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.8-5
504- rebuilt with postgresql-9.0.3
505
506* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.8-4
507- rebuilt with openssl 1.0.0c
508- fix changelog typo..
509
510* Wed Dec 01 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.8-3
511- new upstream release.
512- updated %%patch100 and %%patch210.
513
514* Sat Feb 20 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.5-2
515- removed MySQL-shared from "Requires:" and "BuildRequires:".
516- replaced "Prereq:" with "Requires(pre):".
517- replaced "BuildPrereq:" with "BuildRequires:".
518
519* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-1
520- new upstream release
521- rebuild with db4-4.8.0
522
523* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-2
524- change /var/spool/postfix/pid owner and permission
525  (0700,postfix,postfix -> 0755,root,root)
526
527* Mon Aug  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-1
528- new upstream release
529
530* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.2-1
531- new upstream release.
532
533* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-2
534- added a missing file.
535
536* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-1
537- new upstream release.
538- updated dynamicmaps patch.
539
540* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.7-2
541- made to build -mysql and -pgsql as default.
542- rebuilt with MySQL-5.1.34.
543
544* Wed May 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.7-1
545- new upstream release
546- update Patch200 from fc10
547
548* Sun Mar 01 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.6-2
549- rebuilt with openldap-2.4.11
550
551* Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.6-1
552- new upstream release
553
554* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-4
555- add patch200/patch210 from fedora
556
557* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-3
558- add Requires cyrus-sasl-md5, cyrus-sasl-plain for smtp auth
559- add Japanese description into sub packages
560
561* Sat Oct 11 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-2
562- update patch100/101 to fix libxsasl build issue
563- remove smp flag in build section to solve build error
564- add _data_dir
565
566* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
567- new upstream release
568- update patch100/101 to fit 2.5.5 (from suse)
569- add %exclude dict_{my,pg}sql.so to %%files to avoid unneeded dependancy
570  when option "--with XXsql" is specified. (from Vine 4.x update package)
571- remove HAS_DLOPEN macro.
572
573* Sat Sep 06 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.9-1
574- new upstream release with security fix
575
576* Sat Aug 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-2
577- add %%if %%build_mysql and %%if %%mysql from BuildRequires section again
578- remove unnessary dependency
579
580* Thu Aug 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-1
581- new upstream release with security fix
582
583* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-4
584- spec in UTF-8
585
586* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.7-3
587- rebuilt against db4-4.6.21
588
589* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.7-2
590- add HAS_DLOPEN macro.
591- add USE_CYRUS_SASL macro.
592- modify dynamicmaps.cf (/usr/lib -> %%{_libdir}).
593
594* Thu Mar 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.7-1
595- new upstream release
596- update patch100 (it is based from mdk 2008.0)
597- add smp_mflags in make section
598- build under new versioning policy
599
600* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl10
601- rebuilt with postgresql-devel 8.2.5
602- updated Source20, 30 and 40
603
604* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl9
605- rebuild with new openssl
606
607* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.10-0vl8
608- rebuilt with new toolchain and db4-4.3.x
609
610* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 2.2.10-0vl7
611- <BTS:493> fix typo in %%if statement for %%files mysql section.
612- remove %%if %%build_mysql and %%if %%mysql from BuildRequires section,
613  (Patch100 always builds dict_mysql.o and dict_pgsql.o)
614
615* Fri Oct 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl6
616- disable MySQL, PostgreSQL support by default.
617  use "--with {mysql|pgsql}" to build them.
618
619* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl5
620- add lib64 patch to correct daemon_directory on x86_64 architecture
621
622* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl4
623- remove duplicated entry from aliases. (<BTS:170>)
624
625* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl3
626- add some pseudo accounts to aliases. (<BTS:170>)
627- add BuildPreReq: MySQL-shared
628
629* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl2
630- rebuilt with openldap-2.3.27-0vl1
631
632* Sun Apr 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl1
633- new upstream release
634
635* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
636- new upstream release
637
638* Fri Sep 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.5-0vl1
639- new upstream release
640  - update to 2.2.5
641- update dynamicmaps from debian package
642- update Japaese manpages and jconf
643- add jhtml and jreadme
644- enable TLS/SSL
645
646* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
647- new upstream release
648- update all patches
649- link sasl2 instead of sasl1
650
651* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.20-0vl6
652- enable cyrus-sasl.
653- add TLS/IPv6 patch.
654- modify main.cf to disable IPv6 as default.
655
656* Wed Oct 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl5
657- add PreReq: db4 >= 4.2.52
658  (to avoid errors when upgrading from db40-linked version)
659
660* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl4
661- rebuilt with db4-4.2.52
662
663* Tue Jun  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl3
664- fix first installation time bugs...
665  - remove aliases.db from %%files again
666  - add 'touch aliases.db' in %%post script
667- update default main.cf to use /etc/postfix/aliases as default alias_database
668
669* Mon Jun  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl2
670- add /etc/postfix/aliases.db to %%files
671
672* Sat May  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl1
673- new upstream release
674
675* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.19-0vl1
676- new upstream release
677- build with new postgresql
678
679* Fri Sep 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.16-0vl1
680- new upstream release
681- update jconf/jman/jhtml
682
683* Fri Jul  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.13-0vl1
684- new upstream release
685- update jman/jhtml/jreadme
686
687* Mon Jun 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-0vl1
688- new upstream release
689- update jconf/jman/jhtml/jreadme
690
691* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.10-0vl1
692- new upstream release
693
694* Fri May 23 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.9-0vl5
695- rebuild by new cyrus-sasl(2.1.13-3vl1)
696
697* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl4
698- add more BuildPreReq, Requires
699- fix some typo
700- add missing files to %%files.
701
702* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl3
703- rebuild
704
705* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl2
706- add debian's dynamic map patch.
707  some additional feature is divided to sub package.
708  - postfix-ldap, postfix-mysql, postfix-pgsql, postfix-pcre
709- split common postfix libraries as shared libs.
710  - libpostfix-{master,global,util,dns}.so.1
711- use cyrus-sasl for SMTP-AUTH
712
713* Wed Apr 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl1
714- new upstream release 2.0.9
715- update jman/jhtml/jconf to 2.0.8
716
717* Wed Apr  9 2003 IWAI Masaharu <iwai@alib.jp> 2.0.7-0vl1
718- new upstream version
719- update documents
720    - jman (source4)
721    - jconf (Source5)
722    - faq.html (Source6)
723    - INSTALL.jp (Source7)
724    - jhtml (Source12)
725
726* Sun Jan 19 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.12-0vl3
727- rebuilt against db4
728
729* Wed Dec 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl2
730- rebuild to remove unnecessary dependancy.
731
732* Sat Nov 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl1
733- new upstream version
734- modified /etc/init.d/postfix
735
736* Sun Oct 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl3
737- fixed brainless mistakes...
738  update main.cf again.
739
740* Thu Oct 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl2
741- update main.cf patch
742  - do not use procmail for local mailer.
743  - do not show version and OS name for smtpd greeting banner.
744
745* Thu Jun 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl1
746- new upstream release
747- update jman, jconf, jhtml
748
749* Tue May 28 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl2
750- updated main.cf patch ( Patch0 )
751    undefine myhostname
752
753* Fri May 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl1
754- changed %%{_var}/spool/postfix/private directory permission (0700 -> 0710)
755    Thanks Mr. Daisuke SUZUKI ([VineSeed:06454])
756
757* Thu May 23 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl0
758- upstream release
759- updated japanese documents Source4-9
760    ( and the unofficial Japanese Web Site moved. )
761- added japanese documents  Source10-12
762- updated main.cf patch ( Patch0 )
763- added postdrop group
764- added some directories in %%{_var}/spool/postfix/
765    active, corrupt, deferred, incoming, pid, public, bounce,
766    defer,flush,private and saved directories
767
768* Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl3
769- not stop in %%pre
770- not start but restart in %%post
771
772* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl2
773- added BuildPreReq: db3-devel
774
775* Sat Nov 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl08-0vl1
776- updated to 20010228-pl08
777
778* Fri Nov  9 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl06-0vl1
779- updated to 20010228-pl06
780
781* Sun Sep 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl05-0vl1
782- updated to 20010228-pl05
783
784* Wed Aug  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl04-0vl1
785- updated to 20010228-pl04
786
787* Wed Jun 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl2
788- update Japanese documents and manpages
789
790* Sun May 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl1
791- updated to 20010228-pl03
792
793* Mon May 21 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
794- 0.0.20010228pl02-0vl3
795- modified %%preun script again
796  (to check whether %%{_sysconfidir}/rc.d/init.d/postfix already exists)
797
798* Wed May 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
799- 0.0.20010228pl02-0vl2
800- fixed incorrect %%preun script :-P
801
802* Tue May  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl02-0vl1
803- updated to 20010228-pl02
804
805* Wed Apr 11 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl4
806- add {pcre,regexp}_table to %files
807- don't replace config files
808- start postfix after install/upgrade
809
810* Mon Apr 09 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl2
811- updated jman pages and translations.
812- added japanese sample config files.
813
814* Sat Mar 31 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl1
815- updated to 20010228-pl01
816
817* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl2
818- fixed file location
819
820* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl1
821- updated to 20010228
822
823* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 0.0.199912310pl13-0vl2
824- fixed about mandir
825
826* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl13-0vl1
827- updated to 19991231-pl13
828- use rpm macros in spec
829
830* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl11-0vl1
831- updated to 19991231-pl11
832
833* Thu Nov  9 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl10-0vl1
834- updated to 19991231-pl10
835
836* Thu Oct 12 2000 Yoshihiro Kajiki <kajiki@ylug.org>
837- fix newaliases problem by adding slink
838
839* Sat Oct  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
840- add japanese man pages
841
842* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
843- updates to 19991231-pl09-0vl2
844- fixed Group
845
846* Sat Sep 22 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
847- updates to 19991231-pl09
848
849* Wed Aug 09 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
850- %build, removed bzip2 -9 and strip
851- fixed %files section to handle compressed man page
852
853* Wed Jun 21 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
854- Version name changes to 0.0.version
855- updates to 19991231-pl08
856  + Major changes with postfix-19991231-pl08:
857    Specify "body_checks = regexp:%{_sysconfdir}/postfix/body_checks" for a quick
858    and dirty emergency content filter that looks at non-header lines
859    one line at a time (including MIME headers inside the message body).
860    Details in conf/sample-filter.cf.
861  + Incompatible changes with postfix-19991231-pl07:
862    As required by RFC 822, Postfix now inserts a generic destination
863    message header when no destination header is present.  The text is
864    specified via the undisclosed_recipients_header configuration
865    parameter (default:  "To: undisclosed-recipients:;").
866
867* Thu Apr  6 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
868- updates to 19991231-pl06
869- added percent hack to main.cf
870
871* Sun Feb 20 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
872- adopted to Vine Linux
873
874* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
875- updated to 19991231
876- added postfix group
877- corrected aliases.db bug
878
879* Mon Dec 27 1999 Jerome Dumonteil <jd@mandrakesoft.com>
880- Add postfix check in post to create sub dirs in spool
881
882* Mon Dec 20 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
883- Add -a $DOMAIN -d $LOGNAME to procmail (philippe).
884- New banner.
885
886* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
887- fix if conflicts with sendmail.
888
889* Sat Jun  5 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
890- install bins from libexec/
891
892* Sat Jun  5 1999 Bernhard Rosenkr舅zer <bero@mandrakesoft.com>
893- 19990601
894- .spec cleanup for easier updates
895
896* Wed May 26 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
897- created link from %{_sbindir}/sendmail to %{_libdir}/sendmail
898  so it doesn't bug out when i rpm -e sendmail
899- Now removes %{_var}/lock/subsys/postfix like a good little prog
900  upon rpm -e
901
902* Fri Apr 23 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
903
904- Mandrake adptations.
905
906* Tue Apr 13 1999 Arne Coucheron <arneco@online.no>
907  [19990317-pl04-1]
908
909* Tue Mar 30 1999 Arne Coucheron <arneco@online.no>
910  [19990317-pl03-2]
911- Castro, Castro, pay attention my friend. You're making it very hard
912  maintaining the package if you don't follow the flow of the releases
913
914* Thu Mar 25 1999 Arne Coucheron <arneco@online.no>
915  [19990317-pl02-1]
916
917* Tue Mar 23 1999 Arne Coucheron <arneco@online.no>
918  [19990317-3]
919- added bugfix patch01
920
921* Sat Mar 20 1999 Arne Coucheron <arneco@online.no>
922  [19990317-2]
923- removed the mynetworks line in main.cf, let postfix figure it out
924- striping of the files in %{_sbindir}
925- alias database moved to %{_sysconfdir}/postfix and made a symlink to it in %{_sysconfdir}
926- enabled procmail support in main.cf and added it to Requires:
927- check status on master instead of postfix in the init script
928- obsoletes postfix-beta
929- had to move some of my latest changelog entries up here since Edgard Castro
930  didn't follow my releases
931
932* Thu Mar 18 1999 Edgard Castro <castro@usmatrix.net>
933  [19990317]
934
935* Tue Mar 16 1999 Edgard Castro <castro@usmatrix.net>
936  [alpha-19990315]
937
938* Tue Mar  9 1999 Edgard Castro <castro@usmatrix.net>
939  [19990122-pl01-2]
940- shell and gecho information changed to complie with Red Hat stardand
941- changed the name of the rpm package to postfix, instead of postfix-beta
942
943* Tue Feb 16 1999 Edgard Castro <castro@usmatrix.net>
944  [19990122-pl01-1]
945
946* Sun Jan 24 1999 Arne Coucheron <arneco@online.no>
947  [19990122-1]
948- shell for postfix user changed to /bin/true to avoid logins to the account
949- files in %{_libdir}exec/postfix moved to %{_libdir}/postfix since this complies
950  more with the Red Hat standard
951
952* Wed Jan 06 1999 Arne Coucheron <arneco@online.no>
953  [19981230-2]
954- added URL for the source
955- added a cron job for daily check of errors
956- sample config files moved from /etc/postfix/sample to the docdir
957- dropped making of symlinks in %{_sbindir} and instead installing the real
958  files there
959- because of the previous they're not needed anymore in %{_libdir}exec/postfix,
960  so they are removed from that place
961
962* Fri Jan 01 1999 Arne Coucheron <arneco@online.no>
963  [19981230-1]
964
965* Tue Dec 29 1998 Arne Coucheron <arneco@online.no>
966  [19981222-1]
967- first build of rpm version
Note: See TracBrowser for help on using the repository browser.