source: projects/specs/trunk/p/portreserve/portreserve-vl.spec @ 9339

Revision 9339, 4.0 KB checked in by Takemikaduchi, 9 years ago (diff)

portreserve: update to 0.0.5
kdeutils: fix spec
ttyrec: rebuild

Line 
1Summary: TCP port reservation utility
2Summary(ja): TCP ポート予約ユーティリティ
3Name: portreserve
4Version: 0.0.5
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Daemons
8URL: http://cyberelk.net/tim/portreserve/
9Source0: http://cyberelk.net/tim/data/portreserve/stable/%{name}-%{version}.tar.bz2
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12BuildRequires: xmlto
13
14%description
15The portreserve program aims to help services with well-known ports that
16lie in the portmap range.  It prevents portmap from a real service's port
17by occupying it itself, until the real service tells it to release the
18port (generally in the init script).
19
20%prep
21%setup -q
22
23%build
24%configure --sbindir=/sbin
25make
26
27%install
28rm -rf %{buildroot}
29make DESTDIR=%{buildroot} install
30mkdir -p %{buildroot}%{_localstatedir}/run/portreserve
31mkdir -p %{buildroot}%{_initrddir}
32install -m755 portreserve.init %{buildroot}%{_initrddir}/portreserve
33mkdir -p %{buildroot}%{_sysconfdir}/portreserve
34mkdir -p %{buildroot}%{_sysconfdir}/tmpfiles.d
35cat <<EOF > %{buildroot}%{_sysconfdir}/tmpfiles.d/portreserve.conf
36d %{_localstatedir}/run/portreserve 0755 root root 10d
37EOF
38
39%clean
40rm -rf %{buildroot}
41
42%post
43# Do this unconditionally to fix up the initscript's start priority.
44# Earlier versions had an incorrect dependency (bug #487250).
45/sbin/chkconfig --add portreserve
46
47%preun
48if [ "$1" = 0 ]; then
49  /sbin/service portreserve stop >/dev/null 2>&1
50  /sbin/chkconfig --del portreserve
51fi
52
53%postun
54if [ "$1" -ge "1" ]; then
55  /sbin/service portreserve condrestart >/dev/null 2>&1
56fi
57
58%files
59%defattr(-,root,root)
60%doc ChangeLog README COPYING NEWS
61%ghost %dir %{_localstatedir}/run/portreserve
62%dir %{_sysconfdir}/portreserve
63%config %{_sysconfdir}/tmpfiles.d/portreserve.conf
64%attr(755,root,root) %{_initrddir}/portreserve
65/sbin/*
66%{_mandir}/*/*
67
68%changelog
69* Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.5-1
70- update to 0.0.5
71- remove old patches
72
73* Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.4-1
74- initial build for Vine Linux
75
76* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-8
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
78
79* Thu Dec  2 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-7
80- /var/run changes for systemd (bug #656670).
81
82* Thu Nov 18 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-6
83- Fixed initscript exit code for "status" action (bug #619089).
84
85* Thu Mar  4 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-5
86- Added comments to all patches.
87
88* Fri Jan 22 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-4
89- Walk the list of newmaps correctly (bug #557781).
90
91* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-2
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
93
94* Fri Feb 27 2009 Tim Waugh <twaugh@redhat.com> 0.0.4-1
95- 0.0.4:
96  - Fixed initscript so that it will not be reordered to start after
97    rpcbind (bug #487250).
98
99* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.3-4
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
101
102* Wed Feb  4 2009 Tim Waugh <twaugh@redhat.com> 0.0.3-3
103- No longer need SELinux policy as it is now part of the
104  selinux-policy package.
105
106* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 0.0.3-2
107- New selinux sub-package for SELinux policy.  Policy contributed by
108  Miroslav Grepl (thanks!).
109
110* Tue Jul  1 2008 Tim Waugh <twaugh@redhat.com> 0.0.3-1
111- 0.0.3:
112  - Allow multiple services to be defined in a single configuration
113    file.
114  - Allow protocol specifications, e.g. ipp/udp.
115
116* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 0.0.2-1
117- 0.0.2.
118
119* Fri May  9 2008 Tim Waugh <twaugh@redhat.com> 0.0.1-2
120- More consistent use of macros.
121- Build requires xmlto.
122- Don't use %%makeinstall.
123- No need to run make check.
124
125* Thu May  8 2008 Tim Waugh <twaugh@redhat.com> 0.0.1-1
126- Default permissions for directories.
127- Initscript should not be marked config.
128- Fixed license tag.
129- Better buildroot tag.
130
131* Wed Sep  3 2003 Tim Waugh <twaugh@redhat.com>
132- Initial spec file.
Note: See TracBrowser for help on using the repository browser.