source: projects/specs/trunk/p/popt/popt-vl.spec @ 12215

Revision 12215, 8.5 KB checked in by tomop, 5 years ago (diff)

updated 4 packages

NetworkManager-1.20.2-1

newt-0.52.21-1

popt-1.16-3

slang-2.3.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        C library for parsing command line parameters
3Summary(ja):    コマンドラインパラメータを文法解析するためのCライブラリ
4Name:           popt
5Version:        1.16
6Release:        3%{?_dist_release}
7License:        MIT
8Group:          System Environment/Libraries
9URL:            http://www.rpm5.org/
10Source0:        http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
11Patch0:         popt-1.16-pkgconfig.patch
12Patch1:         popt-1.16-execfail.patch
13Patch2:         popt-1.16-man-page.patch
14Patch3:         popt-1.16-help.patch
15Patch4:         popt-1.16-nextarg-memleak.patch
16Patch5:         popt-1.16-glob-error.patch
17BuildRequires:  gettext
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24Popt is a C library for parsing command line parameters. Popt was
25heavily influenced by the getopt() and getopt_long() functions, but
26it improves on them by allowing more powerful argument expansion.
27Popt can parse arbitrary argv[] style arrays and automatically set
28variables based on command line arguments. Popt allows command line
29arguments to be aliased via configuration files and includes utility
30functions for parsing arbitrary strings into argv[] arrays using
31shell-like rules.
32
33%description -l ja
34Poptはコマンドパラメータを文法解析するためのCライブラリです。
35Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
36もっと強力な引数の拡張を施すことによって、それらをもっと進化
37させています。Poptは 任意の argv[]形式配列を解析して、コマンド
38ライン引数に基づいて変数を自動的に設定します。
39Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
40許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
41てargv[]配列に変換したりするユーティリティ関数を含んでいます。
42
43
44%package devel
45Summary:        Development files for the popt library
46Summary(ja):    popt ライブラリの開発ファイル
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49
50%description devel
51The popt-devel package includes header files and libraries necessary
52for developing programs which use the popt C library. It contains the
53API documentation of the popt library, too.
54
55
56%package static
57Summary: Static library for %{name}
58Summary(ja): %{name} のスタティックライブラリ
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61
62%description static
63The %{name}-static package contains the static library for %{name}.
64
65
66%package -n compat32-%{name}
67Summary: A C library for parsing command line parameters.
68Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71
72%description -n compat32-%{name}
73Popt is a C library for parsing command line parameters. Popt was
74heavily influenced by the getopt() and getopt_long() functions, but it
75improves on them by allowing more powerful argument expansion. Popt
76can parse arbitrary argv[] style arrays and automatically set
77variables based on command line arguments. Popt allows command line
78arguments to be aliased via configuration files and includes utility
79functions for parsing arbitrary strings into argv[] arrays using
80shell-like rules.
81
82%description -n compat32-%{name} -l ja
83Poptはコマンドパラメータを文法解析するためのCライブラリです。
84Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
85もっと強力な引数の拡張を施すことによって、それらをもっと進化
86させています。Poptは 任意の argv[]形式配列を解析して、コマンド
87ライン引数に基づいて変数を自動的に設定します。
88Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
89許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
90てargv[]配列に変換したりするユーティリティ関数を含んでいます。
91
92%package -n compat32-%{name}-devel
93Summary:        Development files for the popt library
94Summary(ja):    popt ライブラリの開発ファイル
95Group:          Development/Libraries
96Requires:       compat32-%{name} = %{version}-%{release}
97Requires:       %{name}-devel = %{version}-%{release}
98
99%description -n compat32-%{name}-devel
100The popt-devel package includes header files and libraries necessary
101for developing programs which use the popt C library. It contains the
102API documentation of the popt library, too.
103
104%prep
105%autosetup
106sed -i "s|libdir=@libdir@|libdir=@prefix@@libdir@|" popt.pc.in
107%ifarch x86_64
108#sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.am
109#sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.in
110%endif
111
112%build
113%configure --libdir=/%{_lib}
114make %{?_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118make DESTDIR=$RPM_BUILD_ROOT install
119
120# Move libpopt.{so,a} to %{_libdir}
121rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
122pushd $RPM_BUILD_ROOT/%{_lib}
123mkdir -p $RPM_BUILD_ROOT%{_libdir}
124ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
125popd
126mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
127
128mv -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}/
129
130# Multiple popt configurations are possible
131mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
132
133%find_lang %{name}
134
135%check
136make check
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142
143%postun -p /sbin/ldconfig
144
145%post -n compat32-%{name} -p /sbin/ldconfig
146
147%postun -n compat32-%{name} -p /sbin/ldconfig
148
149%files -f %{name}.lang
150%defattr(-,root,root)
151%license COPYING
152%doc CHANGES
153%{_sysconfdir}/popt.d
154/%{_lib}/libpopt.so.*
155
156%files devel
157%defattr(-,root,root)
158%doc README
159%{_libdir}/libpopt.so
160%{_libdir}/pkgconfig/popt.pc
161%{_includedir}/popt.h
162%{_mandir}/man3/popt.3*
163
164%files static
165%defattr(-,root,root)
166%{_libdir}/libpopt.a
167
168%if %{build_compat32}
169%files -n compat32-%{name}
170%defattr(-,root,root)
171/%{_lib}/libpopt.so.*
172
173%files -n compat32-%{name}-devel
174%defattr(-,root,root)
175%{_libdir}/libpopt.so
176%endif
177
178
179%changelog
180* Sun Sep 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16-3
181- imported Patch0-5 from rawhide.
182
183* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-2
184- rebuild with VineSeed environment
185
186* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-1
187- update to 1.16
188- create %{name}-static sub package
189
190* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
191- rebuilt with rpm-4.8.1-3
192
193* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
194- rebuilt with new toolchain
195
196* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
197- updated Requires: and %%files section on compat32 subpackages
198
199* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
200- added %%define build_compat32
201- fixed compat32 directories
202
203* Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
204- initial build for Vine Linux
205  - splitted out from rpm, based on rpm5.org source.
206- move libpopt to /lib[64] from /usr/lib[64]
207  - initscripts-8 uses libpopt.
208
209* Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
210- Solved multilib problems at doxygen generated files (#342921)
211
212* Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
213- Revert the broken bind_textdomain_codeset() patch (#433324)
214
215* Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
216- Added patch to work around missing bind_textdomain_codeset()
217
218* Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
219- Upgrade to 1.13 (#290531, #332201, #425803)
220- Solved multilib problems at doxygen generated files (#342921)
221
222* Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
223- Added buildrequirement to graphviz (#249352)
224- Backported bugfixes from CVS (#102254, #135428 and #178413)
225
226* Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
227- Move libpopt to /lib[64] (#249814)
228- Generate API documentation, added buildrequirement to doxygen
229
230* Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
231- Changes to match with Fedora Packaging Guidelines (#249352)
232
233* Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
234- release popt-1.12 through rpm5.org.
235
236* Sat Jun  9 2007 Jeff Johnson <jbj@rpm5.org>
237- release popt-1.11 through rpm5.org.
238
239* Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
240- released 1.2.2; see CHANGES
241
242* Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
243- added man page to default install
244
245* Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
246- see CHANGES file for 1.2
247
248* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
249- added ./configure step to spec file
Note: See TracBrowser for help on using the repository browser.