source: projects/specs/trunk/p/polkit/polkit-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: PolicyKit Authorization Framework
2Summary(ja): PolicyKit 認証フレームワーク
3Name: polkit
4Version: 0.96
5Release: 1%{?_dist_release}
6License: LGPLv2+
7URL: http://www.freedesktop.org/wiki/Software/PolicyKit
8Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10Group: System Environment/Libraries
11BuildRequires: glib2-devel
12BuildRequires: expat-devel
13BuildRequires: pam-devel
14BuildRequires: eggdbus-devel >= 0.6
15BuildRequires: gtk-doc
16BuildRequires: intltool
17BuildRequires: gobject-introspection-devel
18
19Requires: ConsoleKit
20Requires: dbus
21
22#Obsoletes: PolicyKit <= 0.10
23#Provides: PolicyKit = 0.11
24
25%description
26PolicyKit is a toolkit for defining and handling authorizations.
27It is used for allowing unprivileged processes to speak to privileged
28processes.
29
30%package devel
31Summary: Development files for PolicyKit
32Summary(ja): PolicyKit の開発用ファイル
33Group: Development/Libraries
34Requires: %name = %{version}-%{release}
35Requires: %name-docs = %{version}-%{release}
36Requires: pkgconfig
37Requires: glib2-devel
38#Obsoletes: PolicyKit-devel <= 0.10
39#Provides: PolicyKit-devel = 0.11
40
41%description devel
42Development files for PolicyKit.
43
44%package docs
45Summary: Development documentation for PolicyKit
46Summary(ja): PolicyKit の開発用ドキュメント
47Group: Development/Libraries
48Requires: %name-devel = %{version}-%{release}
49Requires: gtk-doc
50#Obsoletes: PolicyKit-docs <= 0.10
51#Provides: PolicyKit-docs = 0.11
52
53%description docs
54Development documentation for PolicyKit.
55
56%package desktop-policy
57Summary: Roles and default policy for desktop usage
58Summary(ja): デスクトップ用途のロールとデフォルトポリシー
59Group: Development/Libraries
60#Requires: %name = %{version}-%{release}
61Requires(pre): /usr/sbin/groupadd
62Requires(preun): /usr/sbin/groupdel
63
64%description desktop-policy
65Roles and default policy for desktop usage.
66
67%prep
68%setup -q
69
70%build
71%configure --enable-gtk-doc --disable-static --libexecdir=%{_libexecdir}/polkit-1 --enable-introspection --enable-examples
72make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make install DESTDIR=$RPM_BUILD_ROOT
77
78rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
79rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
80
81%find_lang polkit-1
82
83###
84### BEGIN DESKTOP POLICY CONFIGURATION ###
85###
86
87cat > $RPM_BUILD_ROOT%{_sysconfdir}/polkit-1/localauthority.conf.d/60-desktop-policy.conf << EOF
88# This allows users in the desktop_admin_r group to authenticate as
89# the administrator.
90#
91# DO NOT EDIT THIS FILE, it will be overwritten on update.
92
93[Configuration]
94AdminIdentities=unix-group:desktop_admin_r
95EOF
96
97cat > $RPM_BUILD_ROOT%{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d/10-desktop-policy.pkla << EOF
98# Authorizations/policy for the desktop_admin_r and desktop_user_r groups.
99#
100# DO NOT EDIT THIS FILE, it will be overwritten on update.
101
102# Allow "standard users" to do some things without being interrupted by
103# password dialogs (TODO: not complete)
104#
105[Desktop User Permissions]
106Identity=unix-group:desktop_user_r
107Action=org.gnome.clockapplet.mechanism.settimezone
108ResultAny=no
109ResultInactive=no
110ResultActive=yes
111
112# Allow "administrative users" to do a lot of things without being interrupted by
113# password dialogs (TODO: not complete)
114#
115[Desktop Administrator Permissions]
116Identity=unix-group:desktop_admin_r
117Action=org.gnome.clockapplet.mechanism.*;org.freedesktop.devicekit.disks.*;org.freedesktop.RealtimeKit1.*
118ResultAny=no
119ResultInactive=no
120ResultActive=yes
121
122EOF
123
124###
125### END DESKTOP POLICY CONFIGURATION
126###
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post -p /sbin/ldconfig
132
133%postun -p /sbin/ldconfig
134
135%pre desktop-policy
136/usr/sbin/groupadd -r desktop_admin_r 2> /dev/null || :
137/usr/sbin/groupadd -r desktop_user_r 2> /dev/null || :
138
139%files desktop-policy
140%{_sysconfdir}/polkit-1/localauthority.conf.d/60-desktop-policy.conf
141%{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d/10-desktop-policy.pkla
142
143%files -f polkit-1.lang
144%defattr(-,root,root,-)
145%doc COPYING
146%{_libdir}/lib*.so.*
147%dir %{_libdir}/polkit-1
148%dir %{_libdir}/polkit-1/extensions
149%{_libdir}/polkit-1/extensions/*.so
150%{_datadir}/man/man1/*
151%{_datadir}/man/man8/*
152%{_datadir}/dbus-1/system-services/*
153%dir %{_datadir}/polkit-1/
154%dir %{_datadir}/polkit-1/actions
155%{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
156%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
157%{_sysconfdir}/pam.d/polkit-1
158%{_sysconfdir}/polkit-1
159%{_bindir}/pkaction
160%{_bindir}/pkcheck
161%{_libexecdir}/polkit-1/polkitd
162%{_libdir}/girepository-1.0/*.typelib
163
164# see upstream docs for why these permissions are necessary
165%attr(4755,root,root) %{_bindir}/pkexec
166%attr(4755,root,root) %{_libexecdir}/polkit-1/polkit-agent-helper-1
167
168%attr(0700,root,root) %dir %{_localstatedir}/lib/polkit-1/
169%dir %{_localstatedir}/lib/polkit-1/localauthority
170%dir %{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d
171%dir %{_localstatedir}/lib/polkit-1/localauthority/20-org.d
172%dir %{_localstatedir}/lib/polkit-1/localauthority/30-site.d
173%dir %{_localstatedir}/lib/polkit-1/localauthority/50-local.d
174%dir %{_localstatedir}/lib/polkit-1/localauthority/90-mandatory.d
175
176%files devel
177%defattr(-,root,root,-)
178%{_libdir}/lib*.so
179%{_libdir}/pkgconfig/*.pc
180%{_datadir}/gir-1.0/*.gir
181%{_includedir}/*
182%{_bindir}/pk-example-frobnicate
183%{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
184
185%files docs
186%defattr(-,root,root,-)
187%{_datadir}/gtk-doc/html/*
188
189%changelog
190* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
191- update to 0.96
192- BR: eggdbus-devel >= 0.6
193
194* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
195- remove Obsoletes:/Provides: PolicyKit*
196
197* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
198- initial build for Vine Linux
199
200* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
201- Refine how Obsolete: is used and also add Provides: (thanks Jesse
202  Keating and nim-nim)
203
204* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
205- Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
206- Obsolete old PolicyKit packages
207
208* Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
209- Update to git snapshot
210- Drop upstreamed patches
211- Turn on GObject introspection
212- Don't delete desktop_admin_r and desktop_user_r groups when
213  uninstalling polkit-desktop-policy
214
215* Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
216- Add some patches from git master
217- Sort pkaction(1) output
218- Bug 23867 – UnixProcess vs. SystemBusName aliasing
219
220* Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
221- Add desktop_admin_r and desktop_user_r groups along with a first cut
222  of default authorizations for users in these groups.
223
224* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
225- Disable GObject Introspection for now as it breaks the build
226
227* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
228- Update to upstream release 0.94
229
230* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
232
233* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
234- Rebuild
235
236* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
237- Update to 0.93
238
239* Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
240- Don't make docs noarch (I *heart* multilib)
241- Change license to LGPLv2+
242
243* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
244- Rebuild
245
246* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
247- Update to 0.92 release
248
249* Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
250- Update to 0.92 snapshot
251
252* Mon Feb  9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
253- Initial spec file.
Note: See TracBrowser for help on using the repository browser.