source: projects/specs/trunk/p/polkit/polkit-vl.spec @ 12546

Revision 12546, 12.8 KB checked in by tomop, 3 years ago (diff)

updated 28 packages

autoconf-2.71-1

automake-1.16.3-1

bison-3.7.5-1

e2fsprogs-1.46.1-1

findutils-4.8.0-1

galera-26.4.7-1

gawk-5.1.0-1

gdbm-1.19-1

gjs-1.66.2-1

gnome-initial-setup-3.36.4-2

grep-3.6-1

help2man-1.48.1-1

ipvsadm-1.31-1

less-563-1

libidn-1.36-1

make-4.3-1

mariadb-10.5.9-1

mozjs78-78.7.0-1

mpfr-4.1.0-1

nettle-3.7.1-1

parted-3.4-1

pcre2-10.36-1

polkit-0.118-1

strongswan-5.9.1-1

tar-1.34-1

trousers-0.3.15-1

wget-1.21-1

wireshark-3.4.3-1

Line 
1%bcond_with systemd
2
3Summary: PolicyKit Authorization Framework
4Summary(ja): PolicyKit 認証フレームワーク
5Name: polkit
6Version: 0.118
7Release: 1%{?_dist_release}%{?with_systemd:.systemd}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: LGPLv2+
13URL: https://www.freedesktop.org/wiki/Software/polkit
14Source0: https://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.gz
15Patch0: polkit-0.115-elogind.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: glib2-devel
19BuildRequires: expat-devel
20BuildRequires: pam-devel
21BuildRequires: mozjs78-devel
22BuildRequires: gtk-doc
23BuildRequires: intltool
24BuildRequires: gobject-introspection-devel
25%if %{with systemd}
26BuildRequires: systemd-devel
27%{?systemd_requires}
28%else
29BuildRequires: elogind-devel
30%endif
31
32Requires: dbus
33
34Obsoletes: PolicyKit <= 0.10
35Provides: PolicyKit = 0.11
36
37Obsoletes: polkit-desktop-policy < 0.103
38Provides: polkit-desktop-policy = 0.103
39
40%if %{with systemd}
41%{?systemd_requires}
42%endif
43
44%description
45PolicyKit is a toolkit for defining and handling authorizations.
46It is used for allowing unprivileged processes to speak to privileged
47processes.
48
49
50%package devel
51Summary: Development files for PolicyKit
52Summary(ja): PolicyKit の開発用ファイル
53Group: programming
54Requires: %name = %{version}-%{release}
55Requires: %name-docs = %{version}-%{release}
56Requires: pkgconfig
57Requires: glib2-devel
58
59%description devel
60Development files for PolicyKit.
61
62
63%package docs
64Summary: Development documentation for PolicyKit
65Summary(ja): PolicyKit の開発用ドキュメント
66Group: documentation
67Requires: %name-devel = %{version}-%{release}
68Requires: gtk-doc
69
70%description docs
71Development documentation for PolicyKit.
72
73
74%debug_package
75
76
77%prep
78%setup -q
79%if !%{with systemd}
80%patch0 -p1
81%endif
82
83
84%build
85autoreconf -vif
86%configure \
87        --with-os-type=redhat \
88        --enable-gtk-doc \
89        --disable-static \
90        --libexecdir=%{_libexecdir}/polkit-1 \
91        --enable-introspection \
92%if %{with systemd}
93        --enable-libsystemd-login=yes \
94%else
95        --enable-libelogind=yes \
96%endif
97        --enable-examples
98
99make %{?_smp_mflags}
100
101
102%install
103rm -rf $RPM_BUILD_ROOT
104make install DESTDIR=$RPM_BUILD_ROOT
105
106rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
107rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
108
109%find_lang polkit-1
110
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115
116%pre
117groupadd -g 27 -r polkitd >/dev/null 2>&1 || :
118useradd -u 27 -g polkitd -r -d '/' -s /sbin/nologin -c "User for polkitd" polkitd >/dev/null 2>&1 || :
119exit 0
120
121%post
122/sbin/ldconfig
123%if %{with systemd}
124%systemd_post polkit.service
125%endif
126
127%if %{with systemd}
128%preun
129%systemd_preun polkit.service
130%endif
131
132%postun
133/sbin/ldconfig
134%if %{with systemd}
135%systemd_postun_with_restart polkit.service
136%endif
137
138
139%files -f polkit-1.lang
140%defattr(-,root,root,-)
141%license COPYING
142%doc NEWS README
143%{_libdir}/lib*.so.*
144%{_datadir}/man/man1/*
145%{_datadir}/man/man8/*
146%{_datadir}/dbus-1/system-services/*
147%if %{with systemd}
148%{_unitdir}/polkit.service
149%endif
150%dir %{_datadir}/polkit-1/
151%dir %{_datadir}/polkit-1/actions
152%attr(0700,polkitd,root) %dir %{_datadir}/polkit-1/rules.d
153%{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
154%dir %{_sysconfdir}/polkit-1
155%{_sysconfdir}/polkit-1/rules.d/50-default.rules
156%attr(0700,polkitd,root) %dir %{_sysconfdir}/polkit-1/rules.d
157%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
158%{_sysconfdir}/pam.d/polkit-1
159%{_bindir}/pkaction
160%{_bindir}/pkcheck
161%{_bindir}/pkttyagent
162%dir %{_prefix}/lib/polkit-1
163%{_prefix}/lib/polkit-1/polkitd
164%{_libdir}/girepository-1.0/*.typelib
165
166# see upstream docs for why these permissions are necessary
167%attr(4755,root,root) %{_bindir}/pkexec
168%attr(4755,root,root) %{_prefix}/lib/polkit-1/polkit-agent-helper-1
169
170%files devel
171%defattr(-,root,root,-)
172%{_libdir}/lib*.so
173%{_libdir}/pkgconfig/*.pc
174%{_datadir}/gir-1.0/*.gir
175%{_includedir}/*
176%{_bindir}/pk-example-frobnicate
177%{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
178%dir %{_datadir}/gettext
179%dir %{_datadir}/gettext/its
180%{_datadir}/gettext/its/*
181
182%files docs
183%defattr(-,root,root,-)
184%{_datadir}/gtk-doc/html/*
185
186
187%changelog
188* Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.118-1
189- new upstream release.
190
191* Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.117-1
192- new upstream release.
193- dropped Patch1-3: fixed in upstream.
194
195* Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-2
196- added systemd support (disabled as default).
197- imported Patch1-3 from rawhide.
198
199* Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-1
200- new upstream release.
201
202* Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-2
203- really enabled elogind.
204
205* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-1
206- new upstream release.
207- enabled elogind: ConsoleKit is obsolete.
208
209* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-2
210- new upstream release
211
212* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-1
213- new upstream release
214
215* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.110-1
216- new upstream release
217
218* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.107-1
219- new upstream release
220- add BuildRequires: js-devel
221- remove BuildRequires: eggdbus-devel
222- remove polkit-desktop-policy subpackage (based on fedora)
223- historical changelogs are following:
224
225  * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.105-1
226  - new upstream release
227
228  * Sat Feb 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.104-1
229  - new upstream release
230
231  * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.102-1
232  - new upstream release
233
234  * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
235  - new upstream release
236
237  * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
238  - build with rpm-4.8.1-1 for pkg-config file
239
240  * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
241  - update to 0.96
242  - BR: eggdbus-devel >= 0.6
243
244  * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
245  - remove Obsoletes:/Provides: PolicyKit*
246
247  * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
248  - initial build for Vine Linux
249
250* Wed Jul 11 2012 David Zeuthen <davidz@redhat.com> 0.107-1%{?dist}
251- Update to upstream release 0.107
252
253* Fri Jun 29 2012 David Zeuthen <davidz@redhat.com> 0.106-2%{?dist}
254- Add forgotten Requires(pre): shadow-utils
255
256* Thu Jun 07 2012 David Zeuthen <davidz@redhat.com> 0.106-1%{?dist}
257- Update to upstream release 0.106
258- Authorizations are no longer controlled by .pkla files - from now
259  on, use the new .rules files described in the polkit(8) man page
260
261* Tue Apr 24 2012 David Zeuthen <davidz@redhat.com> 0.105-1%{?dist}
262- Update to upstream release 0.105
263- Nuke patches that are now upstream
264- Change 'PolicyKit' to 'polkit' in summary and descriptions
265
266* Thu Mar 08 2012 David Zeuthen <davidz@redhat.com> 0.104-6%{?dist}
267- Don't leak file descriptors (bgo #671486)
268
269* Mon Feb 13 2012 Matthias Clasen <mclasen@redhat.com> - 0.104-5%{?dist}
270- Make the -docs subpackage noarch
271
272* Mon Feb 06 2012 David Zeuthen <davidz@redhat.com> 0.104-4%{?dist}
273- Set error if we cannot obtain a PolkitUnixSession for a given PID (#787222)
274
275* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
276- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
277
278* Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-2%{?dist}
279- Nuke the ConsoleKit run-time requirement
280
281* Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-1%{?dist}
282- Update to upstream release 0.104
283- Force usage of systemd (instead of ConsoleKit) for session tracking
284
285* Tue Dec 06 2011 David Zeuthen <davidz@redhat.com> 0.103-1%{?dist}
286- Update to upstream release 0.103
287- Drop upstreamed patch
288- Drop Fedora-specific policy, it is now upstream (fdo #41008)
289
290* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
291- Rebuilt for glibc bug#747377
292
293* Tue Oct 18 2011 David Zeuthen <davidz@redhat.com> 0.102-2%{?dist}
294- Add patch to neuter the annoying systemd behavior where stdout/stderr
295  is sent to the system logs
296
297* Thu Aug 04 2011 David Zeuthen <davidz@redhat.com> 0.102-1
298- Update to 0.102 release
299
300* Fri May 13 2011 Bastien Nocera <bnocera@redhat.com> 0.101-7
301- Allow setting the pretty hostname without a password for wheel,
302  change matches systemd in git
303
304* Mon May  2 2011 Matthias Clasen <mclasen@redhat.com> - 0.101-6
305- Update the action id of the datetime mechanism
306
307* Tue Apr 19 2011 David Zeuthen <davidz@redhat.com> - 0.101-5
308- CVE-2011-1485 (#697951)
309
310* Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.101-4
311- Also allow org.kde.kcontrol.kcmclock.save without password for wheel
312
313* Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-3
314- Fix typo in pkla file (thanks notting)
315
316* Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-2
317- Nuke desktop_admin_r and desktop_user_r groups - just use the
318  wheel group instead (#688363)
319- Update the set of configuration directives that gives users
320  in the wheel group extra privileges
321
322* Thu Mar 03 2011 David Zeuthen <davidz@redhat.com> - 0.101-1
323- New upstream version
324
325* Mon Feb 21 2011 David Zeuthen <davidz@redhat.com> - 0.100-1
326- New upstream version
327
328* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
329- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
330
331* Fri Jan 28 2011 Matthias Clasen <mclasen@redhat.com> - 0.98-6
332- Own /usr/libexec/polkit-1
333
334* Sun Nov 14 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-5
335- Enable introspection
336
337* Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-4
338- Fix #629515 in a way that doesn't require autoreconf
339
340* Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-2
341- Include polkitagentenumtypes.h (#629515)
342
343* Mon Aug 23 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-1
344- Update to upstream release 0.98
345- Co-own /usr/share/gtk-doc (#604410)
346
347* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-5
348- Rebuid to work around bodhi limitations
349
350* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-4
351- Fix a ConsoleKit interaction bug
352
353* Fri Aug 13 2010 David Zeuthen <davidz@redhat.com> - 0.97-3
354- Add a patch to make pkcheck(1) work the way libvirtd uses it (#623257)
355- Require GLib >= 2.25.12 instead of 2.25.11
356- Ensure polkit-gnome packages earlier than 0.97 are not used with
357  these packages
358
359* Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-2
360- Rebuild
361
362* Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-1
363- Update to 0.97. This release contains a port from EggDBus to the
364  GDBus code available in recent GLib releases.
365
366* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 0.96-1
367- Update to 0.96
368- Disable introspection support for the time being
369
370* Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-2
371- Rebuild
372
373* Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-1
374- Update to 0.95
375- Drop upstreamed patches
376
377* Tue Oct 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.95-0.git20090913.3
378- Fix a typo in pklocalauthority(8)
379
380* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
381- Refine how Obsolete: is used and also add Provides: (thanks Jesse
382  Keating and nim-nim)
383
384* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
385- Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
386- Obsolete old PolicyKit packages
387
388* Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
389- Update to git snapshot
390- Drop upstreamed patches
391- Turn on GObject introspection
392- Don't delete desktop_admin_r and desktop_user_r groups when
393  uninstalling polkit-desktop-policy
394
395* Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
396- Add some patches from git master
397- Sort pkaction(1) output
398- Bug 23867 – UnixProcess vs. SystemBusName aliasing
399
400* Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
401- Add desktop_admin_r and desktop_user_r groups along with a first cut
402  of default authorizations for users in these groups.
403
404* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
405- Disable GObject Introspection for now as it breaks the build
406
407* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
408- Update to upstream release 0.94
409
410* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
411- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
412
413* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
414- Rebuild
415
416* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
417- Update to 0.93
418
419* Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
420- Don't make docs noarch (I *heart* multilib)
421- Change license to LGPLv2+
422
423* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
424- Rebuild
425
426* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
427- Update to 0.92 release
428
429* Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
430- Update to 0.92 snapshot
431
432* Mon Feb  9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
433- Initial spec file.
Note: See TracBrowser for help on using the repository browser.