source: projects/specs/trunk/p/polkit/polkit-vl.spec @ 12453

Revision 12453, 12.7 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

dconf-editor-3.36.4-1

fcitx-configtool-0.4.10-1

fcitx-4.2.9.8-1

polkit-0.117-1

Line 
1%bcond_with systemd
2
3Summary: PolicyKit Authorization Framework
4Summary(ja): PolicyKit 認証フレームワーク
5Name: polkit
6Version: 0.117
7Release: 1%{?_dist_release}%{?with_systemd:.systemd}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: LGPLv2+
13URL: https://www.freedesktop.org/wiki/Software/polkit
14Source0: https://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.gz
15Patch0: polkit-0.115-elogind.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: glib2-devel
19BuildRequires: expat-devel
20BuildRequires: pam-devel
21BuildRequires: mozjs68-devel
22BuildRequires: gtk-doc
23BuildRequires: intltool
24BuildRequires: gobject-introspection-devel
25%if %{with systemd}
26BuildRequires: systemd-devel
27%{?systemd_requires}
28%else
29BuildRequires: elogind-devel
30%endif
31
32Requires: dbus
33
34Obsoletes: PolicyKit <= 0.10
35Provides: PolicyKit = 0.11
36
37Obsoletes: polkit-desktop-policy < 0.103
38Provides: polkit-desktop-policy = 0.103
39
40%if %{with systemd}
41%{?systemd_requires}
42%endif
43
44%description
45PolicyKit is a toolkit for defining and handling authorizations.
46It is used for allowing unprivileged processes to speak to privileged
47processes.
48
49%package devel
50Summary: Development files for PolicyKit
51Summary(ja): PolicyKit の開発用ファイル
52Group: programming
53Requires: %name = %{version}-%{release}
54Requires: %name-docs = %{version}-%{release}
55Requires: pkgconfig
56Requires: glib2-devel
57
58%description devel
59Development files for PolicyKit.
60
61%package docs
62Summary: Development documentation for PolicyKit
63Summary(ja): PolicyKit の開発用ドキュメント
64Group: documentation
65Requires: %name-devel = %{version}-%{release}
66Requires: gtk-doc
67
68%description docs
69Development documentation for PolicyKit.
70
71
72%prep
73%setup -q
74%if !%{with systemd}
75%patch0 -p1
76%endif
77
78
79%build
80autoreconf -vif
81
82export CXXFLAGS="%{optflags} -std=gnu++14"
83%configure \
84        --with-os-type=redhat \
85        --enable-gtk-doc \
86        --disable-static \
87        --libexecdir=%{_libexecdir}/polkit-1 \
88        --enable-introspection \
89%if %{with systemd}
90        --enable-libsystemd-login=yes \
91%else
92        --enable-libelogind=yes \
93%endif
94        --enable-examples
95
96make %{?_smp_mflags}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101make install DESTDIR=$RPM_BUILD_ROOT
102
103rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
104rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
105
106%find_lang polkit-1
107
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112
113%pre
114groupadd -g 27 -r polkitd 2>&1 > /dev/null || :
115useradd -u 27 -g polkitd -r -d '/' -s /sbin/nologin -c "User for polkitd" polkitd 2>&1 > /dev/null || :
116exit 0
117
118%post
119/sbin/ldconfig
120%if %{with systemd}
121%systemd_post polkit.service
122%endif
123
124%if %{with systemd}
125%preun
126%systemd_preun polkit.service
127%endif
128
129%postun
130/sbin/ldconfig
131%if %{with systemd}
132%systemd_postun_with_restart polkit.service
133%endif
134
135
136%files -f polkit-1.lang
137%defattr(-,root,root,-)
138%license COPYING
139%doc NEWS README
140%{_libdir}/lib*.so.*
141%{_datadir}/man/man1/*
142%{_datadir}/man/man8/*
143%{_datadir}/dbus-1/system-services/*
144%if %{with systemd}
145%{_unitdir}/polkit.service
146%endif
147%dir %{_datadir}/polkit-1/
148%dir %{_datadir}/polkit-1/actions
149%attr(0700,polkitd,root) %dir %{_datadir}/polkit-1/rules.d
150%{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
151%dir %{_sysconfdir}/polkit-1
152%{_sysconfdir}/polkit-1/rules.d/50-default.rules
153%attr(0700,polkitd,root) %dir %{_sysconfdir}/polkit-1/rules.d
154%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
155%{_sysconfdir}/pam.d/polkit-1
156%{_bindir}/pkaction
157%{_bindir}/pkcheck
158%{_bindir}/pkttyagent
159%dir %{_prefix}/lib/polkit-1
160%{_prefix}/lib/polkit-1/polkitd
161%{_libdir}/girepository-1.0/*.typelib
162
163# see upstream docs for why these permissions are necessary
164%attr(4755,root,root) %{_bindir}/pkexec
165%attr(4755,root,root) %{_prefix}/lib/polkit-1/polkit-agent-helper-1
166
167%files devel
168%defattr(-,root,root,-)
169%{_libdir}/lib*.so
170%{_libdir}/pkgconfig/*.pc
171%{_datadir}/gir-1.0/*.gir
172%{_includedir}/*
173%{_bindir}/pk-example-frobnicate
174%{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
175%dir %{_datadir}/gettext
176%dir %{_datadir}/gettext/its
177%{_datadir}/gettext/its/*
178
179%files docs
180%defattr(-,root,root,-)
181%{_datadir}/gtk-doc/html/*
182
183
184%changelog
185* Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.117-1
186- new upstream release.
187- dropped Patch1-3: fixed in upstream.
188
189* Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-2
190- added systemd support (disabled as default).
191- imported Patch1-3 from rawhide.
192
193* Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-1
194- new upstream release.
195
196* Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-2
197- really enabled elogind.
198
199* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-1
200- new upstream release.
201- enabled elogind: ConsoleKit is obsolete.
202
203* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-2
204- new upstream release
205
206* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-1
207- new upstream release
208
209* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.110-1
210- new upstream release
211
212* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.107-1
213- new upstream release
214- add BuildRequires: js-devel
215- remove BuildRequires: eggdbus-devel
216- remove polkit-desktop-policy subpackage (based on fedora)
217- historical changelogs are following:
218
219  * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.105-1
220  - new upstream release
221
222  * Sat Feb 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.104-1
223  - new upstream release
224
225  * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.102-1
226  - new upstream release
227
228  * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
229  - new upstream release
230
231  * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
232  - build with rpm-4.8.1-1 for pkg-config file
233
234  * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
235  - update to 0.96
236  - BR: eggdbus-devel >= 0.6
237
238  * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
239  - remove Obsoletes:/Provides: PolicyKit*
240
241  * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
242  - initial build for Vine Linux
243
244* Wed Jul 11 2012 David Zeuthen <davidz@redhat.com> 0.107-1%{?dist}
245- Update to upstream release 0.107
246
247* Fri Jun 29 2012 David Zeuthen <davidz@redhat.com> 0.106-2%{?dist}
248- Add forgotten Requires(pre): shadow-utils
249
250* Thu Jun 07 2012 David Zeuthen <davidz@redhat.com> 0.106-1%{?dist}
251- Update to upstream release 0.106
252- Authorizations are no longer controlled by .pkla files - from now
253  on, use the new .rules files described in the polkit(8) man page
254
255* Tue Apr 24 2012 David Zeuthen <davidz@redhat.com> 0.105-1%{?dist}
256- Update to upstream release 0.105
257- Nuke patches that are now upstream
258- Change 'PolicyKit' to 'polkit' in summary and descriptions
259
260* Thu Mar 08 2012 David Zeuthen <davidz@redhat.com> 0.104-6%{?dist}
261- Don't leak file descriptors (bgo #671486)
262
263* Mon Feb 13 2012 Matthias Clasen <mclasen@redhat.com> - 0.104-5%{?dist}
264- Make the -docs subpackage noarch
265
266* Mon Feb 06 2012 David Zeuthen <davidz@redhat.com> 0.104-4%{?dist}
267- Set error if we cannot obtain a PolkitUnixSession for a given PID (#787222)
268
269* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
270- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
271
272* Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-2%{?dist}
273- Nuke the ConsoleKit run-time requirement
274
275* Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-1%{?dist}
276- Update to upstream release 0.104
277- Force usage of systemd (instead of ConsoleKit) for session tracking
278
279* Tue Dec 06 2011 David Zeuthen <davidz@redhat.com> 0.103-1%{?dist}
280- Update to upstream release 0.103
281- Drop upstreamed patch
282- Drop Fedora-specific policy, it is now upstream (fdo #41008)
283
284* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
285- Rebuilt for glibc bug#747377
286
287* Tue Oct 18 2011 David Zeuthen <davidz@redhat.com> 0.102-2%{?dist}
288- Add patch to neuter the annoying systemd behavior where stdout/stderr
289  is sent to the system logs
290
291* Thu Aug 04 2011 David Zeuthen <davidz@redhat.com> 0.102-1
292- Update to 0.102 release
293
294* Fri May 13 2011 Bastien Nocera <bnocera@redhat.com> 0.101-7
295- Allow setting the pretty hostname without a password for wheel,
296  change matches systemd in git
297
298* Mon May  2 2011 Matthias Clasen <mclasen@redhat.com> - 0.101-6
299- Update the action id of the datetime mechanism
300
301* Tue Apr 19 2011 David Zeuthen <davidz@redhat.com> - 0.101-5
302- CVE-2011-1485 (#697951)
303
304* Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.101-4
305- Also allow org.kde.kcontrol.kcmclock.save without password for wheel
306
307* Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-3
308- Fix typo in pkla file (thanks notting)
309
310* Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-2
311- Nuke desktop_admin_r and desktop_user_r groups - just use the
312  wheel group instead (#688363)
313- Update the set of configuration directives that gives users
314  in the wheel group extra privileges
315
316* Thu Mar 03 2011 David Zeuthen <davidz@redhat.com> - 0.101-1
317- New upstream version
318
319* Mon Feb 21 2011 David Zeuthen <davidz@redhat.com> - 0.100-1
320- New upstream version
321
322* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
323- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
324
325* Fri Jan 28 2011 Matthias Clasen <mclasen@redhat.com> - 0.98-6
326- Own /usr/libexec/polkit-1
327
328* Sun Nov 14 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-5
329- Enable introspection
330
331* Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-4
332- Fix #629515 in a way that doesn't require autoreconf
333
334* Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-2
335- Include polkitagentenumtypes.h (#629515)
336
337* Mon Aug 23 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-1
338- Update to upstream release 0.98
339- Co-own /usr/share/gtk-doc (#604410)
340
341* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-5
342- Rebuid to work around bodhi limitations
343
344* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-4
345- Fix a ConsoleKit interaction bug
346
347* Fri Aug 13 2010 David Zeuthen <davidz@redhat.com> - 0.97-3
348- Add a patch to make pkcheck(1) work the way libvirtd uses it (#623257)
349- Require GLib >= 2.25.12 instead of 2.25.11
350- Ensure polkit-gnome packages earlier than 0.97 are not used with
351  these packages
352
353* Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-2
354- Rebuild
355
356* Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-1
357- Update to 0.97. This release contains a port from EggDBus to the
358  GDBus code available in recent GLib releases.
359
360* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 0.96-1
361- Update to 0.96
362- Disable introspection support for the time being
363
364* Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-2
365- Rebuild
366
367* Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-1
368- Update to 0.95
369- Drop upstreamed patches
370
371* Tue Oct 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.95-0.git20090913.3
372- Fix a typo in pklocalauthority(8)
373
374* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
375- Refine how Obsolete: is used and also add Provides: (thanks Jesse
376  Keating and nim-nim)
377
378* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
379- Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
380- Obsolete old PolicyKit packages
381
382* Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
383- Update to git snapshot
384- Drop upstreamed patches
385- Turn on GObject introspection
386- Don't delete desktop_admin_r and desktop_user_r groups when
387  uninstalling polkit-desktop-policy
388
389* Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
390- Add some patches from git master
391- Sort pkaction(1) output
392- Bug 23867 – UnixProcess vs. SystemBusName aliasing
393
394* Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
395- Add desktop_admin_r and desktop_user_r groups along with a first cut
396  of default authorizations for users in these groups.
397
398* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
399- Disable GObject Introspection for now as it breaks the build
400
401* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
402- Update to upstream release 0.94
403
404* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
405- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
406
407* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
408- Rebuild
409
410* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
411- Update to 0.93
412
413* Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
414- Don't make docs noarch (I *heart* multilib)
415- Change license to LGPLv2+
416
417* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
418- Rebuild
419
420* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
421- Update to 0.92 release
422
423* Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
424- Update to 0.92 snapshot
425
426* Mon Feb  9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
427- Initial spec file.
Note: See TracBrowser for help on using the repository browser.