source: projects/specs/trunk/p/polkit/polkit-vl.spec @ 12431

Revision 12431, 12.7 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

control-center-3.30.3-2

docker-ce-19.03.9-1

docker-compose-1.26.2-1

golang-1.14.6-1

polkit-0.116-2

postfix-3.5.6-1

unbound-1.11.0-1

webkitgtk4-2.28.3-1

zabbix-5.0.2-1

Line 
1%bcond_with systemd
2
3Summary: PolicyKit Authorization Framework
4Summary(ja): PolicyKit 認証フレームワーク
5Name: polkit
6Version: 0.116
7Release: 2%{?_dist_release}%{?with_systemd:.systemd}
8Group: System Environment/Libraries
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: LGPLv2+
13URL: https://www.freedesktop.org/wiki/Software/polkit
14Source0: https://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.gz
15Patch0: polkit-0.115-elogind.patch
16Patch1: polkit-0.116-pkttyagent-sigttou-bg-job.patch
17Patch2: pkttyagent-tcsaflush-batch-erase.patch
18Patch3: jsauthority-memleak.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21BuildRequires: elogind-devel
22BuildRequires: glib2-devel
23BuildRequires: expat-devel
24BuildRequires: pam-devel
25BuildRequires: mozjs60-devel
26BuildRequires: gtk-doc
27BuildRequires: intltool
28BuildRequires: gobject-introspection-devel
29
30Requires: dbus
31
32Obsoletes: PolicyKit <= 0.10
33Provides: PolicyKit = 0.11
34
35Obsoletes: polkit-desktop-policy < 0.103
36Provides: polkit-desktop-policy = 0.103
37
38%if %{with systemd}
39%{?systemd_requires}
40%endif
41
42%description
43PolicyKit is a toolkit for defining and handling authorizations.
44It is used for allowing unprivileged processes to speak to privileged
45processes.
46
47%package devel
48Summary: Development files for PolicyKit
49Summary(ja): PolicyKit の開発用ファイル
50Group: Development/Libraries
51Requires: %name = %{version}-%{release}
52Requires: %name-docs = %{version}-%{release}
53Requires: pkgconfig
54Requires: glib2-devel
55
56%description devel
57Development files for PolicyKit.
58
59%package docs
60Summary: Development documentation for PolicyKit
61Summary(ja): PolicyKit の開発用ドキュメント
62Group: Development/Libraries
63Requires: %name-devel = %{version}-%{release}
64Requires: gtk-doc
65
66%description docs
67Development documentation for PolicyKit.
68
69
70%prep
71%setup -q
72%if !%{with systemd}
73%patch0 -p1
74%endif
75%patch1 -p1
76%patch2 -p1
77%patch3 -p1
78
79
80%build
81autoreconf -vif
82
83export CXXFLAGS="%{optflags} -std=gnu++11"
84%configure \
85        --with-os-type=redhat \
86        --enable-gtk-doc \
87        --disable-static \
88        --libexecdir=%{_libexecdir}/polkit-1 \
89        --enable-introspection \
90%if %{with systemd}
91        --enable-libsystemd-login=yes \
92%else
93        --enable-libelogind=yes \
94%endif
95        --enable-examples
96
97make
98
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make install DESTDIR=$RPM_BUILD_ROOT
103
104rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
105rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
106
107%find_lang polkit-1
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%pre
115groupadd -g 27 -r polkitd 2>&1 > /dev/null || :
116useradd -u 27 -g polkitd -r -d '/' -s /sbin/nologin -c "User for polkitd" polkitd 2>&1 > /dev/null || :
117exit 0
118
119%post
120/sbin/ldconfig
121%if %{with systemd}
122%systemd_post polkit.service
123%endif
124
125%if %{with systemd}
126%preun
127%systemd_preun polkit.service
128%endif
129
130%postun
131/sbin/ldconfig
132%if %{with systemd}
133%systemd_postun_with_restart polkit.service
134%endif
135
136
137%files -f polkit-1.lang
138%defattr(-,root,root,-)
139%license COPYING
140%doc NEWS README
141%{_libdir}/lib*.so.*
142%{_datadir}/man/man1/*
143%{_datadir}/man/man8/*
144%{_datadir}/dbus-1/system-services/*
145%if %{with systemd}
146%{_unitdir}/polkit.service
147%endif
148%dir %{_datadir}/polkit-1/
149%dir %{_datadir}/polkit-1/actions
150%attr(0700,polkitd,root) %dir %{_datadir}/polkit-1/rules.d
151%{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
152%dir %{_sysconfdir}/polkit-1
153%{_sysconfdir}/polkit-1/rules.d/50-default.rules
154%attr(0700,polkitd,root) %dir %{_sysconfdir}/polkit-1/rules.d
155%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
156%{_sysconfdir}/pam.d/polkit-1
157%{_bindir}/pkaction
158%{_bindir}/pkcheck
159%{_bindir}/pkttyagent
160%dir %{_prefix}/lib/polkit-1
161%{_prefix}/lib/polkit-1/polkitd
162%{_libdir}/girepository-1.0/*.typelib
163
164# see upstream docs for why these permissions are necessary
165%attr(4755,root,root) %{_bindir}/pkexec
166%attr(4755,root,root) %{_prefix}/lib/polkit-1/polkit-agent-helper-1
167
168%files devel
169%defattr(-,root,root,-)
170%{_libdir}/lib*.so
171%{_libdir}/pkgconfig/*.pc
172%{_datadir}/gir-1.0/*.gir
173%{_includedir}/*
174%{_bindir}/pk-example-frobnicate
175%{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
176%dir %{_datadir}/gettext
177%dir %{_datadir}/gettext/its
178%{_datadir}/gettext/its/*
179
180%files docs
181%defattr(-,root,root,-)
182%{_datadir}/gtk-doc/html/*
183
184
185%changelog
186* Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-2
187- added systemd support (disabled as default).
188- imported Patch1-3 from rawhide.
189
190* Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-1
191- new upstream release.
192
193* Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-2
194- really enabled elogind.
195
196* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-1
197- new upstream release.
198- enabled elogind: ConsoleKit is obsolete.
199
200* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-2
201- new upstream release
202
203* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-1
204- new upstream release
205
206* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.110-1
207- new upstream release
208
209* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.107-1
210- new upstream release
211- add BuildRequires: js-devel
212- remove BuildRequires: eggdbus-devel
213- remove polkit-desktop-policy subpackage (based on fedora)
214- historical changelogs are following:
215
216  * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.105-1
217  - new upstream release
218
219  * Sat Feb 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.104-1
220  - new upstream release
221
222  * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.102-1
223  - new upstream release
224
225  * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
226  - new upstream release
227
228  * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
229  - build with rpm-4.8.1-1 for pkg-config file
230
231  * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
232  - update to 0.96
233  - BR: eggdbus-devel >= 0.6
234
235  * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
236  - remove Obsoletes:/Provides: PolicyKit*
237
238  * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
239  - initial build for Vine Linux
240
241* Wed Jul 11 2012 David Zeuthen <davidz@redhat.com> 0.107-1%{?dist}
242- Update to upstream release 0.107
243
244* Fri Jun 29 2012 David Zeuthen <davidz@redhat.com> 0.106-2%{?dist}
245- Add forgotten Requires(pre): shadow-utils
246
247* Thu Jun 07 2012 David Zeuthen <davidz@redhat.com> 0.106-1%{?dist}
248- Update to upstream release 0.106
249- Authorizations are no longer controlled by .pkla files - from now
250  on, use the new .rules files described in the polkit(8) man page
251
252* Tue Apr 24 2012 David Zeuthen <davidz@redhat.com> 0.105-1%{?dist}
253- Update to upstream release 0.105
254- Nuke patches that are now upstream
255- Change 'PolicyKit' to 'polkit' in summary and descriptions
256
257* Thu Mar 08 2012 David Zeuthen <davidz@redhat.com> 0.104-6%{?dist}
258- Don't leak file descriptors (bgo #671486)
259
260* Mon Feb 13 2012 Matthias Clasen <mclasen@redhat.com> - 0.104-5%{?dist}
261- Make the -docs subpackage noarch
262
263* Mon Feb 06 2012 David Zeuthen <davidz@redhat.com> 0.104-4%{?dist}
264- Set error if we cannot obtain a PolkitUnixSession for a given PID (#787222)
265
266* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
267- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
268
269* Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-2%{?dist}
270- Nuke the ConsoleKit run-time requirement
271
272* Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-1%{?dist}
273- Update to upstream release 0.104
274- Force usage of systemd (instead of ConsoleKit) for session tracking
275
276* Tue Dec 06 2011 David Zeuthen <davidz@redhat.com> 0.103-1%{?dist}
277- Update to upstream release 0.103
278- Drop upstreamed patch
279- Drop Fedora-specific policy, it is now upstream (fdo #41008)
280
281* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
282- Rebuilt for glibc bug#747377
283
284* Tue Oct 18 2011 David Zeuthen <davidz@redhat.com> 0.102-2%{?dist}
285- Add patch to neuter the annoying systemd behavior where stdout/stderr
286  is sent to the system logs
287
288* Thu Aug 04 2011 David Zeuthen <davidz@redhat.com> 0.102-1
289- Update to 0.102 release
290
291* Fri May 13 2011 Bastien Nocera <bnocera@redhat.com> 0.101-7
292- Allow setting the pretty hostname without a password for wheel,
293  change matches systemd in git
294
295* Mon May  2 2011 Matthias Clasen <mclasen@redhat.com> - 0.101-6
296- Update the action id of the datetime mechanism
297
298* Tue Apr 19 2011 David Zeuthen <davidz@redhat.com> - 0.101-5
299- CVE-2011-1485 (#697951)
300
301* Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.101-4
302- Also allow org.kde.kcontrol.kcmclock.save without password for wheel
303
304* Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-3
305- Fix typo in pkla file (thanks notting)
306
307* Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-2
308- Nuke desktop_admin_r and desktop_user_r groups - just use the
309  wheel group instead (#688363)
310- Update the set of configuration directives that gives users
311  in the wheel group extra privileges
312
313* Thu Mar 03 2011 David Zeuthen <davidz@redhat.com> - 0.101-1
314- New upstream version
315
316* Mon Feb 21 2011 David Zeuthen <davidz@redhat.com> - 0.100-1
317- New upstream version
318
319* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
320- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
321
322* Fri Jan 28 2011 Matthias Clasen <mclasen@redhat.com> - 0.98-6
323- Own /usr/libexec/polkit-1
324
325* Sun Nov 14 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-5
326- Enable introspection
327
328* Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-4
329- Fix #629515 in a way that doesn't require autoreconf
330
331* Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-2
332- Include polkitagentenumtypes.h (#629515)
333
334* Mon Aug 23 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-1
335- Update to upstream release 0.98
336- Co-own /usr/share/gtk-doc (#604410)
337
338* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-5
339- Rebuid to work around bodhi limitations
340
341* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-4
342- Fix a ConsoleKit interaction bug
343
344* Fri Aug 13 2010 David Zeuthen <davidz@redhat.com> - 0.97-3
345- Add a patch to make pkcheck(1) work the way libvirtd uses it (#623257)
346- Require GLib >= 2.25.12 instead of 2.25.11
347- Ensure polkit-gnome packages earlier than 0.97 are not used with
348  these packages
349
350* Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-2
351- Rebuild
352
353* Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-1
354- Update to 0.97. This release contains a port from EggDBus to the
355  GDBus code available in recent GLib releases.
356
357* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 0.96-1
358- Update to 0.96
359- Disable introspection support for the time being
360
361* Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-2
362- Rebuild
363
364* Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-1
365- Update to 0.95
366- Drop upstreamed patches
367
368* Tue Oct 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.95-0.git20090913.3
369- Fix a typo in pklocalauthority(8)
370
371* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
372- Refine how Obsolete: is used and also add Provides: (thanks Jesse
373  Keating and nim-nim)
374
375* Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
376- Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
377- Obsolete old PolicyKit packages
378
379* Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
380- Update to git snapshot
381- Drop upstreamed patches
382- Turn on GObject introspection
383- Don't delete desktop_admin_r and desktop_user_r groups when
384  uninstalling polkit-desktop-policy
385
386* Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
387- Add some patches from git master
388- Sort pkaction(1) output
389- Bug 23867 – UnixProcess vs. SystemBusName aliasing
390
391* Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
392- Add desktop_admin_r and desktop_user_r groups along with a first cut
393  of default authorizations for users in these groups.
394
395* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
396- Disable GObject Introspection for now as it breaks the build
397
398* Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
399- Update to upstream release 0.94
400
401* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
402- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
403
404* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
405- Rebuild
406
407* Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
408- Update to 0.93
409
410* Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
411- Don't make docs noarch (I *heart* multilib)
412- Change license to LGPLv2+
413
414* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
415- Rebuild
416
417* Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
418- Update to 0.92 release
419
420* Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
421- Update to 0.92 snapshot
422
423* Mon Feb  9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
424- Initial spec file.
Note: See TracBrowser for help on using the repository browser.