source: projects/specs/trunk/p/pilot-link/pilot-link-vl.spec @ 9686

Revision 9686, 9.8 KB checked in by Takemikaduchi, 9 years ago (diff)

gnome-phone-manager: update
others: rebuild

Line 
1%define ver     0.12.5
2%define srcver  %{ver}
3%define rel     4%{?_dist_release}
4%define support_perl 0
5
6Name:           pilot-link
7Summary:        File transfer utilities between Linux and PalmPilots.
8Summary(ja):    Linux と Palm handheld device を接続する為のユーティリティ
9Version:        %{ver}
10Release:        %{rel}
11Epoch:          1
12
13# libpisock/md5.c       Public Domain
14# libpisock/blob.c      LGPLv2+
15# libpisock/contact.c   GPLv2
16# kittykiller.c         GPLv2+
17License:        GPLv2 and GPLv2+ and LGPLv2+ and Public Domain
18Group:          Applications/Communications
19URL:            http://www.pilot-link.org/
20
21Source0:        http://downloads.pilot-link.org/pilot-link-%{version}.tar.bz2
22Source1:        connect-palm-ppp.tar.bz2
23Source2:        60-libpisock.rules.vine
24Source3:        60-pilot.perms
25
26Patch0:         pilot-link-0.12.1-var.patch
27Patch1:         pilot-link-0.12.2-open.patch
28Patch2:         pilot-link-0.12.3-clio.patch
29Patch3:         pilot-link-0.12.5-mp.patch
30Patch4:         pilot-link-0.12.5-redefinePerlsymbols.patch
31Patch5:         pilot-link-0.12.5-compiler_warnings.patch
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34BuildRequires:  bison >= 1.35
35BuildRequires:  libusb-devel >= 0.1
36BuildRequires:  libpng-devel
37BuildRequires:  readline-devel
38BuildRequires:  bluez-libs-devel
39BuildRequires:  popt-devel
40%if %{support_perl}
41BuildRequires:  perl
42%endif
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46
47%description
48This suite of tools allows you to upload and download programs and
49data files between a Linux/UNIX machine and the PalmPilot.  It has a
50few extra utils that will allow for things like syncing the
51PalmPilot's calendar app with Ical.  Note that you might still need to
52consult the sources for pilot-link if you would like the Python, Tcl,
53or Perl bindings.
54
55Install pilot-link if you want to synchronize your Palm with your Vine
56Linux system.
57
58%description -l ja
59このツールを使うと、Linux/Unix マシンと Palm handheld device の間で
60プログラムやファイルを転送することができます。このツールには、Palm
61handheld device の予定表と Ical との間で同期を可能にするようないくつ
62かのユーティリティが付属しています。もし Python や Tcl、あるいは
63Perl bindingsを使用する場合は、pilot-link の source を調べる必要が
64あることに注意してください。
65
66Palm handheld device を Vine Linux システムで同期させたい場合は
67pilot-link をインストールします。
68
69%package libs
70Summary:        PalmPilot libraries
71Summary(ja):    Palm handheld ライブラリ
72Group:          System Environment/Libraries
73
74%description libs
75Libraries for applications communicating with PalmPilot
76
77%package devel
78Summary:        PalmPilot development header files.
79Summary(ja):    Palm handheld プログラム開発用のヘッダ ファイル
80Group:          Development/Libraries
81Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
82
83%description devel
84This package contains the development headers that are used to build
85the pilot-link package.
86
87If you want to develop PalmPilot synchronizing applications, you'll
88need to install pilot-link-devel.
89
90%description devel -l ja
91このパッケージには、pilot-link パッケージを構築する為に必要な開発用の
92ヘッダファイルが含まれます。
93
94Palm handheld deviceと同期するアプリケーションを開発したい場合は、
95pilot-link-devel パッケージをインストールする必要があります。
96
97%prep
98%setup -q -a 1
99%patch0 -p1 -b .var
100%patch1 -p1 -b .open
101%patch2 -p1 -b .clio
102%patch3 -p1 -b .mp
103%patch4 -p1 -b .symbol
104%patch5 -p1 -b .compiler
105
106iconv -f windows-1252 -t UTF8 doc/README.usb > doc/README.usb.aux
107mv doc/README.usb.aux doc/README.usb
108iconv -f windows-1252 -t UTF8 ChangeLog > ChangeLog.aux
109mv ChangeLog.aux ChangeLog
110iconv -f windows-1252 -t UTF8 NEWS > NEWS.aux
111mv NEWS.aux NEWS
112
113%build
114%configure \
115    --disable-static \
116    --enable-conduits \
117    --enable-libusb \
118    --with-libpng \
119    --with-bluez \
120    --without-python \
121    --without-tcl \
122    --without-java \
123%if %{support_perl}
124    --with-perl
125%else
126    --without-perl
127%endif
128
129sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
130sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
131
132make %{?_smp_mflags}
133
134%install
135[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
136
137make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir}
138make install -C doc/man DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir}
139
140%if %{support_perl}
141if test -f bindings/Perl/Makefile.PL ; then
142   cd bindings/Perl
143   perl -pi -e 's|^\$libdir =.*|\$libdir = "%{buildroot}%{_libdir}";|g' Makefile.PL
144   CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT/usr INSTALLDIRS=vendor
145   make
146   cd ../..
147fi
148%endif
149
150
151%if %{support_perl}
152make install -C bindings/Perl
153rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/vendor_perl/%{perl_version}/*/auto/PDA/Pilot/Pilot.bs \
154      $RPM_BUILD_ROOT%{_libdir}/perl5/site_perl/*/*/*/PDA/Pilot/.packlist
155%endif
156
157# install modified udev rules.
158#mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
159#install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/60-libpisock.rules
160
161# remove files we don't want to include
162rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
163
164# remove broken prog
165rm -f $RPM_BUILD_ROOT%{_bindir}/pilot-prc
166
167# install visor configs to share/udev
168install -p -m644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/pilot-link/udev
169
170# now that rules are moved out HAL, install to /lib/udev/
171install -d $RPM_BUILD_ROOT/lib/udev/rules.d/
172install -p -m644 %{SOURCE2} $RPM_BUILD_ROOT/lib/udev/rules.d/60-libpisock.rules
173
174%post libs -p /sbin/ldconfig
175
176%postun libs -p /sbin/ldconfig
177
178
179%clean
180[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
181
182%files
183%defattr(-,root,root)
184%doc COPYING ChangeLog README NEWS AUTHORS doc/README.*
185%{_bindir}/*
186%{_mandir}/man1/*
187
188%files libs
189%defattr(-,root,root)
190%doc COPYING.LIB
191/lib/udev/rules.d/60-libpisock.rules
192#{_sysconfdir}/udev/rules.d/60-libpisock.rules
193%{_libdir}/*.so.*
194%if %{support_perl}
195%{_libdir}/perl5/vendor_perl/*/*/*/PDA
196%{_libdir}/perl5/vendor_perl/*/*/PDA
197%endif
198%{_datadir}/pilot-link
199%{_mandir}/man7/*
200
201%files devel
202%defattr(-, root, root)
203%{_libdir}/*.so
204#{_libdir}/*.la
205%{_libdir}/pkgconfig/pilot-link.pc
206%{_includedir}/*
207%{_datadir}/aclocal/*.m4
208
209
210%changelog
211* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-4
212- rebuild with readline-6.3
213
214* Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.12.5-3
215- added Patch1, 2, 3, 4 and 5 from Fedora
216- added Source3 from Fedora
217- built with libpng 1.6.12
218- updated devel description
219- moved main package to Applications/Communications Group
220
221* Sat Sep 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.12.5-2
222- rebuilt with current environment
223
224* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.5-1
225- new upstream release
226- split libraries to subpackage
227- built with rpm-4.8.1 for pkg-config
228- added URL tag
229
230* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.4-1
231- new upstream release
232- removed static libraries from devel package
233- added --with-bluez to %%configure (added also BR: bluez-libs-devel)
234
235* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.0-1vl5
236- applied new versioning policy, spec in utf-8
237
238* Sat Sep 30 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl2
239- add modified udev rules (Source2). <BTS:VineLinux:222>
240
241* Sat Sep 02 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl1
242- source update.
243- change Group to Applications/Other
244- use %%configure macro instead of ./configure
245- delete unused configure options for itcl and tk.
246- use '%%__make install' to use DESTDIR variable.
247- comment out '%%makeinstall -C doc/man'(not required to install man).
248- add 60-libpisock.rules for udev in %%files.
249- add pilot-link.pc in %%files for -devel.
250- add Requires libusb and BuildRequires libusb-devel >= 0.1.
251
252* Fri Jan  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.11.8-0vl3
253- rebuild for VineSeed
254- add "%%{epoch}:" to Requires in pilot-link-devel
255
256* Sun Nov 07 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl2
257- convert spec from SJIS to EUC.
258
259* Wed Nov 03 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl1
260- source update
261- add japanese translation(summary & description).
262- use License tag instead of Copyright.
263- change BuildRequires XFree86-devel to XOrg-devel.
264- add BuildRequires readline-devel.
265- add new Patch9.(avoid make error "undefined reference to `pow'")
266
267* Fri May 23 2003 Tomoya TAKA <taka@vinelinux.org> 0.11.7-0vl2
268- disuse %%configure macro to avoid unsuitable prefixed filename
269
270* Mon Mar 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.11.7-0vl1
271- source update
272
273* Fri Jan 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.5-0vl2
274- unfortunately added Epoch 1
275  (the previous version was 0.9.5.pre5-0vl2. Sigh...)
276
277* Sat Oct 13 2001 <uh@u.dhis.portside.net>
278- 0.9.5-0vl1
279- upgrade to 0.9.5
280- add COPYING.LIB to %doc
281
282* Mon Mar 26 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.5-pre5-0vl1
283- New upstream release.
284- Fixed defattr stuff for devel package.
285- Use rpmmacros.
286
287* Wed Oct 20 1999 Preston Brown <pbrown@redhat.com>
288- upgrade to pilot-link 0.9.3, rewrite spec.
289
290* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
291- strip binaries
292
293* Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
294- added missing files from devel subpackage
295
296* Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
297- move /usr/lib/pix to /usr/lib/pilot-link (dumb, BAD name)
298
299* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
300- auto rebuild in the new build environment (release 5)
301
302* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
303- Injected new description and group.
304
305* Thu Jan 21 1999 Bill Nottingham <notting@redhat.com>
306- arm fix
307
308* Thu Sep 24 1998 Michael Maher <mike@redhat.com>
309- cleaned up spec file, updated package
310
311* Tue May 19 1998 Michael Maher <mike@redhat.com>
312- updated rpm
313
314* Thu Jan 29 1998 Otto Hammersmith <otto@redhat.com>
315- added changelog
316- updated to 0.8.9
317- removed explicit requires for /usr/bin/perl
318
Note: See TracBrowser for help on using the repository browser.