source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 574

Revision 574, 6.9 KB checked in by inagaki, 14 years ago (diff)

updated: phonon

Line 
1%define tar_ver 4.4
2
3Summary: Multimedia framework api
4Summary(ja): マルチメディアフレームワーク API
5Name: phonon
6Version: 4.4.0
7Release: 1%{?_dist_release}
8Group: System Environment/Libraries
9License: LGPLv2+
10URL: http://phonon.kde.org/
11Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.4.0/phonon-%{version}.tgz
12
13Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
14Source11: hi16-phonon-gstreamer.png
15Source12: hi22-phonon-gstreamer.png
16Source13: hi32-phonon-gstreamer.png
17Source14: hi48-phonon-gstreamer.png
18Source15: hi64-phonon-gstreamer.png
19Source16: hi128-phonon-gstreamer.png
20
21## Mandriva/upstreamable patches
22Patch51: phonon-4.3.50-fix-decodebin-usage.patch
23Patch52: phonon-4.3.50-gstreamer-fix-seekable-query-failed.patch
24Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
25Patch57: phonon-4.3.80-pulse-devicemove-rejig.patch
26
27## Upstream patches
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: automoc4 >= 0.9.86
31BuildRequires: cmake >= 2.6.2
32BuildRequires: glib2-devel
33BuildRequires: gstreamer-devel
34BuildRequires: gstreamer-plugins-base-devel
35BuildRequires: libxcb-devel
36BuildRequires: libxml2-devel
37BuildRequires: qt4-devel >= 4.4.0
38BuildRequires: xine-lib-devel
39BuildRequires: pulseaudio-libs-devel
40
41Requires: phonon-backend >= %{version}
42Requires: qt4 >= 4.4.0
43
44%description
45Phonon is a cross-platform portable Multimedia Support Abstraction,
46which allows you to play multiple audio or video formats with the same
47quality on all platforms, no matter which underlying architecture is
48used.
49
50%package backend-gstreamer
51Summary: Gstreamer phonon backend
52Group: System Environment/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: gstreamer-plugins-good
55Obsoletes: %{name}-backend-gst < 4.2.0-4
56Provides:  %{name}-backend-gst = %{version}-%{release}
57Provides: phonon-backend = %{version}-%{release}
58
59%description backend-gstreamer
60%{summary}.
61
62%package backend-xine
63Summary: xine phonon backend
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66Provides: phonon-backend = %{version}-%{release}
67
68%description backend-xine
69%{summary}.
70
71%package devel
72Summary: Development files for phonon
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
75Requires: qt4-devel >= 4.4.0
76
77%description devel
78Header files for developing applications using phonon
79
80%prep
81%setup -q -n %{name}-%{tar_ver}
82
83%patch51 -p0 -b .fix-decodebin-usage
84%patch52 -p1 -b .gstreamer-fix-seekable-query-failed
85%patch53 -p1 -b .phonon-allow-stop-empty-source
86%patch57 -p1 -b .pulse-devicemove-rejig
87
88
89%build
90%ifarch x86_64
91PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
92%endif
93
94mkdir -p %{_target_platform}
95pushd %{_target_platform}
96unset QTDIR || : ; . /etc/profile.d/qt4.sh
97%cmake \
98    -DUSE_INSTALL_PLUGIN=TRUE \
99    ..
100popd
101
102make %{?_smp_mflags} -C %{_target_platform}
103
104%install
105rm -rf $RPM_BUILD_ROOT
106make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
107
108# symlink for qt/phonon compatibility
109ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
110
111# move the oxygen-only phonon-xine icons to hicolor
112test -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor && exit 0
113mv $RPM_BUILD_ROOT%{_datadir}/icons/oxygen \
114   $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
115
116# gstreamer icons
117install -D -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
118install -D -m 0644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/phonon-gstreamer.png
119install -D -m 0644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/phonon-gstreamer.png
120install -D -m 0644 %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/phonon-gstreamer.png
121install -D -m 0644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/phonon-gstreamer.png
122install -D -m 0644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/phonon-gstreamer.png
123install -D -m 0644 %{SOURCE16} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/phonon-gstreamer.png
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129
130%postun -p /sbin/ldconfig
131
132%posttrans backend-gstreamer
133gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
134
135%posttrans backend-xine
136gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
137
138%postun backend-gstreamer
139if [ $1 -eq 0 ] ; then
140  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
141fi
142
143%postun backend-xine
144if [ $1 -eq 0 ] ; then
145  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
146fi
147
148%files
149%defattr(-,root,root)
150%doc COPYING.LIB
151%{_libdir}/*.so.*
152%{_datadir}/dbus-1/interfaces/*
153# kde4-specific dirs
154%dir %{_libdir}/kde4/plugins/phonon_backend
155%dir %{_datadir}/kde4/services/phononbackends
156
157%files backend-gstreamer
158%defattr(-,root,root,-)
159%{_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
160%{_datadir}/kde4/services/phononbackends/gstreamer.desktop
161%{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
162
163%files backend-xine
164%defattr(-,root,root,-)
165%{_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
166%{_datadir}/kde4/services/phononbackends/xine.desktop
167%{_datadir}/icons/hicolor/*/apps/phonon-xine.*
168
169%files devel
170%defattr(-,root,root)
171%dir %{_includedir}/KDE
172%{_includedir}/KDE/Phonon/
173%{_includedir}/phonon/
174%{_libdir}/*.so
175%{_libdir}/pkgconfig/*.pc
176
177%changelog
178* Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
179- new upstream release
180- dropt Patch1, 50, 54 and 100
181- added Patch57
182  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
183  - F11: patch/modularize pa device-manager bits
184
185* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
186- added qmake path to PATH (if x86_64)
187
188* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
189- new upstream release
190- built with new toolchain
191
192* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
193- added Patch102 and 103 from FC
194  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
195  - fix for '#' in filenames
196  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
197  - restore patches to the xine backend
198
199* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
200- added Patch100 and 101 from FC
201  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
202  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
203- added backend sub-pakcages
204
205* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
206- new upstream release
207- add BuildPrereq: cmake
208
209* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
210- new upstream release
211
212* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
213- new upstream release
214- update %%files
215- add BuildPrereq: xine-lib-devel libxcb-devel
216
217* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
218- new upstream release
219
220* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
221- added script to append qmake path
222- added option -DLIB_INSTALL_DIR at cmake
223
224* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
225- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.