source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 521

Revision 521, 7.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Multimedia framework api
2Summary(ja): マルチメディアフレームワーク API
3Name: phonon
4Version: 4.3.80
5Release: 2%{?_dist_release}
6Group: System Environment/Libraries
7License: LGPLv2+
8URL: http://phonon.kde.org/
9Source0: ftp://ftp.kde.org/pub/kde/unstable/phonon/phonon-%{version}.tar.bz2
10
11Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
12Source11: hi16-phonon-gstreamer.png
13Source12: hi22-phonon-gstreamer.png
14Source13: hi32-phonon-gstreamer.png
15Source14: hi48-phonon-gstreamer.png
16Source15: hi64-phonon-gstreamer.png
17Source16: hi128-phonon-gstreamer.png
18
19# Prefer PulseAudio
20# This one was easiest to port, but doesn't seem to work by itself as-is
21# maybe we can just wait for the improvie PA support to land.
22Patch1:  phonon-4.3.50-xine_pulseaudio.patch
23
24## Mandriva/upstreamable patches
25Patch50: phonon-4.2.0-ogg-mime-type.patch
26Patch51: phonon-4.3.50-fix-decodebin-usage.patch
27Patch52: phonon-4.3.50-gstreamer-fix-seekable-query-failed.patch
28Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
29Patch54: phonon-4.3.80-fix-gstreamer-pulseaudio-deadlock.patch
30
31## Upstream patches
32# http://bugs.kde.org/223662
33Patch100: phonon-4.3.80-kde223662.patch
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36BuildRequires: automoc4 >= 0.9.86
37BuildRequires: cmake >= 2.6.0
38BuildRequires: glib2-devel
39BuildRequires: gstreamer-devel
40BuildRequires: gstreamer-plugins-base-devel
41BuildRequires: libxcb-devel
42BuildRequires: libxml2-devel
43BuildRequires: qt4-devel >= 4.4.0
44BuildRequires: xine-lib-devel
45BuildRequires: pulseaudio-libs-devel
46#BuildRequires: pulseaudio-libs-devel >= 0.9.21
47
48Requires: phonon-backend >= %{version}
49Requires: qt4 >= 4.6.0
50
51%description
52Phonon is a cross-platform portable Multimedia Support Abstraction,
53which allows you to play multiple audio or video formats with the same
54quality on all platforms, no matter which underlying architecture is
55used.
56
57%package backend-gstreamer
58Summary: Gstreamer phonon backend
59Group: System Environment/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: gstreamer-plugins-good
62Obsoletes: %{name}-backend-gst < 4.2.0-4
63Provides:  %{name}-backend-gst = %{version}-%{release}
64Provides: phonon-backend = %{version}-%{release}
65
66%description backend-gstreamer
67%{summary}.
68
69%package backend-xine
70Summary: xine phonon backend
71Group: System Environment/Libraries
72Requires: %{name} = %{version}-%{release}
73Provides: phonon-backend = %{version}-%{release}
74
75%description backend-xine
76%{summary}.
77
78%package devel
79Summary: Development files for phonon
80Group: Development/Libraries
81Requires: %{name} = %{version}-%{release}
82Requires: qt4-devel >= 4.6.0
83
84%description devel
85Header files for developing applications using phonon
86
87%prep
88%setup -q
89%patch1 -p1 -b .xine_pulseaudio
90
91%patch50 -p0 -b .ogg-mime-type
92%patch51 -p0 -b .fix-decodebin-usage
93%patch52 -p1 -b .gstreamer-fix-seekable-query-failed
94%patch53 -p1 -b .phonon-allow-stop-empty-source
95%patch54 -p1 -b .gstreamer-pulseaudio-deadlock
96%patch100 -p3 -b .kde223662
97
98%build
99%ifarch x86_64
100PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
101%endif
102
103mkdir -p %{_target_platform}
104pushd %{_target_platform}
105unset QTDIR || : ; . /etc/profile.d/qt4.sh
106%cmake \
107    -DUSE_INSTALL_PLUGIN=TRUE \
108    ..
109popd
110
111make %{?_smp_mflags} -C %{_target_platform}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
116
117# symlink for qt/phonon compatibility
118ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
119
120# move the oxygen-only phonon-xine icons to hicolor
121test -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor && exit 0
122mv $RPM_BUILD_ROOT%{_datadir}/icons/oxygen \
123   $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
124
125# gstreamer icons
126install -D -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
127install -D -m 0644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/phonon-gstreamer.png
128install -D -m 0644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/phonon-gstreamer.png
129install -D -m 0644 %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/phonon-gstreamer.png
130install -D -m 0644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/phonon-gstreamer.png
131install -D -m 0644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/phonon-gstreamer.png
132install -D -m 0644 %{SOURCE16} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/phonon-gstreamer.png
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post -p /sbin/ldconfig
138
139%postun -p /sbin/ldconfig
140
141%posttrans backend-gstreamer
142%gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
143
144%posttrans backend-xine
145gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
146
147%postun backend-gstreamer
148if [ $1 -eq 0 ] ; then
149  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
150fi
151
152%postun backend-xine
153if [ $1 -eq 0 ] ; then
154  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
155fi
156
157%files
158%defattr(-,root,root)
159%doc COPYING.LIB
160%{_libdir}/*.so.*
161%{_datadir}/dbus-1/interfaces/*
162# kde4-specific dirs
163%dir %{_libdir}/kde4/plugins/phonon_backend
164%dir %{_datadir}/kde4/services/phononbackends
165
166%files backend-gstreamer
167%defattr(-,root,root,-)
168%{_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
169%{_datadir}/kde4/services/phononbackends/gstreamer.desktop
170%{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
171
172%files backend-xine
173%defattr(-,root,root,-)
174%{_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
175%{_datadir}/kde4/services/phononbackends/xine.desktop
176%{_datadir}/icons/hicolor/*/apps/phonon-xine.*
177
178%files devel
179%defattr(-,root,root)
180%dir %{_includedir}/KDE
181%{_includedir}/KDE/Phonon/
182%{_includedir}/phonon/
183%{_libdir}/*.so
184%{_libdir}/pkgconfig/*.pc
185
186%changelog
187* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
188- added qmake path to PATH (if x86_64)
189
190* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
191- new upstream release
192- built with new toolchain
193
194* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
195- added Patch102 and 103 from FC
196  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
197  - fix for '#' in filenames
198  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
199  - restore patches to the xine backend
200
201* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
202- added Patch100 and 101 from FC
203  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
204  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
205- added backend sub-pakcages
206
207* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
208- new upstream release
209- add BuildPrereq: cmake
210
211* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
212- new upstream release
213
214* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
215- new upstream release
216- update %%files
217- add BuildPrereq: xine-lib-devel libxcb-devel
218
219* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
220- new upstream release
221
222* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
223- added script to append qmake path
224- added option -DLIB_INSTALL_DIR at cmake
225
226* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
227- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.