source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 5383

Revision 5383, 5.9 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

RevLine 
[5383]1%define qt4_ver 4.8.0
[2091]2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
[5383]5%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
[2091]6
[2611]7%global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
[574]8
[1850]9Name: phonon
[521]10Summary: Multimedia framework api
11Summary(ja): マルチメディアフレームワーク API
[5383]12Version: 4.6.0
[5199]13Release: 1%{?_dist_release}
[1850]14
[521]15Group: System Environment/Libraries
16License: LGPLv2+
17URL: http://phonon.kde.org/
18
[5383]19Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.6.0/src/phonon-%{version}.tar.xz
[1850]20
[2611]21Patch1: phonon-4.4.4-no_rpath.patch
[5383]22## upstreamable patches
23# phonon_backend ... could not be loaded
24# http://bugzilla.redhat.com/760039
25Patch50: phonon-4.5.57-plugindir.patch
[521]26
27## Upstream patches
28
[5037]29## Vine patches
30
[521]31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: automoc4 >= 0.9.86
[574]33BuildRequires: cmake >= 2.6.2
[521]34BuildRequires: glib2-devel
[4048]35BuildRequires: libqzeitgeist-devel
[521]36BuildRequires: libxcb-devel
37BuildRequires: libxml2-devel
[2611]38BuildRequires: qt4-devel >= 4.6.0
[5383]39BuildRequires: openssl-devel
[2611]40BuildRequires: pulseaudio-libs-devel >= 0.9.15
[521]41
[2611]42# TODO: enable the following Requires in next release
[4048]43Requires: phonon-backend >= 4.4
[2611]44Requires: pulseaudio-libs >= %{pulseaudio_version}
45Requires: qt4 >= %{_qt4_version}
[521]46
47%description
48Phonon is a cross-platform portable Multimedia Support Abstraction,
49which allows you to play multiple audio or video formats with the same
50quality on all platforms, no matter which underlying architecture is
51used.
52
53%package devel
54Summary: Development files for phonon
[2611]55Summary(ja): phonon の開発用ファイル
[521]56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
[5383]58Requires: qt4-devel >= %{_qt4_version}
[521]59
60%description devel
61Header files for developing applications using phonon
62
63%prep
[1850]64%setup -q
[521]65
[2611]66%patch1 -p1 -b .no_rpath
[5383]67%patch50 -p1 -b .plugindir
[521]68
69%build
70%ifarch x86_64
71PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
72%endif
73
74mkdir -p %{_target_platform}
75pushd %{_target_platform}
76%cmake \
[5383]77    -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
[521]78    ..
79popd
80
81make %{?_smp_mflags} -C %{_target_platform}
82
83%install
84rm -rf $RPM_BUILD_ROOT
[2611]85
[521]86make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
87
88# symlink for qt/phonon compatibility
89ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
90
[2611]91# own these dirs
92mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
93mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
[521]94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102%files
103%defattr(-,root,root)
104%doc COPYING.LIB
105%{_libdir}/*.so.*
[4048]106%{_qt4_plugindir}/designer/*.so
[521]107%{_datadir}/dbus-1/interfaces/*
108# kde4-specific dirs
109%dir %{_libdir}/kde4/plugins/phonon_backend
110%dir %{_datadir}/kde4/services/phononbackends
111
112%files devel
113%defattr(-,root,root)
114%dir %{_includedir}/KDE
115%{_includedir}/KDE/Phonon/
116%{_includedir}/phonon/
117%{_libdir}/*.so
[5383]118%dir %{_libdir}/cmake/
119%{_libdir}/cmake/phonon/
[521]120%{_libdir}/pkgconfig/*.pc
[5383]121%{_datadir}/phonon/buildsystem/
122%{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
[521]123
124%changelog
[5383]125* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
126- new upstream release
127
[5199]128* Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
129- new upstream release
130
[5037]131* Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
132- added Patch100 and 200 to build with pulseaudio-1.0
133
[4048]134* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
135- new upstream release
136- added BR: libqzeitgeist-devel
137
[2981]138* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
139- rebuilt with qt4-4.7.2
140
[2611]141* Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
142- new upstream release
143- rebuilt with qt4-4.7.1 on VineSeed
144
[2342]145* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
146- new upstream release
147
[2091]148* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
149- added sybolic link in %%{_qt4_headerdir}
150
[1850]151* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
152- new upstream release
153- dropt Patch51 and 57
154- rebuilt with rpm-4.8.1
155
[574]156* Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
157- new upstream release
158- dropt Patch1, 50, 54 and 100
159- added Patch57
160  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
161  - F11: patch/modularize pa device-manager bits
162
[521]163* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
164- added qmake path to PATH (if x86_64)
165
166* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
167- new upstream release
168- built with new toolchain
169
170* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
171- added Patch102 and 103 from FC
172  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
173  - fix for '#' in filenames
174  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
175  - restore patches to the xine backend
176
177* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
178- added Patch100 and 101 from FC
179  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
180  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
181- added backend sub-pakcages
182
183* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
184- new upstream release
185- add BuildPrereq: cmake
186
187* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
188- new upstream release
189
190* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
191- new upstream release
192- update %%files
193- add BuildPrereq: xine-lib-devel libxcb-devel
194
195* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
196- new upstream release
197
198* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
199- added script to append qmake path
200- added option -DLIB_INSTALL_DIR at cmake
201
202* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
203- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.