source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 8056

Revision 8056, 5.9 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.11.4
exiv2-0.24
wireshark-1.10.5, etc...

Line 
1%define qt4_ver 4.8.0
2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
5%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
6
7%global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
8
9Name: phonon
10Summary: Multimedia framework api
11Summary(ja): マルチメディアフレームワーク API
12Version: 4.7.1
13Release: 1%{?_dist_release}
14
15Group: System Environment/Libraries
16License: LGPLv2+
17URL: http://phonon.kde.org/
18
19Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.7.1/src/phonon-%{version}.tar.xz
20
21Patch1: phonon-4.7.1-no_rpath.patch
22
23## Upstream patches
24
25## Vine patches
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: automoc4 >= 0.9.86
29BuildRequires: cmake >= 2.6.2
30BuildRequires: glib2-devel
31BuildRequires: libqzeitgeist-devel
32BuildRequires: libxcb-devel
33BuildRequires: libxml2-devel
34BuildRequires: qt4-devel >= 4.6.0
35BuildRequires: openssl-devel
36BuildRequires: pulseaudio-libs-devel >= 0.9.15
37
38# TODO: enable the following Requires in next release
39Requires: phonon-backend >= 4.4
40Requires: pulseaudio-libs >= %{pulseaudio_version}
41Requires: qt4 >= %{_qt4_version}
42
43%description
44Phonon is a cross-platform portable Multimedia Support Abstraction,
45which allows you to play multiple audio or video formats with the same
46quality on all platforms, no matter which underlying architecture is
47used.
48
49%package devel
50Summary: Development files for phonon
51Summary(ja): phonon の開発用ファイル
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: qt4-devel >= %{_qt4_version}
55
56%description devel
57Header files for developing applications using phonon
58
59%prep
60%setup -q
61
62%patch1 -p1 -b .no_rpath
63
64%build
65%ifarch x86_64
66PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
67%endif
68
69mkdir -p %{_target_platform}
70pushd %{_target_platform}
71%cmake \
72    -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
73    ..
74popd
75
76make %{?_smp_mflags} -C %{_target_platform}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
82
83# symlink for qt/phonon compatibility
84ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
85
86# own these dirs
87mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
88mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(-,root,root)
99%doc COPYING.LIB
100%{_libdir}/*.so.*
101%{_qt4_plugindir}/designer/*.so
102%{_datadir}/dbus-1/interfaces/*
103# kde4-specific dirs
104%dir %{_libdir}/kde4/plugins/phonon_backend
105%dir %{_datadir}/kde4/services/phononbackends
106
107%files devel
108%defattr(-,root,root)
109%dir %{_includedir}/KDE
110%{_includedir}/KDE/Phonon/
111%{_includedir}/phonon/
112%{_libdir}/*.so
113%dir %{_libdir}/cmake/
114%{_libdir}/cmake/phonon/
115%{_libdir}/pkgconfig/*.pc
116%{_datadir}/phonon/buildsystem/
117%{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
118
119%changelog
120* Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.1-1
121- new upstream release
122- update Patch1
123- remove Patch50 (phonon-4.5.57-plugindir.patch)
124
125* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
126- new upstream release
127
128* Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
129- new upstream release
130
131* Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
132- added Patch100 and 200 to build with pulseaudio-1.0
133
134* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
135- new upstream release
136- added BR: libqzeitgeist-devel
137
138* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
139- rebuilt with qt4-4.7.2
140
141* Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
142- new upstream release
143- rebuilt with qt4-4.7.1 on VineSeed
144
145* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
146- new upstream release
147
148* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
149- added sybolic link in %%{_qt4_headerdir}
150
151* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
152- new upstream release
153- dropt Patch51 and 57
154- rebuilt with rpm-4.8.1
155
156* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
157- new upstream release
158- dropt Patch1, 50, 54 and 100
159- added Patch57
160  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
161  - F11: patch/modularize pa device-manager bits
162
163* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
164- added qmake path to PATH (if x86_64)
165
166* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
167- new upstream release
168- built with new toolchain
169
170* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
171- added Patch102 and 103 from FC
172  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
173  - fix for '#' in filenames
174  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
175  - restore patches to the xine backend
176
177* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
178- added Patch100 and 101 from FC
179  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
180  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
181- added backend sub-pakcages
182
183* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
184- new upstream release
185- add BuildPrereq: cmake
186
187* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
188- new upstream release
189
190* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
191- new upstream release
192- update %%files
193- add BuildPrereq: xine-lib-devel libxcb-devel
194
195* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
196- new upstream release
197
198* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
199- added script to append qmake path
200- added option -DLIB_INSTALL_DIR at cmake
201
202* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
203- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.