source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 10597

Revision 10597, 8.8 KB checked in by tomop, 8 years ago (diff)

phonon-4.9.0-1

RevLine 
[9067]1%define qt4_ver 4.8.6
[2091]2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
[9067]4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
[5383]5%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
[2091]6
[2611]7%global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
[574]8
[10597]9
10#define bootstrap 1
11
[1850]12Name: phonon
[521]13Summary: Multimedia framework api
14Summary(ja): マルチメディアフレームワーク API
[10597]15Version: 4.9.0
16Release: 1%{?_dist_release}
[1850]17
[521]18Group: System Environment/Libraries
19License: LGPLv2+
20URL: http://phonon.kde.org/
21
[10597]22Vendor: Project Vine
23Distribution: Vine Linux
[1850]24
[10597]25Provides: phonon-experimental = %{version}-%{release}
26%if 0%{?bootstrap}
27Provides: phonon-backend%{?_isa} = 4.7
28%else
29Requires: phonon-backend%{?_isa} => 4.7
30%endif
[521]31
[10597]32Source0: http://download.kde.org/stable/phonon/%{version}/phonon-%{version}.tar.xz
33
[521]34## Upstream patches
35
[10597]36## upstreamable patches
37Patch10: phonon-rpath_use_link_path.patch
38Patch11: phonon-DEFAULT_SOURCE.patch
39
[5037]40## Vine patches
41
[521]42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43BuildRequires: automoc4 >= 0.9.86
[574]44BuildRequires: cmake >= 2.6.2
[521]45BuildRequires: glib2-devel
[4048]46BuildRequires: libqzeitgeist-devel
[521]47BuildRequires: libxcb-devel
48BuildRequires: libxml2-devel
[2611]49BuildRequires: qt4-devel >= 4.6.0
[5383]50BuildRequires: openssl-devel
[2611]51BuildRequires: pulseaudio-libs-devel >= 0.9.15
[10597]52BuildRequires: extra-cmake-modules
53BuildRequires: pkgconfig(Qt5DBus) pkgconfig(Qt5Designer) pkgconfig(Qt5OpenGL) pkgconfig(Qt5Widgets)
54BuildRequires: pkgconfig(Qt5Declarative)
[521]55
[2611]56# TODO: enable the following Requires in next release
57Requires: pulseaudio-libs >= %{pulseaudio_version}
58Requires: qt4 >= %{_qt4_version}
[521]59
60%description
61Phonon is a cross-platform portable Multimedia Support Abstraction,
62which allows you to play multiple audio or video formats with the same
63quality on all platforms, no matter which underlying architecture is
64used.
65
66%package devel
67Summary: Development files for phonon
[2611]68Summary(ja): phonon の開発用ファイル
[521]69Group: Development/Libraries
[10597]70Provides: phonon-experimental-devel = %{version}-%{release}
[521]71Requires: %{name} = %{version}-%{release}
[5383]72Requires: qt4-devel >= %{_qt4_version}
[521]73
74%description devel
75Header files for developing applications using phonon
76
[10597]77%package qt5
78Summary: phonon for Qt5
79Summary(ja): Qt5用phonon
80%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
81%if 0%{?bootstrap}
82Provides: %{name}-qt5-backend%{?_isa} = 4.7
83%else
84Requires: %{name}-qt5-backend%{?_isa} => 4.7
85%endif
86%description qt5
87Phonon is a cross-platform portable Multimedia Support Abstraction,
88which allows you to play multiple audio or video formats with the same
89quality on all platforms, no matter which underlying architecture is
90used.
91
92%package qt5-devel
93Summary: Developer files for %{name}-qt5
94Summary(ja): %{name}-qt5の開発者向けファイル
95Requires: %{name}-qt5%{?_isa} = %{version}-%{release}
96%description qt5-devel
97Header files for developing applications using phonon-qt5
98
99
[521]100%prep
[1850]101%setup -q
[521]102
[10597]103%patch10 -p1 -b .10
104%patch11 -p1 -b .11
105
106
[521]107%build
108%ifarch x86_64
109PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
110%endif
111
112mkdir -p %{_target_platform}
113pushd %{_target_platform}
114%cmake \
[10597]115  -DCMAKE_BUILD_TYPE:STRING="Release" \
116  -DPHONON_INSTALL_QT_COMPAT_HEADERS:BOOL=ON \
117  -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
118  ..
[521]119popd
120
121make %{?_smp_mflags} -C %{_target_platform}
122
[10597]123mkdir -p %{_target_platform}-Qt5
124pushd %{_target_platform}-Qt5
125%cmake \
126  -DCMAKE_BUILD_TYPE:STRING="Release" \
127  -DPHONON_BUILD_PHONON4QT5:BOOL=ON \
128  -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
129  ..
130popd
131
132make %{?_smp_mflags} -C %{_target_platform}-Qt5
133
134
[521]135%install
136rm -rf $RPM_BUILD_ROOT
[2611]137
[521]138make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
[10597]139make install/fast DESTDIR=%{buildroot} -C %{_target_platform}-Qt5
[521]140
[2611]141# own these dirs
142mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
143mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
[10597]144mkdir -p %{buildroot}%{_qt5_plugindir}/phonon4qt5_backend
[521]145
[10597]146
147%check
148export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
149test "$(pkg-config --modversion phonon)" = "%{version}"
150test "$(pkg-config --modversion phonon4qt5)" = "%{version}"
151
152
[521]153%clean
154rm -rf $RPM_BUILD_ROOT
155
[10597]156%post
157/sbin/ldconfig
[521]158
[10597]159%postun
160/sbin/ldconfig
[521]161
[10597]162# https://bugzilla.redhat.com/show_bug.cgi?id=1223956
163# replacing symlink with a dir
164%pretrans devel -p <lua>
165path = "%{_includedir}/phonon/Phonon"
166st = posix.stat(path)
167if st and st.type == "link" then
168  os.remove(path)
169end
170
171
[521]172%files
173%defattr(-,root,root)
[10597]174%license COPYING.LIB
175%{_libdir}/libphonon.so.4*
176%{_libdir}/libphononexperimental.so.4*
[4048]177%{_qt4_plugindir}/designer/*.so
[521]178# kde4-specific dirs
179%dir %{_libdir}/kde4/plugins/phonon_backend
180%dir %{_datadir}/kde4/services/phononbackends
[10597]181%dir %{_datadir}/phonon/
[521]182
183%files devel
184%defattr(-,root,root)
185%dir %{_includedir}/KDE
186%{_includedir}/KDE/Phonon/
187%{_includedir}/phonon/
[10597]188%{_libdir}/libphonon.so
189%{_libdir}/libphononexperimental.so
[5383]190%dir %{_libdir}/cmake/
191%{_libdir}/cmake/phonon/
[10597]192%{_libdir}/pkgconfig/phonon.pc
[5383]193%{_datadir}/phonon/buildsystem/
194%{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
[10597]195%{_datadir}/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
[521]196
[10597]197%files qt5
198%license COPYING.LIB
199%dir %{_datadir}/phonon4qt5
200%{_libdir}/libphonon4qt5.so.4*
201%{_libdir}/libphonon4qt5experimental.so.4*
202%{_qt5_plugindir}/designer/phononwidgets.so
203%dir %{_qt5_plugindir}/phonon4qt5_backend/
204
205%files qt5-devel
206%{_datadir}/dbus-1/interfaces/org.kde.Phonon4Qt5.AudioOutput.xml
207%{_datadir}/phonon4qt5/buildsystem/
208%dir %{_libdir}/cmake/
209%{_libdir}/cmake/phonon4qt5/
210%{_includedir}/phonon4qt5/
211%{_libdir}/libphonon4qt5.so
212%{_libdir}/libphonon4qt5experimental.so
213%{_libdir}/pkgconfig/phonon4qt5.pc
214%{_qt5_archdatadir}/mkspecs/modules/qt_phonon4qt5.pri
215
216
[521]217%changelog
[10456]218* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.2-2
219- rebuilt with new toolchain.
220
[9067]221* Fri Nov  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.8.2-1
222- new upstream release
223
[8056]224* Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.1-1
225- new upstream release
226- update Patch1
227- remove Patch50 (phonon-4.5.57-plugindir.patch)
228
[5383]229* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
230- new upstream release
231
[5199]232* Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
233- new upstream release
234
[5037]235* Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
236- added Patch100 and 200 to build with pulseaudio-1.0
237
[4048]238* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
239- new upstream release
240- added BR: libqzeitgeist-devel
241
[2981]242* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
243- rebuilt with qt4-4.7.2
244
[2611]245* Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
246- new upstream release
247- rebuilt with qt4-4.7.1 on VineSeed
248
[2342]249* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
250- new upstream release
251
[2091]252* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
253- added sybolic link in %%{_qt4_headerdir}
254
[1850]255* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
256- new upstream release
257- dropt Patch51 and 57
258- rebuilt with rpm-4.8.1
259
[8056]260* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
[574]261- new upstream release
262- dropt Patch1, 50, 54 and 100
263- added Patch57
264  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
265  - F11: patch/modularize pa device-manager bits
266
[521]267* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
268- added qmake path to PATH (if x86_64)
269
270* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
271- new upstream release
272- built with new toolchain
273
274* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
275- added Patch102 and 103 from FC
276  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
277  - fix for '#' in filenames
278  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
279  - restore patches to the xine backend
280
281* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
282- added Patch100 and 101 from FC
283  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
284  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
285- added backend sub-pakcages
286
287* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
288- new upstream release
289- add BuildPrereq: cmake
290
291* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
292- new upstream release
293
294* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
295- new upstream release
296- update %%files
297- add BuildPrereq: xine-lib-devel libxcb-devel
298
299* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
300- new upstream release
301
302* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
303- added script to append qmake path
304- added option -DLIB_INSTALL_DIR at cmake
305
306* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
307- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.