source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 10456

Revision 10456, 6.0 KB checked in by tomop, 8 years ago (diff)

phonon-4.8.2-2

Line 
1%define qt4_ver 4.8.6
2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
5%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
6
7%global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
8
9Name: phonon
10Summary: Multimedia framework api
11Summary(ja): マルチメディアフレームワーク API
12Version: 4.8.2
13Release: 2%{?_dist_release}
14
15Group: System Environment/Libraries
16License: LGPLv2+
17URL: http://phonon.kde.org/
18
19Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.7.1/src/phonon-%{version}.tar.xz
20
21Patch1: phonon-4.7.1-no_rpath.patch
22
23## Upstream patches
24
25## Vine patches
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: automoc4 >= 0.9.86
29BuildRequires: cmake >= 2.6.2
30BuildRequires: glib2-devel
31BuildRequires: libqzeitgeist-devel
32BuildRequires: libxcb-devel
33BuildRequires: libxml2-devel
34BuildRequires: qt4-devel >= 4.6.0
35BuildRequires: openssl-devel
36BuildRequires: pulseaudio-libs-devel >= 0.9.15
37
38# TODO: enable the following Requires in next release
39Requires: phonon-backend >= 4.4
40Requires: pulseaudio-libs >= %{pulseaudio_version}
41Requires: qt4 >= %{_qt4_version}
42
43%description
44Phonon is a cross-platform portable Multimedia Support Abstraction,
45which allows you to play multiple audio or video formats with the same
46quality on all platforms, no matter which underlying architecture is
47used.
48
49%package devel
50Summary: Development files for phonon
51Summary(ja): phonon の開発用ファイル
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: qt4-devel >= %{_qt4_version}
55
56%description devel
57Header files for developing applications using phonon
58
59%prep
60%setup -q
61%patch1 -p1 -b .no_rpath
62
63%build
64%ifarch x86_64
65PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
66%endif
67
68mkdir -p %{_target_platform}
69pushd %{_target_platform}
70%cmake \
71    -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
72    ..
73popd
74
75make %{?_smp_mflags} -C %{_target_platform}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
81
82# symlink for qt/phonon compatibility
83ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
84
85# own these dirs
86mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
87mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root)
98%doc COPYING.LIB
99%{_libdir}/*.so.*
100%{_qt4_plugindir}/designer/*.so
101%{_datadir}/dbus-1/interfaces/*
102# kde4-specific dirs
103%dir %{_libdir}/kde4/plugins/phonon_backend
104%dir %{_datadir}/kde4/services/phononbackends
105
106%files devel
107%defattr(-,root,root)
108%dir %{_includedir}/KDE
109%{_includedir}/KDE/Phonon/
110%{_includedir}/phonon/
111%{_libdir}/*.so
112%dir %{_libdir}/cmake/
113%{_libdir}/cmake/phonon/
114%{_libdir}/pkgconfig/*.pc
115%{_datadir}/phonon/buildsystem/
116%{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
117
118%changelog
119* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.2-2
120- rebuilt with new toolchain.
121
122* Fri Nov  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.8.2-1
123- new upstream release
124
125* Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.1-1
126- new upstream release
127- update Patch1
128- remove Patch50 (phonon-4.5.57-plugindir.patch)
129
130* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
131- new upstream release
132
133* Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
134- new upstream release
135
136* Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
137- added Patch100 and 200 to build with pulseaudio-1.0
138
139* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
140- new upstream release
141- added BR: libqzeitgeist-devel
142
143* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
144- rebuilt with qt4-4.7.2
145
146* Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
147- new upstream release
148- rebuilt with qt4-4.7.1 on VineSeed
149
150* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
151- new upstream release
152
153* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
154- added sybolic link in %%{_qt4_headerdir}
155
156* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
157- new upstream release
158- dropt Patch51 and 57
159- rebuilt with rpm-4.8.1
160
161* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
162- new upstream release
163- dropt Patch1, 50, 54 and 100
164- added Patch57
165  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
166  - F11: patch/modularize pa device-manager bits
167
168* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
169- added qmake path to PATH (if x86_64)
170
171* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
172- new upstream release
173- built with new toolchain
174
175* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
176- added Patch102 and 103 from FC
177  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
178  - fix for '#' in filenames
179  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
180  - restore patches to the xine backend
181
182* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
183- added Patch100 and 101 from FC
184  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
185  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
186- added backend sub-pakcages
187
188* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
189- new upstream release
190- add BuildPrereq: cmake
191
192* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
193- new upstream release
194
195* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
196- new upstream release
197- update %%files
198- add BuildPrereq: xine-lib-devel libxcb-devel
199
200* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
201- new upstream release
202
203* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
204- added script to append qmake path
205- added option -DLIB_INSTALL_DIR at cmake
206
207* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
208- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.