source: projects/specs/trunk/p/pessulus/pessulus-vl.spec @ 8119

Revision 8119, 5.4 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define basever 2.30
3
4Name:           pessulus
5Version:        %{basever}.4
6Release:        3%{?_dist_release}
7Summary:        A lockdown editor for GNOME
8
9Group:          Applications/System
10License:        GPLv2+
11URL:            http://live.gnome.org/Pessulus
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{basever}/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14BuildArch:      noarch
15
16BuildRequires:  gtk2-devel
17BuildRequires:  pygtk2-devel
18BuildRequires:  gnome-python-devel
19BuildRequires:  GConf2-devel
20BuildRequires:  gnome-python-desktop
21BuildRequires:  perl-XML-Parser
22#BuildRequires:  pkgconfig
23BuildRequires:  gettext-devel
24BuildRequires:  intltool >= 0.35.0
25BuildRequires:  desktop-file-utils
26Requires:  gnome-python-desktop
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Pessulus is a lockdown editor for GNOME, written in python. Pessulus
33enables administrators to set mandatory settings in GConf. The
34users can not change these settings.
35Use of pessulus can be useful on computers that are open to use by
36everyone, e.g. in an internet cafe.
37
38%prep
39%setup -q
40
41
42%build
43%configure
44make %{?_smp_mflags}
45
46
47%install
48rm -rf $RPM_BUILD_ROOT
49make install DESTDIR=$RPM_BUILD_ROOT
50chmod +x $RPM_BUILD_ROOT%{python_sitelib}/Pessulus/*.py
51
52desktop-file-install --vendor="" --delete-original --remove-category="System" \
53  --dir $RPM_BUILD_ROOT%{_datadir}/applications        \
54  $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
55
56%find_lang %{name}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62touch --no-create %{_datadir}/icons/hicolor
63if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
64  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
65fi
66
67%postun
68touch --no-create %{_datadir}/icons/hicolor
69if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
70  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
71fi
72
73%files -f %{name}.lang
74%defattr(-,root,root,-)
75%doc README AUTHORS COPYING ChangeLog
76%{_bindir}/%{name}
77%{python_sitelib}/Pessulus/
78%{_datadir}/applications/*.desktop
79%{_datadir}/%{name}
80%{_datadir}/icons/hicolor/*/apps/pessulus.*
81
82%changelog
83* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-3
84- rebuild with VineSeed environment
85
86* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-2
87- rebuild with python-2.7.2
88
89* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
90- new upstream release
91
92* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
93- Initial build for Vine Linux
94
95
96* Tue Apr 06 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-2
97- remove gnome-python2-buddy dependency (#579612)
98
99* Tue Mar 23 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-1
100- Updated to 2.30.0
101- more translations
102
103* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.29.91-1
104- Updated to 2.29.91
105
106* Fri Sep 25 2009 Haïkel Guémar <karlthered@gmail.com> - 2.28.0-1
107- Updated to 2.28.0
108
109* Mon Sep 14 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.92-1
110- Updated to 2.27.92
111
112* Wed Jul 29 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.5-1
113- Updated to 2.24.0
114- Remove now unneeded pythondir patch (GNOME #549728 fixed upstream)
115
116* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-5
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
118
119* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-4
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
121
122* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.23.1-3
123- Rebuild for Python 2.6
124
125* Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-2
126- fix missing BR, Requires
127
128* Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-1
129- fix license tag
130- update to 2.23.1
131- install into pythondir (not pyexecdir)
132
133* Mon Apr 16 2007 Damien Durand <splinux@fedoraproject.org> - 2.16.2-2
134- Fix desktop-file
135
136* Fri Dec 22 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.2-1
137- Upgrade to 2.16.2
138- Add gnome-python2-devel in BR
139
140* Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.1-1
141- Upgrade to 2.16.1
142- Fixe #195819
143
144* Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16-4
145- Bump release
146
147* Wed Sep 06 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.0-1
148- Upgrade to 2.16 release
149- Add gnome-python2-gconf in Requires
150
151* Tue Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-2
152- Bump release
153
154* Tue Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-1
155- Upgraded to 2.15.91
156
157* Fri Jul 28 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.90-1
158- Fix URL
159- Upgrad to 2.15.90
160
161* Tue Jul 11 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.4-1
162- upgrad to 0.10.4
163
164* Tue Jul 04 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-3
165- fix debuginfo packages
166
167* Thu Jun 15 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-2
168- fix BuildRequires
169
170* Wed May 3 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-1
171- upgrade version to 0.10.1
172
173* Fri Apr 7 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 0.9-2
174- fix BR
175- remove unnecessary Requires
176- use version-release in changelog entries
177- fix directory ownership
178- use python_sitearch
179- make python "scripts" executable
180
181* Thu Apr 6 2006 Damien Durand <splinux@fedoraproject.org> - 0.9-1
182- Initial package
Note: See TracBrowser for help on using the repository browser.