source: projects/specs/trunk/p/pessulus/pessulus-vl.spec @ 5701

Revision 5701, 5.3 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define basever 2.30
3
4Name:           pessulus
5Version:        %{basever}.4
6Release:        2%{?_dist_release}
7Summary:        A lockdown editor for GNOME
8
9Group:          Applications/System
10License:        GPLv2+
11URL:            http://live.gnome.org/Pessulus
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{basever}/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14BuildArch:      noarch
15
16BuildRequires:  gtk2-devel
17BuildRequires:  pygtk2-devel
18BuildRequires:  gnome-python-devel
19BuildRequires:  GConf2-devel
20BuildRequires:  gnome-python-desktop
21BuildRequires:  perl-XML-Parser
22#BuildRequires:  pkgconfig
23BuildRequires:  gettext-devel
24BuildRequires:  intltool >= 0.35.0
25BuildRequires:  desktop-file-utils
26Requires:  gnome-python-desktop
27
28%description
29Pessulus is a lockdown editor for GNOME, written in python. Pessulus
30enables administrators to set mandatory settings in GConf. The
31users can not change these settings.
32Use of pessulus can be useful on computers that are open to use by
33everyone, e.g. in an internet cafe.
34
35%prep
36%setup -q
37
38
39%build
40%configure
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46make install DESTDIR=$RPM_BUILD_ROOT
47chmod +x $RPM_BUILD_ROOT%{python_sitelib}/Pessulus/*.py
48
49desktop-file-install --vendor="" --delete-original --remove-category="System" \
50  --dir $RPM_BUILD_ROOT%{_datadir}/applications        \
51  $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
52
53%find_lang %{name}
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%post
59touch --no-create %{_datadir}/icons/hicolor
60if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
61  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
62fi
63
64%postun
65touch --no-create %{_datadir}/icons/hicolor
66if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
67  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
68fi
69
70%files -f %{name}.lang
71%defattr(-,root,root,-)
72%doc README AUTHORS COPYING ChangeLog
73%{_bindir}/%{name}
74%{python_sitelib}/Pessulus/
75%{_datadir}/applications/*.desktop
76%{_datadir}/%{name}
77%{_datadir}/icons/hicolor/*/apps/pessulus.*
78
79%changelog
80* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-2
81- rebuild with python-2.7.2
82
83* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
84- new upstream release
85
86* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
87- Initial build for Vine Linux
88
89
90* Tue Apr 06 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-2
91- remove gnome-python2-buddy dependency (#579612)
92
93* Wed Mar 23 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-1
94- Updated to 2.30.0
95- more translations
96
97* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.29.91-1
98- Updated to 2.29.91
99
100* Sun Sep 25 2009 Haïkel Guémar <karlthered@gmail.com> - 2.28.0-1
101- Updated to 2.28.0
102
103* Mon Sep 14 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.92-1
104- Updated to 2.27.92
105
106* Wed Jul 29 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.5-1
107- Updated to 2.24.0
108- Remove now unneeded pythondir patch (GNOME #549728 fixed upstream)
109
110* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-5
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
112
113* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-4
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.23.1-3
117- Rebuild for Python 2.6
118
119* Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-2
120- fix missing BR, Requires
121
122* Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-1
123- fix license tag
124- update to 2.23.1
125- install into pythondir (not pyexecdir)
126
127* Mon Apr 16 2007 Damien Durand <splinux@fedoraproject.org> - 2.16.2-2
128- Fix desktop-file
129
130* Fri Dec 22 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.2-1
131- Upgrade to 2.16.2
132- Add gnome-python2-devel in BR
133
134* Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.1-1
135- Upgrade to 2.16.1
136- Fixe #195819
137
138* Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16-4
139- Bump release
140
141* Wed Sep 06 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.0-1
142- Upgrade to 2.16 release
143- Add gnome-python2-gconf in Requires
144
145* Fri Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-2
146- Bump release
147
148* Fri Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-1
149- Upgraded to 2.15.91
150
151* Fri Jul 28 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.90-1
152- Fix URL
153- Upgrad to 2.15.90
154
155* Tue Jul 11 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.4-1
156- upgrad to 0.10.4
157
158* Tue Jul 04 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-3
159- fix debuginfo packages
160
161* Thu Jun 15 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-2
162- fix BuildRequires
163
164* Wed May 3 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-1
165- upgrade version to 0.10.1
166
167* Fri Apr 7 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 0.9-2
168- fix BR
169- remove unnecessary Requires
170- use version-release in changelog entries
171- fix directory ownership
172- use python_sitearch
173- make python "scripts" executable
174
175* Thu Apr 6 2006 Damien Durand <splinux@fedoraproject.org> - 0.9-1
176- Initial package
Note: See TracBrowser for help on using the repository browser.