source: projects/specs/trunk/p/perl-XML-SAX/perl-XML-SAX-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: SAX(Simple API for XML) for Perl
2Name: perl-XML-SAX
3Version: 0.16
4Release: 2%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7Source0: http://www.cpan.org/authors/id/M/MS/MSERGEANT/XML-SAX-%{version}.tar.gz
8Source1: filter-requires-XML-SAX.sh
9Source2: filter-provides-XML-SAX.sh
10
11URL: http://search.cpan.org/search?dist=XML-SAX
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl >= 5.8.2
15BuildRequires: perl-XML-NamespaceSupport
16Requires: perl >= 5.8.2
17Requires: perl-XML-NamespaceSupport
18Requires(post): perl-XML-LibXML
19Requires(preun): perl-XML-LibXML
20
21# Filter unwanted Requires: perl-XML-SAX has some poorly-structured
22#                           packages that confuse RPM.
23%define __find_requires %{SOURCE1}
24
25# Filter unwanted Provides: perl-XML-SAX should not Provide an
26#                           unversioned perl(XML::SAX) along with the
27#                           versioned one
28%define __find_provides %{SOURCE2}
29
30
31%description
32XML::SAX consists of several framework classes for using and building
33Perl SAX2 XML parsers, filters, and drivers. It is designed around the
34need to be able to "plug in" different SAX parsers to an application
35without requiring programmer intervention. Those of you familiar with
36the DBI will be right at home. Some of the designs come from the Java
37JAXP specification (SAX part), only without the javaness.
38
39%prep
40%setup -q -n XML-SAX-%{version}
41
42%build
43%{__perl} Makefile.PL INSTALLDIRS=vendor <<_OPTION_
44N
45_OPTION_
46make OPTIMIZE="$RPM_OPT_FLAGS"
47
48%check
49make test
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%install
55rm -rf $RPM_BUILD_ROOT
56make pure_install DESTDIR=$RPM_BUILD_ROOT
57find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
58find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
59chmod -R u+w $RPM_BUILD_ROOT/*
60
61touch $RPM_BUILD_ROOT%{perl_vendorlib}/XML/SAX/ParserDetails.ini
62
63[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
64
65#find $RPM_BUILD_ROOT%{_prefix} -type f -print |
66#       sed "s@^$RPM_BUILD_ROOT@@g" |
67#       grep -v ^%{_mandir} |
68#       grep -v perllocal.pod |
69#       grep -v "\.packlist" > %{name}.files
70#if [ "$(cat %{name}.files)X" = "X" ] ; then
71#    echo "ERROR: EMPTY FILE LIST"
72#    exit -1
73#fi
74
75%post
76perl -MXML::SAX -e \
77  'XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()' 2>/dev/null
78
79%preun
80if [ $1 -eq 0 ]; then
81  perl -MXML::SAX -e \
82    'XML::SAX->remove_parser(q(XML::SAX::PurePerl))->save_parsers()'
83fi
84
85%files
86%defattr(-,root,root)
87%doc README Changes LICENSE
88%dir %{perl_vendorlib}/XML
89%{perl_vendorlib}/XML/SAX.pm
90%dir %{perl_vendorlib}/XML/SAX
91%{perl_vendorlib}/XML/SAX/*.pm
92%{perl_vendorlib}/XML/SAX/*.pod
93%{perl_vendorlib}/XML/SAX/PurePerl
94%{_mandir}/man3/*3pm*
95%ghost %{perl_vendorlib}/XML/SAX/ParserDetails.ini
96%exclude %{perl_vendorlib}/XML/SAX/placeholder.pl
97
98%changelog
99* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-2
100- added Requires(post,preun): perl-XML-LibXML
101
102* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-1
103- new upstream release
104- built with perl-5.10.0-2
105- added SOURCE1, 2 for avoiding unwanted dependancies
106
107* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 0.12-0vl2
108- build on perl-5.8.6-0vl1
109
110* Sun Oct 17 2004 Satoshi MACHINO <machino@vinelinux.org> 0.12-0vl1
111- new upstream version
112- updated patch0 to perl-XML-SAX-0.12-makefile.patch
113
114* Mon Apr 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.10-0vl1
115- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.