source: projects/specs/trunk/p/perl-XML-SAX/perl-XML-SAX-vl.spec @ 12120

Revision 12120, 9.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Summary:        XML-SAX Perl module
2Name:           perl-XML-SAX
3Version:        1.00
4Release:        1%{?_dist_release}
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/XML-SAX/
9Source0:        http://www.cpan.org/authors/id/G/GR/GRANTM/XML-SAX-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12Vendor:        Project Vine
13Distribution:  Vine Linux
14
15BuildArch:      noarch
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(XML::NamespaceSupport)
18# The following creates circular dependency, but they are not needed for build.
19#BuildRequires:  perl(XML::LibXML) perl(XML::LibXML::Common)
20# XML::SAX::Base became independent package, BR just for test
21BuildRequires:  perl(XML::SAX::Base)
22
23Requires:       perl(:MODULE_COMPAT_%(perl -MConfig -e 'print $Config{version}'))
24#Requires:       perl(XML::LibXML) perl(XML::LibXML::Common)
25
26%description
27XML::SAX consists of several framework classes for using and building
28Perl SAX2 XML parsers, filters, and drivers. It is designed around the
29need to be able to "plug in" different SAX parsers to an application
30without requiring programmer intervention. Those of you familiar with
31the DBI will be right at home. Some of the designs come from the Java
32JAXP specification (SAX part), only without the javaness.
33
34
35%prep
36%setup -q -n XML-SAX-%{version}
37
38%if %{_dist_release} > "vl6"
39%{?perl_default_filter:
40%filter_from_provides /^perl(XML::SAX::PurePerl)$/d
41%filter_from_requires /^perl(XML::SAX::PurePerl::\(DTDDecls\|DocType\|EncodingDetect\|XMLDecl\|NoUnicodeExt\|UnicodeExt\|Reader::NoUnicodeExt\))/d
42%perl_default_filter}
43%global __provides_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(XML::SAX::PurePerl\\)
44%global __requires_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(XML::SAX::PurePerl::(DTDDecls|DocType|EncodingDetect|XMLDecl|NoUnicodeExt|UnicodeExt|Reader::NoUnicodeExt)\\)
45
46%{?perl_default_subpackage_tests}
47
48%else
49cat << \EOF > %{name}-prov
50#!/bin/sh
51%{__perl_provides} $* |\
52sed -e '/perl(XML::SAX::PurePerl)/d'
53EOF
54
55%global __perl_provides %{_builddir}/XML-SAX-%{version}/%{name}-prov
56chmod +x %{__perl_provides}
57
58cat << \EOF > %{name}-req
59#!/bin/sh
60%{__perl_requires} $* |\
61sed -e '/perl(XML::SAX::PurePerl::\(DTDDecls\|DocType\|EncodingDetect\|XMLDecl\|NoUnicodeExt\|UnicodeExt\|Reader::NoUnicodeExt\))/d'
62EOF
63
64%global __perl_requires %{_builddir}/XML-SAX-%{version}/%{name}-req
65chmod +x %{__perl_requires}
66%endif
67
68
69%build
70echo N | %{__perl} Makefile.PL INSTALLDIRS=vendor
71make %{?_smp_mflags}
72
73%install
74rm -rf %{buildroot}
75make pure_install PERL_INSTALL_ROOT=%{buildroot}
76find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
77find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
78chmod -R u+w %{buildroot}/*
79
80touch %{buildroot}%{perl_vendorlib}/XML/SAX/ParserDetails.ini
81
82%check
83make test
84
85%clean
86rm -rf %{buildroot}
87
88
89%post
90if [ ! -f "%{perl_vendorlib}/XML/SAX/ParserDetails.ini" ] ; then
91  perl -MXML::SAX -e \
92    'XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()' 2>/dev/null || :
93else
94  cp -p "%{perl_vendorlib}/XML/SAX/ParserDetails.ini" "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup"
95fi
96
97%triggerun -- perl-XML-LibXML < 1.58-8
98if [ -f "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" ] ; then
99  mv "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" "%{perl_vendorlib}/XML/SAX/ParserDetails.ini"
100fi
101
102%preun
103# create backup of ParserDetails.ini, therefore user's configuration is used
104if [ $1 -eq 0 ] ; then
105  perl -MXML::SAX -e \
106    'XML::SAX->remove_parser(q(XML::SAX::PurePerl))->save_parsers()' || :
107fi
108[ -f "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" ] && \
109rm -rf "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" || :
110
111%files
112%license LICENSE
113%doc Changes README
114%dir %{perl_vendorlib}/XML
115%{perl_vendorlib}/XML/SAX.pm
116%dir %{perl_vendorlib}/XML/SAX
117%{perl_vendorlib}/XML/SAX/*.pm
118%{perl_vendorlib}/XML/SAX/*.pod
119%{perl_vendorlib}/XML/SAX/PurePerl
120%{_mandir}/man3/XML::*.3pm*
121%ghost %{perl_vendorlib}/XML/SAX/ParserDetails.ini
122
123
124%changelog
125* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.00-1
126- new upstream release.
127- rebuilt with perl-5.26.
128
129* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.99-3
130- rebuilt with perl-5.16.0.
131
132* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-2
133- rebuild
134
135* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-1
136- updated to 0.99
137- revamped spec in accordance with Fedora's 0.99-2
138- previous Vine changelogs as follows:
139
140  - Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16-3
141  - drebuild with perl-5.12.3
142  - using __perl_requires macro for VineSeed (vl6)
143 
144  - Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-2
145  - added Requires(post,preun): perl-XML-LibXML
146 
147  - Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-1
148  - new upstream release
149  - built with perl-5.10.0-2
150  - added SOURCE1, 2 for avoiding unwanted dependancies
151 
152  - Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 0.12-0vl2
153  - build on perl-5.8.6-0vl1
154 
155  - Sun Oct 17 2004 Satoshi MACHINO <machino@vinelinux.org> 0.12-0vl1
156  - new upstream version
157  - updated patch0 to perl-XML-SAX-0.12-makefile.patch
158 
159  - Mon Apr 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.10-0vl1
160  - first build for Vine Linux
161
162* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99-2
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
164
165* Fri Oct 07 2011 Marcela Mašláňová <mmaslano@redhat.com> 0.99-1
166- update to 0.99
167
168* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.96-15
169- Perl mass rebuild
170
171* Fri Jun 24 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-14
172- fix macros to work with new macros
173- clean spec
174
175* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-13
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
177
178* Mon Jan 24 2011 Adrian Reber <adrian@lisas.de> - 0.96-12
179- rebuild for ppc
180
181* Thu Dec 23 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.96-11
182- 661697 rebuild for fixing problems with vendorach/lib
183
184* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.96-10
185- Mass rebuild with perl-5.12.0
186
187* Fri Feb  5 2010 Stepan Kasal <skasal@redhat.com> - 0.96-9
188- anchor the filtering regexps
189
190* Fri Feb  5 2010 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-8
191- XML-LibXML use triggers for XML::SAX update. Deleting of settings in
192 ParserDetails.ini is solved by post and preun part, which create backup.
193
194* Thu Nov 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-7
195- instead of path into post used perl_vendorlib macro
196- rebuilt will be needed for perl-5.10.1
197
198* Thu Nov 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-6
199- post scriptlet needs to check whether the file is installed. When it isn't,
200 then it's needed call for adding PurePerl parser
201 http://perl-xml.sourceforge.net/faq/#parserdetails.ini
202
203* Mon Oct 19 2009 Stepan Kasal <skasal@redhat.com> - 0.96-5
204- use the filtering macros
205
206* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-4
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
208
209* Tue Apr 28 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-3
210- 478905 fix scriptlets
211
212* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-2
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
214
215* Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-1
216- update to 0.96, big leap in versioning
217
218* Sun Mar  2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-5
219- Re-enable XML::LibXML BuildRequires
220
221* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-4
222- Rebuild for perl 5.10 (again)
223
224* Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-3.1
225- temporarily disable BR against perl-XML-LibXML
226
227* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-3
228- rebuild for new perl
229
230* Sat Jul 07 2007 Robin Norwood <rnorwood@redhat.com> - 0.16-2
231- Resolves: rhbz#247213
232- Fix provides and requires scripts.
233
234* Mon Jul 02 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.16-1
235- Update to 0.16.
236- Brings specfile closer to Fedora Perl template.
237- Corrects Source0 URL (upstream maintainer has changed).
238- Move Requires filter into spec, and add Provides filter.
239
240* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.15-1
241- New version: 0.15
242
243* Fri Jun 09 2006 Jason Vas Dias <jvdias@redhat.com> - 0.14-2
244- fix bug 194706: fails to build under (new!) mock
245
246* Mon Jun 05 2006 Jason Vas Dias <jvdias@redhat.com> - 0.14-1
247- upgrade to 0.14
248
249* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.13-1.1
250- rebuild for new perl-5.8.8
251
252* Mon Dec 19 2005 Jason Vas Dias <jvdias@redhat.com> - 0.13-1
253- upgrade to 0.13
254
255* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
256- rebuilt for new gcc
257
258* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
259- rebuilt for new gcj
260
261* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0.12-7
262- #121167
263- Handle ParserDetails.ini parser registration.
264- Require perl(:MODULE_COMPAT_*).
265- Own installed directories.
266
267* Wed Oct 22 2003 Chip Turner <cturner@redhat.com> - 0.12-1
268- Specfile autogenerated.
269
Note: See TracBrowser for help on using the repository browser.