source: projects/specs/trunk/p/perl-XML-LibXML/perl-XML-LibXML-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Perl interface to the libxml2 library
2Name: perl-XML-LibXML
3Version: 1.66
4Release: 1%{?_dist_release}
5License: GPL or Artistic
6Group: Development/Libraries
7URL: http://search.cpan.org/dist/XML-LibXML/
8Source0: XML-LibXML-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: perl >= 2:5.8.0
12BuildRequires: perl-XML-LibXML-Common
13BuildRequires: perl-XML-NamespaceSupport
14BuildRequires: perl-XML-SAX
15BuildRequires: libxml2-devel
16Requires: perl >= %(perl -MConfig -e 'print $Config{version}')
17
18%description
19This module implements a Perl interface to the GNOME libxml2 library
20which provides interfaces for parsing and manipulating XML files. This
21module allows Perl programmers to make use of the highly capable
22validating XML parser and the high performance DOM implementation.
23
24%prep
25%setup -q -n XML-LibXML-%{version}
26
27%build
28CFLAGS="$RPM_OPT_FLAGS" SKIP_SAX_INSTALL=1 perl Makefile.PL INSTALLDIRS=vendor
29make OPTIMIZE="$RPM_OPT_FLAGS"
30
31%install
32rm -rf $RPM_BUILD_ROOT
33make install \
34  PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
35  INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
36find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
37  -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
38find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
39chmod -R u+w $RPM_BUILD_ROOT/*
40
41for i in Changes; do
42  /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && /bin/mv -f $i.conv $i
43done
44
45%check || :
46make test
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%triggerin -- perl-XML-SAX
52for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
53  perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" || :
54done
55
56%preun
57if [ $1 -eq 0 ] ; then
58  for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
59    perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
60      2>/dev/null || :
61  done
62fi
63
64%files
65%defattr(-,root,root,-)
66%doc Changes LICENSE README
67%{perl_vendorarch}/auto/XML
68%{perl_vendorarch}/XML
69%{_mandir}/man3/*.3*
70
71%changelog
72* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
73- new upsteream release
74- built with perl-5.10.0-2
75- changed Group to Development/Libraries
76
77* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
78- changed Group to Development/Languages
79- rebuilt with libxml2-2.6.26
80
81* Sun Apr  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
82- rebuilt for Vine Linux
83
84* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
85- bump again for double-long bug on ppc(64)
86
87* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
88- rebuilt for new gcc4.1 snapshot and glibc changes
89
90* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
91- rebuild for new perl-5.8.8
92
93* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
94- rebuilt for new gcc
95
96* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
97- rebuilt for new gcj
98
99* Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
100- rebuild
101
102* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
103- #121168
104- Update to 1.58.
105- Require perl(:MODULE_COMPAT_*).
106- Handle ParserDetails.ini parser registration.
107- BuildRequires libxml2-devel.
108- Own installed directories.
109
110* Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
111- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.