source: projects/specs/trunk/p/perl-XML-LibXML/perl-XML-LibXML-vl.spec @ 12120

Revision 12120, 6.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Summary: Perl interface to the libxml2 library
2Summary(ja): libxml2 ライブラリへの Perl インターフェイス
3Name: perl-XML-LibXML
4# NOTE: also update perl-XML-LibXSLT to the same version, see
5# https://bugzilla.redhat.com/show_bug.cgi?id=469480
6Version: 2.0200
7Release: 2%{?_dist_release}
8
9License: GPL+ or Artistic
10Group: Development/Libraries
11URL: http://search.cpan.org/dist/XML-LibXML/
12
13Source0: http://www.cpan.org/authors/id/P/PA/PAJAS/XML-LibXML-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: libxcrypt-devel
17BuildRequires: libxml2-devel
18BuildRequires: perl(XML::NamespaceSupport)
19BuildRequires: perl(XML::SAX)
20BuildRequires: perl(ExtUtils::MakeMaker)
21BuildRequires: perl(Test::More)
22
23Requires:       %(perl -MConfig -le 'if (defined $Config{useithreads}) { print "perl(:WITH_ITHREADS)" } else { print "perl(:WITHOUT_ITHREADS)" }')
24Requires:       %(perl -MConfig -le 'if (defined $Config{usethreads}) { print "perl(:WITH_THREADS)" } else { print "perl(:WITHOUT_THREADS)" }')
25Requires:       %(perl -MConfig -le 'if (defined $Config{uselargefiles}) { print "perl(:WITH_LARGEFILES)" } else { print "perl(:WITHOUT_LARGEFILES)" }')
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27
28Provides:       perl-XML-LibXML-Common = %{version}
29Obsoletes:      perl-XML-LibXML-Common <= 0.13
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33
34
35%description
36This module implements a Perl interface to the GNOME libxml2 library
37which provides interfaces for parsing and manipulating XML files. This
38module allows Perl programmers to make use of the highly capable
39validating XML parser and the high performance DOM implementation.
40
41%prep
42%setup -q -n XML-LibXML-%{version}
43
44%define libxml_libs %(pkg-config --libs libxml-2.0)
45%define libxml_cflags %(pkg-config --cflags libxml-2.0)
46
47perl -pi -e 's|Alien::Libxml2->cflags|"%{libxml_cflags}"|' Makefile.PL
48perl -pi -e 's|Alien::Libxml2->libs|"%{libxml_libs}"|' Makefile.PL
49sed -i -e '/Alien/d' Makefile.PL
50
51%build
52%__perl Makefile.PL SKIP_SAX_INSTALL=1 INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
53%__make %{?_smp_mflags}
54
55%install
56%__rm -rf $RPM_BUILD_ROOT
57%__make install \
58  PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
59  INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
60find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
61  -o \( -name '*.bs' -a -empty \) \) -exec %__rm -f {} ';'
62find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
63%__chmod -R u+w $RPM_BUILD_ROOT/*
64
65for i in Changes; do
66  /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && %__mv -f $i.conv $i
67done
68
69%check
70%__make test
71
72%clean
73%__rm -rf $RPM_BUILD_ROOT
74
75%triggerin -- perl-XML-SAX
76for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
77  perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" \
78    2>/dev/null || :
79done
80
81%preun
82if [ $1 -eq 0 ] ; then
83  for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
84    perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
85      2>/dev/null || :
86  done
87fi
88
89%files
90%defattr(-,root,root,-)
91%doc Changes LICENSE README
92%{perl_vendorarch}/auto/XML
93%{perl_vendorarch}/XML
94%{_mandir}/man3/*.3*
95
96%changelog
97* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0200-2
98- rebuilt with perl-5.26.
99
100* Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0200-1
101- new upstream release.
102- added BR:libxcrypt-devel.
103
104* Sun Nov 30 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0117-1
105- new upstream release.
106- built with libxml2 2.9.2
107- added Japanese summary
108
109* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0116-1
110- new upstream release.
111
112* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.70-2
113- rebuild with perl-5.12.3
114
115* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-1
116- new upstream release
117
118* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:1.70-5
119- Mass rebuild with perl-5.12.0
120
121* Fri Jan  8 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-4
122- remove BR XML::LibXML::Common
123
124* Mon Nov 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-3
125- corrected version of obsoletes
126
127* Thu Nov 26 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-2
128- 541605 this package now contains XML::LibXML::Common
129
130* Fri Nov 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-1
131- update to fix 539102
132
133* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-3
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
135
136* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-2
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
138
139* Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.69-1
140- update to 1.69
141
142* Fri Aug 01 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:1.66-2
143- Supress warning about nonexistent file in perl-XML-SAX install trigger
144
145* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
146- new upsteream release
147- built with perl-5.10.0-2
148- changed Group to Development/Libraries
149
150* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
151- changed Group to Development/Languages
152- rebuilt with libxml2-2.6.26
153
154* Sun Apr  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
155- rebuilt for Vine Linux
156
157* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
158- bump again for double-long bug on ppc(64)
159
160* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
161- rebuilt for new gcc4.1 snapshot and glibc changes
162
163* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
164- rebuild for new perl-5.8.8
165
166* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
167- rebuilt for new gcc
168
169* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
170- rebuilt for new gcj
171
172* Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
173- rebuild
174
175* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
176- #121168
177- Update to 1.58.
178- Require perl(:MODULE_COMPAT_*).
179- Handle ParserDetails.ini parser registration.
180- BuildRequires libxml2-devel.
181- Own installed directories.
182
183* Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
184- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.