source: projects/specs/trunk/p/perl-XML-LibXML/perl-XML-LibXML-vl.spec @ 9124

Revision 9124, 5.5 KB checked in by inagaki, 9 years ago (diff)

2014-11-30 Ryoichi INAGAKI <ryo1@…>

  • perl-Perl-Critic-More: rebuilt
  • perl-XML-{Dumper, Filter-BufferText?, Grove, XPath}: rebuilt
  • perl-XML-{LibXML, LibXSLT, SAX-Writer, Writer}: updated
  • perl-YAML-LibYAML: updated


Line 
1Summary: Perl interface to the libxml2 library
2Summary(ja): libxml2 ライブラリへの Perl インターフェイス
3Name: perl-XML-LibXML
4# NOTE: also update perl-XML-LibXSLT to the same version, see
5# https://bugzilla.redhat.com/show_bug.cgi?id=469480
6Version: 2.0117
7Release: 1%{?_dist_release}
8
9License: GPL+ or Artistic
10Group: Development/Libraries
11URL: http://search.cpan.org/dist/XML-LibXML/
12
13Source0: http://www.cpan.org/authors/id/P/PA/PAJAS/XML-LibXML-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: libxml2-devel
17BuildRequires: perl(XML::NamespaceSupport)
18BuildRequires: perl(XML::SAX)
19BuildRequires: perl(ExtUtils::MakeMaker)
20BuildRequires: perl(Test::More)
21
22Requires:       %(perl -MConfig -le 'if (defined $Config{useithreads}) { print "perl(:WITH_ITHREADS)" } else { print "perl(:WITHOUT_ITHREADS)" }')
23Requires:       %(perl -MConfig -le 'if (defined $Config{usethreads}) { print "perl(:WITH_THREADS)" } else { print "perl(:WITHOUT_THREADS)" }')
24Requires:       %(perl -MConfig -le 'if (defined $Config{uselargefiles}) { print "perl(:WITH_LARGEFILES)" } else { print "perl(:WITHOUT_LARGEFILES)" }')
25Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
26
27Provides:       perl-XML-LibXML-Common = %{version}
28Obsoletes:      perl-XML-LibXML-Common <= 0.13
29
30Vendor:         Project Vine
31Distribution:   Vine Linux
32
33
34%description
35This module implements a Perl interface to the GNOME libxml2 library
36which provides interfaces for parsing and manipulating XML files. This
37module allows Perl programmers to make use of the highly capable
38validating XML parser and the high performance DOM implementation.
39
40%prep
41%setup -q -n XML-LibXML-%{version}
42
43%build
44%__perl Makefile.PL SKIP_SAX_INSTALL=1 INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
45%__make %{?_smp_mflags}
46
47%install
48%__rm -rf $RPM_BUILD_ROOT
49%__make install \
50  PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
51  INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
52find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
53  -o \( -name '*.bs' -a -empty \) \) -exec %__rm -f {} ';'
54find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
55%__chmod -R u+w $RPM_BUILD_ROOT/*
56
57for i in Changes; do
58  /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && %__mv -f $i.conv $i
59done
60
61%check
62%__make test
63
64%clean
65%__rm -rf $RPM_BUILD_ROOT
66
67%triggerin -- perl-XML-SAX
68for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
69  perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" \
70    2>/dev/null || :
71done
72
73%preun
74if [ $1 -eq 0 ] ; then
75  for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
76    perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
77      2>/dev/null || :
78  done
79fi
80
81%files
82%defattr(-,root,root,-)
83%doc Changes LICENSE README
84%{perl_vendorarch}/auto/XML
85%{perl_vendorarch}/XML
86%{_mandir}/man3/*.3*
87
88%changelog
89* Sun Nov 30 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0117-1
90- new upstream release.
91- built with libxml2 2.9.2
92- added Japanese summary
93
94* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0116-1
95- new upstream release.
96
97* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.70-2
98- rebuild with perl-5.12.3
99
100* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-1
101- new upstream release
102
103* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:1.70-5
104- Mass rebuild with perl-5.12.0
105
106* Fri Jan  8 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-4
107- remove BR XML::LibXML::Common
108
109* Mon Nov 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-3
110- corrected version of obsoletes
111
112* Thu Nov 26 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-2
113- 541605 this package now contains XML::LibXML::Common
114
115* Fri Nov 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-1
116- update to fix 539102
117
118* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-3
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
123
124* Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.69-1
125- update to 1.69
126
127* Fri Aug 01 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:1.66-2
128- Supress warning about nonexistent file in perl-XML-SAX install trigger
129
130* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
131- new upsteream release
132- built with perl-5.10.0-2
133- changed Group to Development/Libraries
134
135* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
136- changed Group to Development/Languages
137- rebuilt with libxml2-2.6.26
138
139* Sun Apr  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
140- rebuilt for Vine Linux
141
142* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
143- bump again for double-long bug on ppc(64)
144
145* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
146- rebuilt for new gcc4.1 snapshot and glibc changes
147
148* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
149- rebuild for new perl-5.8.8
150
151* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
152- rebuilt for new gcc
153
154* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
155- rebuilt for new gcj
156
157* Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
158- rebuild
159
160* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
161- #121168
162- Update to 1.58.
163- Require perl(:MODULE_COMPAT_*).
164- Handle ParserDetails.ini parser registration.
165- BuildRequires libxml2-devel.
166- Own installed directories.
167
168* Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
169- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.