source: projects/specs/trunk/p/perl-XML-DOM/perl-XML-DOM-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           perl-XML-DOM
2Version:        1.44
3Release:        7%{?_dist_release}
4Summary:        DOM extension to XML::Parser
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/XML-DOM/
9Source0:        http://www.cpan.org/authors/id/T/TJ/TJMATHER/XML-DOM-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12BuildArch:      noarch
13# perl(XML::Parser::PerlSAX)
14BuildRequires:  perl-libxml-perl
15BuildRequires:  perl-XML-RegExp
16# for testing perl(LWP::UserAgent)
17BuildRequires:  perl-libwww-perl
18Requires:       perl-XML-Parser
19Requires:       perl-libwww-perl
20Requires:       perl >= %(eval "`%{__perl} -V:version`"; echo $version)
21Obsoletes:      perl-libxml-enno <= 1.02
22
23%description
24This is a Perl extension to XML::Parser. It adds a new 'Style' to
25XML::Parser, called 'Dom', that allows XML::Parser to build an Object
26Oriented datastructure with a DOM Level 1 compliant interface.  For a
27description of the DOM (Document Object Model), see
28http://www.w3.org/DOM/
29
30
31%prep
32%setup -q -n XML-DOM-%{version}
33
34cat <<EOF > %{name}-prov
35#!/bin/sh
36%{__perl_provides} \$* | grep -v 'perl(XML::XQL::Node)'
37EOF
38%define __perl_provides %{_builddir}/XML-DOM-%{version}/%{name}-prov
39chmod +x %{__perl_provides}
40
41
42%build
43%{__perl} Makefile.PL INSTALLDIRS=vendor
44make %{?_smp_mflags}
45
46
47%install
48rm -rf $RPM_BUILD_ROOT
49make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
50find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
51find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
52chmod -R u+w $RPM_BUILD_ROOT/*
53
54
55%check
56make test
57
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62
63%files
64%defattr(-,root,root,-)
65%doc BUGS Changes README
66%{perl_vendorlib}/XML/
67%{_mandir}/man3/XML::*.3*
68
69
70%changelog
71* Sat Aug 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-7
72- Initial build for Vine Linux
73
74* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-6
75- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
76
77* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-5
78- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
79
80* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-4
81- Rebuild for perl 5.10 (again)
82
83* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-3
84- rebuild for new perl
85
86* Wed Oct 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2.1
87- correct license tag
88- add BR: perl(ExtUtils::MakeMaker)
89
90* Thu Jun 29 2006 Orion Poplawski <orion@cora.nwra.com> - 1.44-2
91- Bump for new perl version (#196667)
92
93* Sat Nov  5 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-1
94- First Fedora Extras release (#172331).
95
96* Thu Oct 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-0.1
97- First build (#128879).
Note: See TracBrowser for help on using the repository browser.