source: projects/specs/trunk/p/perl-XML-DOM/perl-XML-DOM-vl.spec @ 12121

Revision 12121, 3.3 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1Name:           perl-XML-DOM
2Version:        1.46
3Release:        11%{?_dist_release}
4Summary:        DOM extension to XML::Parser
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/XML-DOM/
9Source0:        http://www.cpan.org/authors/id/T/TJ/TJMATHER/XML-DOM-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15BuildArch:      noarch
16# perl(XML::Parser::PerlSAX)
17BuildRequires:  perl-libxml-perl
18BuildRequires:  perl-XML-RegExp
19# for testing perl(LWP::UserAgent)
20BuildRequires:  perl-libwww-perl
21Requires:       perl-XML-Parser
22Requires:       perl-libwww-perl
23Requires:       perl >= %(eval "`%{__perl} -V:version`"; echo $version)
24#Obsoletes:      perl-libxml-enno <= 1.02
25Conflicts:      perl-libxml-enno <= 1.02
26
27%description
28This is a Perl extension to XML::Parser. It adds a new 'Style' to
29XML::Parser, called 'Dom', that allows XML::Parser to build an Object
30Oriented datastructure with a DOM Level 1 compliant interface.  For a
31description of the DOM (Document Object Model), see
32http://www.w3.org/DOM/
33
34
35%prep
36%setup -q -n XML-DOM-%{version}
37
38cat <<EOF > %{name}-prov
39#!/bin/sh
40%{__perl_provides} \$* | grep -v 'perl(XML::XQL::Node)'
41EOF
42%define __perl_provides %{_builddir}/XML-DOM-%{version}/%{name}-prov
43chmod +x %{__perl_provides}
44
45
46%build
47%{__perl} Makefile.PL INSTALLDIRS=vendor
48make %{?_smp_mflags}
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
54find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
55find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
56chmod -R u+w $RPM_BUILD_ROOT/*
57
58
59%check
60make test
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66
67%files
68%defattr(-,root,root,-)
69%doc BUGS Changes README
70%{perl_vendorlib}/XML/
71%{_mandir}/man3/XML::*.3*
72
73
74%changelog
75* Mon May 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.46-1
76- new upstream release.
77- rebuilt with perl-5.26.
78
79* Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.44-10
80- rebuilt with perl-5.16.3.
81
82* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.44-9
83- build with perl 5.12.3
84- add Vendor and Distribution tags
85
86* Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-8
87- s/Obsoletes/Conflicts/
88
89* Sat Aug 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-7
90- Initial build for Vine Linux
91
92* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-6
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
94
95* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-5
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
97
98* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-4
99- Rebuild for perl 5.10 (again)
100
101* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-3
102- rebuild for new perl
103
104* Wed Oct 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2.1
105- correct license tag
106- add BR: perl(ExtUtils::MakeMaker)
107
108* Thu Jun 29 2006 Orion Poplawski <orion@cora.nwra.com> - 1.44-2
109- Bump for new perl version (#196667)
110
111* Sat Nov  5 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-1
112- First Fedora Extras release (#172331).
113
114* Thu Oct 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-0.1
115- First build (#128879).
Note: See TracBrowser for help on using the repository browser.