source: projects/specs/trunk/p/perl-WWW-Mechanize/perl-WWW-Mechanize-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1#
2# Rebuild switches:
3#  --with localtests         enable local tests
4%bcond_with localtests
5#  --with livetests          enable live tests
6%bcond_with livetests
7
8Name:           perl-WWW-Mechanize
9Version:        1.54
10Release:        1%{?_dist_release}
11Summary:        Automates web page form & link interaction
12
13Group:          Development/Libraries
14License:        GPL+ or Artistic
15URL:            http://search.cpan.org/dist/WWW-Mechanize/
16Source0:        http://www.cpan.org/authors/id/P/PE/PETDANCE/WWW-Mechanize-%{version}.tar.gz
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18BuildArch:      noarch
19Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21BuildRequires:  perl(ExtUtils::MakeMaker)
22BuildRequires:  perl(Test::More)
23BuildRequires:  perl(Test::Pod), perl(Test::Pod::Coverage)
24BuildRequires:  perl(Test::Exception)
25BuildRequires:  perl(Test::Memory::Cycle), perl(Test::Taint), perl(Test::Warn)
26BuildRequires:  perl(HTML::TokeParser), perl(LWP::UserAgent) >= 5.829, perl(URI::URL)
27BuildRequires:  perl(IO::Socket::SSL)
28BuildRequires:  perl(URI) >= 1.36
29BuildRequires:  perl(HTTP::Server::Simple)
30BuildRequires:  perl(HTTP::Response::Encoding) >= 0.05
31
32%description
33"WWW::Mechanize", or Mech for short, helps you automate interaction
34with a website.  It supports performing a sequence of page fetches
35including following links and submitting forms. Each fetched page is
36parsed and its links and forms are extracted. A link or a form can be
37selected, form fields can be filled and the next page can be fetched.
38Mech also stores a history of the URLs you've visited, which can be
39queried and revisited.
40
41
42%prep
43%setup -q -n WWW-Mechanize-%{version}
44
45
46%build
47%{__perl} Makefile.PL INSTALLDIRS=vendor \
48%if %{with localtests}
49    --local \
50%else
51    --nolocal \
52%endif
53%if %{with livetests}
54    --live
55%else
56    --nolive
57%endif
58make %{?_smp_mflags}
59
60
61%install
62rm -rf %{buildroot}
63
64make pure_install PERL_INSTALL_ROOT=%{buildroot}
65find %{buildroot} -type f -name .packlist -exec rm -f {} +
66find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
67
68%{_fixperms} %{buildroot}/*
69
70
71%check
72make test
73
74
75%clean
76rm -rf %{buildroot}
77
78
79%files
80%defattr(-,root,root,-)
81%doc Changes etc/www-mechanize-logo.png 
82%{_bindir}/mech-dump
83%{perl_vendorlib}/WWW/
84%{_mandir}/man1/*.1*
85%{_mandir}/man3/*.3pm*
86
87
88%changelog
89* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.54-1
90- initial build for Vine Linux based on fedora development
91
92* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.54-3
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
94
95* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.54-2
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
97
98* Sat Feb 21 2009 Ralf Cors辿pius <corsepiu@fedoraproject.org> - 1.54-1
99- Upstream update.
100- Add BR: perl(URI), perl(HTTP::Server::Simple),
101  perl(HTTP::Response::Encoding).
102- Use %%bcond_with and %%with to process build options.
103
104* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.34-1
105- update to 1.34
106
107* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.32-2
108- rebuild for new perl
109
110* Fri Dec 07 2007 Chris Weyl <cweyl@alumni.drew.edu> - 1.32-1
111- update to 1.32
112
113* Thu Jun  7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-2
114- New rebuild option: "--with livetests".
115
116* Thu Jun  7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
117- Update to 1.30.
118- The Makefile.PL --mech-dump option is now deprecated.
119
120* Thu Jun  7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
121- Update to 1.24.
122
123* Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-2
124- New BR: perl(IO::Socket::SSL).
125
126* Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
127- Update to 1.22.
128
129* Tue Sep  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
130- Update to 1.20.
131- Live tests have been dropped.
132
133* Tue Feb 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-2
134- Re-enable test suite but without local and live tests.
135  One local test fails in mock (see #165650 comment 4).
136- New rebuild option: "--with localtests".
137
138* Thu Feb  2 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
139- Update to 1.18.
140
141* Thu Nov 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
142- Update to 1.16.
143
144* Wed Aug 31 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-2
145- Added Test::LongString to the live tests build requirements.
146
147* Wed Aug 31 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-1
148- Update to 1.14.
149
150* Fri Aug 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-4
151- Added Test::Pod::Coverage to the BR list in order to improve test coverage.
152- Disabled test suite as it fails in mock (see #165650 comment 4).
153
154* Thu Aug 25 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-3
155- Conditional rebuild switch to enable live tests (RFE in #165650).
156
157* Fri Jul  1 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-2
158- Dist tag.
159
160* Sat Feb 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.12-0.fdr.1
161- Update to 1.12.
162
163* Mon Feb 14 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.10-0.fdr.1
164- Update to 1.10.
165
166* Sat Dec 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.08-0.fdr.1
167- Update to 1.08.
168
169* Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.02-0.fdr.1
170- First build.
Note: See TracBrowser for help on using the repository browser.