source: projects/specs/trunk/p/perl-WWW-Mechanize/perl-WWW-Mechanize-vl.spec @ 9140

Revision 9140, 5.5 KB checked in by Takemikaduchi, 9 years ago (diff)

perl-WWW-Curl: NEW
dotconf,perl-HTTP-Server-Simple,speech-dispatcher: new upstream release
others: rebuild

Line 
1#
2# Rebuild switches:
3#  --with localtests         enable local tests
4%bcond_with localtests
5#  --with livetests          enable live tests
6%bcond_with livetests
7
8Name:           perl-WWW-Mechanize
9Version:        1.73
10Release:        1%{?_dist_release}
11Summary:        Automates web page form & link interaction
12
13Group:          Development/Libraries
14License:        GPL+ or Artistic
15URL:            http://search.cpan.org/dist/WWW-Mechanize/
16Source0:        http://www.cpan.org/authors/id/P/PE/PETDANCE/WWW-Mechanize-%{version}.tar.gz
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18BuildArch:      noarch
19Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21BuildRequires:  perl(ExtUtils::MakeMaker)
22BuildRequires:  perl(Test::More)
23BuildRequires:  perl(Test::Pod), perl(Test::Pod::Coverage)
24BuildRequires:  perl(Test::Exception)
25BuildRequires:  perl(Test::Memory::Cycle), perl(Test::Taint), perl(Test::Warn)
26BuildRequires:  perl(HTML::TokeParser), perl(LWP::UserAgent) >= 5.829, perl(URI::URL)
27BuildRequires:  perl(IO::Socket::SSL)
28BuildRequires:  perl(URI) >= 1.36
29BuildRequires:  perl(HTTP::Server::Simple)
30BuildRequires:  perl(HTTP::Response::Encoding) >= 0.05
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36"WWW::Mechanize", or Mech for short, helps you automate interaction
37with a website.  It supports performing a sequence of page fetches
38including following links and submitting forms. Each fetched page is
39parsed and its links and forms are extracted. A link or a form can be
40selected, form fields can be filled and the next page can be fetched.
41Mech also stores a history of the URLs you've visited, which can be
42queried and revisited.
43
44
45%prep
46%setup -q -n WWW-Mechanize-%{version}
47
48
49%build
50%{__perl} Makefile.PL INSTALLDIRS=vendor \
51%if %{with localtests}
52    --local \
53%else
54    --nolocal \
55%endif
56%if %{with livetests}
57    --live
58%else
59    --nolive
60%endif
61make %{?_smp_mflags}
62
63
64%install
65rm -rf %{buildroot}
66
67make pure_install PERL_INSTALL_ROOT=%{buildroot}
68find %{buildroot} -type f -name .packlist -exec rm -f {} +
69find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
70
71%{_fixperms} %{buildroot}/*
72
73
74%check
75make test
76
77
78%clean
79rm -rf %{buildroot}
80
81
82%files
83%defattr(-,root,root,-)
84%doc Changes etc/www-mechanize-logo.png 
85%{_bindir}/mech-dump
86%{perl_vendorlib}/WWW/
87%{_mandir}/man1/*.1*
88%{_mandir}/man3/*.3pm*
89
90
91%changelog
92* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.73-1
93- update to 1.73
94
95* Mon Apr 25 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 1.54-2
96- build with perl 5.12.3
97- add Vendor and Distribution tags
98
99* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.54-1
100- initial build for Vine Linux based on fedora development
101
102* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.54-3
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
104
105* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.54-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
107
108* Sat Feb 21 2009 Ralf Cors辿pius <corsepiu@fedoraproject.org> - 1.54-1
109- Upstream update.
110- Add BR: perl(URI), perl(HTTP::Server::Simple),
111  perl(HTTP::Response::Encoding).
112- Use %%bcond_with and %%with to process build options.
113
114* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.34-1
115- update to 1.34
116
117* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.32-2
118- rebuild for new perl
119
120* Fri Dec 07 2007 Chris Weyl <cweyl@alumni.drew.edu> - 1.32-1
121- update to 1.32
122
123* Thu Jun  7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-2
124- New rebuild option: "--with livetests".
125
126* Thu Jun  7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
127- Update to 1.30.
128- The Makefile.PL --mech-dump option is now deprecated.
129
130* Thu Jun  7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
131- Update to 1.24.
132
133* Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-2
134- New BR: perl(IO::Socket::SSL).
135
136* Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
137- Update to 1.22.
138
139* Tue Sep  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
140- Update to 1.20.
141- Live tests have been dropped.
142
143* Tue Feb 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-2
144- Re-enable test suite but without local and live tests.
145  One local test fails in mock (see #165650 comment 4).
146- New rebuild option: "--with localtests".
147
148* Thu Feb  2 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
149- Update to 1.18.
150
151* Thu Nov 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
152- Update to 1.16.
153
154* Wed Aug 31 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-2
155- Added Test::LongString to the live tests build requirements.
156
157* Wed Aug 31 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-1
158- Update to 1.14.
159
160* Fri Aug 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-4
161- Added Test::Pod::Coverage to the BR list in order to improve test coverage.
162- Disabled test suite as it fails in mock (see #165650 comment 4).
163
164* Thu Aug 25 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-3
165- Conditional rebuild switch to enable live tests (RFE in #165650).
166
167* Fri Jul  1 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-2
168- Dist tag.
169
170* Sat Feb 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.12-0.fdr.1
171- Update to 1.12.
172
173* Mon Feb 14 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.10-0.fdr.1
174- Update to 1.10.
175
176* Sat Dec 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.08-0.fdr.1
177- Update to 1.08.
178
179* Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.02-0.fdr.1
180- First build.
Note: See TracBrowser for help on using the repository browser.