source: projects/specs/trunk/p/perl-Tk/perl-Tk-vl.spec @ 9512

Revision 9512, 4.1 KB checked in by inagaki, 9 years ago (diff)

2015-04-16 Ryoichi INAGAKI <ryo1@…>

  • perl-{Cairo, Clone, Curses, Event, Guard, IO-AIO,

IO-Socket-SSL, IPC-Run, Tk, URI}: updated


Line 
1# if you wanna test, add " --define '_run_test 1' " option to rpmbuild command
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define pkgname Tk
4
5Summary:        A perl module for Tk.
6Name:           perl-%{pkgname}
7Version:        804.033
8Release:        1%{_dist_release}
9Group:          Development/Libraries
10License:        GPL or Artistic
11URL:            http://perltk.org/
12Source0:        %{pkgname}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  libX11-devel
16BuildRequires:  libpng-devel
17BuildRequires:  libjpeg-turbo-devel
18Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
19
20Patch0:         perl-Tk-widget.patch
21# modified version of http://ftp.de.debian.org/debian/pool/main/p/perl-tk/perl-tk_804.027-8.diff.gz
22Patch1:         perl-Tk-debian.patch.gz
23# fix segfaults as in #235666 because of broken cashing code
24Patch2:         perl-Tk-seg.patch
25# Fix freetype detection with 2.5
26Patch4:         perl-Tk-freetype25.patch
27
28Provides:       perl(Tk::LabRadio) = 4.004
29Provides:       perl(Tk::TextReindex) = 4.004
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33
34%description
35Perl bindings to the Tk Graphical User Interface ToolKit.
36
37%prep
38%setup -q -n %{pkgname}-%{version}
39%{__mkdir} pTk.docs
40%{__cp} pTk/Tix.license pTk/license.terms pTk/license.html_lib pTk.docs
41
42# fix for widget as docs
43%patch0
44%{__perl} -pi -e \
45's,\@demopath\@,%{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}/demo
46s,g' demos/widget
47# debian patch
48%patch1 -p1
49# patch to fix #235666 ... seems like caching code is broken
50%patch2 -p1 -b .seg
51# freetype-2.5 detection
52%patch4 -p1
53
54
55%build
56find . -type f -exec %{__perl} -pi -e 's|^#!/.*bin/perl\S*|#!%{__perl}|i;' {} \;
57CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
58#make %{?_smp_mflags}
59make
60
61%if %{run_test}
62make test
63#-------------------------------#
64# Sun May 22 2011 ..last tested #
65# Result: PASS
66#-------------------------------#
67%endif
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install
73
74[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
75
76find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
77        sed "s@^$RPM_BUILD_ROOT@@g" | \
78        grep -v perllocal.pod | \
79        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
80if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
81    echo "ERROR: EMPTY FILE LIST"
82    exit -1
83fi
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files -f %{pkgname}-%{version}-filelist
89%defattr(-,root,root)
90%doc README MANIFEST COPYING Change.log Changes README.linux pTk.docs
91%exclude %{perl_archlib}/perllocal.pod
92%exclude %{perl_vendorarch}/auto/Tk/.packlist
93
94
95%changelog
96* Wed Apr 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 804.033-1
97- new upstream release
98
99* Thu Jul 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 804.032-1
100- new upstream release.
101- replaced patches.
102
103* Sun May 22 2011 Shu KONNO <owa@bg.wakwak.com> 804.028-5
104- added BR: libjpeg-turbo-devel
105
106* Sun May 22 2011 Shu KONNO <owa@bg.wakwak.com> 804.028-4
107- added Patch200: perl-Tk-804.028.Xlib.patch
108- added Patch201: perl-Tk-804.028.pTkCallback.patch
109- added Patch202: perl-Tk-804.028.encGlue.patch
110- added Patch203: perl-Tk-804.028.tkGlue.patch
111- added _run_test option
112
113* Sat Jan  9 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-3
114- add BuildRequires: libX11-devel libpng-devel : <BTS:VineLinux:866>
115- drop X11LIBS argument for Makefile.PL on x86_64 architecture
116- add documents
117
118* Mon Jan  4 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-2
119- add patch11 for fix CPAN bug #38746: <BTS:VineLinux:866>
120  - see http://rt.cpan.org/Public/Bug/Display.html?id=38746
121
122* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 804.028-1
123- new upstream release
124- build with perl-8.10.0
125
126* Fri Mar 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 804.027-3
127- add patch100 for fix CVE-2006-4484
128- with new versioning policy
129- add Vendor/Distribution tag
130
131* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 804.027-0vl2
132- added X11LIB to build (for x86_64)
133
134* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 804.027-0vl1
135- updated to 804.027
136- build with perl-5.8.6
137- no noarch now (arch-dependent files/binaries are actually included)
138
139* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 804.026-0vl1
140- initial build for Vine Linux
141
Note: See TracBrowser for help on using the repository browser.