source: projects/specs/trunk/p/perl-Thread-Serialize/perl-Thread-Serialize-vl.spec @ 9004

Revision 9004, 2.1 KB checked in by inagaki, 10 years ago (diff)

2014-10-11 Ryoichi INAGAKI <ryo1@…>

  • perl-Net-SMTP-SSL, perl-Thread-Tie, perl-Test-MockDBI: rebuild
  • perl-Thread-Serialize, perl-Test-MockObject?, perl-UNIERSAL-can, perl-UNIVERSAL-isa, perl-load: update


Line 
1%define real_name Thread-Serialize
2
3Summary:        serialize data-structures between threads
4Name:           perl-Thread-Serialize
5Version:        1.01
6Release:        1%{?_dist_release}
7License:        Artistic or GPL+
8Group:          Development/Libraries
9Source:         http://search.cpan.org/CPAN/authors/id/E/EL/ELIZABETH/Thread-Serialize-%{version}.tar.gz
10URL:            http://search.cpan.org/dist/Thread-Serialize/
11BuildArch:      noarch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Storable)
16BuildRequires:  perl(Test::More) >= 0.88
17Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
18Requires:       perl(Storable)
19
20%description
21The Thread::Serialize module is a library for centralizing the
22routines used to serialize data-structures between threads.
23Because of this central location, other modules such as
24Thread::Conveyor, Thread::Pool or Thread::Tie can benefit from
25the same optimizations that may take place here in the future.
26
27This module only functions on Perl versions 5.8.0 and later.
28And then only when threads are enabled with -Dusethreads.  It
29is of no use with any version of Perl before 5.8.0 or without
30threads enabled.
31
32%prep
33%setup -q -n %{real_name}-%{version}
34
35%build
36%{expand: %%define optflags %{optflags} -fPIC}
37perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
38make %{?_smp_mflags}
39
40%install
41rm -rf %{buildroot}
42make pure_install DESTDIR=%{buildroot}
43find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
44find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
45%{_fixperms} %{buildroot}
46
47%clean
48%{__rm} -rf %{buildroot}
49
50%check
51make test
52
53%files
54%defattr(-, root, root, 0755)
55%doc MANIFEST README CHANGELOG
56%doc %{_mandir}/man3/Thread::Serialize.3pm*
57%dir %{perl_vendorlib}/Thread/
58%{perl_vendorlib}/Thread/Serialize.pm
59
60%changelog
61* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.01-1
62- updated to 1.01
63- build with perl 5.16.3
64
65* Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
66- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.