source: projects/specs/trunk/p/perl-Thread-Serialize/perl-Thread-Serialize-vl.spec @ 5875

Revision 5875, 2.0 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1%define real_name Thread-Serialize
2
3Summary:        serialize data-structures between threads
4Name:           perl-Thread-Serialize
5Version:        0.11
6Release:        1%{?_dist_release}
7License:        Artistic or GPL+
8Group:          Development/Libraries
9Source:         http://search.cpan.org/CPAN/authors/id/E/EL/ELIZABETH/Thread-Serialize-%{version}.tar.gz
10URL:            http://search.cpan.org/dist/Thread-Serialize/
11BuildArch:      noarch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Storable)
16BuildRequires:  perl(load) >= 0.10
17Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
18Requires:       perl(Storable)
19Requires:       perl(load) >= 0.10
20
21%description
22The Thread::Serialize module is a library for centralizing the
23routines used to serialize data-structures between threads.
24Because of this central location, other modules such as
25Thread::Conveyor, Thread::Pool or Thread::Tie can benefit from
26the same optimizations that may take place here in the future.
27
28This module only functions on Perl versions 5.8.0 and later.
29And then only when threads are enabled with -Dusethreads.  It
30is of no use with any version of Perl before 5.8.0 or without
31threads enabled.
32
33%prep
34%setup -q -n %{real_name}-%{version}
35
36%build
37%{expand: %%define optflags %{optflags} -fPIC}
38perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
39make %{?_smp_mflags}
40
41%install
42rm -rf %{buildroot}
43make pure_install DESTDIR=%{buildroot}
44find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
45find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
46%{_fixperms} %{buildroot}
47
48%clean
49%{__rm} -rf %{buildroot}
50
51%files
52%defattr(-, root, root, 0755)
53%doc MANIFEST README CHANGELOG TODO
54%doc %{_mandir}/man3/Thread::Serialize.3pm*
55%dir %{perl_vendorlib}/Thread/
56%{perl_vendorlib}/Thread/Serialize.pm
57
58%changelog
59* Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
60- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.