source: projects/specs/trunk/p/perl-Text-Template/perl-Text-Template-vl.spec @ 6887

Revision 6887, 2.2 KB checked in by yasumichi, 12 years ago (diff)

first import

Line 
1%define pkgname Text-Template
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.45
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/M/MJ/MJD/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Text::Template - Expand template text with embedded Perl
18Summary(ja):    Text::Template - Perl が埋め込まれたテンプレートテキストの拡張
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27 This is a library for generating form letters, building HTML pages, or
28filling in templates generally. A `template' is a piece of text that has
29little Perl programs embedded in it here and there. When you `fill in' a
30template, you evaluate the little programs and replace them with their
31values.
32
33 You can store a template in a file outside your program. People can modify
34the template without modifying the program. You can separate the formatting
35details from the main code, and put the formatting parts of the program into
36the template. That prevents code bloat and encourages functional separation.
37
38#%%description -l ja
39
40%prep
41%setup -q -n Text-Template-1.45
42
43%build
44%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
45%{__make} %{?_smp_mflags}
46
47%install
48%{__rm} -rf ${RPM_BUILD_ROOT}
49%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
50
51# remove unnecessary files.
52find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
53find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
54find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
55find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
56
57# generate file list
58find $RPM_BUILD_ROOT%{_prefix} -type f -print |
59        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
60
61if [ "$(cat %{name}.files)X" = "X" ] ; then
62        echo "ERROR: EMPTY FILE LIST"
63        exit -1
64fi
65
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70
71%files -f %{name}.files
72%defattr(-,root,root)
73%doc COPYING README
74
75%changelog
76* Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.45-1
77- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.