source: projects/specs/trunk/p/perl-Text-Template/perl-Text-Template-vl.spec @ 9167

Revision 9167, 2.4 KB checked in by inagaki, 9 years ago (diff)

2014-12-19 Ryoichi INAGAKI <ryo1@…>

  • perl-Authen-{Captcha, Radius, SASL}, perl-DBM-Deep, perl-DateTime?-Format-{HTTP, Mail}, perl-Dist-CheckConflicts?, perl-Eval-Closure, perl-Package-DeprecationManager?, perl-Regexp-Common, perl-Term-ReadLine?-Gnu, perl-Text-Template: updated
  • perl-DateTime?-Format-{IBeat, W3CDTF}, perl-Declare-Constraints-Simple, perl-Text-Markdown: rebuilt
  • perl-String-Random: NEW


Line 
1%define pkgname Text-Template
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.46
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9URL:            http://search.cpan.org/~mjd/Text-Template/
10
11Source0:        http://search.cpan.org/CPAN/authors/id/M/MJ/MJD/%{pkgname}-%{version}.tar.gz
12
13Summary:        Text::Template - Expand template text with embedded Perl
14Summary(ja):    Text::Template - Perl が埋め込まれたテンプレートテキストの拡張
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildArch:      noarch
18# Dependency
19BuildRequires:  perl(ExtUtils::MakeMaker)
20Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24Packager:       yasumichi
25
26
27%description
28 This is a library for generating form letters, building HTML pages, or
29filling in templates generally. A `template' is a piece of text that has
30little Perl programs embedded in it here and there. When you `fill in' a
31template, you evaluate the little programs and replace them with their
32values.
33
34 You can store a template in a file outside your program. People can modify
35the template without modifying the program. You can separate the formatting
36details from the main code, and put the formatting parts of the program into
37the template. That prevents code bloat and encourages functional separation.
38
39#%%description -l ja
40
41%prep
42%setup -q -n %{pkgname}-%{version}
43
44%build
45%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
46%{__make} %{?_smp_mflags}
47
48%install
49%{__rm} -rf ${RPM_BUILD_ROOT}
50%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
51
52# remove unnecessary files.
53find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
54find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
55find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
56find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
57
58# generate file list
59find $RPM_BUILD_ROOT%{_prefix} -type f -print |
60        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
61
62if [ "$(cat %{name}.files)X" = "X" ] ; then
63        echo "ERROR: EMPTY FILE LIST"
64        exit -1
65fi
66
67
68%clean
69%{__rm} -rf ${RPM_BUILD_ROOT}
70
71
72%files -f %{name}.files
73%defattr(-,root,root)
74%doc COPYING README
75
76%changelog
77* Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.46-1
78- updated to 1.46
79- built with perl 5.16.3
80- added URL tag
81
82* Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.45-1
83- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.