source: projects/specs/trunk/p/perl-Text-CharWidth/perl-Text-CharWidth-vl.spec @ 8801

Revision 8801, 2.7 KB checked in by yasumichi, 10 years ago (diff)

rebuild with perl-5.16.3

Line 
1%include %{_rpmconfigdir}/macros.perl
2
3# Basic Information
4Name:           perl-Text-CharWidth
5Version:        0.04
6Release:        3%{?_dist_release}
7License:        Artistic/GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/K/KU/KUBOTA/Text-CharWidth-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Text-CharWidth module for perl
17Summary(ja):    Perl の Text-CharWidth モジュール
18
19# Dependency
20# 以下に依存関係を記述してください。
21
22Requires:       perl
23Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
24Requires:       glibc
25
26BuildRequires:  perl
27BuildRequires:  glibc-devel
28BuildRequires:  glibc-headers
29
30%description
31This is a module to provide equivalent feature as wcwidth(3) and
32wcswidth(3).  This also provides mblen(3) equivalent subroutine.
33mbwidth() and mbswidth() are provided subroutines corresponding
34wcwidth(3) and wcswidth(3) in C language.  The prefix "mb" expresses
35that they handles "multibyte character" in C meaning, i.e., character
36encoding specified by LC_CTYPE locale.
37
38%description -l ja
39このモジュールは、wcwidth(3)、wcswidth(3) および mblen(3) と同等の機能を提供
40します。
41mbwidth() および mbswidth() は、C言語の wcwidth(3) および wcswidth(3) に対応
42するサブルーチンとして提供されます。接頭辞「mb」は、Cでは、「マルチバイト文
43字」を扱うことを意味します。文字エンコーディングは、LC_CTYPE によって指定し
44ます。
45
46%prep
47%setup -q -n Text-CharWidth-%{version}
48
49%build
50CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
51%{__make}
52
53%check
54%{__make} test
55
56%install
57%{__rm} -rf ${RPM_BUILD_ROOT}
58%{__make} install DESTDIR=${RPM_BUILD_ROOT}
59
60find $RPM_BUILD_ROOT%{_prefix} -type f -print |
61        sed "s@^$RPM_BUILD_ROOT@@g" |
62        grep -v ^%{_mandir} |
63        grep -v perllocal.pod |
64        grep -v "\.packlist" > %{name}.files
65if [ "$(cat %{name}.files)X" = "X" ] ; then
66    echo "ERROR: EMPTY FILE LIST"
67    exit -1
68fi
69
70# remove unnecessary files.
71%{__rm} -rf  ${RPM_BUILD_ROOT}/%{perl_archlib}/perllocal.pod
72%{__rm} -rf  ${RPM_BUILD_ROOT}/%{perl_vendorarch}/auto/Text/CharWidth/.packlist
73
74%clean
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77%files -f %{name}.files
78%defattr(-,root,root)
79%doc Changes README
80%dir %{perl_vendorarch}/Text
81%dir %{perl_vendorarch}/auto/Text
82%dir %{perl_vendorarch}/auto/Text/CharWidth
83%{_mandir}/*/*
84
85%changelog
86* Sun Jul 13 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.04-3
87- rebuild with perl-5.16.3
88
89* Wed Mar 30 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.04-2
90- Fixed [VineSeed:22926]
91
92* Sun Dec 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.04-1
93- initial build for Vine Linux
94
Note: See TracBrowser for help on using the repository browser.