source: projects/specs/trunk/p/perl-Test-LeakTrace/perl-Test-LeakTrace-vl.spec @ 12120

Revision 12120, 3.3 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Test-LeakTrace
2Summary:        Traces memory leaks
3Version:        0.16
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/Test-LeakTrace-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/Test-LeakTrace
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
11
12BuildRequires:  perl(Exporter)
13BuildRequires:  perl(ExtUtils::MakeMaker)
14BuildRequires:  perl(Test::More)
15BuildRequires:  libxcrypt-devel
16
17Requires:       perl(Exporter)
18
19%{?perl_default_filter}
20%{?perl_default_subpackage_tests}
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24Packager:       shaolin
25
26%description
27'Test::LeakTrace' provides several functions that trace memory leaks.
28This module scans arenas, the memory allocation system, so it can detect
29any leaked SVs in given blocks.  *Leaked SVs* are SVs which are not
30released after the end of the scope they have been created. These SVs
31include global variables and internal caches. For example, if you call a
32method in a tracing block, perl might prepare a cache for the method.
33Thus, to trace true leaks, 'no_leaks_ok()' and 'leaks_cmp_ok()' executes
34a block more than once.
35
36%prep
37%setup -q -n Test-LeakTrace-%{version}
38
39find . -type f -exec chmod -c -x {} +
40
41%build
42%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
43make %{?_smp_mflags}
44
45%install
46rm -rf %{buildroot}
47
48make pure_install DESTDIR=%{buildroot}
49find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
50find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
51find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
52
53%{_fixperms} %{buildroot}/*
54
55%check
56make test
57
58
59%clean
60rm -rf %{buildroot}
61
62%files
63%defattr(-,root,root,-)
64%doc Changes README
65%{perl_vendorarch}/*
66%exclude %dir %{perl_vendorarch}/auto
67%{_mandir}/man3/*.3*
68
69%changelog
70* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.16-1
71- new upstream release.
72- rebuilt with perl-5.26.
73- added BR:libxcrypt-devel.
74
75* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.14-1
76- new upstream release.
77
78* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.13-1
79- initial build for Vine Linux
80
81* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-4
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
83
84* Wed Jun 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.13-3
85- Perl mass rebuild
86
87* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-2
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
89
90* Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.13-1
91- update to 0.13
92  - use ">= 0", instead of "== 0" for no_leaks_ok()
93  - add count_sv() to count all the SVs in a perl interpreter
94  - fix tests broken for some perls in 0.12
95
96* Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.11-1
97- update to 0.11 (#654301)
98  - fix false-positive related to XS code (CPAN RT #58133)
99
100* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.10-2
101- Mass rebuild with perl-5.12.0
102
103* Sun Apr 04 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.10-1
104- specfile by Fedora::App::MaintainerTools 0.006
105
Note: See TracBrowser for help on using the repository browser.