source: projects/specs/trunk/p/perl-Perl-Critic/perl-Perl-Critic-vl.spec @ 5747

Revision 5747, 16.1 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-Perl-Critic
5Version:        1.117
6Release:        1%{?_dist_release}
7Summary:        Critique Perl source code for best-practices
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/Perl-Critic/
11Source0:        http://search.cpan.org/CPAN/authors/id/T/TH/THALJEF/Perl-Critic-%{version}.tar.gz
12BuildArch:      noarch
13Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
14
15# Build process
16BuildRequires:  perl(Module::Build)
17BuildRequires:  perl(Task::Weaken)
18
19# Module requirements
20BuildRequires:  aspell-en
21Requires:       aspell
22BuildRequires:  perl(B::Keywords) >= 1.05
23BuildRequires:  perl(Carp)
24BuildRequires:  perl(charnames)
25BuildRequires:  perl(Config::Tiny) >= 2
26BuildRequires:  perl(Email::Address) >= 1.889
27BuildRequires:  perl(English)
28BuildRequires:  perl(Exception::Class) >= 1.23
29BuildRequires:  perl(Exporter)
30BuildRequires:  perl(File::Basename)
31BuildRequires:  perl(File::Find)
32BuildRequires:  perl(File::Path)
33BuildRequires:  perl(File::Spec)
34BuildRequires:  perl(File::Spec::Unix)
35BuildRequires:  perl(File::Temp)
36BuildRequires:  perl(Getopt::Long)
37BuildRequires:  perl(IO::String)
38BuildRequires:  perl(List::MoreUtils) >= 0.19
39BuildRequires:  perl(List::Util)
40BuildRequires:  perl(Module::Pluggable) >= 3.1
41Requires:       perl(Module::Pluggable) >= 3.1
42BuildRequires:  perl(overload)
43BuildRequires:  perl(Perl::Tidy)
44BuildRequires:  perl(Pod::Parser)
45Requires:       perl(Pod::Parser)
46BuildRequires:  perl(Pod::PlainText)
47BuildRequires:  perl(Pod::Select)
48BuildRequires:  perl(Pod::Spell) >= 1
49BuildRequires:  perl(Pod::Usage)
50BuildRequires:  perl(PPI) >= 1.215
51Requires:       perl(PPI) >= 1.215
52BuildRequires:  perl(PPIx::Regexp) >= 0.010
53BuildRequires:  perl(PPIx::Utilities::Statement) >= 1.001
54BuildRequires:  perl(Readonly) >= 1.03
55BuildRequires:  perl(Scalar::Util)
56BuildRequires:  perl(strict)
57BuildRequires:  perl(String::Format) >= 1.13
58BuildRequires:  perl(Text::ParseWords) >= 3
59BuildRequires:  perl(version) >= 0.77
60BuildRequires:  perl(warnings)
61
62# Optional module requirements
63BuildRequires:  perl(File::HomeDir)
64Requires:       perl(File::HomeDir)
65BuildRequires:  perl(File::Which)
66Requires:       perl(File::Which)
67BuildRequires:  perl(Readonly::XS)
68Requires:       perl(Readonly::XS)
69BuildRequires:  perl(Term::ANSIColor) >= 2.02
70Requires:       perl(Term::ANSIColor) >= 2.02
71
72# Main test suite
73BuildRequires:  perl(Test::Deep)
74BuildRequires:  perl(Test::Memory::Cycle)
75BuildRequires:  perl(Test::More)
76
77# Author tests: not run if we're bootstrapping
78%if 0%{!?perl_bootstrap:1}
79BuildRequires:  perl(Devel::EnforceEncapsulation)
80BuildRequires:  perl(Perl::Critic::Policy::Editor::RequireEmacsFileVariables)
81BuildRequires:  perl(Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions)
82BuildRequires:  perl(Test::Kwalitee)
83BuildRequires:  perl(Test::Perl::Critic)
84BuildRequires:  perl(Test::Pod) >= 1.00
85BuildRequires:  perl(Test::Pod::Coverage) >= 1.04
86BuildRequires:  perl(Test::Without::Module)
87%endif
88
89# don't "provide" private Perl libs
90%{?perl_default_filter}
91
92Vendor:         Project Vine
93Distribution:   Vine Linux
94Packager:       shaolin
95
96%description
97Perl::Critic is an extensible framework for creating and applying coding
98standards to Perl source code. Essentially, it is a static source code
99analysis engine. Perl::Critic is distributed with a number of
100Perl::Critic::Policy modules that attempt to enforce various coding
101guidelines. Most Policy modules are based on Damian Conway's book Perl
102Best Practices. However, Perl::Critic is not limited to PBP and will
103even support Policies that contradict Conway. You can enable, disable,
104and customize those Polices through the Perl::Critic interface. You can
105also create new Policy modules that suit your own tastes.
106
107%package -n perl-Test-Perl-Critic-Policy
108Summary:        A framework for testing your custom Policies
109Group:          Development/Libraries
110License:        GPL+ or Artistic
111
112%description -n perl-Test-Perl-Critic-Policy
113This module provides a framework for function-testing your custom
114Perl::Critic::Policy modules. Policy testing usually involves feeding it a
115string of Perl code and checking its behavior. In the old days, those strings
116of Perl code were mixed directly in the test script. That sucked.
117
118%prep
119%setup -q -n Perl-Critic-%{version}
120find . -type f -exec chmod -c -x {} ';'
121
122%build
123perl Build.PL installdirs=vendor
124./Build
125
126%install
127./Build install destdir=%{buildroot} create_packlist=0
128%{_fixperms} %{buildroot}
129
130%check
131LC_ALL=en_US ./Build %{!?perl_bootstrap:author}test
132
133%files
134%doc Changes LICENSE README TODO.pod examples/ extras/ tools/
135%{_bindir}/perlcritic
136%{perl_vendorlib}/Perl/
137%{_mandir}/man1/perlcritic.1*
138%{_mandir}/man3/Perl::Critic*.3pm*
139
140%files -n perl-Test-Perl-Critic-Policy
141%{perl_vendorlib}/Test/
142%{_mandir}/man3/Test::Perl::Critic::Policy.3pm*
143
144%changelog
145* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-1
146- initial build for Vine Linux
147
148* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 1.117-2
149- drop %%defattr, no longer needed
150
151* Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 1.117-1
152- update to 1.117
153  New Policies:
154  - Variables::ProhibitAugmentedAssignmentInDeclaration reports constructs like
155    'my $x += 1'
156  Policy Changes:
157  - BuiltinFunctions::ProhibitLvalueSubstr: add explicit 'use version'
158    (CPAN RT#68498)
159  - CodeLayout::ProhibitHardTabs: add 'pbp' to the default_themes list
160    (CPAN RT#71093)
161  - ControlStructures::ProhibitMutatingListFunctions now understands that
162    tr///r (introduced in 5.13.7) does not change its operand
163  - ControlStructures::ProhibitMutatingListFunctions now understands that
164    '//=', '<<=', and '>>=' are assignment operators (CPAN RT#70901)
165  - ErrorHandling::RequireCheckingReturnValueOfEval now allows things
166    like grep { eval $_ } (CPAN RT#69489)
167  - Modules::RequireExplicitPackage now has configuraion option
168    allow_import_of, to allow the import of specified modules before the
169    package statement (CPAN RT#72660)
170  - RegularExpressions::ProhibitEnumeratedClasses no longer thinks
171    that [A-Za-z_] matches \w. RT #69322.
172  - RegularExpressions::ProhibitUnusedCaptures now skips the first block of
173    an 'if' or 'elsif' if the regular expression is bound to its operand with
174    the '!~' operator (CPAN RT#69867)
175  - RegularExpressions::ProhibitUnusedCaptures now looks into lists and blocks
176    in the replacement portion of the regular expression if /e is asserted
177    (CPAN RT#72086)
178  - RegularExpressions::RequireDotMatchAnything,
179    RegularExpressions::RequireExtendedFormatting and
180    RegularExpressions::RequireLineBoundaryMatching now honor defaults set with
181    'use re "/modifiers"' (CPAN RT#72151)
182  - Subroutines::ProhibitManyArgs now recognizes '+' as a prototype character
183  - Variables::ProhibitPunctuationVars now recognizes bracketed variables
184    embedded in interpolated strings (e.g. "${$}"); for the purpose of the
185    'allow' configuration, these are considered equivalent to the unbracketed
186    form (CPAN RT#72910)
187  Other Changes:
188  - corrected POD in Perl::Critic::PPI::Utils (CPAN RT#68898)
189  - Perl::Critic::Violation source() method now returns the line containing
190    the violation (not the first line) when the statement containing the
191    violation spans multiple lines
192- this release by THALJEF -> update source URL
193- drop stopwords patch, now included upstream
194
195* Fri Jul 22 2011 Paul Howarth <paul@city-fan.org> - 1.116-6
196- reinstate author tests: META.yml creation issue fixed in perl-5.14.1-182
197
198* Fri Jul 22 2011 Petr Sabata <contyk@redhat.com> - 1.116-5
199- completely disable author tests to avoid Kwalitee META complaints
200
201* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.116-4
202- Perl mass rebuild
203
204* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.116-3
205- Perl mass rebuild
206
207* Wed Jun 29 2011 Paul Howarth <paul@city-fan.org> - 1.116-2
208- move BR: perl(Test::Perl::Critic) to author test section where it belongs
209- run the author tests if we're not bootstrapping
210
211* Mon May 16 2011 Paul Howarth <paul@city-fan.org> - 1.116-1
212- update to 1.116
213  - BuiltInFunctions::ProhibitLvalueSubstr does not report violations if the
214    document contains an explicit 'use n.nnn;' where the version is before
215    5.005 (CPAN RT#59112)
216  - Documentation::RequirePodSections no longer blows up on code having POD but
217    no =head1 (CPAN RT#67231)
218  - RegularExpressions::ProhibitUnusedCapture should more reliably find things
219    like s/(a)/${1}2/ (CPAN RT#67273)
220  - ValuesAndExpressions::ProhibitMagicNumbers and Module::RequireVersionVar
221    now treat versions passed as the second argument of a 'package' statement
222    the same as versions declared as 'our $VERSION ...' (CPAN RT#67159)
223  - Variables::RequireLexicalLoopIterators does not report violations if the
224    document contains an explicit 'use n.nnn;' where the version is before
225    5.004 (CPAN RT#67760)
226
227* Fri Apr  1 2011 Paul Howarth <paul@city-fan.org> - 1.115-1
228- update to 1.115
229  - fatal error in RegularExpressions::ProhibitUnusedCapture here document
230    check (CPAN RT#67116)
231  - internal POD error in Documentation::RequirePodLinksIncludeText
232    (CPAN RT#67012)
233
234* Tue Mar 29 2011 Paul Howarth <paul@city-fan.org> 1.114-1
235- update to 1.114
236  - Documentation::RequirePodLinksIncludeText now handles nested POD formatting
237    (CPAN RT#65569)
238  - clarified relation of severity numbers to names in Perl::Critic POD
239    (CPAN RT#66017)
240  - removed caveats from Variables::RequireLocalizedPunctuationVars, no longer
241    necessary with PPI 1.208 (CPAN RT#65514)
242  - have InputOutput::RequireBriefOpen attempt to expand scope as necessary to
243    deal with the case where the open() and the corresponding close() are not
244    in the same scope (CPAN RT#64437)
245  - RegularExpressions::ProhibitUnusedCapture now looks inside double-quotish
246    things (CPAN RT#38942)
247  - RegularExpressions::ProhibitUnusedCapture now takes logical alternation
248    into account, so that (e.g.)
249        if ( /(a)/ || /(b)/ ) {
250                say $1;
251        }
252    is not a violation (CPAN RT#38942)
253  - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
254    'return { foo => 1, bar => 2 }' as containing a hash constructor, not a
255    block; this was fixed by PPI 1.215 (CPAN RT#61301)
256  - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
257    'bless { foo => 1, bar => 2 }' as containing a hash constructor, not a
258    block; this was fixed by PPI 1.215 (CPAN RT#64132)
259- bump PPI version requirement to 1.215
260- BR/R: perl(Pod::Parser)
261- BR/R: optional modules perl(Readonly::XS), perl(Term::ANSIColor) >= 2.02
262- BR: perl(Pod::Spell) >= 1
263- BR: perl(Text::ParseWords) >= 3
264- add runtime deps for optional modules perl(File::HomeDir), perl(File::Which)
265- drop redundant (for modern rpm) BuildRoot tag and buildroot cleaning
266- split Test::Perl::Critic::Policy off into its own package
267- add dependency on aspell for Perl::Critic::Policy::Documentation::PodSpelling
268- add version 1.889 requirement for perl(Email::Address)
269- add version 0.19 requirement for perl(List::MoreUtils)
270- add version 0.010 requirement for perl(PPIx::Regexp)
271- add version 1.001 requirement for perl(PPIx::Utilities::Statement)
272- add version 0.77 requirement for perl(version)
273- drop unused buildreq perl(Test::Spelling)
274- drop bogus buildreqs perl(lib) and perl(base)
275- add option for building with author tests enabled (--with authortests)
276- add patch with words not in Fedora dictionaries for spell check tests
277- split buildreqs into separate sections for build process, the module, the
278  main test suite and the author tests
279
280* Mon Mar  7 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.113-1
281- update to 1.113
282
283* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.111-2
284- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
285
286* Mon Jan  3 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.111-1
287- update
288
289* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-2
290- rebuild to fix problems with vendorarch/lib (#661697)
291
292* Fri Aug  6 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-1
293- update
294
295* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.105-4
296- mass rebuild with perl-5.12.0
297
298* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-3
299- rebuild against perl 5.10.1
300
301* Wed Nov 25 2009 Stepan Kasal <skasal@redhat.com> - 1.105-2
302- use the new filtering macros (verified that the resulting provides
303  and requires are the same)
304- add version to perl(PPI) require (#541020)
305
306* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-1
307- new upstream version
308- update build requires
309
310* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.098-3
311- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
312
313* Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.098-1
314- "neaten" filtering
315- auto-update to 1.098 (by cpan-spec-update 0.01)
316- added a new br on perl(strict) (version 0)
317- added a new br on perl(Scalar::Util) (version 0)
318- added a new br on perl(File::Temp) (version 0)
319- added a new br on perl(Pod::Usage) (version 0)
320- added a new br on perl(File::Find) (version 0)
321- added a new br on perl(PPI::Token::Whitespace) (version 1.203)
322- added a new br on perl(charnames) (version 0)
323- added a new br on perl(PPI::Document::File) (version 1.203)
324- added a new br on perl(File::Spec::Unix) (version 0)
325- added a new br on perl(List::Util) (version 0)
326- added a new br on perl(lib) (version 0)
327- added a new br on perl(Getopt::Long) (version 0)
328- added a new br on perl(Exporter) (version 0)
329- added a new br on perl(Test::More) (version 0)
330- added a new br on perl(overload) (version 0)
331- added a new br on perl(base) (version 0)
332- added a new br on perl(version) (version 0)
333- added a new br on perl(Carp) (version 0)
334- added a new br on perl(warnings) (version 0)
335- added a new br on perl(PPI::Document) (version 1.203)
336- added a new br on perl(File::Basename) (version 0)
337- added a new br on perl(PPI::Token::Quote::Single) (version 1.203)
338- added a new br on perl(File::Spec) (version 0)
339- added a new br on perl(File::Path) (version 0)
340- added a new br on perl(Pod::PlainText) (version 0)
341- added a new br on perl(Pod::Select) (version 0)
342- added a new br on perl(PPI::Node) (version 1.203)
343- added a new br on perl(English) (version 0)
344
345* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.092-2
346- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
347
348* Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.092-1
349- update to 1.092
350
351* Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.082-1
352- update to 1.082
353- resolve BZ#431577
354- add t/ examples/ extras/ tools/, and filter
355
356* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-3
357- Rebuild for perl 5.10 (again)
358
359* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-2
360- add missing BR: perl-Exception-Class
361
362* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-1
363- bump to 1.080
364
365* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.053-2
366- rebuild for new perl
367
368* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.053-1
369- Update to 1.053.
370
371* Tue Mar 20 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
372- Update to 1.05.
373
374* Thu Feb 15 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
375- Update to 1.03.
376
377* Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-2
378- Bumping release (forgot to commit sources and .cvsignore changes).
379
380* Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-1
381- Update to 1.01.
382- New build requirement: perl(Test::Memory::Cycle).
383
384* Thu Jan 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-2
385- perl(Set::Scalar) is no longer required.
386
387* Wed Jan 24 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-1
388- Update to 0.23.
389- New requirement: perl(B::Keywords).
390- Author tests coverage improved.
391
392* Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-2
393- Enabled author tests.
394- BR perl(HomeDir).
395
396* Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-1
397- Update to 0.22.
398
399* Sat Nov 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.21-1
400- Update to 0.21.
401- New BR: perl(Set::Scalar).
402
403* Sat Sep 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.2-1
404- First build.
Note: See TracBrowser for help on using the repository browser.