source: projects/specs/trunk/p/perl-Perl-Critic/perl-Perl-Critic-vl.spec @ 5797

Revision 5797, 16.2 KB checked in by shaolin, 12 years ago (diff)
  • rebuild
Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-Perl-Critic
5Version:        1.117
6Release:        2%{?_dist_release}
7Summary:        Critique Perl source code for best-practices
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/Perl-Critic/
11Source0:        http://search.cpan.org/CPAN/authors/id/T/TH/THALJEF/Perl-Critic-%{version}.tar.gz
12BuildArch:      noarch
13Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
14
15# Build process
16BuildRequires:  perl(Module::Build)
17BuildRequires:  perl(Task::Weaken)
18
19# Module requirements
20BuildRequires:  aspell-en
21Requires:       aspell
22BuildRequires:  perl(B::Keywords) >= 1.05
23BuildRequires:  perl(Carp)
24BuildRequires:  perl(charnames)
25BuildRequires:  perl(Config::Tiny) >= 2
26BuildRequires:  perl(Email::Address) >= 1.889
27BuildRequires:  perl(English)
28BuildRequires:  perl(Exception::Class) >= 1.23
29BuildRequires:  perl(Exporter)
30BuildRequires:  perl(File::Basename)
31BuildRequires:  perl(File::Find)
32BuildRequires:  perl(File::Path)
33BuildRequires:  perl(File::Spec)
34BuildRequires:  perl(File::Spec::Unix)
35BuildRequires:  perl(File::Temp)
36BuildRequires:  perl(Getopt::Long)
37BuildRequires:  perl(IO::String)
38BuildRequires:  perl(List::MoreUtils) >= 0.19
39BuildRequires:  perl(List::Util)
40BuildRequires:  perl(Module::Pluggable) >= 3.1
41Requires:       perl(Module::Pluggable) >= 3.1
42BuildRequires:  perl(overload)
43BuildRequires:  perl(Perl::Tidy)
44BuildRequires:  perl(Pod::Parser)
45Requires:       perl(Pod::Parser)
46BuildRequires:  perl(Pod::PlainText)
47BuildRequires:  perl(Pod::Select)
48BuildRequires:  perl(Pod::Spell) >= 1
49BuildRequires:  perl(Pod::Usage)
50BuildRequires:  perl(PPI) >= 1.215
51Requires:       perl(PPI) >= 1.215
52BuildRequires:  perl(PPIx::Regexp) >= 0.010
53BuildRequires:  perl(PPIx::Utilities::Statement) >= 1.001
54BuildRequires:  perl(Readonly) >= 1.03
55BuildRequires:  perl(Scalar::Util)
56BuildRequires:  perl(strict)
57BuildRequires:  perl(String::Format) >= 1.13
58BuildRequires:  perl(Text::ParseWords) >= 3
59BuildRequires:  perl(version) >= 0.77
60BuildRequires:  perl(warnings)
61
62# Optional module requirements
63BuildRequires:  perl(File::HomeDir)
64Requires:       perl(File::HomeDir)
65BuildRequires:  perl(File::Which)
66Requires:       perl(File::Which)
67BuildRequires:  perl(Readonly::XS)
68Requires:       perl(Readonly::XS)
69BuildRequires:  perl(Term::ANSIColor) >= 2.02
70Requires:       perl(Term::ANSIColor) >= 2.02
71
72# Main test suite
73BuildRequires:  perl(Test::Deep)
74BuildRequires:  perl(Test::Memory::Cycle)
75BuildRequires:  perl(Test::More)
76
77# Author tests: not run if we're bootstrapping
78%if 0%{!?perl_bootstrap:1}
79BuildRequires:  perl(Devel::EnforceEncapsulation)
80BuildRequires:  perl(Perl::Critic::Policy::Editor::RequireEmacsFileVariables)
81BuildRequires:  perl(Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions)
82BuildRequires:  perl(Test::Kwalitee)
83BuildRequires:  perl(Test::Perl::Critic)
84BuildRequires:  perl(Test::Pod) >= 1.00
85BuildRequires:  perl(Test::Pod::Coverage) >= 1.04
86BuildRequires:  perl(Test::Without::Module)
87%endif
88
89# don't "provide" private Perl libs
90%{?perl_default_filter}
91
92Vendor:         Project Vine
93Distribution:   Vine Linux
94Packager:       shaolin
95
96%description
97Perl::Critic is an extensible framework for creating and applying coding
98standards to Perl source code. Essentially, it is a static source code
99analysis engine. Perl::Critic is distributed with a number of
100Perl::Critic::Policy modules that attempt to enforce various coding
101guidelines. Most Policy modules are based on Damian Conway's book Perl
102Best Practices. However, Perl::Critic is not limited to PBP and will
103even support Policies that contradict Conway. You can enable, disable,
104and customize those Polices through the Perl::Critic interface. You can
105also create new Policy modules that suit your own tastes.
106
107%package -n perl-Test-Perl-Critic-Policy
108Summary:        A framework for testing your custom Policies
109Group:          Development/Libraries
110License:        GPL+ or Artistic
111
112%description -n perl-Test-Perl-Critic-Policy
113This module provides a framework for function-testing your custom
114Perl::Critic::Policy modules. Policy testing usually involves feeding it a
115string of Perl code and checking its behavior. In the old days, those strings
116of Perl code were mixed directly in the test script. That sucked.
117
118%prep
119%setup -q -n Perl-Critic-%{version}
120find . -type f -exec chmod -c -x {} ';'
121
122%build
123perl Build.PL installdirs=vendor
124./Build
125
126%install
127./Build install destdir=%{buildroot} create_packlist=0
128%{_fixperms} %{buildroot}
129
130%check
131LC_ALL=en_US ./Build %{!?perl_bootstrap:author}test
132
133%files
134%doc Changes LICENSE README TODO.pod examples/ extras/ tools/
135%{_bindir}/perlcritic
136%{perl_vendorlib}/Perl/
137%{_mandir}/man1/perlcritic.1*
138%{_mandir}/man3/Perl::Critic*.3pm*
139
140%files -n perl-Test-Perl-Critic-Policy
141%{perl_vendorlib}/Test/
142%{_mandir}/man3/Test::Perl::Critic::Policy.3pm*
143
144%changelog
145* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-2
146- rebuild
147
148* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-1
149- initial build for Vine Linux
150
151* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 1.117-2
152- drop %%defattr, no longer needed
153
154* Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 1.117-1
155- update to 1.117
156  New Policies:
157  - Variables::ProhibitAugmentedAssignmentInDeclaration reports constructs like
158    'my $x += 1'
159  Policy Changes:
160  - BuiltinFunctions::ProhibitLvalueSubstr: add explicit 'use version'
161    (CPAN RT#68498)
162  - CodeLayout::ProhibitHardTabs: add 'pbp' to the default_themes list
163    (CPAN RT#71093)
164  - ControlStructures::ProhibitMutatingListFunctions now understands that
165    tr///r (introduced in 5.13.7) does not change its operand
166  - ControlStructures::ProhibitMutatingListFunctions now understands that
167    '//=', '<<=', and '>>=' are assignment operators (CPAN RT#70901)
168  - ErrorHandling::RequireCheckingReturnValueOfEval now allows things
169    like grep { eval $_ } (CPAN RT#69489)
170  - Modules::RequireExplicitPackage now has configuraion option
171    allow_import_of, to allow the import of specified modules before the
172    package statement (CPAN RT#72660)
173  - RegularExpressions::ProhibitEnumeratedClasses no longer thinks
174    that [A-Za-z_] matches \w. RT #69322.
175  - RegularExpressions::ProhibitUnusedCaptures now skips the first block of
176    an 'if' or 'elsif' if the regular expression is bound to its operand with
177    the '!~' operator (CPAN RT#69867)
178  - RegularExpressions::ProhibitUnusedCaptures now looks into lists and blocks
179    in the replacement portion of the regular expression if /e is asserted
180    (CPAN RT#72086)
181  - RegularExpressions::RequireDotMatchAnything,
182    RegularExpressions::RequireExtendedFormatting and
183    RegularExpressions::RequireLineBoundaryMatching now honor defaults set with
184    'use re "/modifiers"' (CPAN RT#72151)
185  - Subroutines::ProhibitManyArgs now recognizes '+' as a prototype character
186  - Variables::ProhibitPunctuationVars now recognizes bracketed variables
187    embedded in interpolated strings (e.g. "${$}"); for the purpose of the
188    'allow' configuration, these are considered equivalent to the unbracketed
189    form (CPAN RT#72910)
190  Other Changes:
191  - corrected POD in Perl::Critic::PPI::Utils (CPAN RT#68898)
192  - Perl::Critic::Violation source() method now returns the line containing
193    the violation (not the first line) when the statement containing the
194    violation spans multiple lines
195- this release by THALJEF -> update source URL
196- drop stopwords patch, now included upstream
197
198* Fri Jul 22 2011 Paul Howarth <paul@city-fan.org> - 1.116-6
199- reinstate author tests: META.yml creation issue fixed in perl-5.14.1-182
200
201* Fri Jul 22 2011 Petr Sabata <contyk@redhat.com> - 1.116-5
202- completely disable author tests to avoid Kwalitee META complaints
203
204* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.116-4
205- Perl mass rebuild
206
207* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.116-3
208- Perl mass rebuild
209
210* Wed Jun 29 2011 Paul Howarth <paul@city-fan.org> - 1.116-2
211- move BR: perl(Test::Perl::Critic) to author test section where it belongs
212- run the author tests if we're not bootstrapping
213
214* Mon May 16 2011 Paul Howarth <paul@city-fan.org> - 1.116-1
215- update to 1.116
216  - BuiltInFunctions::ProhibitLvalueSubstr does not report violations if the
217    document contains an explicit 'use n.nnn;' where the version is before
218    5.005 (CPAN RT#59112)
219  - Documentation::RequirePodSections no longer blows up on code having POD but
220    no =head1 (CPAN RT#67231)
221  - RegularExpressions::ProhibitUnusedCapture should more reliably find things
222    like s/(a)/${1}2/ (CPAN RT#67273)
223  - ValuesAndExpressions::ProhibitMagicNumbers and Module::RequireVersionVar
224    now treat versions passed as the second argument of a 'package' statement
225    the same as versions declared as 'our $VERSION ...' (CPAN RT#67159)
226  - Variables::RequireLexicalLoopIterators does not report violations if the
227    document contains an explicit 'use n.nnn;' where the version is before
228    5.004 (CPAN RT#67760)
229
230* Fri Apr  1 2011 Paul Howarth <paul@city-fan.org> - 1.115-1
231- update to 1.115
232  - fatal error in RegularExpressions::ProhibitUnusedCapture here document
233    check (CPAN RT#67116)
234  - internal POD error in Documentation::RequirePodLinksIncludeText
235    (CPAN RT#67012)
236
237* Tue Mar 29 2011 Paul Howarth <paul@city-fan.org> 1.114-1
238- update to 1.114
239  - Documentation::RequirePodLinksIncludeText now handles nested POD formatting
240    (CPAN RT#65569)
241  - clarified relation of severity numbers to names in Perl::Critic POD
242    (CPAN RT#66017)
243  - removed caveats from Variables::RequireLocalizedPunctuationVars, no longer
244    necessary with PPI 1.208 (CPAN RT#65514)
245  - have InputOutput::RequireBriefOpen attempt to expand scope as necessary to
246    deal with the case where the open() and the corresponding close() are not
247    in the same scope (CPAN RT#64437)
248  - RegularExpressions::ProhibitUnusedCapture now looks inside double-quotish
249    things (CPAN RT#38942)
250  - RegularExpressions::ProhibitUnusedCapture now takes logical alternation
251    into account, so that (e.g.)
252        if ( /(a)/ || /(b)/ ) {
253                say $1;
254        }
255    is not a violation (CPAN RT#38942)
256  - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
257    'return { foo => 1, bar => 2 }' as containing a hash constructor, not a
258    block; this was fixed by PPI 1.215 (CPAN RT#61301)
259  - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
260    'bless { foo => 1, bar => 2 }' as containing a hash constructor, not a
261    block; this was fixed by PPI 1.215 (CPAN RT#64132)
262- bump PPI version requirement to 1.215
263- BR/R: perl(Pod::Parser)
264- BR/R: optional modules perl(Readonly::XS), perl(Term::ANSIColor) >= 2.02
265- BR: perl(Pod::Spell) >= 1
266- BR: perl(Text::ParseWords) >= 3
267- add runtime deps for optional modules perl(File::HomeDir), perl(File::Which)
268- drop redundant (for modern rpm) BuildRoot tag and buildroot cleaning
269- split Test::Perl::Critic::Policy off into its own package
270- add dependency on aspell for Perl::Critic::Policy::Documentation::PodSpelling
271- add version 1.889 requirement for perl(Email::Address)
272- add version 0.19 requirement for perl(List::MoreUtils)
273- add version 0.010 requirement for perl(PPIx::Regexp)
274- add version 1.001 requirement for perl(PPIx::Utilities::Statement)
275- add version 0.77 requirement for perl(version)
276- drop unused buildreq perl(Test::Spelling)
277- drop bogus buildreqs perl(lib) and perl(base)
278- add option for building with author tests enabled (--with authortests)
279- add patch with words not in Fedora dictionaries for spell check tests
280- split buildreqs into separate sections for build process, the module, the
281  main test suite and the author tests
282
283* Mon Mar  7 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.113-1
284- update to 1.113
285
286* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.111-2
287- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
288
289* Mon Jan  3 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.111-1
290- update
291
292* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-2
293- rebuild to fix problems with vendorarch/lib (#661697)
294
295* Fri Aug  6 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-1
296- update
297
298* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.105-4
299- mass rebuild with perl-5.12.0
300
301* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-3
302- rebuild against perl 5.10.1
303
304* Wed Nov 25 2009 Stepan Kasal <skasal@redhat.com> - 1.105-2
305- use the new filtering macros (verified that the resulting provides
306  and requires are the same)
307- add version to perl(PPI) require (#541020)
308
309* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-1
310- new upstream version
311- update build requires
312
313* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.098-3
314- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
315
316* Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.098-1
317- "neaten" filtering
318- auto-update to 1.098 (by cpan-spec-update 0.01)
319- added a new br on perl(strict) (version 0)
320- added a new br on perl(Scalar::Util) (version 0)
321- added a new br on perl(File::Temp) (version 0)
322- added a new br on perl(Pod::Usage) (version 0)
323- added a new br on perl(File::Find) (version 0)
324- added a new br on perl(PPI::Token::Whitespace) (version 1.203)
325- added a new br on perl(charnames) (version 0)
326- added a new br on perl(PPI::Document::File) (version 1.203)
327- added a new br on perl(File::Spec::Unix) (version 0)
328- added a new br on perl(List::Util) (version 0)
329- added a new br on perl(lib) (version 0)
330- added a new br on perl(Getopt::Long) (version 0)
331- added a new br on perl(Exporter) (version 0)
332- added a new br on perl(Test::More) (version 0)
333- added a new br on perl(overload) (version 0)
334- added a new br on perl(base) (version 0)
335- added a new br on perl(version) (version 0)
336- added a new br on perl(Carp) (version 0)
337- added a new br on perl(warnings) (version 0)
338- added a new br on perl(PPI::Document) (version 1.203)
339- added a new br on perl(File::Basename) (version 0)
340- added a new br on perl(PPI::Token::Quote::Single) (version 1.203)
341- added a new br on perl(File::Spec) (version 0)
342- added a new br on perl(File::Path) (version 0)
343- added a new br on perl(Pod::PlainText) (version 0)
344- added a new br on perl(Pod::Select) (version 0)
345- added a new br on perl(PPI::Node) (version 1.203)
346- added a new br on perl(English) (version 0)
347
348* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.092-2
349- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
350
351* Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.092-1
352- update to 1.092
353
354* Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.082-1
355- update to 1.082
356- resolve BZ#431577
357- add t/ examples/ extras/ tools/, and filter
358
359* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-3
360- Rebuild for perl 5.10 (again)
361
362* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-2
363- add missing BR: perl-Exception-Class
364
365* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-1
366- bump to 1.080
367
368* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.053-2
369- rebuild for new perl
370
371* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.053-1
372- Update to 1.053.
373
374* Tue Mar 20 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
375- Update to 1.05.
376
377* Thu Feb 15 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
378- Update to 1.03.
379
380* Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-2
381- Bumping release (forgot to commit sources and .cvsignore changes).
382
383* Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-1
384- Update to 1.01.
385- New build requirement: perl(Test::Memory::Cycle).
386
387* Thu Jan 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-2
388- perl(Set::Scalar) is no longer required.
389
390* Wed Jan 24 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-1
391- Update to 0.23.
392- New requirement: perl(B::Keywords).
393- Author tests coverage improved.
394
395* Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-2
396- Enabled author tests.
397- BR perl(HomeDir).
398
399* Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-1
400- Update to 0.22.
401
402* Sat Nov 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.21-1
403- Update to 0.21.
404- New BR: perl(Set::Scalar).
405
406* Sat Sep 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.2-1
407- First build.
Note: See TracBrowser for help on using the repository browser.