source: projects/specs/trunk/p/perl-Path-Tiny/perl-Path-Tiny-vl.spec @ 12120

Revision 12120, 16.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Run optional test
2%bcond_with perl_Path_Tiny_enables_optional_test
3
4Name:           perl-Path-Tiny
5Version:        0.108
6Release:        3%{?_dist_release}
7Summary:        File path utility
8License:        ASL 2.0
9URL:            https://metacpan.org/release/Path-Tiny
10Source0:        https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/Path-Tiny-%{version}.tar.gz
11
12Vendor:        Project Vine
13Distribution:  Vine Linux
14
15BuildArch:      noarch
16# Module Build
17BuildRequires:  coreutils
18BuildRequires:  findutils
19BuildRequires:  make
20BuildRequires:  perl >= 2:5.26.2
21BuildRequires:  perl(ExtUtils::MakeMaker)
22# Module Runtime
23BuildRequires:  perl(Carp)
24BuildRequires:  perl(Config)
25BuildRequires:  perl(constant)
26BuildRequires:  perl(Cwd)
27BuildRequires:  perl(Digest)
28BuildRequires:  perl(Digest::MD5)
29BuildRequires:  perl(Digest::SHA)
30BuildRequires:  perl(Encode)
31BuildRequires:  perl(Exporter)
32BuildRequires:  perl(Fcntl)
33BuildRequires:  perl(File::Copy)
34BuildRequires:  perl(File::Glob)
35BuildRequires:  perl(File::Path)
36BuildRequires:  perl(File::Spec)
37BuildRequires:  perl(File::stat)
38BuildRequires:  perl(File::Temp)
39BuildRequires:  perl(overload)
40BuildRequires:  perl(strict)
41BuildRequires:  perl(threads)
42BuildRequires:  perl(warnings)
43BuildRequires:  perl(warnings::register)
44# Test Suite
45BuildRequires:  perl(blib)
46BuildRequires:  perl(File::Basename)
47BuildRequires:  perl(File::Spec::Functions)
48BuildRequires:  perl(File::Spec::Unix)
49BuildRequires:  perl(File::Temp)
50BuildRequires:  perl(lib)
51BuildRequires:  perl(open)
52BuildRequires:  perl(Test::More)
53%if %{with perl_Path_Tiny_enables_optional_test}
54# Optional Tests
55BuildRequires:  perl(CPAN::Meta)
56BuildRequires:  perl(CPAN::Meta::Prereqs)
57BuildRequires:  perl(Test::FailWarnings)
58BuildRequires:  perl(Test::MockRandom)
59%endif
60# Runtime
61Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
62Requires:       perl(Cwd)
63Requires:       perl(Digest)
64Requires:       perl(Digest::MD5)
65Requires:       perl(Digest::SHA)
66Requires:       perl(Encode)
67Requires:       perl(Fcntl)
68Requires:       perl(File::Copy)
69Requires:       perl(File::Glob)
70Requires:       perl(File::Path)
71Requires:       perl(File::stat)
72Requires:       perl(File::Temp)
73Requires:       perl(threads)
74Requires:       perl(warnings::register)
75
76# For performance and consistency
77%if !(0%{?rhel})
78BuildRequires:  perl(PerlIO::utf8_strict)
79Requires:       perl(PerlIO::utf8_strict)
80%endif
81#BuildRequires: perl(Unicode::UTF8)
82#Requires:      perl(Unicode::UTF8)
83
84%description
85This module attempts to provide a small, fast utility for working with file
86paths. It is friendlier to use than File::Spec and provides easy access to
87functions from several other core file handling modules.
88
89It doesn't attempt to be as full-featured as IO::All or Path::Class, nor does
90it try to work for anything except Unix-like and Win32 platforms. Even then, it
91might break if you try something particularly obscure or tortuous.
92
93All paths are forced to have Unix-style forward slashes. Stringifying the
94object gives you back the path (after some clean up).
95
96File input/output methods flock handles before reading or writing, as
97appropriate.
98
99The *_utf8 methods (slurp_utf8, lines_utf8, etc.) operate in raw mode without
100CRLF translation.
101
102%prep
103%setup -q -n Path-Tiny-%{version}
104
105%build
106perl Makefile.PL INSTALLDIRS=vendor
107make %{?_smp_mflags}
108
109%install
110make pure_install DESTDIR=%{buildroot}
111find %{buildroot} -type f -name .packlist -delete
112%{_fixperms} -c %{buildroot}
113
114%check
115make test
116
117%files
118%license LICENSE
119%doc Changes CONTRIBUTING.mkdn README
120%{perl_vendorlib}/Path/
121%{_mandir}/man3/Path::Tiny.3*
122
123%changelog
124* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.108-3
125- initial build for Vine Linux.
126
127* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.108-2
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
129
130* Wed Aug  1 2018 Paul Howarth <paul@city-fan.org> - 0.108-1
131- Update to 0.108
132  - Fixed a bug where failure to load optional modules would trigger an
133    external $SIG{__DIE__} handler
134
135* Mon Jul 16 2018 Paul Howarth <paul@city-fan.org> - 0.106-1
136- Update to 0.106
137  - The PERL_PATH_TINY_NO_FLOCK environment variable has been added to allow
138    users to disable file locking (and any associated warnings)
139  - Detection of unsupported 'flock' is no longer BSD-specific; this allows
140    detecting and warning, for example, with the Luster filesystem on Linux
141  - Improve reliability and diagnostics of tests run via 'do'
142
143* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.104-7
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
145
146* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.104-6
147- Perl 5.28 rebuild
148
149* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.104-5
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
151
152* Fri Dec 08 2017 Petr Pisar <ppisar@redhat.com> - 0.104-4
153- Enable Test::MockRandom test
154
155* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.104-3
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
157
158* Tue Jun 06 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.104-2
159- Perl 5.26 rebuild
160
161* Sat Feb 18 2017 Paul Howarth <paul@city-fan.org> - 0.104-1
162- Update to 0.104
163  - The 'absolute' method now always returns an absolute path, even if a user
164    provided a relative path for the base path; the old, odd behavior was
165    documented, but people often don't read docs so the new behavior avoids
166    surprises
167  - Added 'cached_temp' method
168
169* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.100-2
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
171
172* Sun Jan 15 2017 Paul Howarth <paul@city-fan.org> - 0.100-1
173- Update to 0.100
174  - Fixed tests for eventual removal of '.' from @INC in Perl
175  - Fixed filehandle mode doc typo
176  - Fixed doc typo in relative() that mentioned rel2abs instead of abs2rel
177
178* Mon Oct 10 2016 Paul Howarth <paul@city-fan.org> - 0.098-1
179- Update to 0.098
180  - Added 'realpath' option for 'tempfile' and 'tempdir' for situations where
181    an absolute temporary path just isn't enough
182
183* Sun Jul  3 2016 Paul Howarth <paul@city-fan.org> - 0.096-1
184- Update to 0.096
185  - Improved method for hiding some modules during tests
186- BR: perl-generators unconditionally
187
188* Mon May 23 2016 Paul Howarth <paul@city-fan.org> - 0.094-1
189- Update to 0.094
190  - Path::Tiny will prefer PerlIO::utf8_strict over encoding(UTF-8) if
191    available and Unicode::UTF8 is not installed
192  - The 'touch' method can now set the current time on files that aren't owned,
193    as long as they are writeable
194  - Improved consistency of symlink support inspection; now always looks at
195    $Config{d_symlink}
196  - Skips impossible test on 'msys' platform.
197- BR: perl-generators where possible
198- Drop redundant Group: tag
199
200* Mon May 16 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.090-2
201- Perl 5.24 rebuild
202
203* Tue May  3 2016 Paul Howarth <paul@city-fan.org> - 0.090-1
204- Update to 0.090
205  - Fix spew_utf8 to allow array references as input
206
207* Mon Apr 18 2016 Paul Howarth <paul@city-fan.org> - 0.088-1
208- Update to 0.088
209  - Fixed bugs in relative symlink resolution for realpath, spew and edit_lines
210  - Symlink resolution will detect circular loops and throw an error
211
212* Mon Apr  4 2016 Paul Howarth <paul@city-fan.org> - 0.086-1
213- Update to 0.086
214  - Improved documentation of copy and move
215- Simplify find command using -delete
216
217* Fri Mar  4 2016 Paul Howarth <paul@city-fan.org> - 0.084-1
218- Update to 0.084
219  - Fixed relative() for the case with regex metacharacters in the path
220
221* Wed Mar  2 2016 Paul Howarth <paul@city-fan.org> - 0.082-1
222- Update to 0.082
223  - The relative() method no longer uses File::Spec's buggy rel2abs method;
224    the new Path::Tiny algorithm should be comparable and passes File::Spec
225    rel2abs test cases, except that it correctly accounts for symlinks
226  - Added 'edit' and 'edit_lines' plus _utf8 and _raw variants; this is
227    similar to perl's -i flag (though without backups)
228  - Fixed lines_utf8() with chomping for repeated empty lines
229  - Fixed lines_utf8+chomp and relative() bugs on Windows
230  - Documented that subclassing is not supported
231
232* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.076-2
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
234
235* Mon Nov 16 2015 Paul Howarth <paul@city-fan.org> - 0.076-1
236- Update to 0.076
237  - Tilde expansion on Windows was resulting in backslashes; now they are
238    correctly normalized to forward slashes
239  - Typos fixed
240  - Fixed spewing to a symlink that crosses a filesystem boundary
241  - Add Test::MockRandom to META as a recommended test prerequisite
242
243* Tue Jul 21 2015 Paul Howarth <paul@city-fan.org> - 0.072-1
244- Update to 0.072
245  - Fixed incorrect error argument for File::Path functions (mkpath and
246    remove_tree)
247
248* Mon Jul 20 2015 Paul Howarth <paul@city-fan.org> - 0.070-2
249- Fixed incorrect error argument for File::Path functions (mkpath and
250  remove_tree) (GH#144)
251
252* Mon Jun 29 2015 Paul Howarth <paul@city-fan.org> - 0.070-1
253- Update to 0.070
254  - The 'copy' method now returns the object for the copied file
255  - The 'visit' method only dereferences the callback return value for scalar
256    refs, avoiding some common bugs
257
258* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.068-3
259- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
260
261* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.068-2
262- Perl 5.22 rebuild
263
264* Tue Mar 24 2015 Paul Howarth <paul@city-fan.org> - 0.068-1
265- Update to 0.068
266  - Added exclusive locking option to filehandle opens; spew now exclusively
267    locks tempfile used for atomic writes
268
269* Fri Mar  6 2015 Paul Howarth <paul@city-fan.org> - 0.065-1
270- Update to 0.065
271  - Added 'assert' method
272  - Added 'visit' method
273  - Added support for a negative count for 'lines' to get the last lines of a
274    file
275  - Fixed tilde expansion if path has spaces
276  - Make realpath non-fatal if the parent path exists and only the final path
277    component does not (was fatal on Windows and some Unixes)
278  - Removed redundant locking on tempfile use for spewing
279  - Work around File::Temp bugs on older ActiveState Windows Perls
280    https://bugs.activestate.com/show_bug.cgi?id=104767
281  - Fixed SYNOPSIS example
282
283* Fri Nov 14 2014 Paul Howarth <paul@city-fan.org> - 0.061-1
284- Update to 0.061
285  - Fixed append_utf8 and append_raw with 'truncate' option
286
287* Thu Nov  6 2014 Paul Howarth <paul@city-fan.org> - 0.060-1
288- Update to 0.060
289  - Added 'truncate' option to append for in-place replacement of file contents
290
291* Tue Oct 14 2014 Paul Howarth <paul@city-fan.org> - 0.059-1
292- Update to 0.059
293  - Fixed precedence bug in the check for Unicode::UTF8
294
295* Thu Sep 25 2014 Paul Howarth <paul@city-fan.org> - 0.058-1
296- Update to 0.058
297  - Added a 'sibling' method as a more efficient form of calling
298    $path->parent->child(...).
299  - Documentation for every method annotated with the version number of the
300    last API change
301
302* Tue Sep 23 2014 Paul Howarth <paul@city-fan.org> - 0.057-1
303- Update to 0.057
304  - On AIX, reads that default to locking would fail without write permissions,
305    because locking needs write permissions; the fix is only to lock reads if
306    write permissions exist, otherwise locking is skipped
307
308* Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.056-2
309- Perl 5.20 rebuild
310
311* Thu Aug 14 2014 Paul Howarth <paul@city-fan.org> - 0.056-1
312- Update to 0.056
313  - Fixed problem throwing errors from 'remove'
314  - The 'digest' method now takes a 'chunk_size' option to avoid slurping files
315    entirely into memory
316  - The 'dirname' method is deprecated due to exposing File::Spec
317    inconsistencies
318- Use %%license
319
320* Tue Jul  1 2014 Paul Howarth <paul@city-fan.org> - 0.055-1
321- Update to 0.055
322  - tempfile/tempdir won't warn if used as functions without arguments
323
324* Sat Jun  7 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.054-2
325- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
326
327* Tue May  6 2014 Paul Howarth <paul@city-fan.org> - 0.054-1
328- Update to 0.054
329  - The 'is_file' method now does -e && ! -d and not -f because -f is often
330    more restrictive than people intend or expect
331  - Added 'chmod' method with symbolic chmod support ("a=r,u+rx")
332  - The 'basename' method now takes a list of suffixes to remove before
333    returning the name
334  - Added FREEZE/THAW/TO_JSON serialization helpers
335  - When constructing a Path::Tiny object from another, the original is
336    returned unless it's a temp dir/file, which significantly speeds up calling
337    path($path) if $path is already a Path::Tiny object
338  - Constructing any path - e.g. with child() - with undef or zero-length
339    parts throws an error instead of constructing an invalid path
340
341* Wed Jan 15 2014 Paul Howarth <paul@city-fan.org> - 0.052-1
342- Update to 0.052
343  - Backslash-to-slash conversion now only happens on Windows (since backslash
344    is legal on Unix, we must allow it)
345
346* Sat Dec 21 2013 Paul Howarth <paul@city-fan.org> - 0.051-1
347- Update to 0.051
348  - Recursive iteration won't throw an exception if a directory is removed or
349    unreadable during iteration
350
351* Thu Dec 12 2013 Paul Howarth <paul@city-fan.org> - 0.049-1
352- Update to 0.049
353  - Added 'subsumes' method
354  - The 'chomp' option for 'lines' will remove any end-of-line sequences fully
355    instead of just chomping the last character
356  - Fixed locking test on AIX
357  - Revised locking tests for portability again: locks are now tested from a
358    separate process
359  - The 'flock' package will no longer indexed by PAUSE
360  - Hides warnings and fixes possible fatal errors from pure-perl Cwd,
361    particularly on MSWin32
362  - Generates filename for atomic writes independent of thread-ID, which fixes
363    crashing bug on Win32 when fork() is called
364
365* Fri Oct 18 2013 Paul Howarth <paul@city-fan.org> - 0.044-1
366- Update to 0.044
367  - Fixed child path construction against the root path
368  - Fixed path construction when a relative volume is provided as the first
369    argument on Windows; e.g. path("C:", "lib") must be like path("C:lib"),
370    not path("C:/lib")
371  - On AIX, shared locking is replaced by exclusive locking on a R/W
372    filehandle, as locking read handles is not supported
373
374* Mon Oct 14 2013 Paul Howarth <paul@city-fan.org> - 0.043-1
375- Update to 0.043
376  - Calling 'absolute' on Windows will add the volume if it is missing (e.g.
377    "/foo" will become "C:/foo"); this matches the behavior of
378    File::Spec->rel2abs
379  - Fixed t/00-report-prereqs.t for use with older versions of
380    CPAN::Meta::Requirements
381
382* Sun Oct 13 2013 Paul Howarth <paul@city-fan.org> - 0.042-1
383- Update to 0.042
384  - When 'realpath' can't be resolved (because intermediate directories don't
385    exist), the exception now explains the error clearly instead of complaining
386    about path() needing a defined, positive-length argument
387  - On Windows, fixed resolution of relative paths with a volume, e.g. "C:foo"
388    is now correctly translated into getdcwd on "C:" plus "foo"
389
390* Fri Oct 11 2013 Paul Howarth <paul@city-fan.org> - 0.041-1
391- Update to 0.041
392  - Remove duplicate test dependency on File::Spec that triggers a CPAN.pm bug
393
394* Wed Oct  9 2013 Paul Howarth <paul@city-fan.org> - 0.040-1
395- Update to 0.040
396  - The 'filehandle' method now offers an option to return locked handles
397    based on the file mode
398  - The 'filehandle' method now respects default encoding set by the caller's
399    open pragma
400
401* Wed Oct  2 2013 Paul Howarth <paul@city-fan.org> - 0.038-1
402- Update to 0.038
403  - Added 'is_rootdir' method to simplify testing if a path is the root
404    directory
405
406* Thu Sep 26 2013 Paul Howarth <paul@city-fan.org> - 0.037-1
407- Update to 0.037
408  - No longer lists 'threads' as a prerequisite; if you have a threaded perl,
409    you have it and if you've not, Path::Tiny doesn't care
410  - Fixed for v5.8
411
412* Tue Sep 24 2013 Paul Howarth <paul@city-fan.org> - 0.035-1
413- Update to 0.035
414  - Fixed flock warning on BSD that was broken with the autodie removal; now
415    also applies to all BSD flavors
416
417* Tue Sep 24 2013 Paul Howarth <paul@city-fan.org> - 0.034-1
418- Update to 0.034
419  - Exceptions are now Path::Tiny::Error objects, not autodie exceptions; this
420    removes the last dependency on autodie, which allows us to support Perls as
421    far back as v5.8.1
422  - BSD/NFS flock fix was not backwards compatible before v5.14; this fixes it
423    harder
424  - Lowered ExtUtils::MakeMaker configure_requires version to 6.17
425
426* Thu Sep 12 2013 Paul Howarth <paul@city-fan.org> - 0.033-1
427- Update to 0.033
428  - Perl on BSD may not support locking on an NFS filesystem: if this is
429    detected, Path::Tiny warns and continues in an unsafe mode (the 'flock'
430    warning category may be fatalized to die instead)
431  - Added 'iterator' example showing defaults
432
433* Fri Sep  6 2013 Paul Howarth <paul@city-fan.org> - 0.032-1
434- Update to 0.032
435  - Removed several test dependencies; Path::Tiny now only needs core modules,
436    though some must be upgraded on old Perls
437
438* Tue Sep  3 2013 Paul Howarth <paul@city-fan.org> - 0.031-3
439- BR: perl(Config) for the test suite (#1003660)
440
441* Mon Sep  2 2013 Paul Howarth <paul@city-fan.org> - 0.031-2
442- Sanitize for Fedora submission
443
444* Mon Sep  2 2013 Paul Howarth <paul@city-fan.org> - 0.031-1
445- Initial RPM version
Note: See TracBrowser for help on using the repository browser.