source: projects/specs/trunk/p/perl-Parse-Yapp/perl-Parse-Yapp-vl.spec @ 521

Revision 521, 2.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3Summary: Perl extension for generating and using LALR parsers.
4Name: perl-Parse-Yapp
5Version: 1.05
6Release: 31%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9Source0: Parse-Yapp-%{version}.tar.gz
10Url: http://www.cpan.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: perl >= 5.8.2
13Requires: perl >= 5.8.2
14BuildArch: noarch
15
16%description
17Parse::Yapp (Yet Another Perl Parser compiler) is a collection of
18modules that let you generate and use yacc like thread safe
19(reentrant) parsers with perl object oriented interface.  The script
20yapp is a front-end to the Parse::Yapp module and let you easily
21create a Perl OO parser from an input grammar file.
22
23
24# Provide perl-specific find-{provides,requires}.
25%define __find_provides /usr/lib/rpm/find-provides.perl
26%define __find_requires /usr/lib/rpm/find-requires.perl
27
28%prep
29%setup -q -n Parse-Yapp-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
33#PREFIX=$RPM_BUILD_ROOT%{_prefix}
34make
35
36%check
37make test
38
39%clean
40rm -rf $RPM_BUILD_ROOT
41
42%install
43rm -rf $RPM_BUILD_ROOT
44mkdir -p $RPM_BUILD_ROOT%{_prefix}
45#make PREFIX=$RPM_BUILD_ROOT%{_prefix} install
46make DESTDIR=$RPM_BUILD_ROOT install
47
48[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
49
50find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
51
52find $RPM_BUILD_ROOT/usr -type f -print |
53        sed "s@^$RPM_BUILD_ROOT@@g" |
54        grep -v perllocal.pod |
55        grep -v "\.packlist" > Parse-Yapp-%{version}-filelist
56if [ "$(cat Parse-Yapp-%{version}-filelist)X" = "X" ] ; then
57    echo "ERROR: EMPTY FILE LIST"
58    exit -1
59fi
60
61%files -f Parse-Yapp-%{version}-filelist
62%defattr(-,root,root)
63#%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/Parse/Yapp
64
65%changelog
66* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 1.05-31vl5
67- applied new versioning policy
68
69* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.05-30vl6
70- installed files to vendor_perl
71- changed Group to Development/Libraries
72
73* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 1.05-30vl5
74- build on perl-5.8.6-0vl1
75
76* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl4
77- built on perl-5.8.2
78
79* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl3
80- built on perl-5.8.1
81
82* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl2
83- build on perl-5.8.0
84
85* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 1.05-30vl1
86- Build for VineLinux
87
88* Mon Jan 27 2003 Chip Turner <cturner@redhat.com>
89- version bump and rebuild
90
91* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
92- automated release bump and build
93
94* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
95- properly claim directories owned by package so they are removed when package is removed
96
97* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
98- automated rebuild
99
100* Fri Dec 7 2001 root <root@redhat.com>
101- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.